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Welcome to the GeneGhip® Operating 
System 1

Welcome to the Affymetrix® GeneChip® Operating Software 1.0 User’s 
Guide. This manual explains how to use the following applications:

■ GeneChip® Operating Software (GCOS) 1.0 (formerly Affymetrix® 
Microarray Suite)

■ GCOS Manager (formerly Affymetrix® LIMS Manager)
■ GCOS Administrator

Introducing GeneChip® 
Operating Software

GCOS 1.0 manages Affymetrix® GeneChip® array data. GCOS 1.0 manages 
data on the local work station using a Microsoft® Data Engine database on 
the workstation. GCOS also has the ability to connect with Affymetrix® 
GeneChip® Array Operating Software Server, a separate application for large 
scale, network accessible databases.

GCOS, GCOS Manager, and GCOS Administrator are a trio of applications 
that:

■ automate control of the GeneChip® instruments 
■ capture and analyze the array image
■ provide workflow tracking of experiment data (image, cell intensities, 

probe analysis data)
■ manage experiment data
■ automate basic expression analysis and publishing
■ provide end user administration tools for workstation databases 
3
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Conventions Used in This 
Guide

This manual provides a detailed outline for all tasks associated with 
Affymetrix® GCOS, GCOS Manager, and GCOS Administrator. Various 
conventions are used throughout the manual to help illustrate the procedures 
described. Explanations of these conventions are provided below.

Steps

Instructions for procedures are written in a step format. Immediately 
following the step number is the action to be performed. On the line below 
the step there may be the following symbol: ⇒. This symbol defines the 
system response or consequence that happens as a result of user action; what 
you see and what has happened.

Following the response additional information pertaining to the step may be 
found and is presented in paragraph format. For example:

9. Click Yes to continue.

⇒ The Delete task proceeds.  
In the lower right pane the status is displayed. 

To view more information pertaining to the delete task, right-click 
Delete and select View Task Log from the shortcut menu that appears.

Font Styles

Bold fonts indicate names of commands, buttons, options or titles within a 
dialog box. When asked to enter specific information, such input appears in 
italics within the procedure being outlined. 
For example:

1. Click the Find button  or select Edit → Find from the menu bar.

⇒ The Find dialog box appears.

2. Enter AFFX-BioB-5_at in the Find what box, then click Find Next to 
view the first search result.

3. Continue to click Find Next to view each successive search result.
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Screen Captures

The steps outlining procedures are frequently supplemented with screen 
captures to further illustrate the instructions given. The screen captures 
depicted in this manual may not exactly match the windows displayed on 
your screen.

Additional Comments

Resources

Online Documentation

The CD with GCOS includes an electronic version of this user’s guide. The 
online documentation is in Adobe Acrobat® format (a *.pdf file) and is 
readable with the Adobe® Acrobat Reader® software, available at no charge 
from Adobe at http://www.adobe.com.

The online help contains a version of this user’s guide as a Microsoft® 
HTML help file.

Information presented in Tips provide helpful advice or shortcuts for 
completing a task.

The Note format presents important information pertaining to the text or 
procedure being outlined.

Caution notes advise you that the consequence(s) of an action may be 
irreversible and/or result in lost data.

Warnings alert you to situations where physical harm to person or 
damage to hardware is possible.

http://www.adobe.com
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Technical Support

Affymetrix provides technical support to all licensed users via phone or E-
mail. To contact Affymetrix® Technical Support:

Affymetrix, Inc.
3380 Central Expressway
Santa Clara, CA 95051 USA

E-mail: support@affymetrix.com
Tel: 1-888-362-2447 (1-888-DNA-CHIP)
Fax: 1-408-731-5441

Affymetrix UK Ltd.,
Voyager, Mercury Park,
Wycombe Lane, Wooburn Green,
High Wycombe HP10 0HH
United Kingdom

E-mail: supporteurope@affymetrix.com
Tel: +44 (0) 1628 552550
Fax: +44 (0) 1628 552585

Affymetrix Japan, K. K.
Mita NN Bldg
16 Floor, 4-1-23 Shiba,
Minato-ku, Tokyo 108-0014
Japan

〒 108 － 0014

東京都港区芝 4－ 1 － 23

三田 NN ビル 16F

Tel: (03) 5730-8200
Fax: (03) 5730-8201

www.affymetrix.com
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Installing GCOS 2

This chapter provides detailed instructions for installing the 
GeneChip® Operating Software (GCOS) for new users and for users 
upgrading from Affymetrix® Microarray suite 5.x. 

For information on installing the library files, see Chapter 3, 
Affymetrix® GeneChip® Library Install, on page 25. For information on 
installing the instruments, see Appendix C, GCOS Instrument 
Installation, on page 467.               

Steps to Install GCOS for 
New Users 

At least 500 MB of available disk space is recommended for the 
installation.

1. Insert the GCOS CD-ROM.

2. If the autorun feature does not start the program:

a. Click Start → Run. 

b. Type <cd drive letter>:\setup.exe.

c. Click OK.

⇒ The Affymetrix Software Setup window appears (Figure 2.1).

You must be logged in as an administrator to install GCOS.

The screen captures depicted in this manual may not exactly match the 
windows displayed on your screen.
9
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3. Click Install GCOS.

4. In the Welcome window (Figure 2.2), click Next.

⇒ The License Agreement windows appear (Figure 2.3).

Figure 2.1    
Install window

Figure 2.2    
Welcome to GCOS setup
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5. Review the contents and click Yes to accept the terms of the licensing 
agreement.

⇒ The Customer Information window appears (Figure 2.4).

Figure 2.3    
License Agreement Window

Figure 2.4    
Customer Information window
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6. Enter your Name, Company, and Serial Number.

The serial number is located on the Affymetrix® Software Product 
Registration card.

 

7. Click Next.

⇒ The GCOS Server Name window appears (Figure 2.5). 

8. Enter the name of the remote GCOS server that you want to connect to. 
If you do not have one, leave the server name blank.

9. Click Next.

⇒ The Choose Destination Locations window opens (Figure 2.6).

If you do not have a serial number, contact Affymetrix Technical 
Support. 

Figure 2.5    
GCOS Server Name window
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10. Select the destination where GCOS will be installed.

C:\GeneChip is the default location. If you are upgrading from 
Microarray Suite, we recommend installing in the same directory.

11. Enter and confirm the password for the MSDE system administrator 
(sa). 

⇒ The installation begins. When the install is completed, the GCOS 
Software Setup Completed window appears (Figure 2.7).

Figure 2.6    
Choose Destinations Locations window

The password should be at least six characters long and must contain at 
least two digits.
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12. Choose Yes, I want to restart my computer now, and click Finish. 

⇒ The system reboots.

If you are not prompted to reboot your computer, the installation is 

complete.

Figure 2.7    
GeneChip Operating Software Setup Completed window

If you are upgrading from a version of Microarray Suite, it is necessary 
to run the library migrate program to migrate the library files into the 
local database. 

If GCOS will be used with an GCOS server, it is important to ensure the 
library migration has been completed on the GCOS server.
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Steps to Install GCOS for 
Users Upgrading from 
Microarray Suite 5.x

At least 500 MB of available disk space is recommended for the 
installation.

1. Insert the GCOS CD-ROM.

2. If the autorun feature does not start the program:

a. Click Start → Run. 

b. Type <cd drive letter>:\setup.exe.

c. Click OK.

⇒ The Affymetrix Software Setup window appears (Figure 2.1).

3. Click Install GCOS.

You must be logged in as an administrator to install GCOS.

The screen captures depicted in this manual may not exactly match the 
windows displayed on your screen.

Figure 2.8    
Install window
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4. In the Welcome window (Figure 2.2), click Next.

⇒ The License Agreement windows appear (Figure 2.3).

Figure 2.9    
Welcome to GCOS setup

Figure 2.10    
License Agreement Window
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5. Review the contents and click Yes to accept the terms of the licensing 
agreement.

⇒ The Customer Information window appears (Figure 2.4).

6. Enter your Name, Company, and Serial Number.

The serial number is located on the Affymetrix® Software Product 
Registration card.

 

7. Click Next.

⇒ The GCOS Server Name window appears (Figure 2.5). 

Figure 2.11    
Customer Information window

If you do not have a serial number, contact Affymetrix Technical 
Support. 



CHAPTER 2   Installing GCOS18
8. Enter the name of the remote GCOS server that you want to connect to. 
If you do not have one, leave the server name blank.

9. Click Next.

⇒ The Choose Destination Locations window opens (Figure 2.6).

Figure 2.12    
GCOS Server Name window
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10. Select the destination where GCOS will be installed.

C:\GeneChip is the default location. If you are upgrading from 
Microarray Suite, we recommend installing in the same directory.

11. Enter and confirm the password for the MSDE system administrator 
(sa). 

⇒ The software prompts you to start the batch import tool after the 
installation is complete (Figure 2.14).

Figure 2.13    
Choose Destinations Locations window

The password should be at least six characters long and must contain at 
least two digits.
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12. To import Microarray Suite files (.exp, .dat, .cel, and .chp) after the 
installation is complete, place a check mark next to Import MAS 5 
data files using Batch Import Tool.

If you do not select batch import option at this time, you can access the 
batch import tool later from the Windows Start menu (Start → 
Programs → Affymetrix → Batch Import Tool).

13.  Click Next.

⇒ The installation begins. When the install is completed, the 
GeneChip Operating Software Setup Completed window appears 
(Figure 2.15).

Figure 2.14    
Batch Import Option window
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14. Choose Yes, I want to restart my computer now and click Finish.

⇒ The system reboots.

15. After the reboot, login using the same user name.

⇒ The library update program starts.

16. To install library files, refer to Steps for Installing Library Files on an 
Upgraded GCOS Install, on page 30.

To run the library update program at another time, navigate to the 
GeneChip\Migrate directory and run the setup.exe.

17. When the library update program is completed, the batch import tool 
starts (if this option was selected in step 12).

Figure 2.15    
GeneChip Operating Software Setup Completed 

To complete the installation, you must reboot the computer and login 
again as the same user.

If you are upgrading from a version of Microarray Suite, it is necessary 
to run the library migrate program to migrate the library files. 
Alternatively, use GCOS to scan and analyze the data.
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To import Microarray Suite files to GCOS, refer to the instructions for 
the batch import tool on the GCOS CD. This completes the install.
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Affymetrix® GeneChip® Library Install 3

This chapter provides detailed instructions for installing Affymetrix® 
GeneChip® probe array library files using the library install program. 
The probe information or library data include the probe array design 
characteristics, probe utilization and content, and scanning and 
analysis parameters. Library data are unique to each probe array 
type. The library install program includes a full install and an update 
program. The full install should be used when installing the 
Affymetrix® GeneChip® Operating Software (GCOS) on a new system. 
If upgrading from a previous version of Affymetrix® Microarray Suite, 
use the library update program.

 

Steps for Installing Library 
Files on a New GCOS 
Install

This section of the manual guides you through the full library install 
program. The full install is required on a GCOS system that was not 
upgraded from a previous version of Affymetrix® Microarray Suite.

1. Insert the library files CD-ROM for the appropriate probe array type.

⇒ The Affymetrix Library Files Setup window appears (Figure 3.1).
25
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2. Click Full Library Install.

⇒ The InstallShield Wizard for Affymetrix Library Files starts 
(Figure 3.2).

 

Figure 3.1    
Library Files Setup window

Figure 3.2    
InstallShield Wizard Welcome window
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3. Click Next.

⇒ The Select Probe Array Types window appears (Figure 3.3).

4. Click Select All to select all array types for installation. Alternatively, 
place a check mark next to the array type(s) that you want to install.

For example, in Figure 3.3, the HG-U133A and HG-U133B probe arrays 
will be installed on the system.

GCOS does not allow you to modify the location of the library file 
directory. By default, all probe array type information is installed in the 
library subdirectory of the GCOS installation.

Do not move or delete the library directory or the files in the 
directory. This will render the GCOS installation invalid.

Figure 3.3    
Select Probe Array Types window
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5. Click Next.

⇒ The Start Installing Files window appears Figure 3.4.

This window shows the install options selected, including the:

■ probe array types that will be installed on the system
■ location of the library directory where the probe array library data will 

be saved
■ location of the protocol directory where the fluidic station script files 

will be saved.

6. Click Next.

⇒ The install process begins.

After the installation is complete, the software displays the Finish 
window (Figure 3.5).

Figure 3.4    
Start Installing Files window
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7. Choose Yes, I want to view the Audit Report file now, and click 
Finish.

⇒ The installation completes.

If an error occurs, the software displays an error dialog box Figure 3.6.

8. Click Yes to view the SQL.log and Audit XXX.log that contain 
information about the error that occurred. Forward this file to 
Affymetrix® technical support to obtain a solution for the problem. 

Figure 3.5    
Finish window

Figure 3.6    
Error dialog box
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Steps for Installing Library 
Files on an Upgraded 
GCOS Install 

The library install program includes a full install and an update program. 
Use the update program when you upgrade from a version of Affymetrix® 
Microarray Suite to GCOS. The update program migrates probe array type 
information from the files in the library directory that was used with 
Microarray Suite.

1. Insert the library files CD_ROM for the appropriate probe array type.

⇒ The Affymetrix Library Files Setup window appears (Figure 3.7).

2. Click Update Library Files.

⇒ The InstallShield Wizard for Affymetrix Library Files starts 
(Figure 3.8).

Figure 3.7    
Library Files Setup window
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3. Click Next.

⇒ The Select Source Library Directory window appears (Figure 3.9).

Figure 3.8    
InstallShield Wizard Welcome window

Figure 3.9    
Select Source Library Directory window



CHAPTER 3   Affymetrix® GeneChip® Library Install32
4. To select the location of the source library directory from which to 
migrate the information into the GCOS database, click Browse. Click 
Next.

⇒ The Select Source Protocol Directory window appears (Figure 3.10).

5. Click Browse and select the location of the fluidics protocols directory 
from which to migrate the information into the GCOS database.

6. Click Next to display the probe array types available for migration.

⇒ The Select Probe Array Types window appears (Figure 3.11).

This library directory is the directory that was used with Affymetrix 
Microarray suite. It contains .CIF and .CDF files that contain information 
about the probe array types used in the system.

Figure 3.10    
Select Source Protocol Directory window
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7. Select the probe array types that you want to migrate from the library 
directory. Click Select All to select all of the array types or place a 
check mark next to the probe array type(s) that you want to install.

For example, in Figure 3.11, the RG-U34A probe array will be installed 
on the system.

To migrate a probe array type from a previous version of Microarray 
Suite software, the library directory must contain the .CIF and .CDF files. 
The update program will not install the gene descriptions, sequences, or 
annotations. These should exist in the GCOS database from the 
previous Microarray Suite install.

To migrate fluidics scripts from the protocols directory, the .BIN file 
must exist along with the .MAC file. If the .BIN file is missing, the 
software will not update the database with the associated script. 
However, if a .BIN file exists in the directory without the associated 
.MAC file (for example, the “Home” script that can be executed without 
selecting an experiment) the update program will copy the file to the 
new protocols directory.

Figure 3.11    
Select Probe Array Types window
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8. Click Next.

⇒ The Select Protocols window appears and displays the fluidics 
protocols that will be migrated to the GCOS installation Figure 3.12.

9. Select the fluidics scripts that you want to migrate from the protocols 
directory. To select all of the scripts, click Select All. To select scripts 
individually, place a check mark next to the script.

For example, in Figure 3.12, the scripts EukGE-WS1v4, EukGE-WS2v4, 
FlexGE-WS1v4, FlexGE-WS2v4 will be installed on the system.

10. Click Next.

⇒ The Start Importing Library Files window appears (Figure 3.13).

It shows the:

■ probe array types and fluidics scripts that will be installed
■ location of the library directory for the probe array type data
■ location of the protocol directory for the fluidics station scripts

Figure 3.12    
Select Protocols window
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11. Click Next to start the installation.

After the installation is complete, the software displays the Finish 
window (Figure 3.14). 

Figure 3.13    
Start Importing Library Files window
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12. Choose Yes, I want to view the Audit Report file now and click 
Finish.

⇒ The installation completes.

If an error occurs, the software displays an error dialog box (Figure 3.15).

13. Click Yes to view the sql.log and updateXXX.log files that contain 
information about the error that occurred. Forward this file to 
Affymetrix® technical support to obtain a solution for the problem.

Figure 3.14    
Finish window

Figure 3.15    
Error dialog box
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GeneChip® System Overview 4

This chapter provides background information on the Affymetrix® 
GeneChip® array and instrument platform. It provides a brief 
overview of the software applications that acquire, analyze, and 
manage the data.

System Overview

The Affymetrix® GeneChip® platform uses high-density GeneChip 
oligonucleotide probe arrays to efficiently acquire and analyze genetic 
information. This integrated and complete system includes the:

■ GeneChip® Hybridization Oven 640
■ GeneChip® Fluidics Station 
■ Affymetrix® GeneChip® Scanner 3000 or the GeneArray® 2500 scanner
■ Computer workstation
■ GeneChip® Operating Software (GCOS) 1.0 (formerly Microarray Suite)
■ GCOS Manager (formerly LIMS Manager)
■ GCOS Administrator
■ GeneChip® Operating Software Server (GCOS Server) (formerly LIMS)
■ Affymetrix® Data Mining Tool (DMT) 
■ GeneChip® DNA Analysis Software (GDAS)
39
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GeneChip® Assay

The GeneChip® Operating Software (GCOS) automates instrument control 
and provides a central infrastructure to acquire, track, and analyze 
experiment data. Table 4.1 shows the major steps and software functions in a 
GeneChip® assay. 

Table 4.1
GeneChip® Assay

Assay Step Output Software Function

Prepare the target.

Register the sample and 
set up an experiment.

Experiment 
information 

GCOS adds the sample and experiment 
information to the process database. GCOS 
tracks the sample and the associated experiment 
data (image, cell intensities, and probe analysis 
data) in the workflow monitor.

Hybridize, wash, and stain 
the probe array.

GCOS automates control of the fluidics station 
and scanner.

Scan the probe array. Image data 

Cell intensity 
data

GCOS automates control of the scanner, 
acquires and saves the scan data. 

GCOS automatically computes and saves the cell 
intensities from the image data. GCOS tracks the 
image and cell intensity data in the process 
database.

Analyze the cell 
intensities.

Probe analysis The GCOS Statistical Expression algorithm 
analyzes the cell intensities of expression arrays, 
and saves the probe analysis or chip data.

The GDAS algorithms analyze the cell intensities 
of other types of GeneChip® arrays, and saves 
the probe analysis or chip data.

Generate a report. Report (.rpt) GCOS generates and saves the Expression 
report (.rpt).

GDAS generates and saves a report (.rpt) for 
array types other than expression.

Publish the sample and 
experiment data.

GCOS copies expression experiment data (cell 
intensity and probe analysis data) to the publish 
database where the data are accessible to the 
Affymetrix® Data Mining Tool (DMT) software 
and other third party analysis tools.
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GCOS provides a workflow-based tracking system for the data. The 
workflow monitor (Figure 4.1) tracks sample or experiment status through a 
series of steps or queue that includes:

■ hybridization
■ scan
■ grid alignment
■ cell intensity analysis (for image data files that require manual grid 

alignment)
■ probe array analysis for expression assay
■ publish expression probe array analysis data

You can easily confirm the status of an experiment by checking the 
workflow monitor. For example, the Hybridization tab shows experiments to 
be processed in the fluidics station. 

Preparing the Target Sample 

Refer to the appropriate GeneChip® probe array package insert, the 
Expression Analysis Technical Manual, or to other Affymetrix® technical 
documentation relevant to your particular project.

Figure 4.1    
Workflow monitor, Hybridization tab
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Registering a Sample and Setting Up an Experiment 

You must identify or register a sample (target) and define an experiment in 
GCOS before processing a probe array in the fluidics station or scanning an 
array. You register the sample by entering the sample type (required) and 
sample information (attributes), and associating the sample with a project 
(which may include several different samples) (Figure 4.2). The registration 
process adds the sample information to the process database. Now GCOS 
tracks the sample and the associated experiment data (image, cell intensities, 
probe analysis data) in the workflow monitor.

To define an experiment, you specify the type of probe array to which the 
target sample will be hybridized as well as other information relevant to the 
experiment (Figure 4.2). You can also associate a barcode with an experiment. 
If an Affymetrix® barcode is entered (manually or using a keyboard wedge 
reader), GCOS automatically reads and displays the probe array type, lot 
number, and expiration date. GCOS uses the experiment information to 
select scanner specifications for the probe array and identify the user-
modifiable algorithm parameters for data analysis. 

You can also use a template (defined in GCOS Manager) to register a sample 
and define an experiment. For more information on creating a template, see 
Template Tab, on page 344.
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Hybridizing, Washing, and Staining a Probe Array 

During hybridization, the probe array is incubated with a hybridization 
cocktail containing the labeled target and control oligonucleotides in a buffer 
optimized for each type of probe array (refer to the appropriate GeneChip® 
probe array package insert).

The hybridization reaction occurs in the GeneChip® fluidics station, except 
for assays requiring longer hybridization periods in which case the 
hybridization reaction occurs in the GeneChip® Hybridization Oven 640.

During hybridization in the fluidics station, the probe array is repeatedly 
filled and drained with the hybridization cocktail. The strongest 
hybridization occurs between the array probes and sequences in the target 
that are most nearly complementary. 

After hybridization, the probe array undergoes a series of stringent washes 
(specifically optimized for each type of probe array) in the fluidics station. If 

Figure 4.2    
Sample and experiment information
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the target was labeled with a fluorescent tag, the array may be scanned at this 
point using the GeneChip® Scanner 3000 or the GeneArray® scanner. In 
applications that use a biotin-labeled target, the probe array must be stained 
with a streptavidin-conjugated fluorescent stain and requires antibody 
amplification prior to scanning.

GCOS controls the fluidics station using pre-programmed fluidics protocols 
for hybridizing, washing, and staining the probe arrays. The computer 
workstation running GCOS can simultaneously control up to eight fluidics 
stations. A fluidics station contains four modules and each module can 
independently process a probe array using different fluidics protocols. Some 
of the fluidics protocols may be customized. Utilities for station 
maintenance are also included.

Scanning a Probe Array 

After the GeneChip® probe array has undergone hybridization, washing, and 
staining, it is ready to be scanned.

GCOS automates control of the scanner and uses the experiment information 
to manage the scanner settings for each type of probe array. The software 
enables you to start a scan and view the intensity data as it is collected 
during scanning. After the scan is completed, GCOS displays a picture of the 
image data in the Image window (Figure 4.3). GCOS tracks the image data and 
the scan parameters in the process database. For more information on image 
data, see Chapter 9, Working with Images on page 135.

The Affymetrix® GeneChip® Scanner 3000 requires about 4 to 7 minutes to 
scan an array depending on the size of the scan region, the number of scans, 
the autofocusing adjustment, and other parameters. 

The GeneArray® 2500 scanner requires 5 to 25 minutes to scan an array 
depending on the size of the scan region, the number of scans, and other 
parameters. 

Computing Cell Intensities 

After the scan is completed, GCOS displays a picture of the scan image in 
the image window. The software represents the fluorescence intensity values 

The Affymetrix® Scanner 3000 cannot scan fluorescein labeled arrays.
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from each pixel on the array in a grayscale or pseudocolor mode and 
superimposes a grid on the image to delineate the probe cells (features).

GCOS automatically:

■ analyzes the image data and computes a single intensity value for 
each probe cell on an array

■ saves the cell intensity data (Figure 4.3)

GCOS tracks the cell intensity data and the parameters used in the cell 
intensity analysis in the process database.

Figure 4.3    
Image window, scan image (left) and computed cell intensity data (right)
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Expression Analysis 

The Statistical Expression algorithm processes the cell intensity data. A 
single-array analysis examines the cell intensity data from one experiment 
(GeneChip® probe array). For each transcript represented on the array, the 
algorithm computes the detection call (present, absent, or marginal (unable 
to call the transcript present or absent), or no call) and other call metrics.

A comparison analysis compares the cell intensities of the same probe set on 
two different probe arrays (an experiment and baseline of the same probe 
array type) to determine the relative change in the expression level of a 
transcript. For each transcript represented on the array, the algorithm 
computes the change call (increase, marginal increase, no change, marginal 
decrease, decrease) or no call, and other call metrics.

GCOS saves the probe analysis data and automatically displays it in the 
Expression Analysis window (Figure 4.4). GCOS tracks the probe analysis 
data and the analysis parameters in the process database.

Figure 4.4    
Expression Analysis window, probe analysis data
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Publishing Experiment Data 

GCOS copies or publishes expression experiment data (cell intensity and 
probe analysis data) in AADM format to the publish database (see Figure 4.5 
on page 49). The publish database is accessible to the Affymetrix® Data 
Mining Tool (DMT) or several other third party analysis tools. The DMT is a 
separate application that provides powerful query and analysis tools. 

Databases 

GCOS installs Microsoft® Data Engine (MSDE) databases on the 
workstation. Table 4.2 shows the GCOS databases and their functions. 
Alternatively, the Affymetrix® GeneChip® Operating Software Server 
(GCOS Server) installs Microsoft® SQL Server or Oracle databases on a 
network accessible server. GCOS also provides the end user interface to 
GCOS Server. GCOS Server enables users to register samples and set up 
experiments, and access and analyze data from any client workstation on the 
network. 

GCOS analyzes expression cell intensity data only. GDAS analyzes cell 
intensity data from other types of probe arrays.

Table 4.2
GCOS databases

Database Name  Contents

Process Data tracking information about samples and experiments, and 
information about the image, intensity, and probe analysis data for 
a particular sample and experiment.

Publish Expression data in the Affymetrix® Analysis Data Model (AADM) 
database schema that can be accessed by the Affymetrix® Data 
Mining Tool (DMT) and other software.

Gene Information Accession numbers, probe set descriptions, target sequence, and 
user annotations accessible to DMT.



CHAPTER 4   GeneChip® System Overview48
Database Management & Administration

GCOS Manager is a separate application that helps you manage your 
expression data. This software tool provides a convenient way to:

■ manage the process and publish databases
■ delete process or publish data
■ create templates for entering sample and experiment attributes
■ create a userset (a predefined set of Statistical Expression algorithm 

parameter settings) for expression analysis
■ archive image, cell intensity, and probe analysis data to a network 

drive
■ restore image, cell intensity, and probe analysis data to a network 

drive
■ export an experiment and the associated data files to a user-specified 

location on the workstation 
■ define user privileges (roles) for the GCOS server
■ apply additional file security to the GCOS server 

GCOS Administrator enables you to:

■ monitor free and used workstation disk space
■ back up a publish or process database, sample, or project on the 

workstation to an archival file (.cab) that can be restored to another 
GCOS system

■ restore a publish or process database, sample, or project from an 
archival file (.cab) to another GCOS system

■ change the location of a publish database
■ change the password for the process database or a publish database

Together GCOS, GCOS Manager, and GCOS Administrator provide full 
functionality for the GeneChip® instrument and array platform as well as 
basic expression analysis (Figure 4.5). 
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Figure 4.5    
GCOS, GCOS Manager, GCOS Administrator, and Data Mining Tool software
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This chapter explains how to:

■ start the GeneChip® Operating Software (GCOS) 
■ configure the software to run with a remote Affymetrix® GeneChip 

Operating Software (GCOS) server
■ specify filters that determine the data displayed by the system 
■ configure the fluidics station and scanner 

Starting GCOS 

1. Turn on the power for the computer workstation. If the workstation is 
connected to the instruments, also turn on the power for the GeneChip® 
Fluidics Station 400 and the Affymetrix® GeneChip® Scanner 3000 or 
the GeneArray® 2500 scanner. 

2. After the computer startup is complete, press Ctrl+Alt+Delete to open 
the logon dialog box. Enter your user name, password, and domain.

3. Click the Windows Start menu button , then select Programs → 
Affymetrix → GeneChip Operating Software. 

When GCOS starts, the program displays the shortcut bar, data tree, and 
status log (Figure 5.1). 

Laser in use during scanning. 

The scanner laser should be turned on and warmed up at least 10 
minutes (if using the GeneChip® Scanner 3000) or 15 minutes (if using 
the GeneArray® 2500 scanner) before use. Refer to Appendix D, Using 
the GeneChip® Scanner 3000, on page 491 or to the Agilent GeneArray 
Scanner User’s Guide.
53
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Figure 5.1    
GCOS user interface (local database)
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Instrument Control, 
& Settings
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Configuring GCOS 

The GCOS software may be configured to run with a network accessible 
GeneChip® Operating Software (GCOS) server. 

Data Storage 

Check the database setting to make sure GCOS is properly configured for 
your system (workstation or GCOS server database).

1. In the Settings shortcut bar, click the Defaults button . Alternatively, 
select Tools → Defaults from the menu bar.

⇒ The Defaults dialog box appears (Figure 5.2). 

2. Click the Database tab 

Figure 5.2    
Defaults dialog box, Database tab

The GCOS Server data storage option is available if all windows are 
closed and no instrument is active.
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3. To store experiment data on the GCOS server, choose the Affymetrix 
GCOS option. 

If the GCOS Server option is not selected, the data are stored in the 
local MSDE database.

GCOS User Interface 

Shortcut Bar 

The shortcut bar provides quick alternatives to menu bar commands. The 
shortcut bar has three sections: 

■ GeneChip Software
■ Instrument Control
■ Settings

■ To display a particular section of the shortcut bar, click the shortcut bar 
section name (Figure 5.3 through Figure 5.4).

GeneChip Software Shortcut Bar 

Figure 5.1 shows the GeneChip Software shortcut bar at startup. Additional 
buttons may be displayed in the shortcut bar, depending on the data types 
that are open (Figure 5.3). 

For example, if a scan image or cell intensity data are open, the shortcut bar 

includes the Image Views button . Click this button to view the cell 
intensity image in the main display area.
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Figure 5.3    
GeneChip Software shortcut bar
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Instrument Control Shortcut Bar 

Figure 5.4    
Instrument control shortcut bar

The instrument control shortcut bar does not display instrument buttons 
if the workstation is not connected to the instruments, or if the default 
configuration settings specify no fluidics station or scanner installed 
(select Tools → Defaults from the menu bar to view the default 
settings).

Instrument Control 
Shortcut Bar Functions 

Open Station 
Selection 
& Fluidics 
Station 
dialog box

Open the 
Scanner 
dialog box

Click a button to perform 
the following functions.
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Settings Shortcut Bar 

Figure 5.5    
Settings shortcut bar 
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Data Tree

The data tree displays the data in the system (process database), including:

■ experiments
■ image data
■ cell intensities 
■ analysis results 

There are two different views of the data tree (Figure 5.6): 

■ Classic View organizes the experiment by data type.
■ Project/Sample view organizes the experiment data by sample, and 

samples are organized by project.

Figure 5.6    
Data tree, Classic View (left), Project/Sample View (right)
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Data Tree Display Options
■ To select the data tree view, right-click the data tree and choose Classic 

View or Project/Sample View from the shortcut menu that appears.
■ To collapse or expand the list of data types in the tree, click the minus [-] 

or plus [+] sign next to each data type icon.

■ To hide (or display) the data tree, click the Data Tree button .

Data Tree Shortcut Menu
■ To view a shortcut menu of commands (specific to the data type), right-

click a data name in the tree (Figure 5.7). 

From the data tree you can:

■ open an experiment, an image, cell intensity data, or probe analysis 
data

■ update the data source tree to show new information in the system
■ display information about the data (attributes)
■ rename an experiment, sample, or project
■ analyze an image (generate the cell intensity data)
■ analyze the cell intensity data from an expression probe array 

(generates the probe analysis data)
■ generate an expression report

Figure 5.7    
Data tree shortcut menu for cell intensities
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Status Log

The status log displays system status messages (Figure 5.1).

1. To clear the messages, right-click the status log and select Clear 
Messages in the shortcut menu that appears.

2. To mute the error message sound, right-click the status log and remove 
the check mark from the Play Error Sound option.

3. Click the Status Log button  in the main toolbar to hide (or display) 
the status log. 

Renaming a Project, 
Sample, or Experiment

In the data tree project/sample view, you can rename an project, sample, or 
experiment. In the data tree classic view, you can rename an experiment.

1. Right-click the data tree, and select Project/Sample View from the 
shortcut menu that appears (Figure 5.8).

2. Expand the data tree, and right-click the item (project, experiment, or 
sample) that you want to rename.

3. Select Rename Project (Rename Experiment or Rename Sample) in 
the shortcut menu that appears.

⇒ A Rename dialog box appears (Figure 5.9).

Figure 5.8    
Data tree, project/sample view
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4. Enter a new name and click OK.

GCOS Data

There are three types of GCOS data. 

■ Probe information or library files are unique for each probe array type and 
contain information about the probe array design characteristics, 
scanning parameters, and default analysis parameters.

■ Fluidics protocol files define the hybridization, wash, or stain protocols 
run by the GeneChip® Fluidics Station.

■ Experiment data include the sample and experiment created by the user 
when an experiment is defined, as well as the other data types GCOS 
generates during an analysis: image data, cell intensity data, and probe 
analysis data.

For more information about the data types, see Appendix F, GCOS Data 
Types, on page 567.

Opening Data and Viewing Information

You can view information (attributes) about experiments, images, cell 
intensity data, and probe analysis data.

1. In the data tree, double-click the data name. Alternatively, right-click 
the data name in the tree and select Open from the shortcut menu that 
appears.

⇒ This displays the data in the main display area.

Figure 5.9    
Rename Project dialog box
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Many data types may be open at the same time, but you can view only 
one at a time in the main display area (except for a cascade or tile view 
of images or cell intensity data). 

2. Click a GeneChip Software shortcut bar button (Figure 5.3) to toggle the 
view between the different types of open data. 

3. To view information about the data, right-click the data name in the data 
tree and select Information in the shortcut menu that appears.

⇒ An Information dialog box appears (Figure 5.10 and Figure 5.11).

4. To copy experiment data information to the system clipboard, click 
Copy.

Figure 5.10    
Experiment information (left) and image information (right)
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Filtering Data

You may apply filters to the experiment data. The filters determine the data 
that GCOS displays in the data tree, the sample history view, workflow 
monitor, and the instrument control dialog boxes.

Filters are applied on a per user basis (identified by the logon name). The 
filters you specify do not affect the filters specified by other users.

1. Select Tools → Filters from the menu bar.

⇒ The Filters dialog box appears (Figure 5.12).

Figure 5.11    
Cell intensity data information (left) and probe analysis data information (right)
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2. Make selections from the drop-down lists to specify the filters. 

3. If you want to view the experimental data for a specific time period, 
choose the Date From or To options and click the drop-down arrows to 
select calendar dates. 

4. Click OK when finished to close the Filters dialog box and apply the 
filters.

⇒ The status bar indicates that filters are applied (Figure 5.13).

Figure 5.12    
Filters dialog box
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Figure 5.13    
Status bar in the lower right indicates filters applied 
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Configuring the Fluidics 
Station & Scanner

Before you use the fluidics station, check the fluidics station configuration 
and prime the fluidics station with appropriate buffer. For information on 
how to prime the fluidics station, and set up and run a fluidics protocol, see 
Chapter 8, Controlling the Instruments, on page 97.

Configuring the Fluidics Station

Before running a fluidics protocol, check to make sure the fluidics station(s) 
is properly configured.

1. Select Tools → Defaults from the menu bar.

⇒ The Defaults dialog box appears (Figure 5.14).

2. Click the Fluidics tab.

3. Confirm the number of fluidics stations installed is correct or enter a 
new value.

4. If desired, check mark Notification Message when protocol is 
complete to display a notification message when a fluidics protocol is 
completed.

Figure 5.14    
Defaults dialog box, Fluidics tab
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5. Click OK to close the Defaults dialog box.

Configuring the Scanner 

1. Select Tools → Defaults from the menu bar.

⇒ The Defaults dialog box appears (Figure 5.15).

2. Click the Scanner tab.

3. If the workstation is connected to the scanner, choose the Scanner 
Installed option.

4. To automatically turn the scanner laser on at startup, choose the Turn 
on Laser at startup option.

5. If the AutoLoader is present and you would like to disable the autorun 
feature and add cartridges one by one, choose the Enable Manual 
Mode option.

6. If the AutoLoader is present and you would like to disable it and use the 
GCOS software without the AutoLoader, choose Disable AutoLoader 
option. 

Figure 5.15    
Defaults dialog box, Scanner tab
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Chapter 6



Setting Up an Experiment 6

This chapter explains how to set up an experiment. You must define an 
experiment in GCOS before processing a probe array in the fluidics 
station or scanning a probe array. GCOS relies on the experiment 
information to direct the scanner and apply the correct cell and data 
analysis algorithms. 

Figure 6.1    
Assay & analysis flow chart
73



CHAPTER 6   Setting Up an Experiment74
Registering a Sample & 
Defining an Experiment 

You identify, or register, a sample by entering sample information 
(attributes) and associating the sample with a project (which may include 
several different samples) (Figure 6.3). 

To define an experiment, specify the type of probe array to which the target 
(sample) will be hybridized as well as other information relevant to the 
experiment. You may define one or more experiments per sample (for 
example, the different probe arrays of a multiple probe array set hybridized 
to the same sample). 

You can associate a barcode with an experiment. If you entered an 
Affymetrix® barcode (manually or using a keyboard wedge reader) GCOS 
automatically reads and displays the probe array type, lot number, and the 
expiration date. GCOS uses the experiment information to select scanner 
specifications for the probe array and identify the user-modifiable algorithm 
parameters for data analysis. 

You can also use a template (defined in GCOS Manager) to register a sample 
and define an experiment. For more information on creating a template, see 
Template Tab, on page 344.

GCOS automatically adds the sample and experiment information to the 
process database. This enters the experiment in the workflow and enables 
you to track its status in the workflow monitor. After you define an 
experiment, the Hybridization tab of the workflow monitor displays the 
experiment and associated sample (Figure 6.2). The Hybridization tab displays 
experiments that have not yet been processed in the fluidics station. See 
Workflow Monitor, on page 90 for more information about the workflow 
monitor.

The software uses sample and experiment information to maintain 
relationships among the experiment data (image, cell intensity data, probe 
analysis data), manage the workflow queue, and identify the user-modifiable 
algorithm parameters for data analysis.

GeneChip® Operating Software Server supports expression, 
Resequencing, Mapping, and Universal data.
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1. In the GeneChip Software shortcut bar, click Experiment Info , or 
select File → New Experiment from the menu bar.

⇒ The Experiment Information tab appears (Figure 6.3).

Figure 6.2    
Workflow monitor, hybridization tab

Sample Umb 243 is registered and associated with the ESC project.
Experiment ESC1 is defined and entered into the workflow.

Workflow monitor tabs. Hybridization tab shows the 
ESC1 experiment is defined, but not yet processed in 
the fluidics station.

Workflow monitor
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2. Enter a new sample name (up to 64 alphanumeric characters) or select 
an existing sample name from the drop-down list. This is required by 
GCOS. If you enter a new sample name, the sample type and project are 
also required.

Or, if you want to use a sample template, make a selection from the 
Sample Template drop-down list and enter the sample information. A 
template specifies the information fields available in the Experiment 
Information tab. You can define a template in GCOS Manager. For more 
information on creating templates, see Template Tab, on page 344.

3. Enter a unique experiment name (up to 64 alphanumeric characters). 
This is required by GCOS. Or, if you want to use an experiment 
template, make a selection from the Experiment Template drop-down 
list and enter the experiment information.

Figure 6.3    
Experiment Information tab

In the Experiment Information tab, items in bold are required entries.

Enter information 
here to register 
the sample

Enter information 
here to define 
the experiment
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The experiment name also serves as the name for the subsequent data 
types generated during the analysis. See Appendix F, GCOS Data Types, 
on page 567 for a description of GCOS data types. 

4. Make a selection from the Probe Array Type drop-down list (required 
by GCOS).

5. You may add a barcode (up to 64 characters). Enter a barcode value in 
the dialog box, or use a barcode reader to read the barcode directly from 
the probe array cartridge. 

If you use a barcode reader to read an Affymetrix® barcode from the 
probe array cartridge:
■ GCOS automatically fills in the probe array type, probe array lot and 

expiration date fields
■ the Probe Array Type drop-down list is disabled

6. To automatically publish expression probe analysis data:

a. Make a selection from the User Set drop-down list.

A user set is defined in GCOS Manager. The userset specifies the values 
for the user-modifiable expression algorithm parameters. For more 
information about user sets, see Userset Tab, on page 335.

b. Make a selection from the Publish Database drop-down list. See 
Publishing Data on page 245 for more information about publishing 
data.

c. To include the cell intensity data in the publish database, choose the 
Publish Intensities option.

GCOS has the ability to store barcodes. You can enter barcode 
information in either of two places: in the Experiment tab (Figure 6.3) or in 
the Fluidics dialog box (see Figure 8.4 on page 101). When you enter a 
valid barcode (maximum of 64 characters), GCOS stores the barcode 
with the experiment.

You must specify both a user set and a publish database, otherwise the 
probe analysis data will not be published. If you specify only a user set, 
the analysis proceeds using the analysis settings in the Expression 
Analysis Settings dialog box, but the data are not published. To view the 

Expression Analysis Settings dialog box, click Expression Settings  
in the Settings shortcut bar.
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7. Click the Save button .

⇒ This saves the experiment and displays it in the data tree.

After the probe array is processed in the fluidics station and scanned, click 
the Instrument Info tab to view information about the fluidics protocol and 
scanning parameters captured by GCOS (Figure 6.4).

The instrument information page is blank until the probe array has been 
processed in the fluidics station.

Publishing cell intensity data uses large amounts of computer memory. 
For example, publishing the probe analysis data for a high density probe 
array requires approximately 2 MB of disk space compared to 30 MB for 
both the probe analysis and cell intensity data.

If you specified a user set and publish database during experiment 
setup, the software prompts you for the publish database password 
before the experiment is saved.
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Figure 6.4    
Instrument Info tab
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Viewing or Editing an 
Experiment

1. To display an experiment, double-click the experiment name in the data 
tree. Alternatively, right-click the experiment name and select Open 
from the shortcut menu that appears.

2. To edit an entry, highlight the entry and enter the new information. 
Alternatively, right-click to open a shortcut menu of edit commands 
(Figure 6.5). 

3. To clear all fields, select Edit → Clear from the menu bar (equivalent to 
closing the experiment without saving).

Figure 6.5    
Experiment information and shortcut menu of edit commands

When connected to a GCOS server database, only users authorized by 
the System Administrator may delete data from the system using the 
GCOS Manager software. When operating using the local MSDE 
database, there is no data security.
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4. When finished, click the Close button  in the upper right corner of 
the window or select File → Close from the menu bar.

Before the experiment is closed, GCOS prompts you to save changes.
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Sample History & Workflow Monitor 7

This chapter explains how to use the sample history feature and 
workflow monitor to track samples and experiment data. 

Sample History

The sample history feature provides two different views of the samples in the 
system:

■ Data view shows the experiment data derived from a particular sample
■ Process view shows all stages (sample registration, experiment setup, 

hybridization, scan, grid alignment, cell intensity analysis, probe array 
analysis, and publishing) that are completed or pending for a sample

Displaying Sample History 

1. In the GeneChip Software shortcut bar, click Sample History .

⇒ The sample history data view appears (Figure 7.1).

The data view is the default. If the data view is not displayed, select 
View → Data from the menu bar.

The sample tree displays all assay samples. The expression folder 
contains all registered expression analysis samples. 

If filters have been applied, not all registered samples may be displayed. 
See Filtering Data on page 65 for more information about filters.
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2. To display a tree of the experiment data derived from a sample, click the 
sample name in the sample tree.

3. To display a list of data properties and their values (bottom right pane), 
click an item in the sample history tree.

Figure 7.1    
Sample history, data view

Click a sample in 
the tree to display 
experiment data 
derived from the 
sample

Sample tree

Sample history, data view

Property list

Click an item to 
display property 
values

Data tree
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Displaying Sample History Process View

The process view shows all completed or pending stages for a particular 
sample. 

1. In the GeneChip Software shortcut bar, click Sample History .

⇒ The sample history view appears.

2. To display the process view (Figure 7.2), select View → Processes from 
the menu bar.

The expression folder in the sample tree contains registered expression 
analysis samples. 

If filters have been applied, not all registered samples may be displayed. 
See Filtering Data on page 65 for more information about filters.
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Figure 7.2    
Sample history, process view
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3. To display the sample history tree, click a sample name in the sample 
tree.

Gray bullets indicate completed processes and green bullets indicate 
those that are pending. 

4. Click the plus sign [+] to the left of a process name to expand the 
information in the sample history tree (Figure 7.2). Use the scroll bars to 
the right or below the process tree to view the expanded information.

The tree displays the inputs and outputs for each process. For example, 
cell intensity data is the input to the probe array analysis process that 
generates probe analysis data.

5. To display a list of data properties (bottom right pane), click one of the 
following in the sample history tree (Figure 7.2):

■ sample name
■ experiment name
■ a process input or output 
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Workflow Monitor

When you define an experiment, it automatically enters the workflow and 
may be tracked through the sequential tabs in the workflow monitor (see 
Table 7.1).

Opening the Workflow Monitor

1. In the GeneChip Software shortcut bar, click Workflow Monitor . 

⇒ The workflow monitor appears (Figure 7.3).

Table 7.1
Workflow monitor tabs

Workflow Monitor Tab Displays...

Hybridization Experiments that have not been processed in the fluidics 
station.

Scan Experiments that have been processed in the fluidics station, 
but have not been scanned.

Grid Alignment Image data that require manual grid alignment.

Cell Intensity Analysis Image data that have been manually aligned, but have not been 
analyzed by the cell analysis algorithm (no cell intensity data 
exists)

Probe Array Analysis Cell intensity data that have not been analyzed by the expression 
analysis algorithm.

Publish Expression probe array analysis data that have not been 
published. 
Note: The GeneChip® DNA Analysis Software (GDAS) handles 
mapping and resequencing probe array data for publishing 
queue purposes.

If filters have been applied, not all registered samples or experimental 
data may be displayed.   See the Filtering Data on page 65 for more 
information about filters.
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2. To update the display, select View → Refresh from the menu bar.

This refreshes the workflow monitor so that it displays any new items 
added to the system since it was last opened.

3. To view a list of experiments, click the List button . To view sample 
and project information for each experiment, click the Details button 

.

4. To view experiment or data information, right-click the item and select 
Open Item from the shortcut menu that appears. Alternatively, select 
View → Open Item from the menu bar.

Figure 7.3    
Workflow monitor, details view

Data 
tree

Workflow monitor tabs

Shortcut
bar

Workflow monitor
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Workflow Monitor Tabs

1. Click a tab to view the items in that part of the workflow queue. 

2. To update the workflow monitor, select View → Refresh from the menu 
bar.

Hybridization Tab

The Hybridization tab displays experiments that have not been processed in 
the fluidics station. An experiment is automatically moved to the Scan tab 
after it has been processed in the fluidics station. 

If a probe array is not processed (hybridized, or washed and stained) in the 
fluidics station, the experiment must be manually advanced to the Scan tab. 
To manually advance an experiment to the Scan tab:

■ Right-click the experiment and click Advance to Scan in the shortcut 
menu that appears. Alternatively, click the experiment and select View → 
Advance to Scan from the menu bar.

Scan Tab

The Scan tab displays experiments that have been processed in the fluidics 
station, but have not been scanned. After the scan and grid alignment 
processes are completed, the cell intensity analysis is automatically run and 
the experiment is moved to the Probe Array Analysis tab. If the grid was not 
successfully aligned by the Alignment algorithm, the Grid Alignment tab 
displays the experiment.

Grid Alignment Tab

The Grid Alignment tab displays image data that require manual grid 
alignment. 

To manually align the grid:

1. Right-click the image data in the Grid Alignment tab and click Open 
Item in the shortcut menu that appears.

⇒ The image is displayed.

2. Align the grid at each corner of the image:

a. Click the  button in the Image window task bar and choose a 
corner.
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b. Place the mouse arrow over the grid (or sub-grid) perimeter (the 

arrow becomes a double arrow, ).
The diagonal orientation of the double arrow along the perimeter of 
a corner probe cell indicates horizontal and vertical adjustments can 
be made simultaneously using the click-and-drag method or by 
using the keyboard arrow keys.

c. Use the click-and-drag method or the keyboard arrow keys to adjust 
the horizontal or vertical position of the grid so that it is aligned over 
the corner of the image (Figure 7.4).

3. After you align the grid at each corner of the image, click the Save 

button  (Figure 7.4).

⇒ The grid is saved.

Figure 7.4    
Manual grid alignment: align the grid at each corner of the image and click the Save button
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Cell Intensity Analysis Tab

The Cell Analysis tab displays image data after the grid has been manually 
aligned. GCOS does not automatically generate the cell intensity data 
from an image that requires manual grid alignment. As a result, no cell 
intensity data exist for the image data under the Cell Analysis tab.

To generate the cell intensity data:

■ In the Cell Analysis tab, right-click the image and click Analyze Item in 
the shortcut menu that appears.

⇒ This generates the cell intensity data and places it under the Probe 
Array Analysis tab.

To generate the cell intensity data and probe array analysis data:

1. In the Cell Analysis tab, right-click the image and click Open Item in 
the shortcut menu that appears.

⇒ This displays the image data.

2. Select Run Analysis from the menu bar.

⇒ This generates the cell intensity and probe analysis data.

The Publish tab displays the probe analysis data.

Probe Array Analysis Tab

The Probe Array Analysis tab displays cell intensity data that have not been 
analyzed by the expression analysis algorithm (no probe array analysis data 
exists).

To analyze cell intensity data:

■ In the Probe Array Analysis tab, right-click the cell intensity data and click 
Analyze Item in the shortcut menu that appears. Alternatively, select 
View → Analyze Item from the menu bar.

After the cell intensity data have been analyzed and the probe analysis data 
have been generated, the experiment is moved to the Publish tab.

Publish Tab

The Publish tab displays expression probe analysis data that have not been 
published. The probe analysis data is removed from the Publish tab and the 
workflow monitor after it is published.
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Controlling the Instruments 8

This chapter describes how to use the GeneChip® Operating Software 
(GCOS) to control the GeneChip® Fluidics Station and the   
Affymetrix® GeneChip® Scanner 3000 or the GeneArray® 25000 
scanner (Figure 8.1).

Figure 8.1    
Assay & analysis flow chart
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The Fluidics Station

 The fluidics station hybridizes, washes, and stains the probe arrays. One 
workstation can control up to eight fluidics stations. Each fluidics station 
contains four modules and each module can independently process a probe 
array using a different fluidics protocol. Refer to the GeneChip® Fluidics 
Station User’s Guide for a description of the instrument, its components, and 
set up.

Priming the Fluidics Station 

Priming fills the fluidics station lines with wash buffers and deionized water. 
The GeneChip® Fluidics Station must be primed before it can be used to run 
assay protocols. Prime the fluidics station when:

■ the fluidics station is first turned on
■ a wash solution is changed
■ the fluidics station is to be used again after a shutdown has been 

performed
■ a module LCD window informs you that the module is not primed

1. Click the Fluidics button  in the Instrument Control shortcut bar or 
the main toolbar. Alternatively, select Run → Fluidics from the menu 
bar.

⇒ If more than one fluidics station is installed on the workstation, the 
Station Selection dialog box appears (Figure 8.2).

⇒ If only one fluidics station is installed on the workstation, the 
Fluidics Station dialog box appears (Figure 8.3). 

2. If more than one fluidics station is installed on the workstation, select 
the number designation of the current fluidics station from the Station 
Number drop-down list.

Before you use the fluidics station, check the fluidics station 
configuration and prime the fluidics station with appropriate buffer. For 
more information, see Configuring the Fluidics Station & Scanner, on 
page 68.
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3. Click OK to close the Station Selection dialog box. 

⇒ The Fluidics Station dialog box for the currently selected station 
appears (Figure 8.3).

4. Select Prime from the Protocol drop-down list and No Probe Array 
from the Experiment drop-down list for each module to be used.

5. Fill the intake buffer reservoirs A and B with the appropriate priming 
buffer. (Refer to the appropriate GeneChip® probe array package insert.) 

6. Empty the waste bottle and fill the water reservoir with deionized water. 

Figure 8.2    
Station Selection dialog box

Figure 8.3    
Fluidics Station dialog box, Prime protocol selected
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7. Load an empty, standard 1.5 mL microcentrifuge tube in the sample 
holder of each module to be primed.

8. Click Run for each module to be primed and follow the prompts in the 
fluidics station dialog box (also shown in the module LCD window). 
Alternatively, to prime all modules, choose the All Modules option. 
Click Run to start the priming on all modules and follow the prompts in 
the Fluidics Station dialog box.

⇒ The Fluidics Station dialog box and the module LCD window 
display the status of the procedure. The fluidics station is ready to 
use when priming is completed and Priming done, Ready appears 
in the module LCD window. 

Setting Up a Fluidics Protocol 

1. In the Instrument Control shortcut bar, click Fluidics . Alternatively, 
select Run → Fluidics from the menu bar.

⇒ If more than one fluidics station is installed on the workstation, the 
Station Selection dialog box appears (Figure 8.2).

⇒ If only one fluidics station is installed on the workstation, the 
Fluidics Station dialog box appears (Figure 8.4). 

2. If more than one fluidics station is installed on the workstation, select 
the number designation of the current fluidics station from the Station 
Number drop-down list.

3. In the Fluidics Station dialog box (Figure 8.4):

a. Select the current fluidics station module.

b. Choose an experiment and protocol from the drop-down lists. (Refer 
to the appropriate GeneChip® probe array package insert.)

c. If a barcode was entered when the experiment was created, enter the 
barcode using the keyboard or scan the barcode with an external 
barcode reader, and press the Tab key. This selects the experiment 
associated with the barcode from the database.

4. If the selected experiment has no barcode, you can associate a barcode 
with the experiment by entering the barcode using the keyboard or an 
external barcode reader.
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5. Click View to display information about the selected experiment.

6. Click Run to start the protocol on the selected module.

7. Repeat as necessary for other modules in the fluidics station(s).

Running the Fluidics Protocol

1. Load the probe array and sample vial holder containing the appropriate 
solution in each active module. 

Sensors in the fluidics station detect when the probe array and sample 
vial holder have been loaded. The process will proceed automatically 
from this point, although some protocols may require removal and 
substitution of the sample vial and solution. The Fluidics Station dialog 
box and each module LCD window display the status of the procedure.

2. After the protocol is finished, remove the probe array and inspect the 
probe array window for air bubbles. 

If filters have been applied, the Experiment drop-down list may not 
include all experiments. Click Filter to open the Filters dialog box and 
view or specify filters.

Choose the Include Hybridized Experiments option to include 
hybridized experiments in the drop-down list.

Figure 8.4    
Fluidics Station dialog box
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If air bubbles are present, reinsert the probe array into the fluidics 
station to automatically drain and refill the probe array with the last 
wash buffer used. (Refer to the appropriate GeneChip® probe array 
package insert.) If no bubbles are present, the probe array is ready to be 
scanned.

Running a Maintenance Protocol in All Modules

The software can start a maintenance protocol in all modules of the fluidics 
station using a single button click. A maintenance protocol (for example, 
CLEAN, DRAIN, HOME, PRIME, RECOVER, SHUTDOWN, or 
BLEACH) does not require an experiment.

1. Select a maintenance protocol from the Protocol drop-down list.

2. Select the All Modules option.

3. Click Run.

Resuming a Fluidics Protocol

GCOS tracks the progress of a fluidics protocol run. If the protocol stops 
before completion, it can be resumed at the point where it was interrupted.

1. When ready to resume the protocol, select the appropriate protocol from 
the Protocol drop-down list in the Fluidics Station dialog box.

2. Select the All Modules option.

3. Click Run.

⇒ The selected protocol is started in modules one through four of the 
fluidics station.

The resume feature is only available for fluidics protocols that display 
multiple steps in the Step drop-down list of the Fluidics Station dialog 
box. 

If you exit GCOS while a fluidics protocol is running, the resume feature 
will be unavailable upon startup of GCOS.
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Bypassing Steps in a Fluidics Protocol 

Some multi-step fluidics protocols can be started at any step, so that part of a 
protocol can be bypassed.

1. In the Instrument Control shortcut bar, click Fluidics . Alternatively, 
select Run → Fluidics from the menu bar.

⇒ The Fluidics Station dialog box appears (Figure 8.5).

2. Select the desired experiment, module, and protocol from the drop-
down lists in the Fluidics Station dialog box.

3. Select the desired beginning step from the Step drop-down list 
(Figure 8.5).

4. Click Run to start the fluidics protocol at the selected step.

Figure 8.5    
Fluidics Station dialog box, bypassing protocol steps 1 and 2 

The bypass function is only available for fluidics protocols that display 
multiple steps in the Step drop-down list of the Fluidics Station dialog 
box.



CHAPTER 8   Controlling the Instruments104
Editing a Fluidics Protocol

You can edit some hybridization and wash (Hybwash) protocols.

1. Select Tools → Edit Protocol from the menu bar.

⇒ The Fluidics Protocol dialog box appears (Figure 8.6).

2. Choose the fluidics protocol you want to edit from the Protocol Name 
drop-down list.

3. Highlight the parameter value you want to change and enter the new 
value. (Parameters values must be within the ranges in Table 8.1.) Enter a 
Hybridization Time of zero if only a wash is desired. To omit Wash A or 
B, enter zero for the Number of Wash A or Wash B cycles.

Modifications to a Hybwash protocol must be completed before it is run. 
Protocol changes made during a run do not affect the run in progress.

Figure 8.6    
Fluidics Protocol dialog box

Only the protocols in this list may be edited. All others are defined for 
specific applications and cannot be customized.
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4. To save the parameters under the same protocol name (overwrites the 
old protocol), click Save. 

5. To save the parameters under a new protocol name, enter a new name in 
the Protocol Name field, then click Save. 

⇒ This adds the new protocol name to the drop-down list.

6. Click Defaults to return the parameter settings to the default values.

7. Click Delete to delete the currently selected protocol from the system.

Editing the Fluidics ID Associated with a Fluidics Station

GCOS has the ability to determine the fluidics station identity (ID) and 
module number used to wash and stain a probe array. The local or GCOS 
server database keeps track of the fluidics station ID and the module number 
that processes an experiment (probe array).

To enable this feature, you must configure the registry using the regedit 
application so that GCOS can read the fluidics station ID and module 
number information from the registry.

1. Click the Windows Start menu button  and select Run.

⇒ The Run box appears (Figure 8.7).

Table 8.1
Valid ranges for hybridization or stain protocol parameters

Parameter Valid Range

Hybridization or stain time 0 - 86,399 seconds

Temperature 15 - 50° C

Number of Wash cycles 0 - 99

Mixes per Wash cycle 1 - 99
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2. Enter regedit at the command prompt and click OK.

⇒ The Registry Editor appears (Figure 8.8).

3. Open the HKEY_LOCAL_MACHINE registry hive.

4. Select the Software → Affymetrix → GeneChip → Fluidics node under 
the HKEY_LOCAL_MACHINE registry hive (Figure 8.9).

Figure 8.7    
Run box

Figure 8.8    
Registry Editor
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5. In the right window, right-click and select New → DWORD Value from 
the shortcut menu to create a new name/data pair. Repeat for each 
fluidics station whose ID is to be captured (Figure 8.10).

Figure 8.9    
Registry Editor

GCOS allows a maximum of eight fluidics stations to be controlled by a 
single workstation.
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6. Select the first newly created Name/Data pair, right-click the name, and 
select Rename from the shortcut menu. Rename the entry to “ID1”. 

The example in Figure 8.11 shows four Name/Data pairs that have been 
renamed ID1, ID2, ID3, and ID4.

Figure 8.10    
Registry Editor. create new name/data pair
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Figure 8.11    
Registry Editor, four newly created Name/Data pairs renamed ID1, ID2, ID3, and ID4
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7. To edit the value of an entry, double-click the entry.

⇒ The Edit DWORD Value box appears (Figure 8.12).

8. Select the Decimal option and enter a new value for the station ID.

9. Repeat step 7 and 8 to edit the value of each entry.

In this example, stations one through four have the ID 1001, 1002, 1003, 
and 1004 respectively (Figure 8.13). When a fluidics protocol is run on 
any of these stations, the fluidics station ID and the module number will 
be tracked in the process database.

Figure 8.12    
Edit DWORD Value box

Figure 8.13    
Registry Editor
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Scanning a Probe Array–
GeneChip® Scanner 3000

This section shows you how to scan a GeneChip® probe array using the 
Affymetrix® GeneChip® Scanner 3000. Make sure to read and understand 
Appendix D, Using the GeneChip® Scanner 3000, on page 491 before you 
scan a probe array.

Using Tough-Spots™ to Prevent Leaks

Tough-Spots™ are chemically inert polyvinyl labels that adhere to all 
plastics. Affymetrix recommends using 3/8-inch circle diameter Tough-
Spots to prevent leakage from the cartridge septa.

Before loading the probe array cartridge, follow this procedure to prevent the 
leaking of fluids from the cartridge during scanning.

Even if you have already applied Tough-Spots to the cartridge prior to 
hybridization or after washing, you must remove the old Tough-Spots and 
apply new ones before you load them into the AutoLoader.

Affymetrix recommends the use of Tough-Spots™  obtained from 
Affymetrix P/N 64-0158

or from

USA Scientific, Inc. P.O. Box 3565 Ocala, FL 34478 (800)LAB-
TIPS P/N 9185-0000

1. On the back of the probe array cartridge, clean excess fluid from around 
septa (Figure 8.14).

To reduce the risk of leakage, do not use excessively large pipette tips to 
pierce the septa. 
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2. Carefully apply one Tough-Spot over each of the two septa. Press to 
ensure that the spots remain flat. If a Tough-Spot does not apply 
smoothly; that is, if you observe bumps, bubbles, tears or curled edges, 
do not attempt to smooth them out. Remove the spot and apply a new 
one (Figure 8.15).

Figure 8.14    
The GeneChip® probe array cartidge

Figure 8.15    
Applying Tough-Spots™ to cartridge septa

Tough-SpotsTM
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Scanning a Probe Array

1. Press the on/off (I/O) switch on the front panel. The scanner’s on board 
computer will boot up. The bootup process takes a couple of minutes. 
During this time both the yellow and green lights will be on. 

2. Click the Start Scanner button  in the Instrument Control shortcut 
bar or the main toolbar. Alternatively, select Run → Start Scanner from 
the menu bar.

⇒ The Scanner dialog box appears (Figure 8.16). Note that the dialog 
also displays barcode information if you entered it when you 
created the experiment or set up the fluidics protocol.

3. To include scanned experiments in the Experiment Name drop-down 
list, choose the Include Scanned Experiments option.

By default, the Experiment Name drop-down list displays the 
experiments in the current directory that have not been scanned (no 
image data exists for the experiments). 

4. Select the experiment name of the probe array to be scanned from the 
Experiment Name drop-down list. Alternatively, set the focus to the 

Figure 8.16    
Scanner dialog box, laser off (left) and laser on (right)

If filters have been applied, the drop-down list may not include all 
experiments. Click Filter to open the Filters dialog box and view or 
specify filters.
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barcode field. If a barcode was associated with the experiment to be 
scanned, scan or manually enter the barcode from the probe array. This 
automatically retrieves the experiment from the database.

The Probe Array Type field automatically displays the probe array 
type that was entered during experiment setup. If a barcode was entered 
when the experiment was created or hybridized, the barcode field 
displays the barcode. 

GCOS sets the Number of Scans per probe array type (generally one 
for the Scanner 3000). You may change the number of scans in the 
Scanner dialog box (Figure 8.16). Multiple scans are statistically 
averaged to create the image data.

5. If it is necessary to rescan a probe array, select the experiment name 
from the Experiment Name drop-down list. Also select Include 
Scanned Experiments. 

6. Click Start in the Scanner dialog box. 

⇒ The GeneChip Scanner dialog box appears (Figure 8.17).

Increasing the number of scans increases the scan time as well as the 
amount of fluorophore bleaching and may result in lower fluorescence 
intensities.

The existing image data will be overwritten when the probe array is 
rescanned. To retain the original scan data, use the File → Save As 
command from the menu bar to save the original image data under a 
different name. 

When the software displays the Laser is On button in the scanner 
dialog box, the Start button is activated and you can start a scan.

Figure 8.17    
Scanner dialog box
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⇒ The scanner door opens and the chip transport mechanism raises to 
accept a probe array.

7. Load the probe array (Figure 8.18) into the scanner chip transport 
mechanism. Insert the probe array into the chip transport mechanism 
such that the front of the probe array (label side) faces to the rear of the 
scanner (Figure 8.19).

The scanner will enter Park mode if it is unattended for 15 minutes and 
will enter standby, or sleep, mode if it is unattended for 60 minutes (45 
minutes after entering Park mode). The green light will turn off and the 
yellow light will turn on. To reactivate the laser, click Turn Laser On in 
the scanner dialog box (Figure 8.16)and wait 10 minutes.

Figure 8.18    
Affymetrix® GeneChip® probe arrays: note the location of the flange. The scanner will accept 
the probe array in only one orientation.
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To view the scanner options, click Options in the GeneChip Scanner 
dialog box (Figure 8.20).

Figure 8.19    
Loading the probe array into the chip transport mechanism. Note that the front of the probe 
array faces to the rear of the scanner.

Do not force the probe array cartridge. If the cartridge does not drop 
easily into the chip transport mechanism, eject the cartridge and try 
again. If this does not remedy the situation, see Troubleshooting on page 
504 or call Affymetrix technical support.

If a probe array becomes lodged in the scanner, you can manually 
remove it. See Issues Relating to the Scanner’s Operation on page 505.
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8. Click OK in the GeneChip Scanner dialog box to start scanning the 
probe array.

During the scan, the green light will flash, and the yellow light will be 
off.

If the scan in progress feature is enabled (select View → Scan in 
Progress from the menu bar), the Image window automatically opens in 
the main display area when a scan starts. It displays the fluorescence 
intensity of the probe array at approximately 50 lines at a time as the 
scan progresses. 

To enable (or disable) this option, select View from the menu bar and 
place (or remove) a check mark next to Scan in Progress. 

After the scan is completed, GCOS:
■ saves the image data (displayed in the main display area)
■ aligns a grid on the image to identify the probe cells
■ automatically computes probe cell intensities and generates the cell 

intensity data
■ ejects the probe array

Figure 8.20    
Scanner options dialog box. You cannot change these options. This is for information only.

You cannot modify the scanner settings. GCOS automatically selects the 
appropriate settings based on the probe array type specified during 
experiment setup.
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Stopping a Scan

1. Click the STOP button  or select Run → Stop Scanner from the 
menu bar.

2. At the prompt, click Yes to stop the scanner or No to cancel stopping 
(Figure 8.21).

3. After you stop a scan, the scanner will automatically eject the chip. 

If you leave the scanner idle for an additional 15 minutes, the scanner 
will also enter “Park” mode. The yellow light will be off and the green 
light on.The chip transport mechanism will retract and the scanner door 
will close. You must click the Eject Chip button to open the scanner 
door and raise the chip transport mechanism.

Figure 8.21    
Stop scanner prompt

If you click Yes, the data from a partial scan will be lost. This is different 
from using earlier software or scanner versions where you could save 
the data from a partial scan.

If you rescan a probe array that has been partially scanned, the 
previously scanned area of the probe array may experience fluorophore 
bleaching. This will result in non-uniform fluorescence intensity across 
the probe array.

The scanner dialog box (Figure 8.16 on page 113) has an eject chip button. 
This is reserved for ejecting a chip after the scanner goes into sleep 
mode or when you must manually eject the chip for any other reason.

If the probe array cartridge becomes stuck, see Troubleshooting on page 
504 or call Affymetrix technical support.
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Shutting Down the Scanner

1. Close the GCOS software. 

2. Press the I/O (on/off) button on the front panel to turn off the 
instrument.

The laser also has a sleep mode that activates after 1 hour of inactivity.
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Scanning a Probe Array–
GeneArray® 2500 Scanner

GCOS controls the GeneArray® 2500 scanner and enables you to initiate a 
scan of a GeneChip® probe array, view the image data as they are collected 
during scanning, and analyze the data after the scan is completed. Refer to 
the Agilent GeneArray Scanner User’s Guide for a description of the 
instrument, its components, and set up.

Scanning a Probe Array 

1. Click the Start button  in the Instrument Control shortcut bar or the 
main toolbar. Alternatively, select Run → Start Scanner from the menu 
bar.

⇒ The Scanner dialog box appears (Figure 8.22).

For Windows 2000, Affymetrix recommends that you boot up the 
workstation first, log into the workstation, then turn the GeneArray® 
2500 scanner on and launch GCOS.

If you do not follow this sequence, the GeneArray® 2500 scanner may 
freeze and show the red LED. If this occurs, turn off then turn on the 
scanner.

This does not affect the Affymetrix GeneChip® Scanner 3000.

Do not attempt to scan until the laser has completed its warmup period 
(15 minutes).

Figure 8.22    
Scanner dialog box
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The Experiment Name drop-down list displays the experiments in the 
current directory that have not been scanned (no image data exists for 
the experiments).

 

After the scanner completes a scan, GCOS saves the scanned image 
data. 

2. To include scanned experiments in the Experiment Name drop-down 
list, choose the Include Scanned Experiments option.

3. Select the experiment name of the probe array to be scanned from the 
Experiment Name drop-down list. Alternatively, set the focus to the 
barcode field. If a barcode was associated with the experiment to be 
scanned, scan or manually enter the barcode from the probe array. This 
automatically retrieves the experiment from the database.

When you have choosen the experiment name, the Start button will 
highlight.

The Probe Array Type field automatically displays the probe array 
type that was entered during experiment setup. If a barcode was entered 
when the experiment was created or hybridized, the barcode field 
displays the barcode.

GCOS sets the Number of Scans according to the probe array type 
(generally two for the GeneArray® scanner). You may change the 
number of scans in the Scanner dialog box (Figure 8.22). Multiple scans 
are combined to create the image data.

4. If it is necessary to rescan a probe array, select the experiment name 
from the Experiment Name drop-down list.

If filters have been applied, the drop-down list may not include all 
experiments. Click Filter to open the Filters dialog box and view or 
specify filters.

Increasing the number of scans increases the scan time as well as the 
amount of fluorophore bleaching and may result in lower fluorescence 
intensities.

The existing image data will be overwritten when the probe array is 
rescanned. To retain the original scan data, use the File → Save As 
command from the menu bar to save the original image data under a 
different name. 
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5. Click Start in the Scanner dialog box. 

⇒ The GeneChip Scanner options window appears (Figure 8.23).

6. Load the probe array in the scanner and close the scanner door Figure 8.24 
and Figure 8.25).

Figure 8.23    
Scanner options window

Figure 8.24    
Affymetrix® GeneChip® probe arrays: note the location of the flange. The scanner will accept 
the probe array in only one orientation.
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7. To view the scanner options, click Options in the GeneChip Scanner 
options window (Figure 8.23).

⇒ The Scanner Options dialog box appears (Figure 8.26).

Figure 8.25    
Loading the probe array into the GeneArray scanner. 
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8. Click OK to close the Scanner Options dialog box.

9. Click OK in the GeneChip Scanner dialog box to start scanning the 
probe array.

If the view scan in progress feature is enabled (select View → Scan in 
Progress from the menu bar), the Image window automatically opens in 
the main display area when a scan starts. It displays the fluorescence 
intensity of the probe array line by line as the scan progresses. 

To enable (or disable) this option, select View from the menu bar and 
place (or remove) a check mark next to Scan in Progress. 

After the scan is completed, GCOS:
■ saves the image data (displayed in the main display area)
■ aligns a grid on the image to identify the probe cells

Figure 8.26    
Scanner options dialog box

Do not modify the scanner settings. GCOS automatically selects the 
appropriate settings based on the probe array type specified during 
experiment setup.
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■ automatically computes probe cell intensities and generates the cell 
intensity data

Stopping a Scan

1. Click the STOP button  or select Run → Stop Scanner from the 
menu bar.

2. At the prompt, click Yes to stop the scanner or No to cancel stopping 
(Figure 8.27).

Shutting Down the Scanner

1. Click the Scanner button  or select Run → Start Scanner from the 
menu bar.

⇒ The Scanner dialog box appears (Figure 8.28).

2. Click Turn laser Off in the Scanner dialog box.

Figure 8.27    
Stop scanner prompt

Selecting the same experiment name and repeating a scan of the probe 
array overwrites the image data of a partial scan that was saved. To 
retain the original scan data, use the File → Save As commands from 
the menu bar to save the image data under a different name prior to 
starting another scan of the probe array.
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3. If the Stop Scanner prompt appears, click Yes to turn off the laser power 
immediately and start the laser cool down routine.

The laser cool down routine lasts for several minutes and is finished 
when the cooling fan in the laser power supply shuts down. After the 
cooling fan shuts down, you can safely turn off the scanner power 
switch.

Editing the Scanner ID Associated with the GeneArray® Scanner

GCOS can determine the identity (ID) of the scanner used to scan a probe 
array. The local or GCOS server database tracks the scanner ID for an 
experiment (probe array). This feature is automatically enabled when using 
the GeneChip® 3000 scanner.

To enable this feature for the GeneArray® scanner, you must configure the 
registry using the regedit application so that GCOS can read the scanner ID 
information from the registry.

1. Click the Windows Start menu button  and select Run.

⇒ The Run box appears (Figure 8.29).

Figure 8.28    
Scanner dialog box
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2. Enter regedit at the command prompt and click OK.

⇒ The Registry Editor appears (Figure 8.30).

3. Open the HKEY_LOCAL_MACHINE registry hive.

4. Select the Software → Affymetrix → GeneChip → Scanner node under 
the HKEY_LOCAL_MACHINE registry hive (Figure 8.31).

Figure 8.29    
Run box

Figure 8.30    
Registry Editor
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5. In the right window, right-click and select New → String Value from the 
shortcut menu to create a new name/data pair (Figure 8.10).

Figure 8.31    
Registry Editor
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6. Right-click the newly created Name/Data pair and select Rename from 
the shortcut menu. Rename the entry to “ID” as shown in Figure 8.33.

Figure 8.32    
Registry Editor
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Figure 8.33    
Registry Editor, newly created Name/Data pair renamed “ID”
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7. To edit the value of the entry, double-click the entry. 

⇒ The Edit String box appears (Figure 8.34).

8. Rename the ID to a small string value of less than eight characters and 
click OK.

In this example, the scanner ID is renamed to AFFX8 (Figure 8.35). When 
an experiment is scanned on this scanner, the scanner ID will be tracked 
in the process database.

 

Figure 8.34    
Edit String box

Figure 8.35    
Registry Editor
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Chapter 9



Working with Images 9

This chapter explains how to view the scanned image or cell intensity 
data in the Image window. In the Image window, you can:

■ adjust image settings for the image or cell intensity data 
■ view data for a user specified probe cell 
■ highlight user specified tiles on the probe array
■ create bookmarks in the image data or cell intensity data
■ view and mask probe cell outliers

The Image Window

The Image window (Figure 9.1) displays scanned image data or the computed 
cell intensity data. 

The Image window opens when:

■ a probe array is scanned and the Scan in Progress feature is enabled  
See the section  on page 108 or Scanning a Probe Array–GeneArray® 
2500 Scanner on page 120. 

■ image data or cell intensity data are open (double-click the item in the 

data tree or click the Open button . Alternatively, select File → Open 
from the menu bar to view the data in the current directory).
135
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The Image window displays the image data or cell intensity data name (same 
as the experiment name entered during experiment setup) in the upper left 
corner. 

■ Use the scroll bars at the bottom and right side of the Image window to 
navigate the scan image. 

Figure 9.1    
Image data in the Image window

Image window task bar
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Commands in the Image Window Task Bar

Opening Multiple Image Windows

You can open and view more than one Image window in the main display 
area.

1. In the data tree, double-click the image data or cell intensity data that 
you want to view.

This displays each data type in the main display area.

2. Select Window → Cascade from the menu bar to display an overlapping 
cascade of the open Image windows. Select Window → Tile to display 
the open Image windows side by side (Figure 9.2).

Auto Automatically scales the intensity of the current image based 
on the range of intensity levels in a selected region of the scan 
image. See Adjusting the Image Settings on page 143.

Grid Toggles the grid on and off the scan image. (Press the G key.) 
See Viewing the Grid on page 138.

Mask Masks user selected areas of the scan image. Masked probe 
cells are excluded from the analysis. See Outliers on page 159.

Avg Calculates the average intensity and standard deviation for a 
user selected region of the scan image. See Calculating 
Average Intensity for User Specified Probe Cells in a Scan 
Image on page 143.

In Incrementally zooms in on the scan image. Press the I key. 
Alternatively, use a click-and-drag operation to draw a 
rectangle over the area of interest, then click In to zoom 
directly to the selected area.

Out Zooms out incrementally from the scan image (press the O 
key).

Full Zooms out completely to the full scan image view (press the 
Shift+O keys).

Enables the user to select and zoom directly to each corner of 
the scan image to check grid alignment. See Manually Aligning 
a Grid on page 139.
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3. If other data types are open (for example, an experiment or probe 
analysis data) and displayed in the main display area, click Image 
Views  in the GeneChip Software shortcut bar to display the open 
Image windows.

Working With the Grid

The Alignment algorithm uses the checkerboard image of the control probes 
located at the corners of the probe array to superimpose a grid on the scan 
image. The algorithm aligns the grid so that each square in the grid 
delineates a probe cell.

For a CustomSeq™ probe array, the algorithm aligns a grid composed of sub-
grids on the scan image from. The position of each sub-grid can be adjusted 
independent of the other sub-grids.

Viewing the Grid

1. To toggle the grid on or off, do one of the following:

■ click Grid in the Image window task bar (Figure 9.1) 

Figure 9.2    
Multiple image windows, cascade view (left) and tile view (right)
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■ press the G key

■ select View → Grid from the menu bar

2. To confirm the grid is properly aligned, do one of the following to check 
each corner of the scan image close up:

■ click the  button in the Image window task bar and choose a 
corner

■ press F5 (upper left corner), F6 (upper right corner), F7 (lower left 
corner), or F8 (lower right corner)

■ select View → Corner from the menu bar and choose the corner you 
want to view

Manually Aligning a Grid

On a rare occasion the grid may be misaligned and require manual 
adjustment. GCOS notifies you if manual adjustment is required. 

1. Align the grid at each corner of the image:

a. Click the  button in the Image window task bar and choose a 
corner.

b. Place the mouse arrow over the grid perimeter (the arrow becomes a 

double arrow, ).
The diagonal orientation of the double arrow along the perimeter of 
a corner probe cell indicates horizontal and vertical adjustments can 
be made simultaneously using the click-and-drag method or by 
using the keyboard arrow keys.

c. Use the click-and-drag method or the keyboard arrow keys to adjust 
the horizontal or vertical position of the grid so that it is aligned over 
the corner of the image (Figure 9.3).
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2. After you align the grid, click the Save button  or select File → Save 
from the menu bar.

⇒ The grid is aligned.

Figure 9.3    
Manual grid alignment: align the grid at each corner of the image
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Computing Cell Intensities

GCOS automatically generates the cell intensity data from the image data 
(Figure 9.5). The Cell Analysis algorithm analyzes the image data and 
computes a single intensity value for each probe cell on the array and saves 
the cell intensity data. 

 

Figure 9.4    
Assay & analysis flow chart
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Reanalyzing Image Data 

GCOS automatically generates the cell intensity data from the image data. In 
some cases you may want to generate new cell intensity data (for example, if 
the grid has been realigned). 

To reanalyze image data, right-click the open image and select Cell Grids → 
Recalculate Cell Intensity from the shortcut menu that appears.

Figure 9.5    
Image window, scan image data (left) and computed cell intensity data (right)
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Viewing a Scan Image or 
Cell Intensity Data

Calculating Average Intensity for User Specified Probe Cells in a Scan Image

GCOS can calculate the average intensity for a user-specified group of probe 
cells in the image data.

1. In the image, use the click-and-drag method to select the probe cells of 
interest.

⇒ The selected probe cells are outlined in the image.

2. Click AVG in the Image window task bar (Figure 9.1 on page 136).

⇒ The status bar displays the average intensity and the standard 
deviation.

3. Position the mouse arrow inside the selected area of the image.

⇒ A pop-up tool tip displays the average intensity and the standard 
deviation for the selected group of probe cells (Figure 9.6).

Adjusting the Image Settings

You can adjust image settings (intensity range, color, coordinates, and 
highlights) for image or cell intensity data. The image settings may be 
adjusted for the current data only or globally for all subsequently opened 
image or cell intensity data.

Figure 9.6    
Average intensity and standard deviation for user-specified probe cells in the image data (.dat)

Average Intensity = 17328, Std Dev = 15989.19
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Making Adjustments to the Current Image or Cell Intensity Data Only
■ To adjust the settings for the current image or intensity data only, do one 

of the following:

■ Click the Image settings button .
■ Press the S key. 

■ Select Edit → Image Settings from the menu bar.

⇒ This displays the Image Settings dialog box for the active image or 
cell intensity data (Figure 9.7).

 

All settings (except the color setting) in the Image Settings dialog box 
apply only to the current image or cell intensity data and do not affect 
other image or intensity data. The settings (except for the color setting) 
are not saved after you close the image or intensity data.

Figure 9.7    
Image Settings dialog box for the active image or cell intensity data (left); Defaults dialog box, 
Image Settings tab (right)

Click the S key Select Tools → Defaults from the menu bar

Settings for the active image or cell intensity 
data only.

Default settings for subsequently opened 
image or cell intensity data
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Making Global Adjustments to Subsequently a Opened Image or Cell 
Intensity data

■ To adjust settings globally, select Tool → Defaults from the menu bar. 

⇒ This displays the Image Settings tab of the Defaults dialog box 
(Figure 9.7). 

Setting the Intensity Range

GCOS records a dynamic intensity range from 0 to 65,000 and provides 256 
colors from black through white for image display. The intensity range for 
image or cell intensity data is divided into 256 bins and each bin is assigned 
a color or gray scale. 

You may enter a new lower or upper limit for the intensity range associated 
with image or cell intensity data and apply this subset of the dynamic range 
to the image. Lowering the upper limit increases the image brightness and 
raising the lower limit decreases the brightness. This process is called image 
scaling and can be used to adjust the display of image or cell intensity data 
for optimum viewing. Alternatively, GCOS can automatically scale the 
image using the minimum and maximum pixel intensities of the image.

1. To autoscale the current image, choose the Autoscale option in the 
Image Settings dialog box (Figure 9.7) 

2. Click OK to automatically scale the image.

When the Image Settings dialog box is reopened, it displays the 
minimum and maximum pixel intensities used to scale the image.

3. To return the intensity settings (autoscale option and intensity range) to 
the defaults in the Defaults dialog box, click Defaults in the Image 
Settings dialog box.

The settings specified in the Image Settings tab of the Defaults dialog 
box do not affect open image or cell intensity data, but are applied to all 
subsequently opened image or cell intensity data. These default image 
settings are saved when the image is closed.
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Selecting Color Settings
■ To display the image or cell intensity data in:

■ Gray scale - choose the Gray color option (Figure 9.7).
■ Pseudo color - choose the Pseudo Color option.

⇒ This applies rainbow colors to the intensity scale.
■ To display a gray scale or pseudo color bar at the top of the Image 

window, choose the Color Bar option.

Selecting Display Coordinates
■ Click the image to display image coordinates.

⇒ A red cross hairs  marks the location.

The status bar (lower left in the main window) displays the intensity 
data and x,y coordinates of a probe cell or pixel indicated by the cross 
hairs. 

If you choose the Cell option in the Image Settings dialog box (Figure 9.7), the 
status bar and a pop-up tool tip display the x,y coordinates of the cell, the 
cell intensity, and the pixel intensity (Figure 9.8). 

If you choose the Pixel option, the pop-up tool tip and the status bar display 
the x,y coordinates of the pixel and the pixel intensity (Figure 9.8).

Only the Cell option is available for cell intensity data.



  Affymetrix®  GeneChip®  Operating Software User’s Guide 147
Figure 9.8    
Image data, probe cell coordinates (top) and pixel coordinates (bottom)

Cell X = 186, Y = 41, Cell Intensity = 22561.8, Pixel Intensity = 24692

Pixel X = 1727, Y = 573, Intensity = 22409
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Specifying Highlight Colors

You may specify new highlighting colors for the grid, masked cells, outlier 
cells, or highlighted probe array cells (features).

1. Click Highlights in the Image Settings dialog box (Figure 9.7 on page 
144).

⇒ The Highlight Colors dialog box appears (Figure 9.9). 

2. To change the color of a particular item (for example, the grid overlay):

a. Click the associated color box in the Highlight Colors dialog box.

⇒ The Color palette is displayed (Figure 9.10).

Figure 9.9    
Highlight Colors dialog box
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b. To select a predefined color, click one of the basic colors.

c. To define a custom color, click Define Custom Colors, then use the 
click-and-drag method to move the cross hairs in the custom color 
field. Adjust the color brightness using the luminosity scale to the 
right. When finished, click Add to Custom Colors to apply the 
color.

⇒ The new color is applied to the selected item.

d.  Click OK to close the Color palette.

Image Display Options

Intensity Display

You can view the probe cell intensity in the image data as a measured, 
average, or difference image. 

1. Open the image data.

2. Select View → Image from the menu bar, then choose one of the three 
viewing options: Measured, Difference, or Average.

Figure 9.10    
Color palette

Luminosity scaleCustom color field
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Measured Image View

The measured image view (Figure 9.11) displays the raw data from a scanned 
image.

Cell Image View

The cell image view (Figure 9.12) displays the probe cell intensity values 
calculated by the Cell Analysis algorithm.

Difference Image View

The difference image view (Figure 9.13) displays the absolute difference 
between the measured and the cell intensity values for each pixel. The 
difference image of a probe cell with hybridized target typically displays 
high intensity at the perimeter where there is a large difference between the 
measured and the cell intensity value, but displays low intensity at the center 
due to small differences between the measured and the cell intensity values. 

Figure 9.11    
Measured image view

Figure 9.12    
Cell image view
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The difference image of a hybridized probe array is the reverse of the 
measured image (Figure 9.11) where the hybridized probe cells appear bright 
at the center and dark at the perimeter. The difference image helps assess the 
uniformity of the hybridization signal in the probe cell and whether the grid 
lines properly delineate the probe cells.

Viewing Probe Cell Data

You can click a probe cell (feature) in the image or cell intensity data to 
obtain more information about the feature and the associated gene.

To display the probe cell data for image or cell intensity data, do one of the 
following:

■ Double-click the probe cell of interest.

■ Click the probe cell of interest; right-click the image, and select View 
Probe Cell Data in the shortcut menu that appears.

■ Click a probe cell of interest and select View → Probe Cell Data from 
the menu bar.

⇒ The Probe Cell Data dialog box appears (Figure 9.14).

Click other probe cells in the image to update the displayed data.

Figure 9.13    
Difference image view
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Figure 9.14    
Probe cell data, GeneChip® Hu6800 probe array

Cell Coordinates The probe cell x and y coordinates in cell units.

Intensity The cell intensity calculated by the cell analysis 
algorithm.

Probe Set The identifier of the probe set containing the probe cell.

Direction The direction (sense or antisense) of the target (sample).

Target Base The expected nucleotide at the position that corresponds 
to the substitution position of the probe.

Probe Base The actual nucleotide located at the substitution position 
of the probe.

Position The numbered position of the perfect match and 
mismatch probe pair within the probe set (for example, 
1-20 for a probe set consisting of 20 probe pairs).

Tile The identification number for the probe set.
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Viewing Probe Set 
Information

Viewing Probe Array Tiling Information

You can view probe array tiling information for the current image or cell 
intensity data in the Image window.

1. Right-click the image or cell intensity data and click View Probe Tiling 
in the shortcut menu that appears. Alternatively, select View → Probe 
Tiling from the menu bar.

⇒ The View Probe Tiling dialog box appears (Figure 9.15).
 

The Features tab of the View Probe Tiling dialog box lists all probe sets 
tiled on the probe array for the current image or cell intensity data.

2. In the Features tab, press and hold the Ctrl key while you click the 
features of interest (Figure 9.15). Click Apply when the selection is 
completed.

⇒ This highlights the probe sets in the image or cell intensity data that 
correspond to the selected features so that hybridization data may 
be quickly located (Figure 9.16).

Figure 9.15    
View Probe Tiling dialog box
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3. Click OK to close the View Probe Tiling dialog box.

Viewing Probe Cell Data for a Highlighted Probe Set(s)

1. In the image or cell intensity data, click a probe cell of interest.

⇒ This places the red cross hairs over the feature.

2. Right-click and select View Probe Cell Data from the shortcut menu 
that appears. Alternatively, select View → Probe Cell Data from the 
menu bar.

⇒ This displays the probe cell data (Figure 9.17).

Figure 9.16    
Highlighted probe cells in the image data

Turn off the grid (press the G key) so that the highlighted probe cells can 
be easily seen. The highlighting color for the selected probe cells may 
be changed. See Specifying Highlight Colors on page 148.
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3. To place the red cross hairs over the next feature of the highlighted 
probe set, click the image (to return focus to the Image window) and do 
one of the following:
■ Press the N key.
■ Right-click the image and select View Next Highlight in the shortcut 

menu that appears.

■ Select View → Next Highlight from the menu bar.

If it is open, the Probe Cell Data dialog box is automatically updated 
with the new probe cell data.

If you click another probe cell, GCOS automatically updates the probe 
Cell Data dialog box.

Figure 9.17    
Probe cell data for a selected feature
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4. To return the cross hairs to a previous feature, do one of the following:

■ Press the P key.
■ Right-click the image and select View Previous Highlight in the 

shortcut menu that appears.

■ Select View → Previous Highlight from the menu bar.

5. To remove all highlights, do one of the following:

■ Press the E key.
■ Right-click the image and select Clear Highlights from the shortcut 

menu that appears.

■ Select View → Clear Highlights from the menu bar.

Highlighting Tiles on the Probe Array

You can highlight: 

■ all tiles or a particular tile on the probe array (by tile number)
■ all positions or a particular position of all tiles or a selected tile

1. Right-click the image or cell intensity data and click View Probe Tiling 
in the shortcut menu that appears. Alternatively, select View → Probe 
Tiling from the menu bar.

⇒ The View Probe Tiling dialog box appears (Figure 9.18).

2. Click the Positions tab, select a Position and Tile, then click Apply.

⇒ This highlights the selection in the image.

Figure 9.18 shows two examples: all positions of tile number 3000 
highlighted and only position 15 of tile 3000 highlighted.

Highlights are automatically cleared when you close the image or cell 
intensity data.
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Bookmarks

A bookmark denotes a specific area of the image or cell intensity data at a 
particular magnification level. Bookmarks make it easy to quickly view the 
hybridization data at a specific location in different images. 

When you select a bookmark, the Image window automatically displays the 
image location at the magnification specified by the bookmark.

Creating a Bookmark

1. Use the task bar zoom commands and scroll bars in the Image window 
to locate the image area of interest at the desired magnification level.

2. Right-click the image and select View Bookmarks → Add Bookmark 
from the shortcut menu that appears. Alternatively, select View → 
Bookmarks → Add Bookmark from the menu bar.

⇒ The Add Bookmark dialog box appears (Figure 9.19).

Figure 9.18    
Cell intensity data, all positions of tile 3000 highlighted (left), position 15 of tile 3000 highlighted (right)
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3. Enter a name in the Bookmark Name box or use the default name 
Bookmark 1, 2,3....

4. Click OK to create the bookmark.

Viewing Bookmarks

To view bookmarks, do either of the following:

■ Right-click the image and select View Bookmarks → Edit Bookmarks 
from the shortcut menu that appears. Alternatively, select View → 
Bookmarks → Edit Bookmarks from the menu bar.

⇒ The Edit Bookmarks dialog box displays a list of all the bookmarks 
(Figure 9.20).

■ Select View → Bookmarks from the menu bar. (A maximum of 20 
bookmark names are displayed here.)

Figure 9.19    
Add Bookmark dialog box

Figure 9.20    
Edit Bookmarks dialog box
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Commands in the Edit Bookmarks Dialog Box

Highlight the bookmark name in the Edit Bookmarks dialog box, then click 
the command of interest.

Outliers

Outliers are probe cells that are obscured or non-uniform in intensity (for 
example, probe cells with bright or dark streaks). The Outlier Detection 
algorithm automatically determines whether a probe cell is an outlier.

You can exclude or mask outliers from a probe array in an expression 
analysis. The Statistical Expression algorithm (generates the probe analysis 
data from the cell intensity data) ignores the probe cell data from masked 
outliers.

Viewing Outliers

1. Open the image or cell intensity data of interest.

2. Right-click in the Image window and select View → Cells Masked from 
the shortcut menu. Alternatively, select View → Cells → Outliers from 
the menu bar. 

⇒ This highlights outlier probe cells with diagonal lines . 

Delete Permanently removes the selected bookmark.

Rename Allows the selected bookmark to be renamed.

Go To Displays the selected bookmark in the image.

Close Closes the Edit Bookmarks dialog box.

The color that highlights outliers may be changed. See Specifying 
Highlight Colors on page 148.
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Masking Outliers

1. Open the image or cell intensity data of interest.

2. Select Edit → Mask All Outliers from the menu bar.

⇒ All outliers identified by the Outlier Detection algorithm are 
masked. 

3. To mask user-specified probe cells:

a. Use the click-and-drag method to select a probe cell or area of the 
image to be masked.

b. Select Edit → Mask Cells from the menu bar. 

4. To view masked probe cells, right-click in the Image window and select 
View Cells → Masked from the shortcut menu that appears.

Unmasking Outliers

1. Select Edit → Unmask All Cells from the menu bar.

⇒ This removes all masking. 

2. To unmask only a selected probe cell or area:

a. Use the click-and-drag method to select a probe cell or area of 
interest.

b. Select Edit → Unmask Cells from the menu bar.

Turn off the grid (press the G key) to easily view the masked probe cells 
highlighted with diagonal lines.

If you manually adjust the grid or change the probe array type in the 
experiment, the mask or outlier data will be lost when new cell intensity 
data are generated.
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The Expression Analysis algorithm analyzes cell intensity data from 
GeneChip® expression arrays (Figure 10.1). 

This chapter explains how to:

■ perform single-array or comparison array expression analysis
■ view the expression probe analysis data in graphical or tabular format in 

the Expression Analysis window (EAW)
■ generate a report

Figure 10.1    
Assay & analysis flow chart
163
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Overview of Single-Array 
& Comparison Array 
Expression Analysis

Single-Array Expression Analysis

A single-array expression analysis examines the cell intensity data from one 
experiment (GeneChip® probe array). For each transcript represented on the 
probe array, the expression algorithm computes the:

■ Detection call (present, absent, or marginal (unable to call the transcript 
present or absent), or no call)

■ Detection p-value
■ Signal (background-subtracted and adjusted for noise)
■ Stat Pairs
■ Stat Pairs Used

GCOS saves the probe analysis or chip data.

To run a single-array analysis (Figure 10.2):

■ confirm the defaults or specify new values in the Expression Analysis 
Settings dialog box

■ in the data tree, select the cell intensity data for the analysis 
■ analyze the cell intensity data and view the probe analysis data in the 

Expression Analysis window (EAW)
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Figure 10.2    
Single-array expression analysis 

Single-Array Expression Analysis

1. Expression Analysis Settings   

In the Settings shortcut bar, click the  
shortcut button to open the Expression 
Analysis Settings dialog box. Confirm or 
specify new analysis settings. Do not 
choose Use Baseline Comparison File 
option.

2. Select & Analyze Cell Intensity Data In 
the data tree, right-click the cell intensity 
data and select Analyze from the shortcut 
menu.

3. View Probe 
Analysis Data 
Expression Analysis 
window (EAW) 
displays single-array 
probe analysis data.
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Comparison Expression Analysis of an Experiment & Baseline

A comparison analysis compares the cell intensities of the same probe set on 
two different probe arrays (an experiment and baseline of the same probe 
array type) to determine the relative change in the expression level of a 
transcript.

For each transcript represented on the probe array, the expression algorithm 
computes the:

■ Change call (increase, marginal increase, no change, marginal decrease, 
decrease) or no call

■ Change Detection p-value
■ Signal Log Ratio (background-subtracted and adjusted for noise)
■ Signal Log Ratio Low
■ Signal Log Ratio high
■ Stat Common Pairs

GCOS saves the probe analysis data.

To run a comparison analysis (Figure 10.3):

■ select the baseline probe analysis data
■ confirm the default expression analysis settings or specify new 

values
■ select the experiment cell intensity data from the data tree
■ analyze the experiment cell intensity data and view the comparison 

probe analysis data in the EAW
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Figure 10.3    
Comparison expression analysis of an experiment and baseline

1. Expression Analysis Settings    

In the Settings shortcut bar, click the  
shortcut button to open the Expression 
Analysis Settings dialog box. Confirm or 
specify new analysis settings. Choose 
the Use Baseline Comparison Data 
option. Click Browse to select the 
baseline probe analysis data.

2. Select & Analyze Cell Intensity Data 
In the data tree, right-click the cell 
intensity data and select Analyze from 
the shortcut menu.

3. View Probe 
Analysis Data 
Expression Analysis 
window (EAW) 
displays comparison 
analysis output.

Comparison Array Expression Analysis Compares an Experiment & Baseline
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Expression Analysis 
Settings

The Statistical Expression algorithm relies on the expression analysis 
settings to derive biologically meaningful results from the hybridization 
intensity data. The Expression Analysis Settings dialog box (Figure 10.4) 
displays the:

■ the type of expression probe array for the analysis

■ a scaling or normalization factor (for more information, see Appendix E, 
Expression Algorithm, Expression Analysis Metrics & Settings, on 
page 515)

■ probe mask definition (for more information, see Appendix E on page 
515)

■ the baseline data selected for a comparison analysis
■ the user-modifiable parameters of the expression analysis algorithm (for 

more information, see Appendix E on page 515)

Figure 10.4    
Expression Analysis Settings dialog box, Baseline tab

Before running a single-array or comparison analysis, confirm the 
defaults or specify new values for the expression analysis settings.
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1. To open the Expression Analysis Settings dialog box (Figure 10.4), click 

Expression  in the Settings shortcut bar.

2. Click a tab to view each type of setting. See Expression Analysis 
Settings on page 532 for more information about the settings and how to 
change them.

The expression analysis settings are saved on a per user basis. Changes 
made by one user (identified by the logon name) do not affect the 
settings of other users.

Single-Array Expression 
Analysis

A single-array expression analysis analyzes the cell intensity data of a 
GeneChip® expression probe array. For each transcript represented on the 
probe array, the algorithm computes a Detection call, Detection p-value, and 
Signal. 

1. Open the Expression Analysis Settings dialog box (Figure 10.4), and:

■ select the probe array type for the baseline from the Probe Array 
Type drop-down list 

■ click the Baseline tab and confirm that the Use Baseline 
Comparison File option is not chosen

■ confirm or change the other expression analysis settings as desired

2. To analyze cell intensity data, do one of the following:

■ in the data tree, right-click the cell intensity data name (or image data 
name), then click Analyze in the shortcut menu that appears

To compare the probe analysis data of several experiments, scale the 
experiments to the same target intensity using the All Probe Sets or 
Selected Probe Sets scaling option. See Scaling Tab on page 533.

An expression analysis run from the data tree, menu bar, toolbar, or 
workflow monitor uses the expression analysis settings in the 
Expression Analysis Settings dialog box. The userset specified during 
experiment setup is not applied. For more information on usersets, see 
Userset Tab on page 335.



CHAPTER 10   Gene Expression Analysis170
■ select File → Analyze from the menu bar and choose the cell 
intensity data that you want to analyze from the Analyze dialog box 
that appears.

■ if the cell intensity data or image data is open, click the Analyze . 
Alternatively, select Run → Analysis from the menu bar.

⇒ The Save Results As dialog box appears (if chosen as a default 
option, see Analysis Settings on page 263) and displays the probe 
analysis data default name (same as the experiment name specified 
during experiment setup) (Figure 10.5).

3. If an analysis was previously run and you want to save the current 
results without overwriting the previous results, enter a new name in the 
Save Results As dialog box. 

4. Click OK.

⇒ This closes the Save As dialog box and runs the single-array 
analysis.

When the analysis is finished, the Expression Analysis window (EAW) 
displays the probe analysis data (Figure 10.6). 

The status log (Figure 10.6) displays:

■ the name of the probe analysis data 
■ the location of the probe analysis data 
■ a message indicating when the analysis is completed

If the status log is not displayed, click the Status Log button  or 
select View → Status Bar from the menu bar.

Figure 10.5    
Save Results As dialog box

The Expression Analysis Settings dialog box appears next if chosen as a 
default option. For more information on this default setting, see Analysis 
Settings on page 263.



  Affymetrix®  GeneChip®  Operating Software User’s Guide 171
 

If the EAW is already open, the results are added to the open window 
and it may be necessary to use the scrollbars at the bottom and right 
side of the EAW to see the newly added results.

Figure 10.6    
Expression Analysis Window (EAW), pivot tab, single-array analysis data

Status 
log

Data 
tree

EAW

Shortcut
bar
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Comparison Expression 
Analysis

A comparison expression analysis compares the cell intensity data of an 
experiment to a baseline GeneChip® expression probe array (of the same 
probe array type). The comparison analysis identifies the relative change in 
the expression level of each transcript represented on the probe array. 

For each transcript represented on the array, the Statistical Expression 
algorithm computes a Change call, Change p-value, Signal Log Ratio, 
Signal Log Ratio low, and Signal Log Ratio high. 

Selecting the Baseline

1. Open the Expression Analysis Settings dialog box (Figure 10.7) (click 

Expression  in the Settings shortcut bar).

2. Select the probe array type for the baseline from the Probe Array Type 
drop-down list.

A single-array analysis of the baseline must be run prior to running a 
comparison analysis of the experiment and baseline.

Figure 10.7    
Expression Analysis Settings dialog box
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3. Click the Baseline tab and choose the Use Baseline Comparison File 
option.

4. Click Browse.

⇒ The Open dialog box appears (Figure 10.8).

5.  Select the baseline data and click OK.

Running the Comparison Analysis

1. To run the comparison analysis of an experiment and baseline, do one of 
the following:
■ in the data tree, right-click the experiment cell intensity data or 

image, and click Analyze in the shortcut menu that appears

■ select File → Analysis from the menu bar and choose the experiment 
cell intensity data from the Analyze dialog box that appears

■ if the cell intensity data or image is open, click the Analyze button 

. Alternatively, select Run → Analysis from the menu bar.

⇒ The Save Results As dialog box appears (if chosen as a default 
option, see Analysis Settings on page 263) and displays the default 
name for the probe analysis data (same as the experiment name 
specified during experiment setup) (Figure 10.9).

Figure 10.8    
Open dialog box
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2. Enter a new name in the Save Results As dialog box if an analysis was 
previously run and you want to save the current results without 
overwriting the previous results. Click OK.

⇒ The Expression Analysis Settings dialog box appears next if 
chosen as a default option (Figure 10.10). For more information on 
this default setting, see Analysis Settings on page 263.

3. If the Expression Analysis Settings dialog box appears, review and 
confirm the settings for the probe array type and baseline data:

a. In the Baseline tab, select the probe array type for the baseline from 
the Probe Array Type drop-down list (Figure 10.10). 

Figure 10.9    
Save Results As dialog box

Figure 10.10    
Expression Analysis Settings dialog box, baseline tab
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b. Choose the Use Baseline Comparison Data option, then click 
Browse

⇒ The Open dialog box appears (Figure 10.11).

c. Double-click the baseline data. Alternatively, click the baseline data, 
then click Open or OK.

⇒ The Expression Analysis Settings dialog box displays the 
selected baseline data (.chp) (Figure 10.12).

Figure 10.11    
Open dialog box
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4. In the Expression Analysis Settings dialog box (Figure 10.12), click the 
normalization tab and specify a normalization option for the 
experimental data.

5. Confirm or specify other probe array analysis parameters as desired. For 
more details on the parameters, see Appendix E, Expression Algorithm, 
Expression Analysis Metrics & Settings, on page 515.

6. Click OK.

⇒ The Expression Analysis Settings dialog box closes and the 
comparison analysis runs.

When the analysis is finished, the Expression Analysis window (EAW) 
displays the probe analysis data (Figure 10.13). 

Figure 10.12    
Expression Analysis Settings, baseline tab displays the baseline data for the comparison 
analysis

You need only specify a normalization option for the experiment, not the 
baseline. You may use the scaling option instead of the normalization 
option. If you use the scaling option, scale both the experiment and the 
baseline. For more details on normalization and scaling, see Appendix 
E, Expression Algorithm, Expression Analysis Metrics & Settings, on 
page 515. 
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The status log (Figure 10.13) displays:
■ the name of the probe analysis data 
■ the location of the probe analysis data
■ a message indicating when the analysis is completed

If the status log is not displayed, click the Status Log button  or 
select View → Status Bar from the menu bar.

If the EAW is already open, the results are added to the open window 
and it may be necessary to use the scrollbars at the bottom and right 
side of the EAW to see the newly added results.

Figure 10.13    
Expression Analysis Window (EAW), comparison probe analysis data, pivot tab 
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Expression Analysis 
Tabular Data

The Expression Analysis window (EAW) has three tables that display the 
tabular and graphic analysis output for gene expression assays:

■ Analysis information table
■ Metrics table
■ Pivot table

 The EAW opens after you complete an expression analysis or when you 
open expression probe analysis data. 

You can open more than one set of probe analysis data in the EAW. Use the 
EAW scroll bars to view all of the results. A second toolbar and additional 
menu bar commands are available in the EAW (see Appendix I, Toolbars, 
Hot Keys, & Windowpanes, on page 613).

Analysis Information Table

The analysis information table (Figure 10.14) displays experiment and sample 
information entered during experiment setup, values for user-modifiable 
expression analysis algorithm settings, and other information. Each column 
in the analysis information table represents one analysis (probe array).
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Figure 10.14    
Expression Analysis window, analysis information table
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Exporting Analysis Information

You can export the data in the analysis information table to a tab delimited 

text file (.txt) or Microsoft® Excel file (.xls).

1. If it is not already open, open the EAW (in the data tree, double-click the 
probe analysis data that you want to export).

2. Click the Analysis Information tab.

3. To export a user-selected portion of the data table, highlight the cells of 
interest.

4. Click the Save button . Alternatively, select File → Save As from the 
menu bar.

⇒ The Save As dialog box appears (Figure 10.15).

5. Choose a Save Option:
■ Save All exports all of the analysis information table data to the text 

file.
■ Save Selected exports only the user-selected portion of the analysis 

information table to the text file.

6. Enter a name for the text file and confirm or select another directory for 
the text file.

Figure 10.15    
Save As dialog box
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7. Click Save to export the experiment information table or selected 
experiment data.

Metrics Table

The metrics table (Figure 10.16) displays data for each probe set in the selected 
probe analysis data (Table 10.1). See Expression Analysis Metrics, on 
page 524 for definitions of the Statistical expression metrics.

Table 10.1
Statistical expression algorithm metrics

Single-Array Analysis Comparison Analysis

Stat Pairs Stat Common pairs

Stat Pairs Used Signal Log Ratio 

Signal Signal Log Ratio low 

Detection Signal Log Ratio high

Detection p-value Change 

Change p-value

Figure 10.16    
Expression Analysis window, metrics tab, single-array probe analysis data for experiments 
N002 and N004
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Exporting Metrics Data

You can export metrics data and the associated analysis information as a text 

file (.txt) or Microsoft® Excel file (.xls). 

Setting Metrics Export Preferences

1. Click the Analysis Options button .

⇒ The Analysis Options dialog box appears (Figure 10.17).

2. Click the metrics tab to view export preferences.

3. Choose the Save Analysis Info option to include the analysis 
information with the metrics data for export.

4. Choose the Save All Metric Results option to view the save 
preferences:
■ The Save all analyses to one file option exports the analysis 

information and metrics data for all analyses in the EAW to one text 
file (.txt).

Figure 10.17    
Analysis Options, Metrics tab
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■ The Save each analysis to a separate file option exports the 
analysis information and metrics data for each analysis in the EAW to 
a separate text file.

5. Click OK to close the Analysis Options dialog box.

Exporting Metrics Data

1. If it is not already open, open the EAW (in the data tree, double-click the 
probe analysis data of interest), then click the Metrics tab.

2. To export:

■ All of the metrics table, click the Save button . Alternatively, 
select File → Save As from the menu bar.

■ A selected portion of the metrics table, highlight the rows of interest, 

then click the Save button  or select File → Save As from the 
menu bar.

⇒ The Save As dialog box appears (Figure 10.18).

The save preferences set in the metrics tab do not affect the save 
function in the Pivot or Analysis Information tab in the EAW.

Do not choose the Save All Metric Results option (Figure 10.17) if you 
want to save selected results.

Figure 10.18    
Save As dialog box
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3. Enter a name for the text file and confirm or select another directory for 
the text file.

4. Click Save to export the metrics data according to the preferences set in 
the Analysis Options (Metrics tab) (Figure 10.17).

Pivot Table

To view the pivot table:

■ open probe analysis data (double-click the data in the data tree)
■ click the Pivot tab in the EAW

Each row in the pivot table (Figure 10.19) begins with a probe set name and 
each set of columns displays the results from one probe analysis. The pivot 
table displays probe analysis data and descriptions for each transcript 
represented on the probe array. 

If several sets of probe analysis data from the same probe array type are open 
in the EAW, each row of the pivot table displays the data for one probe set 
from the different experiments. The pivot table is organized so that probe 
analysis data from different experiments may be easily compared.

Figure 10.19    
Expression Analysis window (EAW), pivot table, single-array probe analysis data for 
experiments N002 and N006
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Pivot Table Display Options

Single-array or comparison analysis output

You can select the types of single-array or comparison analysis output 
(columns) displayed in the pivot table.

1. Click the Analysis Options button . Alternatively, select Analysis → 
Options from the menu bar.

⇒ The Analysis Options dialog box appears (Figure 10.20). 

2. Click the Pivot tab.

The pivot table includes column headers for the items selected in the 
Analysis Options dialog box. You can also view these items by selecting 
View → Pivot Data from the menu bar.

Figure 10.20    
Analysis Options dialog box, Pivot tab

The pivot table can also display probe analysis data for experiments 
analyzed using the Empirical expression analysis algorithm (in 
Microarray Suite versions lower than 5.0).

Select the output for display 
in the Pivot table.
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3. Click an unchecked item to add it to the pivot table or click a checked 
item to remove it from the table. 

4. To reorder an experiment result column in the pivot table, use the drag-
and-drop method to move the column header in the table.

Probe Set Descriptions

To view probe set descriptions, do either of the following: 

■ scroll to the Descriptions (far right column) in the pivot table
■ double-click the row of interest in the pivot table

⇒ The Description dialog box is displayed (Figure 10.21).

Obtaining Further Information

You can search for further information about a probe set at an Internet site.

1. In the metrics or pivot table:

a. Right-click the probe set (row) of interest. 

b. Select External Database → NetAffx (or Entrez) from the shortcut 
menu that appears.

⇒ This starts the default Internet browser (for example, Microsoft® 
Internet Explorer or Netscape® Communicator) and automatically 
opens the selected Internet site.

Figure 10.21    
EAW, probe set Description dialog box
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Exporting the Pivot Table

You can export the pivot table as a text file (.txt) or Excel file (.xls). 

1. If it is not already open, open the EAW (in the data tree, double-click the 
probe analysis data of interest).

2. Click the Pivot tab.

3. To export only a user-selected portion of the data table, highlight the 
cells of interest.

4. Click the Save button  or select File → Save As from the menu bar.

⇒ The Save As dialog box appears (Figure 10.22).

5. Choose a save option:

■ Save All places all of the pivot table in the text file.
■ Save Selected places only the selected pivot data in the text file.

6. Enter a name for the text file and confirm or select another directory for 
the text file.

7. Click Save to export the pivot table or selected pivot data.

Figure 10.22    
Save As dialog box
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Finding Probe Set Information 

You can perform text searches in the EAW.

1. To start a text search, do one of the following:

■ click the Find button 

■ select Edit → Find from the menu bar

■ right-click the metrics or pivot table and select Find in the shortcut 
menu that appears.

⇒ The Find dialog box appears (Figure 10.23).

2. Enter the text string for the search (up to 256 alphanumeric characters). 

3. Choose the Match or Direction search option, then click Find Next. 
Click Find Next again to continue the search.

Sorting Probe Set Information 

You can sort the metrics or pivot table by any category of data displayed in 
the table. 

Single Column Sort

1. In the EAW, click the Metrics or Pivot tab.

2. Right-click the column header of interest and click Sort Ascending or 
Sort Descending in the shortcut menu that appears.

Figure 10.23    
Find dialog box

The Find command finds all strings that match the text string for the 
search. For example, using the Find command to search for the text 
string biob would find AFFX-BioB-5 as well as other occurrences of BioB.
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Multiple Column Sort

1. In the EAW, click the Metrics or Pivot tab.

2. Click the Sort button . Alternatively, select Edit → Sort from the 
menu bar.

⇒ The Sort dialog box appears (Figure 10.24).

3. Select the desired sort category from the first (top) drop-down list and 
choose an ascending or descending sort order.

Up to three additional sort categories may be specified. 

4. Click OK when finished specifying the sort.

The sort category and order are displayed at the bottom of the EAW.

Reordering or Removing Probe Set Information

Reordering Columns in the Metrics or Pivot Table

1. In the Metrics or Pivot tab, click the column header of interest 

2. Use the drag-and-drop method to move the column to a new position in 
the table.

Figure 10.24    
Sort dialog box
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Reordering Rows in the Metrics or Pivot Table

Use the Edit commands in the menu bar to remove or reorder tabular data in 
the metrics or pivot table:

Hiding Probe Set Information

You can hide tabular data in the metrics or pivot table. Use the View 
commands in the menu bar to hide (unhide) selected rows or all of the 
tabular data. 

Alternatively, right-click the metrics or pivot table to display a shortcut 
menu of hide commands:

 

Edit → Move Selected to Top Moves a selected row(s) to the top of 
the metric or pivot table.

Edit → Remove Analyses When the pivot table contains only one 
analysis, removes the analysis from the 
table (equivalent to closing the probe 
analysis data). When the pivot table 
includes more than one analysis, this 
displays an Open dialog box that 
enables you to select the analyses you 
want to remove from the table.

Edit → Select All Highlights all rows in the metric or 
pivot table.

View → Hide Selected Hides the currently selected row(s) in the 
metrics or pivot table. The status bar at the 
bottom of the EAW displays the remaining 
number of rows in the table.

View → Hide Unselected Hides all unselected rows in the metrics or pivot 
table. The status bar at the bottom of the EAW 
displays the remaining number of rows in the 
data table.

View → Unhide All Displays all previously hidden rows at the 
bottom of the data table.
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Expression Analysis 
Measured Images 

A measured image displays the probe set hybridization intensity data (from 
the image data).

Displaying Measured Images

1. Click the desired probe set name(s) in the metrics or pivot table. 

To select adjacent probe set names, press and hold the Shift key and 
click the first and last probe set name in the selection. To select non-
adjacent probe set names, press and hold the Ctrl key while you click 
the desired names.

2. Click the Image button . Alternatively, select Graphs → Measured 
Images from the menu bar.

⇒ The graph pane (Intensity tab) opens and displays the measured 
image and the intensity signal range for the selected probe set 
(Figure 10.25).

When an additional image is created, the graph pane automatically 
scrolls to the new image. Use the scroll bar to view all of the measured 
images created during a session. See Working with Windowpanes & 
Columns, on page 624 for information about resizing the graph pane.
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Clearing Measured Images 

You can remove all or selected images from the graph pane.

1. To remove all measured images from the graph pane, right-click the 
graph pane and select Clear All Graphs from the shortcut menu that 
appears. Alternatively, select Graph → Clear All Graphs from the 
menu bar.

2. To remove selected images from the graph pane:

a. Double-click the measured image.

b. Right-click the image and select Clear Selected Graphs from the 
shortcut menu that appears or select Graph → Clear Selected 
Graphs from the menu bar.

Figure 10.25    
EAW, measured images in the graph pane (top)

Probe set 
measured 
images in 
the graph 
pane
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Expression Analysis Graphs

GCOS plots three types of expression analysis graphs (Table 10.2). The 
graphs are displayed in the graph pane that appears at the top of the EAW 
(Figure 10.26).

The graph pane has three tabs: Scatter Graph, Series Graph, and Intensity. 
Click the graph pane tabs to toggle the display among the different graph 
types. See Working with Windowpanes & Columns, on page 624 for 
information about resizing the graph pane.

6

Table 10.2
Expression analysis graphs

Expression
Graph Type Plots...

Scatter A user-specified metric for all probe sets from two experiments (of the 
same probe array type) using a traditional scatter plot.

Series A user-specified metric for each probe set on the array in a bar or line graph 
format.

Intensity The intensities of the probe pairs in a probe set using a bar graph format.

The intensity graph  and images  functions are unavailable until a 
probe set(s) is highlighted in the metrics or pivot table.
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Scatter Graph

The scatter graph plots user-selected expression data for all probe sets from 
one or more pairs of analyses using a traditional scatter plot (Figure 10.26). 
Each point in the scatter graph represents a probe set common to both 
experiments and is defined by the intersection of the analysis result value on 
the x and y axes for the common probe set. The scatter graph displays fold 
change lines (four pairs) that help identify probe sets in the comparison that 
change expression levels. 

Figure 10.26    
Expression Analysis window (EAW), Scatter graph tab of the graph pane (top) and Pivot tab (bottom)

Scatter graph in the 
graph pane

Pivot table
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Plotting a Scatter Graph

1. Click the Scatter graph button . Alternatively, select Graph → 
Scatter Correlation Graph from the menu bar.

⇒ The Scatter Graph dialog box displays the pivot table columns 
available for the scatter graph (Figure 10.27). 

For the scatter plot, select pairs of analyses that are derived from the 
same probe array type. The order of the analyses is critical. For example, 
the analyses from a multiple probe array set must be ordered identically 
along the x and y-axes since the scatter graph compares the first set of 
analysis outputs on the x-axis with the first set of analysis outputs on the 
y-axis (and so forth). If the analysis outputs are not in identical order, 
many probe sets will not be compared and plotted (only the probe sets 
in common such as the controls).

Figure 10.27    
Scatter graph dialog box

This box shows the pivot 
table columns available 
for the scatter graph
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2. To select a column for the x-axis, do either of the following:

■ Use the drag-and-drop method to move the column name from the 
Available Columns box to the Select X Axis Columns box 
(Figure 10.27).

■ Highlight the column name in the Available Columns box, then click 

the down arrow  (on the left side) to place the column in the 
Select X Axis Columns box.

3. To select a column for the y-axis, do either of the following:

■ Use the drag-and-drop method to move the column name from the 
Available Columns box to the Select Y Axis Columns box 
(Figure 10.27).

■ Highlight the column name in the Available Columns box and click 

the down arrow  (on the right side) to place the column in the 
Select Y Axis Columns box.

4. To change the order of columns, do either of the following:
■ Use the drag-and-drop method to move the column to the desired 

location in the list.

■ Highlight the column name, then use the up  and down  arrows 
located to the inside of the Select Axis Columns boxes.

5. To select linear scaling, remove the check mark from the Log Scale 
check box.

Logarithmic scaling is the default.

6. Click OK to generate the scatter graph.

⇒ The graph pane (Scatter Graph tab) displays the scatter graph 
(Figure 10.26).

Working with the Scatter Graph

Right-click the scatter graph to display a shortcut menu of commands that 
include:

Points Displays the absolute call combinations and the color 
assigned to each. The scatter graph displays the check 
marked items. Click an item to remove or add a check 
mark. The scatter graph is immediately updated.
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Magnifying the Graph

1. Press and hold the Shift key while you use the click-and-drag method to 
draw a rectangle over the graph area of interest (Figure 10.28).

2. Release the mouse key.

⇒ This magnifies the area selected by the rectangle (Figure 10.29).

3. To zoom out and restore the graph, right-click the graph and select Full 
Out Zoom from the shortcut menu that appears.

Copy Graph Copies the Scatter graph to the system clipboard.

Close Graph 
Pane

Closes the graph pane. Graphs created during the session 
are not saved.

Full Out 
Zoom

Restores the graph to the original magnification view.

Redraw 
Graph

Redraws the scatter graph so that it plots only the points 
that correspond to rows displayed in the pivot table. Points 
that correspond to hidden rows are not plotted.

Select 
Highlighted 
Points

Selects rows in the Pivot and Metric tables that correspond 
to points selected (roped) in the Scatter graph.

Options Displays the Analysis Options dialog box.
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Figure 10.28    
Scatter graph, rectangle selects an area to magnify

Figure 10.29    
Magnified area in the scatter graph
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Displaying Probe Set and Gene Information

1. Click a point in the scatter graph.

⇒ This displays the probe set name, parameter value, detection call, 
and a brief description of the probe set (Figure 10.30). The 
corresponding row in the pivot table is highlighted. 

2. To obtain further gene information, select a database from the drop-
down list and click Info. 

⇒ The Internet browser window opens and displays information for 
the selected gene (Figure 10.31).

Figure 10.30    
Scatter graph, click a point to display corresponding probe set and gene information

Database drop-down list
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Selecting Points in the Scatter Graph

1. Click the Lasso button . Alternatively, select Graph → Lasso Points 
from the menu bar.

⇒ The mouse pointer changes to a cross hairs (+) when it is positioned 
over the scatter graph

2. To rope points of interest, position the cross hairs near the group of 
points, then do either of the following:

■ Use the click-and-drag method to draw a circle around the points, 
then release the mouse button near the starting point.

■ Click the mouse, move it to draw a line segment, then click the 
mouse again to start drawing a new line segment. Repeat until you 

Figure 10.31    
Internet browser window
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return the cross hairs to the starting point and the line segments 
enclose the points of interest.

⇒ This completes the lasso operation (Figure 10.32). 

The scatter graph displays the selected points in orange. The metrics and 
pivot tables highlight the corresponding probe sets.

Press the Esc key to cancel the lasso operation.

Figure 10.32    
Roping points in the scatter graph highlights the corresponding probe set rows in the metrics 
and pivot tables
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Hiding Points in the Scatter Graph

You can hide points in the scatter graph according to detection or Change 
call (if the scatter graph points are color coded using the Color by 
Detection/Absolute Call or Color by Change/Difference Call option, see 
Point Options on page 203.

1. Right-click the scatter graph and select Points from the shortcut menu 
that appears.

⇒ This displays a key for the scatter graph point colors (Figure 10.33).

2. Click a point color combination to remove (or add) a check mark.

⇒ This hides (unhides) the selected points in the scatter graph.

Scatter Graph Options

You can modify some display features of the scatter graph. The Analysis 
Options dialog box displays the user-modifiable features (Figure 10.34).

1. To open the Analysis Options dialog box, do one of the following:

■ Click the Options button .
■ Right-click the scatter graph and select Options from the shortcut 

menu that appears.

After you select points in the scatter graph, hide the unselected rows in 
the pivot table, then use the Redraw Graph command to display only 
the selected points in the scatter graph.

Figure 10.33    
Scatter graph shortcut menu, point color combinations for detection calls
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■ Select Analysis → Options from the menu bar.

⇒ The Analysis Options dialog box appears (Figure 10.34).

2. Click the Scatter Graph tab.

Point Options

Figure 10.34    
Analysis Options, Scatter Graph tab

Point Size Determines the size of the graph points. Enter 
a larger point size number for easier viewing, 
but use a smaller point size for high resolution 
graphs.

Color by Detection/
Absolute Call

Displays the graph points using the colors 
assigned to the single-array call combination 
of the x and y-axis analyses. There are nine 
possible call combinations:
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Fold Change Lines

The default fold change lines are defined in pairs: y = 2x and y = 1/2x, y = 
3x and y = 1/3x, y = 10x and y = 1/10 x, y = 30x and y = 1/30x.

The fold change lines (four pairs) are drawn using the values entered in the 
edit boxes. Only integer values may be entered. Removing a check mark 
turns off the display of that pair of fold change lines.

Colors

You can change the colors assigned to the:

■ single-array analysis call categories
■ comparison analysis call categories
■ scatter graph points

Absent in Y Marginal in Y Present in Y

Absent in X A-A M-A A-P

Marginal in X M-A M-M M-P

Present in X P-A P-M P-P

Color coding the combinations can help quickly determine whether a 
highly expressed gene in one experiment was present or absent in 
another experiment.

If the call is No Call in either analysis, the point is displayed using the No 
Call Point Color (the default is black).

Color by Change/Difference Call Displays the data points using the 
colors assigned to the comparison 
analysis call of the y-axis analysis. 
There are five possible calls: 
Decrease (D), Marginal Decrease 
(MD), No Change (NC), Marginal 
Increase (MI), and Increase (I). 

Use Point Color Displays points using the color 
assigned to the Point Color.
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■ graph background
■ selected (roped) scatter graph points
■ fold change lines 

1. In the Analysis Options dialog box (Figure 10.34), click the color square 
associated with the item you want to change.

⇒ This displays the color palette (Figure 10.35).

2. To select a predefined color, click one of the basic colors.

3. To define a custom color, click Define Custom Colors, then use the 
click-and-drag method to move the cross hairs in the custom color field. 
Adjust the color brightness using the luminosity scale to the right. When 
finished, click Add to Custom Colors to apply the color.

4. Click OK to close the color palette.

The color choices are saved on a per user basis.

Defaults

Click Defaults to return all analysis option settings to the factory set 
defaults.

Figure 10.35    
Color palette

Luminosity scaleCustom color field
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Series Graph

The series graph plots a line or bar graph of user-selected expression data for 
all analyses or for all probe sets of analyses open in the EAW (Figure 10.36 
and Figure 10.37). The line graph format is the default.

Hidden probe sets are not included in the series graph.

Figure 10.36    
Series line graph, signal
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Plotting a Series Graph

1. Click the Series Graph button . Alternatively, select Graph → Series 
Graph from the menu bar.

⇒ The Series Graph dialog box appears (Figure 10.38).

Figure 10.37    
Series bar graph, signal

Figure 10.38    
Series Graph dialog box
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2. Select the pivot table columns for the series graph.

⇒ This generates the series line graph for the probe sets displayed in 
the data tables (Figure 10.36).

The line graph format is the default. For information on how to change 
the bar graph format, see Series Graph Options on page 208.

Working with the Series Graph

1. Place the mouse arrow over a probe set name, data point, or bar to view 
a pop-up tool tip that displays the analysis or probe set name and 
parameter value.

2. Right-click the series graph to display a shortcut menu of commands 
that include:

Series Graph Options

Some display features of the series graph may be modified. The Analysis 
Options dialog box displays the user-modifiable features (Figure 10.39).

1. To open the Analysis Options dialog box, do one of the following:

■ Click the Options button .
■ Right-click the scatter graph and select Options from the shortcut 

menu that appears.

■ Select Analysis → Options from the menu bar.

⇒ The Analysis Options dialog box appears (Figure 10.39) 

2. Click the Series Graph tab and choose the Bar Graph or Line Graph 
option.

Copy Graph Copies the graph to the system clipboard.

Close Graph Pane Closes the graph pane (graphs created during the 
session are not saved).

Options Displays the Analysis Options dialog box.
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Series Bar Graph Options

Series Line Graph Options

Colors

The color of the points or background in the series line graph may be 
changed.

Figure 10.39    
Analysis Options, Series Graph tab

Probe Set Width (%) Determines the graph bar width.

X-Axis Parameters 
Visible

The number of probe sets displayed on the x-axis 
within the viewable portion of the graph.

X-Axis Select Probe Sets or Columns (from the X-Axis 
drop-down list) for display on the x-axis.

Point Size Determines the size of the graph points.

X-Axis Parameters 
Visible

Specifies the number of probe sets or columns 
displayed on the x-axis within the viewable portion 
of the graph.
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1. In the Analysis Options dialog box (Figure 10.39), click the Point Color 
or Background color square.

⇒ This displays the color palette (Figure 10.40).

2. To select a predefined color, click one of the basic colors.

3. To define a custom color, click Define Custom Colors, then use the 
click-and-drag method to move the cross hairs in the custom color field. 
Adjust the color brightness using the luminosity scale to the right. When 
finished, click Add to Custom Colors to apply the color

4. Click OK to close the color palette.

The color choices are saved on a per user basis.

Intensity Bar Graph

The intensity bar graph displays the intensities of the probe pairs of a probe 
set in a bar graph format (Figure 10.41). The intensity bar graph is a useful way 
to: 

■ evaluate the relative performance of the probe pairs in a probe set

■ determine whether an image or probe mask has been applied to a probe 
pair 

Figure 10.40    
Color palette

Luminosity scaleCustom color field
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Plotting the Intensity Bar Graph

1. Highlight a row or cell in the metrics or pivot table.

2. To plot the intensity bar graph(s) for the highlighted probe set(s), do 
either of the following:

■ Click the Intensity Bar Graph button .

■ Select Graph → Intensity Bar Graph from the menu bar.

3. If necessary, use the scroll bar to view all of the intensity bar graphs 
created during a session. 

Intensity Bar Graph Options

You can modify some display features of the intensity bar graph. The 
Analysis Options dialog box displays the user-modifiable features 
(Figure 10.42).

1. To open the Analysis Options dialog box, do one of the following:

■ click the Options button 
■ right-click the intensity bar graph, then click Options in the shortcut 

menu that appears

■ select Analysis → Options from the menu bar

⇒ The Analysis Options dialog box appears (Figure 10.42) 

2. Click the Intensity Graph tab.

Figure 10.41    
Intensity bar graph of probe set X54925_at (from experiment N004)
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Show Values

Choose the Show Values option to display numerical intensity values on the 
intensity bar graph.

Scale

Figure 10.42    
Analysis Options, Intensity Graph tab

Relative to Pair Scales each probe pair set independently. The scale for 
each PM and MM pair is 0 → max (PM, MM).

Relative to 
Probe Set

Scales each probe pair relative to all probe pairs of a 
particular probe set. The scale is determined by all pairs 
of the probe set and ranges from 0 → max (all PM/MM 
probe pairs in the set).

Absolute Scales all probe pairs according to a user specified 
intensity range (for example, 10 to 1000 in (Figure 10.42)).
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Colors

The color code specifies the colors for:

To change the colors specified by the color code:

1. Click the color square of the item you want to change (for example, 
Match in Figure 10.42).

⇒ This displays the color palette (Figure 10.43).

2. To select a predefined color, click one of the basic colors.

3. To define a custom color, click Define Custom Colors, then use the 
click-and-drag method to move the cross hairs in the custom color field. 

Match Perfect match probe intensities

Mismatch Mismatch probe intensities

Image Mask Probe pairs included in an image mask

Probe Mask Probe pairs included in a probe mask

Not in Average Probe pairs excluded from the Average Difference 
calculation (Empirical expression algorithm only)

Figure 10.43    
Color palette

Luminosity scaleCustom color field
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Adjust the color brightness using the luminosity scale to the right. When 
finished, click Add to Custom Colors to apply the color

4. Click OK to close the color palette.

The color choices are saved on a per user basis.

Defaults

Click Defaults to restore the factory set defaults for all intensity bar graph 
options.

Clearing Intensity Bar Graphs

1. To remove all intensity bar graphs from the graph pane, right-click the 
graph pane and select Clear All Graphs from the shortcut menu that 
appears. Alternatively, select Graph → Clear All Graphs from the 
menu bar.

2. To remove user-selected intensity bar graphs from the graph pane:

a. Double-click the graph(s) you want to remove

b. Right-click the selected graph and select Clear Selected Graphs 
from the shortcut menu that appears. Alternatively, choose Graph → 
Clear Selected Graphs from the menu bar.

Expression Report

The expression report summarizes information about the expression analysis 
settings, algorithm settings, and probe set hybridization intensity data.

Generating an Expression Report

1. Confirm or change the user-modifiable report settings. See the next 
section Expression Report Settings. 

2. To generate the report, do either of the following:
■ In the data tree, right-click the probe analysis data for the report and 

select Report from the shortcut menu that appears.

■ Select File → Report from the menu bar, then in the Report dialog 
box (Figure 10.44) that appears, double-click the probe analysis data for 
the report.
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⇒ This displays the expression report in the main display area. 
Figure 10.45 and Figure 10.46 show an example expression report.

3. To best view the expression report:

a. Use Arial font (10 point) (select View → Set Font from the menu 
bar).

b. Set the tab stops set at 10 (select View → Set Tab Stops from the 
menu bar).

Figure 10.44    
Report dialog box

A previously generated report will be overwritten. To save a previous 
report, rename it and save it under the new name. See the Saving an 
Expression Report, on page 224.
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Figure 10.45    
Expression report, comparison analysis, Statistical Expression algorithm (page 1) 



  Affymetrix®  GeneChip®  Operating Software User’s Guide 217
Figure 10.46    
Expression report, comparison analysis, Statistical Expression algorithm (page 2)
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Expression Report Components 

Statistical Expression Algorithm

Probe Pair 
Threshold

The minimum number of probe pairs a probe set must 
have in order for the probe set data to be included in 
the calculation of the report statistics

Alpha1 (α1) The significance level for the Detection p-value in an 
analysis. Alpha1 is a user-modifiable parameter that is 
set in the Parameters tab of the Expression Analysis 
Settings. See Expression Analysis Settings, on 
page 532. 

If the probe set Detection p-value < alpha1, the call is 
present.

Alpha2 (α2) The second significance level for the Detection p-
value in an analysis. Alpha2 is a user-modifiable 
parameter set in the Parameters tab of the Expression 
Analysis Settings. See Expression Analysis Settings, 
on page 532. 

If the probe set Detection p-value ≥ alpha2, the call is 
absent. If alpha1 ≤ Detection p-value < alpha2, the call 
is marginal.

Tau (τ ) Tau is a user-modifiable parameter that is set in the 
Parameters tab of the Expression Analysis Settings 
See Expression Analysis Settings, on page 532. 
Ideally, tau should be set to a value that is a little larger 
than the median of the discrimination scores of the 
probe sets whose targets are absent to avoid false 
detected calls.

Noise (Raw Q) The degree of pixel-to-pixel variation among the 
probe cells used to calculate the background. See 
Statistical Expression Algorithm, on page 524.

Scale Factor (SF) The scale factor specified in the Scaling tab of the 
Expression Analysis Settings dialog box or computed 
by the algorithm. See Expression Analysis Settings, on 
page 532.
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TGT Value The user-specified target signal for scaling of the 
experiment probe array. The target signal is set in the 
Scaling tab of the Expression Analysis Settings dialog 
box. See Expression Analysis Settings, on page 532.

Norm Factor (NF) The normalization factor specified in the 
Normalization tab of the Expression Analysis Settings 
dialog box or computed by the algorithm. See 
Expression Analysis Settings, on page 532.

Gamma1H (γ 1H) The small significance level for Change calls at high 
intensities. Gamma1H is a user-modifiable parameter 
that is set in the Parameters tab of the Expression 
Analysis Settings. See Expression Analysis Settings, 
on page 532.

Gamma2H (γ 2H) The large significance level for Change calls at high 
intensities. Gamma2H is a user-modifiable parameter 
that is set in the Parameters tab of the Expression 
Analysis Settings. See Expression Analysis Settings, 
on page 532.

Gamma1L (γ 1L) The small significance level for Change calls at low 
intensities. Gamma1L is a user-modifiable parameter 
that is set in the Parameters tab of the Expression 
Analysis Settings. See Expression Analysis Settings, 
on page 532.

Gamma2L (γ 2L) The large significance level for Change calls at low 
intensities. Gamma2L is a user-modifiable parameter 
that is set in the Parameters tab of the Expression 
Analysis Settings. See Expression Analysis Settings, 
on page 532.

Perturbation A user-modifiable expression algorithm parameter 
that is set in the parameters tab of the Expression 
Analysis Settings. See Expression Analysis Settings, 
on page 532. Perturbation influences the p-value 
computed for a probe set in a comparison analysis.
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Baseline Noise 
(Raw Q)

The degree of pixel-to-pixel variation among the 
probe cells used to calculate the background in the 
baseline probe array. See Statistical Expression 
Algorithm, on page 524.

Baseline Scale 
Factor (SF)

The scale factor specified for the baseline probe array 
in the Scaling tab of the Expression Analysis Settings 
dialog box or computed by the algorithm. See 
Expression Analysis Settings, on page 532.

Background Minimum, maximum, average, and standard deviation 
of the background intensity calculated for the probe 
array.

Noise The minimum, maximum, average, and standard 
deviation of the noise calculated for the probe array.

Corner+ The average cell intensity for the sense probe cells 
used in the grid alignment process.

Corner- The average cell intensity of the antisense probe cells 
used in the grid alignment process.

Central+ The average cell intensity for the nine probe cells that 
comprise the cross at the center of a sense probe array.

Central- The average cell intensity for the nine probe cells that 
comprise the cross at the center of an antisense probe 
array.

Total Probe Sets The number of probe sets on the array that exceed the 
probe pair threshold and are not called No Call.

Average Signal The average signal for all probe sets that exceed the 
probe pair threshold and are not called No Call.

Controls The expression report includes the signal and call data 
for the probe sets that correspond to the housekeeping 
or spike control transcripts. Separate signal and call 
data are reported for the probe pairs specific to the 5’, 
middle (M), and 3’ regions of the control transcripts.

Sig(all) The average signal for all control probe sets. 

Sig(3′ /5′ ) For a probe set, Sig(3′ )/Sig(5′ ).
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Expression Report Settings

The expression report has user-modifiable settings.

1. To view the user-modifiable settings, click Settings in the shortcut bar, 

then click Expression Report . 

⇒ The Expression Report dialog box appears (Figure 10.47).

Figure 10.47    
Expression Report dialog box

Probe Pair Threshold The minimum number of probe pairs a probe set 
must have in order for the probe set data to be 
included in the calculation of the report statistics.

Antisense Probe Sets Choose this option for probe arrays that have 
antisense control probes. (Refer to the probe array 
product insert.)

Sense Probe Sets Choose this option for probe arrays that have sense 
control probes. (Refer to the probe array package 
insert.)
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Housekeeping Controls

Housekeeping controls are housekeeping gene transcripts that are usually 
constitutively expressed in the sample. The transcripts serve as endogenous 
controls and are useful for monitoring the quality of the target. 

The report includes the signal (Sig) for probe sets that are designed to be 
specific to the 5′ , middle, or 3′  portion of the transcript. These data are 
informative about the reverse transcription and IVT steps in sample 
preparation. 

Differences greater than three fold between the Sig 3′  and Sig 5′   (Sig 3′ /
5′ ) for a housekeeping control indicate the target may be degraded and 
should be prepared again. 

■ To delete a housekeeping control from the expression report:

1. Double-click the probe set name.

2. Right-click probe set and select Delete from the shortcut menu that 
appears.

Spike Controls

Spike controls are transcripts that are added to or spiked in the sample. These 
are exogenous transcripts that are useful for monitoring assay procedures 
such as hybridization, washing, and staining. 

■ To delete a spike control from the expression report:

1. Double-click the probe set name.

2. Right-click probe set and select Delete from the shortcut menu that 
appears.

Other Controls

You can choose any probe set on the array as a control. Enter the probe set 
name in the Other Controls box. The expression report includes the signal 
and detection call for user-specified controls. 
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Expression Report View Options

Find Feature

The Find feature searches the report. 

1. Click the Find button  or select Edit → Find from the menu bar.

⇒ The Find dialog box appears (Figure 10.48).

2. Enter the text for the search (up to 256 alphanumeric characters 
including spaces) in the Find what box, then click Find Next to view 
the first search result. 

3. Click Find Next or the Find Next button  to view each successive 
search result. 

Editing an Expression Report

Edit commands for the expression report are available in the:

■ Edit menu bar 
■ Report window toolbar
■ Shortcut menu (right-click the report)

Replace Feature

The replace feature performs a text search and replaces the search item with 
specified text.

1. Select Edit → Replace from the menu bar.

⇒ The Replace dialog box appears (Figure 10.49).

Figure 10.48    
Find dialog box
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2. Enter the text for the search in the Find what box and enter the 
replacement text in the Replace with box.

3. Click Find Next to begin the search, then click Replace to replace the 
search item with the specified text. Repeat to find and replace successive 
instances of the search item. Alternatively, click Replace All to find and 
replace all occurrences of the search item in the report.

Saving an Expression Report 

When GCOS generates a report for expression probe analysis data, it 
overwrites a previously generated report. To prevent a previous report from 
being overwritten, save it under a new name.

1. To open the report that you want to save under a new name, click the 

Open button .

⇒ The Open dialog box appears (Figure 10.50).

Figure 10.49    
Replace dialog box

Figure 10.50    
Open dialog box
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2. Double-click the report name.

⇒ The report is displayed.

3. Select File → Save As from the menu bar.

⇒ The Save As dialog box appears (Figure 10.51).

4. Click the report to be saved, then enter a new name for the report in the 
File name box.

5. Click Save.

Figure 10.51    
Save As dialog box
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Batch Analysis 11

Batch analysis is a convenient way to analyze the cell intensity data from many different experiments and to generate 
probe analysis data with unattended operation.

Figure 11.1    
Assay & analysis flow chart
229
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Opening the Batch Analysis 
Window

Do either of the following to open the Batch Analysis window:

■ In the GeneChip Software shortcut bar, click Batch Analysis .

■ Select Run → Batch Analysis from the menu bar.

⇒ The Batch Analysis window opens (Figure 11.2).

Selecting Data for Batch 
Analysis

You may select cell intensity data or probe analysis data for batch analysis. If 
you select cell intensity data, GCOS automatically places the parent cell 
intensity data and baseline probe analysis data (if applicable) in the Batch 
Analysis window.

Figure 11.2    
Batch Analysis window

Batch analysis will overwrite previous probe analysis data.
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Using the Drag-and-Drop Method

1. In the data tree, select the cell intensity data or probe analysis data that 
you want to analyze.

To select adjacent items, press and hold the Shift key while you click 
the first and last item in the selection. To select non-adjacent items, 
press and hold the Ctrl key while you click the items.

2. Drag the selected data from the data tree to the Batch Analysis window 
(Figure 11.3). 

Figure 11.3    
Batch Analysis window

Batch analysis windowData tree

Shortcut bar
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Using the Toolbar or Menu Commands

1. Click the Add button  or select Edit → Add Item from the menu bar.

⇒ The Add Cell/Chip Data dialog box appears (Figure 11.4).

Click Details  to display experiment and sample information for the 
cell intensity or probe analysis data.

2. To filter the data in the Add Cell/Chip Data dialog box:

a. Click Filter.

⇒ The advanced filter appears (Figure 11.5). 

b. Make selections from the drop-down lists.

c. Click Apply.

Figure 11.4    
Add Cell/Chip Data dialog box
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3. Select the data for the batch analysis, then click OK.

To select adjacent items, press and hold the Shift key while you click 
the first and last item in the selection. To select non-adjacent items, 
press and hold the Ctrl key while you click the items. 

⇒ The selected cell intensity data are added to the Batch Analysis 
window (Figure 11.6).

The Batch Analysis window displays previously analyzed cell intensity 
data in red to indicate that the existing probe analysis data will be 
overwritten. To reanalyze experiments without overwriting existing 
probe analysis data, specify a different name for the .chp from the batch 
analysis. See Renaming Results from Batch Analysis on page 238.

Figure 11.5    
Add Cell/Chip Data dialog box, advanced filter

Batch analysis will overwrite previous probe analysis data. 
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Selecting a Userset for Expression Analysis

A userset specifies the expression analysis settings (scaling, normalization, 
probe masks, baseline experiment, values for user-modifiable Statistical 
Expression algorithm parameters). See Userset Tab on page 335 for more 
information about usersets.

1. To select other than the default userset, double-click the Userset 
column.

⇒ This displays a drop-down list of available usersets (Figure 11.7).

Figure 11.6    
Batch Analysis window, cell intensity data (.cel) selected for batch analysis

 In a batch analysis, the settings for the default userset are specified in 
the Expression Analysis Settings dialog. The default userset is not the 
userset specified during experiment setup.

If a userset with a baseline experiment is selected and the field under the 
baseline column is empty, the baseline experiment from the userset is 
used during the analysis.
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2. Select a userset from the drop-down list. Alternatively, highlight the cell 
intensity data of interest, select Edit → Select Userset from the menu 
bar, then make a selection from the drop-down list.

Selecting a Baseline for a Comparison Expression Analysis

1. In the Batch Analysis window, double-click in the baseline column of 
the cell intensity data for the comparison expression analysis 
(Figure 11.8). 

Alternatively, select the .cel of interest and choose Edit → Select 
Baseline from the menu bar.

⇒ The Select Baseline Data dialog box appears (Figure 11.9).

Figure 11.7    
Batch Analysis window, drop-down list of usersets

Figure 11.8    
Batch Analysis window
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2. Click Details  to display experiment and sample information for the 
data. 

3. To filter the data in the Select Baseline dialog box:

a. Click Filter.

⇒ This displays the advanced filter (Figure 11.10). 

b. Make selections from the drop-down lists.

c. Click Apply.

Figure 11.9    
Select Baseline dialog box, List view (left) and Details view (right)
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4. Double-click the baseline data.

⇒ The Batch Analysis window displays the baseline data (Figure 11.11).
 

Figure 11.10    
Select Baseline dialog box, advanced filter

Figure 11.11    
Batch Analysis window, baseline selected
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5. To clear a baseline from the batch analysis window, right-click the 
baseline data and select Clear Baseline from the shortcut menu that 
appears.

Alternatively, click the baseline experiment and select Edit → Clear 
Baseline from the menu bar.

Renaming Results from 
Batch Analysis

To reanalyze experiments without overwriting existing analysis output, 
rename the output .chp data from the batch analysis. 

Renaming Results Automatically 

If you select .cel data for batch analysis, GCOS can automatically rename all 
of the output .chp data by adding a user-specified prefix and/or suffix to the 
data name.

1.  Click the Options button  or select View → Options from the menu 
bar.

⇒ The Batch Analysis Options dialog box appears (Figure 11.12).

2. To add a prefix to the .chp name, choose the Prefix option and enter a 
prefix for the name in the associated box.

If you select .chp data for batch analysis, the prefix or suffix are not 
applied to the output name.

Figure 11.12    
Output Naming Options dialog box
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3. To add a suffix to the .chp name, choose the Suffix option and enter a 
suffix for the name in the associated box.

4. Click OK.

⇒ When cell intensity data are placed in the Batch Analysis window, 
the user-specified prefix and/or suffix is automatically added to the 
output analysis name.

Renaming Results Individually 

You can individually rename an output results from the batch analysis. 

Editing the Output Name

To edit the default name, do either of the following:

■ Double-click the name in the Batch Analysis window and enter a new 
name.

■ Select the cell intensity data of interest in the Batch Analysis window, 
select Edit → Rename Output Data from the menu bar, and enter a new 
name.

Adding a Prefix or Suffix to the Output Name

1. In the Batch Analysis window, use one of the following methods to 
select one or more outputs.

■ To select all data, right-click a name and click Select All in the 
shortcut menu that appears. Alternatively, select View → Select All 
from the menu bar.

■ To select adjacent data, press and hold the Shift key while you click 
the first and last name in the selection. 

■ To select non-adjacent data, press and hold the Ctrl key while you 
click the names. 

2. Right-click the selected outputs and select Set Prefix/Suffix from the 
shortcut menu that appears. 

Alternatively, click the selection and select Edit → Set Prefix/Suffix 
from the menu bar.

⇒ The Set Prefix/Suffix dialog box appears (Figure 11.13).
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3. Enter a prefix and/or suffix, then click OK.

⇒ The prefix and/or suffix are added to the selected output names.

Removing Data from the 
Batch Analysis Window

To remove cell intensity data from the Batch Analysis window, do either of 
the following:

■ Select the data name and click the Remove button .

■ Select the data name, then select Edit → Remove Item from the 
menu bar.

Running a Batch Analysis

1. To run the batch analysis, click the Analyze button . Alternatively, 
select Edit → Start Analysis from the menu bar.

2. To stop a batch analysis in progress, click the Stop button . 
Alternatively, select Edit → Stop Analysis from the menu bar.

The software completes the current analysis and cancels the remaining 
data in the batch analysis queue.

Figure 11.13    
Set Prefix/Suffix dialog box
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Resuming a Batch Analysis

If the batch analysis is interrupted before all analyses are completed, GCOS 
can resume the run and analyze the remaining .cel data in the batch. 

To resume a batch analysis:

1. Open the Batch Analysis window.

⇒ The Batch Analysis window displays the remaining unanalyzed 
data.

2. Click the Analyze button . Alternatively, select Edit → Start 
Analysis from the menu bar.

Exporting a Batch File

The Batch Analysis window contents can be exported to a text file (tab 
delimited .txt). The batch file provides a record of the analysis and can be 
imported for a subsequent batch analysis.

1. Select Edit → Export Batch from the menu bar.

⇒ The Export Batch dialog box appears (Figure 11.14).

2. Enter a name for the batch file, then click Save.

⇒ The batch file (.txt) is created (Figure 11.15).

Figure 11.14    
Export Batch dialog box
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Importing a Batch File

GCOS can import a batch file (tab delimited .txt) that follows the format 
shown in Figure 11.15.

To import a batch file:

1. Open the Batch Analysis window.

2. Select Edit → Import Batch from the menu bar.

⇒ The Import Batch dialog box appears (Figure 11.16).

3. Double-click the batch file (.txt) you want to import.

⇒ The batch file is imported to the Batch Analysis window.

Figure 11.15    
Batch file (.txt)

Figure 11.16    
Import Batch dialog box
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Publishing Data 12

GCOS can copy expression sample and experiment data, including 
cell intensity data and probe analysis data from the process database 
to a publish database. This is called publishing. Published expression 
data can be queried by the Affymetrix® Data Mining Tool (DMT) 
software or several other third party analysis tools.

Figure 12.1    
Assay & analysis flow chart
245
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Selecting the Publish 
Database

1. In the GeneChip Software shortcut bar, click Publish . Alternatively, 
select Run → Publish from the menu bar.

⇒ This displays the publish window (Figure 12.2). 

The top windowpane displays all publish databases. The bottom 
windowpane displays a status log of tasks.

2. Click the publish database destination for the data.

A yellow icon indicates the currently selected database. A gray icon 
indicates an unselected database.

Figure 12.2    
Publish window

Each database requires a login password before publishing can proceed.
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Specifying the Task 

A task consists of all data selected for publishing. Each experiment or type 
of data to be published is called a task item. Table 12.1 shows the data that are 
published for each type of task item.

To select the tasks, use either of the following methods:

Using the Drag-and-Drop Method

1. Drag the task item that you want to publish from the data tree onto a 
database icon in the top pane of the publish window. 

2. Repeat the drag-and-drop operation for the remaining task items to be 
published (Figure 12.5). 

Using the Add Toolbar Button

1. Click the Add button  or select Publish → Add Item from the menu 
bar.

⇒ The Open dialog box appears (Figure 12.3).

Table 12.1
Data published for different types of task items

Task Item Data Published

Experiment All cell intensity data associated with the 
experiment.
All probe analysis data associated with the 
experiment.

Image data All cell intensity data associated with the 
experiment.
All probe analysis data associated with the 
experiment.

Cell intensity data The associated experiment.
The cell intensity data.
All probe analysis data associated with the cell 
intensity data.

Probe analysis data The associated experiment.
The probe analysis data.
All cell intensity data associated with the 
probe analysis data.
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2. Click Details to display experiment and sample information for each 
data type.

3. To filter the list of data types in the Open dialog box, click Filter 

⇒ The advanced filters are displayed (Figure 12.4).
 

Figure 12.3    
Open dialog box, list view (left) and details view (right)

Figure 12.4    
Open dialog box, advanced filter
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4. Make selections from the drop-down lists and click Apply to filter the 
list.

5. Make a selection from the Data Type drop-down list and select the data 
to be published. 

To select adjacent data, press and hold the Shift key while you click the 
first and last name in the selection. To select non-adjacent data, press 
and hold the Ctrl key while you click the names. 

6. Click OK to add the data to the selected publish database (Figure 12.5).

7. To remove a task item from the publish window, select the task item in 

the publish window and click the Remove button . Alternatively, 
choose Publish → Remove Item from the menu bar.

Figure 12.5    
Publish window
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Publishing Options

You may publish intensity data or overwrite a previously published task 
item. You must be authorized by the GCOS administrator to overwrite data. 
The status bar at the bottom of the publish window displays the publishing 
options (Figure 12.5). 

Publishing Intensity Data

Cell intensity data (.cel) are not automatically published. Publishing .cel data 
uses large amounts of computer memory. For example, publishing the probe 
analysis data for a high density probe array requires approximately 2 MB of 
disk space compared to 30 MB for both the probe analysis and cell intensity 
data.

1. To include cell intensity data in the publish database, select Publish → 
Options → Publish Intensities from the menu bar.

⇒ The Publish Intensities menu item is check marked.

2. To not include cell intensity data in the publish database, select Publish 
→ Options → Publish Intensities from the menu bar to remove the 
check mark.

Overwriting Data

A previously published task item can be overwritten. Users must be 
authorized by the GCOS administrator to overwrite data.

■ Select Publish → Options → Overwrite Data from the menu bar.

The image data are not published.



  Affymetrix®  GeneChip®  Operating Software User’s Guide 251
Publishing, Canceling, or 
Restarting a Task

Publishing the Task

1. After you have specified the task, click the Publish button . 
Alternatively, select Publish → Publish from the menu bar.

⇒ The Publish Login dialog box appears if this is the first time during 
the session that an item has been published to the database 
(Figure 12.6).

2. Enter the password for the database.

⇒ The task is displayed in the task log and will be published during 
the time frame specified by the GCOS administrator.

Canceling a Task

You can cancel tasks waiting to be published (the status in the task log is 
WAIT). 

1. Select the task in the task log.

2. Click the Cancel button . Alternatively, select Publish → Monitor → 
Cancel Publish from the menu bar.

⇒ The task is now canceled (the status is CANCELED).

It is recommended that users not publish and restore to the same 
publish database simultaneously. Sometimes the restore will be 
rejected and sometimes the publishing will be rejected. If the restore of 
a publish database fails, an error message is displayed.

Figure 12.6    
Publish Database Login
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Restarting a Publishing Task

You can reinstate or restart a canceled task and return it to the publishing 
queue.

1. Select the canceled task in the task log.

2. Click the Restart button . Alternatively, select Publish → Monitor → 
Restart Publish from the menu bar.

The task is now restarted (the status is WAIT) and will be published 
during the time frame specified by the GCOS administrator.
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Defaults 13

This chapter explains how to change the factory set defaults for:

■ image settings
■ data locations
■ fluidics station configuration
■ analysis prompts
■ experiment data storage

Viewing Default Settings

■ Select Tools → Defaults from the menu bar.

⇒ The Defaults dialog box appears (Figure 13.1).

Figure 13.1    
Defaults dialog box, Image Settings tab
255
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Image Settings 

The image settings (Figure 13.1) affect the display of image and cell intensity 
data in the Image window. For more information on this window, see The 
Image Window on page 135.

Intensity Range

GCOS software records a dynamic intensity range from 0 to 65,000 and 
provides 256 colors from black through white for image display. The 
intensity range of an image is divided into 256 bins and each bin is assigned 
a color or gray scale. 

You may enter a new lower or upper limit for the intensity range associated 
with an image and apply this subset of the dynamic range to the image. 
Lowering the upper limit increases the image brightness and raising the 
lower limit decreases the brightness. 

Using this image scaling process, you can adjust the display of a data or cell 
intensity file for optimum viewing. Alternatively, GCOS can automatically 
scale the image using the minimum and maximum pixel intensities of the 
image.

1. To automatically scale an image, choose the Autoscale option in the 
Defaults dialog box (Figure 13.1) and click OK.

2. In the Image Settings dialog box for the current image or cell intensity 
data, you may click Defaults to return the intensity parameters 
(Autoscale option and Intensity range) to the settings in the Image 
Settings tab of the Defaults dialog box. See Making Adjustments to the 
Current Image or Cell Intensity Data Only on page 144 for more 
information about the Image Settings dialog box.

The image settings specified in the Defaults dialog box (except for the 
color option) are applied to subsequently opened image or cell intensity 
data and do not affect active, open data.
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Color

You can view the pixel intensity values in gray scale or pseudo color 
(generated by applying rainbow colors to the intensity scale). Choose the 
Color Bar option (Figure 13.1) to display a gray scale or pseudo color bar at 
the top of the Image window.

Coordinates

When you click the image, a red cross hairs  marks the location. The 
status bar at the lower left of the main window displays the intensity data and 
x-y coordinates of a probe cell or pixel indicated by the cross hairs. 

If you choose the Cell option in the Defaults dialog box (Figure 13.1), a pop-up 
tool tip and the status bar display the x-y coordinates of the cell, the cell 
intensity, and the pixel intensity (Figure 13.2). 

If you choose the Pixel option, the pop-up tool tip and the status bar display 
the x-y coordinates of the pixel and the pixel intensity (Figure 13.2).
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Figure 13.2    
Image data, probe cell coordinates (top) and pixel coordinates (bottom)

Cell X = 186, Y = 41, Cell Intensity = 22561.8, Pixel Intensity = 24692

Pixel X = 1727, Y = 573, Intensity = 22409
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Highlight Colors

You may specify new highlighting colors for the grid, masked cells, outlier 
cells, or highlighted probe array cells (features).

1. Click Highlights in the Defaults dialog box (Figure 13.1).

⇒ The Highlight Colors dialog box appears (Figure 13.3). 

2. To change the color of a particular item (for example, the grid overlay):

a. Click the associated color box in the Highlight Colors dialog box.

⇒ The Color palette is displayed (Figure 13.4).

Figure 13.3    
Highlight Colors dialog box
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b. To select a predefined color, click one of the basic colors.

c. To define a custom color, click Define Custom Colors, then use the 
click-and-drag method to move the cross hairs in the custom color 
field. Adjust the color brightness using the luminosity scale to the 
right. When finished, click Add to Custom Colors to apply the 
color.

⇒ The new color is applied to the selected item.

d.  Click OK to close the Color palette.

Grid Overlay

Choose the Grid Overlay option (Figure 13.1) to automatically display the 
grid on a image or cell intensity data. Remove the check mark to toggle the 
grid overlay off. Alternatively, click Grid in the Image window task bar (or 
press the G key) to toggle the grid on or off.

Figure 13.4    
Color palette

Luminosity scaleCustom color field
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Fluidics Settings

In the Fluidics tab (Figure 13.5) you can:

■ specify the number of fluidics stations installed on the system (up to 
eight fluidics stations may be simultaneously controlled by one work 
station)

■ specify each fluidics station’s number and ID

Scanner Settings

In the Scanner tab (Figure 13.6) you can:

■ specify whether a scanner is installed on the system
■ if a scanner is installed, choose the option to turn on the laser at startup
■ if the AutoLoader is installed, choose to use it in manual mode
■ if the AutoLoader is installed, choose to disable it.

Figure 13.5    
Defaults, Fluidics tab

Notification Message when 
protocol is complete

Choose this option to display a notification 
of completion at the end of a protocol



CHAPTER 13   Defaults262
Figure 13.6    
Defaults, Scanner tab

Scanner Installed Choose this option after the scanner is 
installed.

Turn on Laser at startup Confirm this option is chosen (default) so 
that the laser automatically turns on when 
GCOS is started.

Enable Manual Mode Choose this option if you are using a 
scanner equipped with the AutoLoader and 
would like to disable the AutoLoader’s 
autorun feature. This will allow you to add 
and scan cartridges one at a time.

Disable AutoLoader Choose this option if you are using a 
scanner equipped with the AutoLoader and 
would like to disable the AutoLoader 
completely. This will allow you to use the 
software without communicating with the 
AutoLoader.
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Analysis Settings

The Analysis Settings tab (Figure 13.7) displays two options that are available 
when an analysis is run.

Prompt for Output Data Name

1. Choose the Prompt for output data name option (Figure 13.7) to display 
a Save Results As dialog box (Figure 13.8) at the start of an analysis.

The default name for the probe analysis data is the same as the 
experiment name. The Save Results As dialog box displays the default 
name.

Figure 13.7    
Defaults, Analysis Settings tab

Figure 13.8    
Save Results As dialog box
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2. Click OK to keep the default data name. Alternatively, enter a new 
name and click OK.

Display Settings When Analyzing Data

Choose the Display settings when analyzing data option (Figure 13.7) to 
display the Expression Analysis Settings dialog box (Figure 13.9) at the start of 
an analysis.

Database 

The Database tab (Figure 13.10) specifies how GCOS manages experiment 
data, including image, cell intensity, and probe analysis data.

Choose the  GCOS Server option to store the experiment data on the remote 
GCOS server. If this option is not chosen, the experiment data are stored on 
the MSDE database on the workstation.

Figure 13.9    
Expression Analysis Settings dialog box

The Experiment Data Storage option is only available if all windows are 
closed and no instruments are active.
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Figure 13.10    
Defaults, Database tab
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Printing 14

This chapter explains how to print:

■ image data 
■ cell intensity data
■ probe analysis data 
■ reports

Printing Image or Cell 
Intensity Data 

1. When the Image window is open, click the Print button  or select 
File → Print from the menu bar.

⇒ The Print dialog box appears (Figure 14.1). 

No print range options are available.

Figure 14.1    
Print dialog box in the Image window
269
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2. Click OK to print the image or cell intensity data.

Printing Probe Analysis 
Data

You may print tabular data and graphs from the Expression Analysis window 
(EAW).

1. When the EAW is open, click the Print button  or select File → Print 
from the menu bar.

⇒ The Print dialog box appears (Figure 14.2).

The All and Selection options apply only to the Experiment 
Information, Metrics, and Pivot tables. If the Graphics option is chosen, 
the displayed graphs are automatically printed. 

2. Choose Results and:

■  All to print the entire table in a tab (Experiment Information, Metrics, 
or Pivot).

■ Selection to print only highlighted table rows.

Figure 14.2    
Print dialog box, EAW
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Printing an Expression 
Report

You may print all or selected pages from an expression report.

1. When a report is open in the main display area, click the Print button 

 or select File → Print from the menu bar.

⇒ The Print dialog box appears (Figure 14.3).

2. Choose:

■ All to print all pages of a report.
■ Pages and enter a page range to print selected pages of a report.

Figure 14.3    
Print dialog box, report (.rpt)
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GCOS Manager 15

The GCOS Manager application provides software tools to:

■ manage the GeneChip® data in the process and publish databases
■ define and manage templates for sample registration and experiment 

setup
■ create usersets for analysis
■ create and manage publish databases
■ import data to the process database
■ export experiment and analysis data
■ archive and restore analysis data
■ create and manage roles that define user access privileges (available 

only to users connected to a GCOS server)

This chapter explains the GCOS Manager functions and how to use 
them.

Getting Started

1. To start the GCOS Manager, click the Windows Start menu button 

, then select Programs → Affymetrix → GCOS Manager.

⇒ The GCOS Manager starts and displays the user interface 
(Figure 15.1).

The software functions are organized in the following tabs: Process, 
Publish, Import, Userset, Template, and Roles.

 

Table 15.1 lists the functions found in each tab.

2. To select the active server, make a selection from the server drop-down 
list in the toolbar (Figure 15.1).

The Roles tab is available when the GCOS Manager is connected to a 
GCOS server.
275
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Figure 15.1    
GCOS Manager user interface, Microsoft® MSDE workstation database (top), GCOS server database (bottom)
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Table 15.1
GCOS Manager tab functions for Affymetrix® GeneChip® data

GCOS Manager 
Tab Functions in This Tab

Process Archive or restore experiment data (.dat, .cel, .chp).
Delete process data.
Export experiment data.
Assume ownership of data (available only to users connected to a GCOS 
server).
Print an experiment.
Register or unregister the local workstation or GCOS server.

Publish Delete published data or a probe array type from a publish database.
Create a publish database.

Import Import experiment data to the process database

Userset tab Create or modify a userset (a set of predefined parameter settings for 
the Statistical Expression algorithm).
Delete a probe array type from a userset.
Delete a userset.

Template Create a template (a predefined form used to register samples and 
define experiments in GCOS 1.0).
Deactivate or activate a template for use in GCOS 1.0.
Rename a template.

Roles
(available only to 
users connected to 
a GCOS server)

Create a role (a defined set of user privileges).
Delete a role.
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GCOS Manager Icons

Table 15.2 shows the icons used in GCOS Manager.

Table 15.2
GCOS Manager Icons

Sample Template Properties information

Project Global Gray bullet indicates processes 
that have been completed.

Experiment information Server Green bullet indicates processes 
waiting to commence.

Scanned probe array image 
data (.dat)

Process database 
(yellow)

Red check mark on an 
experiment, .dat, .cel, or .chp 
icon(s) indicates that the data 
already exist in the publish 
database.

Computed cell intensities 
(.cel)

Publish database  
(gray)

Export status

Probe analysis data (.chp) Import to database Import status

Probe array type Domain Delete status

Chip User group Archive status

Vessel User Create publish database status

Userset Role Filter
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Terminology

Table 15.3 lists terms that are used frequently throughout this chapter. For 
your convenience, the terms are listed under the tabs where they are most 
frequently found.

 

Table 15.3
Terminology common to all tabs

Data & Object Types 
Across All Tabs Definition

Automate A monitored task whose status, either on or off, is viewed in the 
Local Task pane. Automate On indicates GCOS will automatically 
track an experiment through data analysis after the probe array has 
been scanned. 

Sample A set of experiments.

Experiment Specifies the type of probe array to which the target (sample) will 
be hybridized as well as other information relevant to the 
experiment. The experiment name provides the name for the data 
types that are subsequently generated in the analysis. 

Note: The Import tab shows experiment, cell intensity, or probe 
analysis data that can be imported or copied to the process 
database. In GCOS, the process database includes the experiment 
and sample data. 

Image data (.dat) The .dat file contains the image data of the scanned probe array 
data acquired in GCOS. The image data along with the image 
attributes stored in the database define the raw image data.

Cell intensity data (.cel) The cell file (.cel) of computed intensities that GCOS automatically 
generates from the image data file (.dat). GCOS can publish the 
.cel to a publish database where it is accessible to the Affymetrix® 
Data Mining Tool (DMT).

Probe analysis data 
(.chp)

The probe analysis output or chip file that is generated by the 
GeneChip data algorithms. GCOS can publish expression .chp to a 
publish database where it is accessible to the Affymetrix® DMT.
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Table 15.4
Terminology in the Process tab

Process Tab Terms Definition

Active server More than one GCOS server may be registered. The active server 
refers to the GCOS server where the displayed process database 
resides.

Archive Move files from the process database to an external location.

Unarchive Restore archived files to the process database.

Export Copy data from the process database and send to an external 
location.

Note: For an export from GCOS to Microarray Suite (MAS) 5.x, 
data created in GCOS are used to generate data files that are 
added to the default file location in MAS.

Process database Database residing on the workstation or GCOS server that 
contains experiment and sample data. There is only one process 
database per workstation or GCOS server.

Project A set of experiments with a common bond that are grouped 
together by their affiliation with a project. A project is created 
during sample registration in GCOS.

Table 15.5
Terminology in the Publish tab

Publish Tab Terms Definition

Affymetrix® Analysis 
Data Model (AADM)

The AADM is the relational database schema that Affymetrix uses 
to store experiment data (.dat, .cel, .chp) in the publish database 
so that results may accessed by the Affymetrix® Data Mining Tool 
and other third party analysis tools. The AADM includes additional 
tables to support expression results. The AADM is publicly 
available to support open access to experiment information 
generated and managed by Affymetrix® software.

Cell intensities The computed intensities that GCOS automatically generates from 
the image data (.dat). GCOS can copy or publish the cell intensity 
data to a publish database.

Publish database An AADM database residing on a server that contains select 
published process data. More than one publish database may 
reside on a single server.

Publish To copy or migrate experiment data to an AADM database on the 
workstation or GCOS server.
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Table 15.6
Terminology in the Import tab

Import Tab Terms Definition

Create Sample Creating a sample captures sample information and identifies the 
relationship between the experiment and experiment data (.cel, 
.chp) that are being imported.

Import Copies experiment data (.cel, .chp) created in GCOS to the process 
database on the workstation or the GCOS server.

Note: For an import to GCOS from Microarray Suite (MAS) 5.X, 
data are extracted from the experiment data files created in MAS 
and are added to the process data base.

Table 15.7
Terminology in the Userset tab 

Userset Tab Terms Definition

Userset A predefined set of values for modifiable parameters in the 
Statistical Expression algorithm.

Independent parameter Static settings defined in the userset that are not influenced by the 
probe array type.

Dependent parameters Settings defined in the userset that are specific to a particular 
probe array type.
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Table 15.8
Terminology in the Template tab

Template Tab Terms Definition

Activate Restores an inactive (deactivated) attribute or template.

Template A form created by the administrator that defines the attributes and 
values which are required to register samples and define 
experiments in GCOS.

Deactivate attribute Renders an attribute inactive. The attribute is not permanently 
removed from the system. A deactivated attribute does not appear 
in GCOS until it is restored by the Activate command.

Deactivate template Permanently deletes a template from the system if it is not 
currently used by an experiment or sample. Otherwise, the 
template is deactivated and does not appear in GCOS until it is 
restored by the Activate command.

Table 15.9
Terminology in the Roles tab

Roles Tab Terms Definition

Privileges The functions or permissions that define a role.

Role Definitions Identifies the first branch under the active server where the role 
names are listed.

Role A defined set of user access privileges.

User Definitions Identifies the branch under the process database where role 
membership is defined.
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Process Tab

This section of the manual explains the layout of the Process Tab window, its 
functions, and how to accomplish tasks here.

The Process tab shows you the data in the system for all registered servers, 
where the data are found, and environmental property information about the 
data.

The Process tab window is divided into three windowpanes (Figure 15.2).

Figure 15.2    
Process tab windowpanes
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Process Tab Windowpanes

Process Tab Functions

The primary tasks in the Process tab are:

■ archive or unarchive data
■ delete data
■ export data
■ assume ownership of data
■ print data

The primary data types in the Process tab are: 

■ sample
■ project
■ experiment
■ image data, cell intensity data, and probe analysis data

The tasks associated with each data type are found under Process in the 
menu bar. Alternatively, right-click an item to view a shortcut menu 
(Figure 15.3).

Process 
database 
tree 

Shows the active server, process database, and data types (samples, projects, and 

types of probe arrays). The data type subfolders contain samples , projects , 

or probe array types . Click a sample or project to display the associated 
experiment data (.dat, .cel, .chp) in the data pane.

Selected 
data 

Shows the experiment data of the sample or project selected in the process 

database tree. The first time you click an experiment  in the tree of selected data,
the information is read and a + sign appears next to the experiment name. Click the +
sign to display the associated data.

Task 
status/
Properties

Displays the property information or local task view, depending on the item selected
in process database tree or the selected data pane. Property information is defined 
by the template that was used during sample registration in GCOS. The task status 
view shows the status of processes that may be occurring in the database (for 
example, export, import, delete, archive, or create). In the task status view, you can 
monitor these jobs while you work on other tasks in the system.
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Archiving Data

Archiving data moves a user-selected data type to an external storage 
location. An archived data type no longer exists in the process database; 
however, its representative icon remains in the data tree and appears gray to 
indicate the data are available through the unarchive process.

1. In the Process tab, click the sample or project that contains the data you 
want to archive.

2. In the data pane, right-click the data that you want to archive and select 
Archive from the shortcut menu that appears (Figure 15.3). Alternatively, 
click the data and select Process → Archive Data Path from the menu 
bar.

⇒ The Select Archive Data Path dialog box appears (Figure 15.4).

Figure 15.3    
Process tab shortcut menus 
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3. Select a drive from the Drive drop-down list and navigate to the 
directory where you want to archive the data.

4. Click OK.

⇒ The data are archived in the specified directory.

Figure 15.4    
Select Archive Data Path dialog box

To view more information about the archive task status, right-click 

 in the Task Status/Properties pane and select View Task Log 
from the shortcut menu that appears (Figure 15.5). Alternatively, double-

click  to view the archive task log (Figure 15.6).

Figure 15.5    
Task Status/Properties pane
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\

Unarchiving Data

The icon for archived data appears gray. The unarchive command restores 
archived data to the process database.

1. In the Process tab, click the sample or project that contains the file you 
want to unarchive.

2. In the data pane, right-click the data that you want to unarchive and 
select Unarchive from the shortcut menu that appears (Figure 15.3 on 
page 285). Alternatively, click the data and select Process → Unarchive 
from the menu bar.

Selecting the parent data includes all related child data in the unarchive 
process.

If GCOS Manager cannot find the archived file, a Data Location dialog 
box appears. Enter the location of the data you want to unarchive in this 
dialog box.

⇒ The data are unarchived and restored to the process database on the 
active server. 

Figure 15.6    
Archive task log

Use the Find function to generate a list of files associated with a specific 
project. Next, SHIFT-select and archive the data in one quick step. This is 
only available for .dat, .cel, and .chp files in the process database.

The Process window does not automatically refresh upon completion of 
the Archive or Unarchive task. Therefore, if you unarchive data, the 
icon remains gray even though the task was completed successfully. To 
refresh the view, select View → Refresh from the menu bar.
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Changing Data Ownership

If needed for security or management purposes, you can assume or assign 
ownership of data (change the user attribute of data). 

If the Take Ownership Process Data option is defined for a user in the 
Roles tab, the user can:

■ assume ownership of samples, experiments, or analyses
■ assign ownership of samples, experiments, or analyses to a user who is 

also a member of a user group that the assignor belongs to

(For more information on role definition, see Roles Tab, on page 357). 

Data ownership means you have permission to overwrite a file with new 
contents. For example, an owner can reanalyze cell intensity data using 
different parameter settings for the Statistical Expression algorithm to 
generate new probe analysis data.

Assuming Ownership

1. In the Process tab, right-click the sample, project, or data of interest.

2. Select Assume Ownership from the shortcut menu that appears.

⇒ Your user name is displayed in the Task Status/Properties pane 
(Figure 15.8).

Assigning Ownership

1. In the Process tab, right-click the sample, project, or data of interest.

2. Select Assign Ownership from the shortcut menu that appears.

⇒ The Assign Owner dialog box appears (Figure 15.7).

This feature is only available to users connected to a GCOS server.
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3. Enter the name of the new owner, and click OK.

⇒ The user name of the new owner is displayed in the Task Status/
Properties pane (Figure 15.8).

Figure 15.7    
Assign Owner dialog box

Figure 15.8    
Process tab, Task status/Properties pane shows the user name of the owner of the selected data

Data
owner

Task status/
Properties
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Deleting Process Data

You can delete samples, experiments, experiment data (.cel, .chp), or 
usersets. Deleting a sample deletes all associated experiments and analyses 
(.cel, .chp). Deleting an experiment deletes the associated analyses (.cel, 
.chp). 

1. Right-click the item that you want to delete, and select Delete from the 
shortcut menu that appears. Alternatively, click the item and select 
Process → Delete from the menu bar.

⇒ A warning/confirmation box appears (Figure 15.9).

2. Click Yes to continue.

⇒ The Task Status/Properties pane displays the delete local task status.

The Delete option permanently removes data from the database.  
There is no restore function to recover deleted data.

Figure 15.9    
Delete warning/confirmation box

To view more information about the delete task status, right-click 

 in the Task Status/Properties pane and select View Task Log 
from the shortcut menu that appears (Figure 15.10). Alternatively, double-

click  to view the delete task log (Figure 15.11).

Figure 15.10    
Task Status/Properties pane
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Figure 15.11    
Delete task log

Deleting process data is different from deleting publish data (see 
Chapter 12 Publishing Data on page 275). Deleting published data 
removes only the data that has been published to a publish database. 
The data source in the process database remains available.
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Deleting a Probe Array Type

You can remove an unused or unwanted probe array type from the process 
database.

1. In the process pane data tree, expand the assay folder (for example, 
Expression) under the Probe Array Type folder (Figure 15.12).

2. Right-click the probe array type that you want to delete and select 
Delete from the shortcut menu that appears. Alternatively, click the 
probe array type and select Process → Delete from the menu bar.

⇒ A warning/confirmation box appears (Figure 15.13).

Deleting a probe array type deletes the associated usersets. The data 
created with these usersets remain, but are not accessible.

Figure 15.12    
Process pane

Figure 15.13    
Delete warning/confirmation box
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3. Click Yes to continue.

⇒ The selected probe array type is removed from the process database.

Exporting Data

You can export (copy) sample or experiment data (.dat, .cel, .chp) to an 
external storage location.

 

1. In the Data pane, right-click the item that you want to export and select 
Export from the shortcut menu that appears. Alternatively, select the 

item and click the Data Path button  or select Tools → Data Path 
from the menu bar. 

Selecting an object includes all of the data that are associated with it. 
For example, selecting image data (.dat) includes any related cell 
intensity data (.cel) and probe analysis data (.chp).

⇒ The Select Export Data Path dialog box appears (Figure 15.14).

2. Choose a drive from the Drive drop-down list and a directory path from 
the Directories box. 

3. Click Network to map a network drive to a drive letter.

Sample and experiment information are exported to an Affymetrix® 
Microarray Suite 5.x .exp file.

Figure 15.14    
Select Export Data Path dialog box
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4. Click OK.

⇒ The Task Status/Properties pane displays the export local task 
status.

 

To view more information about the export task status, right-click 

 in the Task Status/Properties pane and select View Task Log 
from the shortcut menu that appears (Figure 15.15). Alternatively, double-

click  to view the export task log (Figure 15.16).

Figure 15.15    
Task Status/Properties pane

Figure 15.16    
Export task log
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Registering a GCOS Server

Registering a GCOS server makes it available to GCOS Manager. 

1. Click the  button or select Tools → Register GCOS Server from the 
menu bar.

⇒ The Register GCOS Server dialog box appears (Figure 15.17).

2. Select the server that you want to register and click OK.

⇒ The selected server is added to the drop-down list on the toolbar and 
becomes the active server.

If the selected server is not GCOS aware, an error message is displayed 
(Figure 15.18).

Figure 15.17    
Register GCOS Server dialog box

Figure 15.18    
Register GCOS Server error message
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Unregistering a GCOS Server
■ In the process pane, right-click the GCOS server that you want to remove 

and select Unregister GCOS Server from the shortcut menu that 
appears.

Viewing Server Events

The server events option displays a log of the events that occurred on the 
active server.

■ To display the Event Viewer, click the Server Events button  or select 
Tools → Server Events from the menu bar (Figure 15.19).

The error message indicates that there is no GCOS Server software 
installed, or that there is an installation error. For further information, 
please refer to the Affymetrix® GeneChip® Operating Software Server 
Installation and Administration Guide.

Figure 15.19    
Event Viewer shows an event log for the active server
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Viewing the Publish Tasks

You can use the Server Task option to view the publishing queue on the 
active server.

1. Click the Server Tasks  button or select Tools → Server Tasks from 
the menu bar.

⇒ The task list for the active server appears and shows all items in the 
publishing queue (Figure 15.20).

2. To sort the task list in ascending order, click a column header to define 
the primary sort order (for example, the Started column header). To sort 
the task list in descending order, click the same column header again. 

Figure 15.20    
Task list displays the publishing queue on the active server

Service status

Select a column header to define the primary sort order. 
Click the header once to sort the task list in ascending 
order. Click again to sort in descending order.

Click to view the task list menu 
or right-click a task in the list.
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Task List Items & Commands

 indicates a new task in the queue waiting to be published

 blue check mark indicates a task that is being published

 green check mark indicates a completed (published) task

 indicates an incomplete task that was not published due to an error

To view the task list commands, click the  icon (upper left corner of the 
window) (Figure 15.20) or right-click a task to display a shortcut menu. 

Task List Menu Command Use this command to...

View Tasks Display the status of each task in the publishing queue on the 
active server (Figure (Figure 15.21)).

View Task Items Display all items for a selected task (Figure 15.21).

View All Items Display all items for all tasks in the Task List window.

Cancel Cancel a pending publish task.

Restart Reactivate the publish process for a cancelled task.

Save As Save the task list to a text file (.txt).

Delete Task Items Remove all task items from the Task List window.

Figure 15.21    
Server Task window, View Task Items command displays all items for a selected task
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Saving the Task List

You can save the items in the Server Task window to a text file (.txt).

1. Right-click a task in the Server Task window and select Save As from 

the shortcut menu that appears. Alternatively, click the  icon in the 
upper left corner of the Task List window and select Save As from the 
drop-down menu.

⇒ The Save As dialog box appears (Figure 15.22).

2. From the Save in drop-down list, navigate to the destination where you 
want to save the .txt file.

3. Name the file and click Save.

⇒ The task list is saved as a text file in the defined destination.

Figure 15.22    
Save As dialog box
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Deleting Task Items

To remove all of the task items from the Server Task Window:

1. Right-click a task and select Delete Task Items from the shortcut menu 

that appears. Alternatively, click the  icon in the upper left corner of 
the Task List window and select Delete Task Items from the drop-down 
menu.

⇒ A warning/confirmation window appears (Figure 15.23).

2. Click Yes to delete all tasks on and before the date and time indicated.

⇒ The items are deleted and Server Task window is empty.

Cancelling or Restarting an Active Publish Task
■ To stop the publish process, right-click a pending task and select Cancel 

from the shortcut menu that appears.
■ To reactive the publish process for a task that has been cancelled or 

stopped due to error, right-click the task and select Restart from the 
shortcut menu that appears.

Figure 15.23    
Task Delete warning/confirmation
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Find Function

You can use the Find feature to search the process database for samples, 
experiments, or experiment data (.dat, .cel, .chp), then apply the Export, 
Archive, Assume Ownership or Delete command to the objects returned by 
the search. The action affects only the selected objects and does not affect 
related children objects.

1. Click the Find button . Alternatively, select Tools → Find from the 
menu bar. 

⇒ The Find window appears (Figure 15.24).

The Find window has three tabs: 
■ Select Object 
■ Advanced Filter 
■ Date Filter

The Find function searches only the process database.

All three Find tabs work in union. For example, if you select sample 
(object type) in the Select Object tab, then only the boxes that pertain to 
finding samples will be active in the Advanced Filter tab.

You may open multiple Find windows.
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Figure 15.24    
Find window, Select Object tab
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2. Click the Select Object, Advanced Filter, or Data Filter tab and make 
selections from the drop-down lists, or enter text for the search.

Further refine your search by specifying additional search parameters in 
the other Find tabs.

3. Click Find Now.

⇒ The search results are displayed at the bottom of the window 
(Figure 15.25).

Figure 15.25    
Find window, Select Object tab
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4. To sort the search results, choose a column header to define the primary 
sort order. Click the column header to sort the results in ascending order. 
Click the header again to sort in descending order.

5. To apply the Export, Archive/Unarchive, Delete, or Assume 
Ownership command to the returned search objects:

a. Select the objects for the command.

To select adjacent objects, press and hold the Shift key, and 
click the first and last object in the selection. To select non-
adjacent objects, press and hold the Ctrl key while you click 
the objects of interest.

b. Right-click the selection and choose the command that you want to 
apply in the shortcut menu that appears (Figure 15.25). Alternatively, 
select the command from the Find menu in the menu bar.

Filtering Samples

You can filter the samples that are displayed in the Process tab data tree 
(Figure 15.26). Sample filters are available in the Process or Import tab when 
you click a subfolder of the Samples directory. The filters remain active from 
session to session until the parameters are changed.

1. In the data tree, click the Samples folder and the assay folder (for 
example, Expression).

⇒ The data tree displays the samples and the Filter button  
becomes available.

2. Click the Filter button .

⇒ The Sample Filter dialog box appears (Figure 15.26).

3. Select filter parameters from the drop-down boxes.

The Role and User filter options are mutually exclusive. You may select 
one or the other, but not both.

4. Click Apply. 

⇒ The sample filters are applied to the data tree.

When you apply a command to selected search results, the command 
affects only the selected objects and does not affect any associated data 
(related children objects).
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Figure 15.26    
Selections in the Sample Filters dialog box (top) determine the samples displayed in the process pane data tree 
(bottom)

Specify sample filters 
that determine the 
samples displayed in 
the data tree.
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Publish Tab

In the Publish tab you can create new publish databases and delete published 
data from a database. This section of the manual explains the layout of the 
Publish tab window, its functions, and how to accomplish tasks here. 

■ Click the Process tab.

⇒ The three Process tab windowpanes are displayed (Figure 15.27).

Figure 15.27    
Publish tab windowpanes

This pane is 
blank until 
you initiate 
a create 
database 
command.

Database tree

Task status/
Properties

Create 
database   
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Publish Tab Windowpanes

Publish Tab Functions

The primary tasks in the Publish tab are:

■ create a publish database
■ delete data or a probe array type from the publish database

The tasks associated with a publish database, published data, or a probe 
array type are found under Publish in the menu bar. Alternatively, right-
click an item to view a shortcut menu that appears (Figure 15.28).

Publish database 
tree 

Displays a tree that shows the active server, the publish databases on the 
server, and the supported probe array types and their contents experiment 
data and analysis data (.cel, .chp) that have been published for that probe 
array type).

Create database Shows the Create Database dialog box when you initiate a create database 
command.

Task Status/
Properties 
pane

Displays the status of processes that may be occurring in the database (for 
example, export, import, delete, archive, or create). In the task status view, 
you can monitor these jobs while you work on other tasks in the system.

Figure 15.28    
Publish tab shortcut menus
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Accessing a Publish Database

Each publish database is password protected. The password is defined 
during the creation of the database. You can change the password for a 
database on the GCOS server using the GCOS Server Sync utility. (For more 
information on the GCOS Server Sync utility, see the Affymetrix® GeneChip® 
Operating Software Server Installation and Administration Guide.)

1. In the publish pane, click the database that you want to access.

⇒ A Publish Database Login window appears (Figure 15.29).

2. Enter the database password and click Login.

⇒ The publish database tree expands and displays the Probe Array 
Type folder (Figure 15.29).

Deleting a Probe Array Type

Probe array types that are no longer used may be removed from a publish 
database. When you delete a probe array type, all of the associated published 
data (from the parent down) are also deleted.

Passwords are case-sensitive.

Figure 15.29    
Publish Database Login box



  Affymetrix®  GeneChip®  Operating Software User’s Guide 309
1. Click the Probe Array Type folder under the publish database of 
interest.

2. Right-click the probe array type that you want to delete and select 
Delete from the shortcut menu that appears. Alternatively, click the 
probe array type and select Publish → Delete from the menu bar.

⇒ A warning window appears (Figure 15.30).

3. Click Yes to continue.

⇒ The probe array type and all associated data are removed from the 
publish database.

Deleting Published Data

Deleting publish data removes selected cell intensity or probe analysis data 
from the publish database. When you delete published data, all children data 
are also removed.

1. In the server drop-down list, select the server where the publish database 
resides.

2. In the publish pane, select the database of interest and expand the tree.

3. Right-click the data that you want to delete and select Delete from the 
shortcut menu that appears. Alternatively, click the data and select 
Publish → Delete from the menu bar.

Figure 15.30    
Probe array delete warning/confirmation box

Deleting publish data permanently removes the data from the publish 
database. If the information still resides on the process database, the 
data can be restored to the publish database by repeating the publish 
procedure in GCOS.
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4. On the menu bar select Publish → Delete.

⇒ A warning/confirmation box appears (Figure 15.31).

5. Click Yes to continue.

⇒ The Delete task proceeds. 

The task status/properties pane displays the status of the delete task. 

Figure 15.31    
Analysis delete warning / confirmation window

To view more information about the delete task status, right-click 

 in the Task Status/Properties pane and select View Task Log 
from the shortcut menu that appears (Figure 15.32). Alternatively, double-

click  to view the delete task log (Figure 15.33).

Figure 15.32    
Task Status/Properties pane
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Creating a Publish Database

In the Publish tab, you can create a new publish database. Table 15.10 shows 
the location, size, and storage capacity options for a publish database.

Along with the new database, GCOS Manager also creates the ODBC DSNs 
that are required for publishing data. Several key pieces of information are 
needed to create a publish database, including:

■ the server where the database will reside
■ a username and password with appropriate permissions for creating 

databases on the selected server
■ the database size
■ the proper drive and path for the database files

The server name is represented by an ODBC data source name description. 
This ODBC DSN specifies the location of an administration database that is 
used to create the actual publish database. This DSN is usually created 
during installation of the software.

The initial size of a Microsoft® SQL Server 2000 publish database on the 
GCOS server can range from 128 to 1024 MB. The size can easily be 
increased after the database is created. For information on increasing the size 
of a publish database on the GCOS server, see the GCOS Server 
Administration and Installation Guide.

Figure 15.33    
Delete task log
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A MSDE publish database on the workstation has a 2 GB size limit. If the 
database reaches this limit, create a new publish database.

Creating a Microsoft® MSDE Publish Database on the Workstation

1. Select the server where the publish database will reside from the drop-
down list on the toolbar (Figure 15.34).

2. In the publish pane, right-click the server name in the data tree and 
select Create MSDE Database from the shortcut menu that appears. 
Alternatively, click the server name and select Publish → Create 
MSDE Database from the menu bar.

⇒ The Create Database dialog box appears (Figure 15.34).

 

MSDE cannot create a publish database on a network drive.

Table 15.10
Publish database location, size, and storage capacity options

Publish Database/
Location Size Options Storage Capacitya

a. Based on a probe array with 270x270 features, 1800 probe sets per array.

Microsoft® MSDE/
workstation

up to 2 GB 8 MB per experiment (includes experiment 
information, .cel, .chp)

8 MB per library file

128 MB database = 4 library files & 12 
experiments

Microsoft® SQL 
Server 2000/GCOS 
server

128-1024 MB 
initial size range

8 MB per experiment (includes experiment 
information, .cel, .chp)

8 MB per library file

128 MB database = 4 library files & 12 
experiments

1024 MB database = 16 library files & 110 
experiments

Oracle®/GCOS server Small (~6 GB)
Large

~500 experiments
~1000 experiments
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3. In the Create Database dialog box:

a. Enter a name for the new database.

The database name is limited to 22 characters in length. 

b. Enter a password for the database. Re-enter the password to confirm 
it.

The publish database can only be accessed with this 
password.

4. To select the path for the database, do either of the following:

■ Enter the path for the publish database

Figure 15.34    
Publish tab, create a MSDE publish database

Select the server for the 
publish database

Create Database dialog box

Database tree
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■ Click Browse and select a folder from the Choose Folder dialog box 
(Figure 15.35).

5. Click Install.

⇒ It takes several minutes to create the database and allocate the 
amount of drive space requested (2 -15 minutes or more, depending 
on the speed of the workstation and drive).

Once it is created, the database is available for publishing without 
further configuration. 

Creating a Microsoft® SQL Server 2000 Publish Database on the GCOS 
Server

1. Select the server where the publish database will reside from the drop-
down list on the toolbar (Figure 15.36).

2. In the database tree, right-click the server name and select Create SQL 
Server Database from the shortcut menu that appears. Alternatively, 
click the server name and select Publish → Create SQL Database from 
the menu bar.

⇒ The Create Database dialog box appears (Figure 15.36).

3. In the Create Database dialog box:

Figure 15.35    
Choose Folder dialog box
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a. Enter a name for the new database.

The database name is limited to 22 characters in length. 

b. Enter a password for the database. Re-enter the password to confirm 
it.

The publish database can only be accessed with this 
password. 

Figure 15.36    
Publish tab, create a Microsoft® SQL Server publish database

Database tree

Select the server for the publish database Create Database dialog box
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4. Enter the following information in the Data device, Index device, and 
Log device sections:
■ Path: Use the complete drive description, including the drive letter, 

colon, and backslash (for example, E:\Affymetrix DBDevices).

■ Size (MB): The size depends on the number of experiments that will 
be published to the database and the amount of available space on 
the selected drive. A Microsoft® SQL Server database is easy to 
expand after creation; therefore, creating a smaller database and 
expanding it as necessary is recommended.

5. Click Install.

It takes several minutes to create the database and allocate the amount of 
drive space requested (12-15 minutes or more, depending on the speed 
of the server and drive).

Once created, the database is available for publishing without further 
configuration. If the new database does not appear in the data tree, 
verify that the database and ODBC DSN were created properly.

Creating an Oracle® Publish Database on the GCOS Server

An Oracle publish database is much larger than the default Microsoft SQL 
Server database. Before you create an Oracle database, verify that there is 
adequate space available on the server. The small size Oracle publish 
database requires 6 GB and the large size requires 12 GB. These sizes have 
capacity for approximately 500 and 1,000 published experiments 
respectively.

1. Select the server where the publish database will reside from the drop-
down list on the toolbar (Figure 15.37).

2. In the database tree, right-click the server name in the data tree and 
select Create Oracle Database from the shortcut menu that appears. 
Alternatively, click the server name and select Publish → Create 
Oracle Database from the menu bar.

⇒ The Create Database dialog box appears (Figure 15.37).

3. In the Create Database dialog box:

The drive letter specifies the drive on the actual publish database server. 
If you are creating the publish database on a remote server, make sure 
the selected drive letter is available on that server.
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a. Enter a name for the new database.

The database name is limited to 22 characters in length. 

b. Enter a password for the database. Re-enter the password to confirm 
it.

The publish database can only be accessed with this 
password. 

Figure 15.37    
Publish tab, create Oracle® database

Select the server for the publish database Create Database dialog box
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4. In the Data Device section enter the following information:

■ Server Device Path: This is the complete path for the database files. 
Use the complete drive description for Windows 2000 (for example, 
E:\Affymetrix DBdevices\). Be sure to include the trailing slash.

■ Database Size: make a selection from the drop-down list. 
The Small database requires approximately 6 GB of drive space and 
the Large requires approximately 12 GB.

5. Click Install.

It takes several minutes to create the database and allocate the amount of 
drive space requested (15 - 30 minutes or more, depending on the speed 
of the server and drive).

Once it is created, the database is available for publishing without 
further configuration. If the newly created database does not appear in 
the data tree, verify that the database and the ODBC DSN were created 
properly.

Import Tab

In the Import tab you can copy experiment data (.exp, .cel, .chp created in 
MAS 5.x) into the GCOS or GCOS server process database. This section of 
the manual explains the layout of the Import tab window and how to 
accomplish tasks here. 

■ Click the Import tab.

⇒ The four windowpanes of the Import tab are displayed (Figure 15.38).

The data file path directly specifies the file location on the actual publish 
database server. If you are creating a publish database on a remote 
server, make sure the specified path is available on that server.

The data file path directory used specifies the file location on the actual 
publish database server. If the publish database is being created on a 
remote server, make sure the path specified is available on that server.
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Filtering Samples

You can filter the samples that are displayed in the sample tree (Figure 15.38). 
Sample filters are available in the Import or Process tab when you click a 
subfolder of the Samples directory. The filters remain active from session to 
session until the parameters are changed.

1. In the sample tree, click the Samples folder and the assay folder (for 
example, Expression).

⇒ The sample tree displays the samples and the Filter button  
becomes available.

Figure 15.38    
Import tab windowpanes

 Staging area  Available data

Sample tree

Task status/
Properties

Active 
server
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2. Click the Filter button .

⇒ The Sample Filter dialog box appears (Figure 15.26).

3. Select filter parameters from the drop-down boxes.

The Role and User filter options are mutually exclusive. You may select 
one or the other, but not both.

4. Click Apply. 

⇒ The sample filters are applied to the data tree.
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Figure 15.39    
Selections in the Sample Filters dialog box (top) determine the samples displayed in the sample data tree (bottom)

Specify 
sample 
filters that 
determine 
the samples 
displayed in 
the sample 
tree.
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Import Tab Windowpanes

Importing Data

The Import function imports or copies experiment data created in MAS 5.x 
and moves them to a process database on the workstation or a GCOS server. 
You can import data to multiple GCOS servers. 

Importing data is a three-step process:

■ Select the data path that specifies the location of the MAS 5.x 
experiment data (.exp, .dat, .cel, .chp) that you want to import.

■ Create a new sample or select an existing sample to associate with 
the experiment data (the data will be also be associated with the 
project specified by the sample information).

■ Associate the experiment data with the selected sample so that 
GCOS Manager can track the data in the process database.

Selecting an Import File Path

1. Click the data path button . Alternatively, select Tools → Data Path 
from the menu bar.

⇒ The Select Import Data Path dialog box appears (Figure 15.40).

Sample tree Shows the active server, process database, and samples in the system.

Staging area Shows the sample(s) that will be associated with experiment data for import.

Data 
available for 
import

Displays the experiment data located at the defined import data path.

Task status/
properties 
status/
Properties

Displays the property information or local task view, depending on the item 
selected in process database tree or the selected data pane. Property 
information is defined by the template that was used during sample registration 
in GCOS. The task status view shows the status of processes that may be 
occurring in the database (for example, export, import, delete, archive, or 
create). In the task status view, you can monitor these jobs while you work on 
other tasks in the system.
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2. Make a selection from the Drives from the drop-down list and navigate 
to the data that you want to import.

3. Click OK.

⇒ The defined data path and the experiment data at that location are 
displayed in the available data windowpane (upper right) in the 
Import tab (Figure 15.41).

Figure 15.40    
Select Import Data Path dialog box

Figure 15.41    
Import tab, available data windowpane shows data available for import at the current import 
data path

Import data path



CHAPTER 15   GCOS Manager324
Specifying a Sample for Imported Data

The experiment data for import are not associated with a sample or project. 
You must associate the data with a sample and a project so that GCOS 
Manager can track the data in the process database. You can associate the 
imported data with a new sample or an existing sample. 

Creating & Editing a New Sample

1. Right-click the appropriate assay folder (for example, Expression) in the 
process database tree and select Create Sample from the shortcut menu 
that appears. Alternatively, click the assay folder and select Import → 
Create Sample from the menu bar.

⇒ The Create Sample dialog box appears (Figure 15.42).

Table 15.11 and Figure 15.14 list the data entry rules for the fields in the Create 
Expression Sample dialog box.

The default data path is the same path assigned to Affymetrix® GCOS 
experiment data.

Table 15.11
Rules for data input

Data Input Rule

Character length < 64 characters

Invalid characters \ / : * ? “ < > | ‘ ~ ´, { } [ ]

Required data fields Required fields are indicated by blue titles and may not 
be left blank.

Data fields A name may not duplicate an existing name.
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2. Enter the following required information (or make selections from the 
drop-down lists):

■ Sample name
■ Sample project name
■ Sample type

3. Enter any descriptions or comments.
 

4. Click OK.

⇒ The new sample appears in the import staging area (middle pane).

Table 15.12
Valid field lengths

Sample 
Attribute Length (characters)

Sample project 64

Sample type 64

Description 64

Comments 64

Sample name 64

If the sample name, project name, and sample type do not match the 
information stored in the experiment file, the software notifies you and 
directs you to the import log to determine inconsistencies.
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If necessary, you can edit the information for a new sample before you start 
the data import. 

Figure 15.42    
Import tab window and Create Sample dialog box

The sample name cannot be edited. You can only edit a new sample 
prior to data import. After data import, a sample cannot be edited. 
Samples created in GCOS cannot be edited.

Staging
area
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5. To edit the sample information prior to data import:

a. Right-click the sample name and select Edit from the shortcut menu 
that appears (Figure 15.43). Alternatively, click the sample name and 
select Import → Edit from the menu bar.

⇒ The Create Sample dialog box appears (Figure 15.42).

b. Enter the new information in the Create Sample dialog box and click 
OK when finished.

Selecting an Existing Sample

1. In the process database tree, expand the sample folder and click the 
sample of interest (Figure 15.44).

2. Drag the sample to the staging area.

⇒ The sample and all of the associated data are displayed with red 
check marks that indicate the data already exist in the database.

Figure 15.43    
Sample for imported data, shortcut menu
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Removing a Sample From the Staging Area

You can remove samples from the Staging Area.

■ Right-click the sample that you want to remove, and select Remove 
(for new samples) or Remove All (for existing samples) from the 
shortcut menu that appears (Figure 15.43). Alternatively, click the 

Figure 15.44    
Import tab, drag an existing sample to the Staging Area

Data available for import

 Staging Area
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sample and select Import → Remove or Import → Remove All from 
the menu bar. 

⇒ A new sample or an existing sample and its children files are 
removed from the staging area.

Associating Data & Samples

The last step in the import process is to associate the experiment data (.cel, 
.chp) with a sample. You can only associate data from probe array types 
installed in the process database. If you attempt to associate data from a 
probe array type that is not installed in the process database, an error is 
displayed.

Associating .exp with a Sample

In the available data pane (Figure 15.45), the EXP tab displays the experiment 
data (.exp) available for import at the designated data import path. When you 
associate an experiment (.exp) with a sample, the .dat, .cel, and .chp with the 
same prefix (if they exist) are also automatically associated with the sample. 

1. To associate a .exp with a sample, drag the data to the sample in the 
staging area (Figure 15.45).

⇒ The .exp is added to the below the sample along with the .cel and 
.chp with the same prefix (Figure 15.46).

2. To associate another .exp and its children data with the sample, repeat 
step 1.

The names of imported data must conform to the naming conventions 
in GCOS (see Table 15.12 on page 325). If necessary, rename a file so that 
the name complies with the naming conventions.
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Figure 15.45    
Import tab, drag the .exp to associate it with a sample in the staging area

 Staging area  Available data

File path that specifies location of 
experiment data available for import 
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Associating Additional .cel or .chp with a Sample

You can associate additional .cel or .chp that have different prefixes with a 
sample that is already associated with an .exp. This is done in a hierarchical 
manner by adding the .cel to the .exp that is associated with the sample of 
interest, and adding the .chp to the .cel.

■ To associate a .cel with a sample:

1. Select the CEL tab in the available data pane.

2. Drag the .cel to the .exp that is associated with the sample of interest in 
the staging area (Figure 15.47). Repeat this step to associate another .cel 
with the sample.

⇒ The .cel is displayed below the .exp (Figure 15.48).

Figure 15.46    
Staging Area showing N004.exp and children data associated with sample N008
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■ To associate a .chp with a sample:

1. Select the CHP tab in the available data pane.

2. Drag the .chp to the .cel that is associated with the sample of interest in 
the staging area. Repeat this step to associate another .cel with the 
sample. 

⇒ The .chp is displayed below the .cel (Figure 15.48).

To avoid having to associate a .cel and .chp with each .exp imported into 
the process database, simply import the .exp, then regenerate the.cel 
and .chp in GCOS using batch analysis. This minimizes potential errors 
from dragging a .chp to the wrong .cel. See Batch Analysis on page 229 
for more information.

Figure 15.47    
Import tab

 Available data Staging area
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Removing Data from the Staging Area

You can remove experiment data (.exp, .cel, or .chp) from the staging area. 
Use either of the following methods to remove data:

■ Right-click the sample that you want to remove, and select Remove 
(for data without children) or Remove All (for data and associated 
children data) from the shortcut menu that appears (Figure 15.43). 
Alternatively, click the sample and select Import → Remove or 
Import → Remove All from the menu bar. 

⇒ The selected data or data and children data are removed from the 
staging area.

■ Drag the data from the staging area to the available data pane. This 
must be done in an ascending hierarchical manner by dragging the 
.chp to the CHP tab, the .cel to the CEL tab, and the .exp to the EXP 
tab.

Figure 15.48    
Staging area showing .cel and .chp data associated with the sample N008

Additional .cel and .chp with different 
prefixes that are associated with 
sample N008
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Starting the Import

1. Right-click the process database, a sample, or one of the data items and 
select Start Import from the shortcut menu that appears. Alternatively, 
click one of these items and select Import → Start Import from the 
menu bar.

⇒ The import task proceeds and the task status/properties pane 
displays the import status.

2. To view more information about the import task status, right-click 
 in the Task Status/Properties pane and select View Task Log 

from the shortcut menu that appears (Figure 15.49). Alternatively, double-
click .

⇒ The import task log is displayed (Figure 15.50).

 

Figure 15.49    
Task Status/Properties pane

Figure 15.50    
Import task log
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Userset Tab

This section of the manual explains how to create, modify, or delete a 
userset. A userset is a set of modifiable Statistical Expression algorithm 
parameters with predefined values. For more information about the 
expression algorithm parameters, see Expression Analysis Algorithm, on 
page 515. 

A userset is defined by an administrator or other authorized user. It provides 
a convenient way to select analysis parameters without having to set each 
parameter individually before an analysis. A userset is applied in GCOS 
when you analyze expression cell intensity data.   

Userset Tab Windowpanes

■ Click the Userset tab. 

⇒ The three Userset windowpanes are displayed (Figure 15.38).



CHAPTER 15   GCOS Manager336
 

Figure 15.51    
Userset tab windowpanes

Userset tree Shows the active server, process database, user sets and associated probe 
array types.

Create/
Update pane 

Shows new userset information that can be specified or existing userset 
information that can be modified (Figure 15.52).

Task status/
properties 

Displays the property information or local task view, depending on the item 
selected in process database tree or the selected data pane. Property 
information is defined by the template that was used during sample registration 
in GCOS. The task status view shows the status of processes that may be 
occurring in the database (for example, export, import, delete, archive, or 
create). In the task status view, you can monitor these jobs while you work on 
other tasks in the system.

 Userset tree

Task status/
Properties

 Create/Update 
pane
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Creating a Userset

Creating a userset includes the following steps:

■ Enter a name for the userset.
■ Select the probe array type(s) that the userset will analyze.
■ Confirm the defaults or enter new values for the independent 

parameters.
■ Confirm the defaults or enter new values for the dependent 

parameters. 

Figure 15.52    
Create/Update pane 

Probe array 
types in the 
process 
database 

Existing 
userset 
names 

Probe array types included in an 
existing userset. Or probe array 
types to include in a new user set

New 
userset 
name

Independent
parameters

Dependent 
parameters
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1. In the Create set name box, enter a unique name for the userset.

2. In the Probe array types box, select a probe array type and click the 
arrow button >>. Repeat this step to add other probe array types for the 
userset.

⇒ The selected probe array type(s) is displayed in the Probe array 
types used box and the independent and dependent parameters are 
set to the default values (Figure 15.53).

 

3. If you want to use the independent and dependent parameter defaults, 
click Create Set.

⇒ The userset is created and the name appears in the Existing userset 
name(s) box.

If you do not want to accept the defaults, see the following sections on 
modifying the independent and dependent parameters. 

Figure 15.53    
Create/Update pane

Independent parametersDependent parameters
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Modifying Independent or Dependent Parameter Values

The statistical expression algorithm parameter settings are independent 
parameters. These are static settings that are not influenced by the probe 
array type. 

A dependent parameter is a setting that is specific to a particular probe array 
type. Dependent parameters include the scaling, normalization, probe mask, 
and baseline settings. For more information on these parameters, see 
Expression Analysis Settings, on page 532.

1. To modify an independent parameter:

a. In the independent parameters box, click the parameter that you 
want to modify.

⇒ The parameter name and current setting are displayed in the box 
above (Figure 15.54).

 

b. Enter a new value in the box and click Modify.

⇒ The new parameter value is displayed in the box below.

Figure 15.54    
Create/Update pane

Current value 
for the 
selected 
independent 
parameter. 
Enter a new 
value here.
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c. Repeat step b to modify other independent parameters.

2. To modify a dependent parameter:

a. Click the tab for the parameter you want to modify (Scaling, 
Normalization, Probe Mask, or Baseline).

b. Choose the analysis option that you want to include in the userset 
and enter any additional necessary information.

3. Click Create Set after you finish modifying the parameter values.

⇒ The userset is created and the name appears in the Existing userset 
name(s) box (Figure 15.54).

Modifying a Userset

You can modify the independent or dependent parameter values for a 
userset, or add or remove a probe array type(s) from a userset.

1. In the Existing userset name(s) box, click the userset that you want to 
modify.

⇒ The Create/Update pane shows the parameter values for the selected 
userset (Figure 15.55).

The new parameter values are applied after you click Create Set.
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2. To add a probe array type to the userset, select a probe array type in the 
Probe array types box, and click the arrow button >>. Repeat this step 
to add other probe array types for the userset.

⇒ The selected probe array type(s) is displayed in the Probe array 
types used box (Figure 15.55).

3. To remove a probe array type from the userset, do either of the 
following:

■ Select a probe array type in the Probe array types used box, and 
click the arrow button <<.

⇒ The selected probe array type is removed from the Probe array 
types used box.

■ In the userset tree, expand the Statistical folder and the userset that 
you want to modify. Right-click the probe array of interest and select 
Delete from the shortcut menu that appears (Figure 15.56).

Figure 15.55    
Create/Update pane
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4. To modify an independent or dependent parameter value, see the section 
Modifying Independent or Dependent Parameter Values, on page 339.

5. Click Update Set after you finish modifying the userset.

⇒ The modifications are saved to the userset and the task status/
properties pane displays the Statistical Expression algorithm 
properties (Figure 15.57).

If you remove a probe array type from the process database in the 
Process tab, the probe array is also removed from any userset that 
includes this array type in its Probe Array Types Used list.

Figure 15.56    
Userset tab window
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This information is metadata that exists in the process database and is used 
internally by GCOS and the GCOS server to distinguish different algorithms 
in the system.

Deleting a Userset

1. In the userset tree, right-click the userset that you want to delete and 
select Delete from the shortcut menu that appears. Alternatively, click 
the userset and select Userset → Delete from the menu bar.

⇒ A warning/confirmation box appears (Figure 15.58).

2. Click Yes to delete the userset.

⇒ The userset is removed from the userset tree and the Existing 
userset name(s) box in the create/update pane.

Figure 15.57    
Task Status/Properties pane

Figure 15.58    
Delete userset warning/confirmation box
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Template Tab

A template is a form that defines the attributes and values needed to register 
a sample or set up an experiment in GCOS. A sample or experiment 
template is created by the administrator or other authorized user. This 
section of the manual explains how to create and manage sample or 
experiment templates.

Template Tab Windowpanes

■ Click the Template tab.

⇒ The three Template tab windowpanes are displayed (Figure 15.59).

Figure 15.59    
Template tab windowpanes

 Template tree  Attributes

Task status/
Properties

This pane is blank until you select a 
template in the template tree or initiate 
a create template command. 



  Affymetrix®  GeneChip®  Operating Software User’s Guide 345
MIAME Sample Template

GCOS Manager provides a sample template based on the Minimum 

Information About a Microarray Experiment (MIAME).1 The MIAME 
sample template includes 23 types of sample attributes. For each attribute, 
you may:

■ define the data type
■ specify whether the attribute information is required for sample 

registration
■ specify the values available for a controlled value attribute

1. To view the MIAME Sample Information template, click the MIAME 
Sample Information template in the Sample Templates folder 
(Figure 15.60).

⇒ The Attributes pane displays the MIAME Sample Information 
template.

2. To enter template information, follow step 5 to step 12 in the section 
Creating a Template, on page 347.

Template 
tree 

Shows the active server, process database, and the experiment and sample 
templates that reside there. Click a sample or project to display the associated 
experiments and data (.dat, .cel, .chp) in the data pane. Select a template to display 
the attributes and values in the attribute pane.

Attributes Displays the template selected in the template tree. Displays a blank template 
when a Create Template command is initiated.

Task 
status/
Properties

Displays the property information or local task view, depending on the item 
selected in process database tree or the selected data pane. Property information 
is defined by the template that was used during sample registration in GCOS. The 
task status view shows the status of processes that may be occurring in the 
database (for example, export, import, delete, archive, or create). In the task status 
view, you can monitor these jobs while you work on other tasks in the system.

1. A. Brazma, P. Hingamp, J. Quackenbush, G. Sherlock, P. Spellman, C. Stoeckert, J. Aach, W. 
Ansorge, C.A. Ball, H.C. Causton, T. Gaasterland, P. Glenisson, F.C. P. Holstege, I.F. Kim, V. 
Markowitz, J.C. Matese, H. Parkinson, A. Robinson, U. Sarkans, S. Schulze-Kremer, J. Stew-
art, R Taylor, J. Vilo, and M. Vingron. Minimum information about a microarray experiment 
(MIAME)- toward standards for microarray data. Nature Genetics, 29:365-371.
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Figure 15.60    
MIAME Sample Information template
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Working with Templates

Creating a Template

When you create a template, you specify:

■ the attributes included in the template 
■ the data type for each attribute (for example, an integer or a character 

string)
■ whether the attribute is required
■ value options for a controlled data attribute

1. To create an experiment template, right-click the Experiment Templates 
folder and select Create from the shortcut menu that appears. 
Alternatively, click the folder and select Template → Create from the 
menu bar (Figure 15.61).

To create a sample template, right-click the Sample Templates folder 
and select Create from the shortcut menu that appears. Alternatively, 
click the folder and select Template → Create from the menu bar.

⇒ The Create Template box appears (Figure 15.62).

Figure 15.61    
Template tree, shortcut menu for experiment templates
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2. Enter a name for the template.

⇒ A blank template appears in the attribute pane (Figure 15.63) and the 
template name is added to the appropriate folder (experiment or 
sample). Click the folder and expand it to view the newly added 
template name.

Figure 15.62    
Create Template box

Figure 15.63    
Template tab, experiment template
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3. In the template, double-click the first blank cell under the Name 
column.

⇒ The mouse pointer becomes an I-beam and the other cells in the row 
are blocked (Figure 15.64).

4. Enter an attribute name and press ENTER.

⇒ The attribute name is inserted and numbered (Figure 15.65).

Figure 15.64    
Attributes pane

During the process of defining an attribute, you can click Undo to 
remove the entries from the Attributes pane. 
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5. Click the cell under the Type column and click the drop-down arrow that 
appears.

⇒ A drop-down list of data type options for the attribute appears 
(Figure 15.65).

6. Make a selection from the Type drop-down list.

⇒ The selected data type is displayed in the cell (Figure 15.66).

Figure 15.65    
Attributes pane

Integer Whole number

Float Floating point number

String Limited to 255 characters

Date Date

Time Time

Controlled Limits user response to the value options listed in the template.

Name 
attribute 
inserted
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7. Click the cell under the Required column and click the drop-down arrow 
that appears. 

8. In the drop-down list that appears, click Yes if the information is 
required or No if it is not (Figure 15.67).

If the information is required, GCOS requires the user to enter a value 
during the sample registration or experiment set up process.

Figure 15.66    
Attributes pane



CHAPTER 15   GCOS Manager352
9. If the attribute data type is controlled, double-click the cell under the 
Values column.

⇒ The Controlled Values Edit List box appears (Figure 15.68).

Figure 15.67    
Attributes pane

Figure 15.68    
Attribute pane and the Controlled Values Edit List box
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10. To define a controlled value:

a. Enter a value option in the box.

b. Press Enter. 

c. Repeat steps a and b to enter additional controlled values. 

d. Click OK when finished.

⇒ The controlled values appear in the Values drop-down list 
(Figure 15.69).

11. Click Apply.

⇒ The defined attributes are now in effect.

12. To define additional attributes for the template, repeat step3 through 
step 11.

Editing a Template

You can edit an existing template. 

1. In the template tree, click the template you want to edit.

⇒ The attributes pane displays the selected template.

Figure 15.69    
Attributes pane and the drop-down list of controlled values for the attribute
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2. To edit an attribute name, double-click the current entry and enter a new 
name.

3. Follow step 3 to step 11 in the section Creating a Template, on page 347 
to edit the attribute definition.

Deactivating or Activating a Template

You can deactivate a template to make it unavailable in GCOS. An inactive 
template can be activated to restore it for use in GCOS. 

1. To deactivate a template:

a. Right-click the template of interest in the template tree and select 
Deactivate from the shortcut menu that appears. Alternatively, click 
the template and select Template → Deactivate from the menu bar.

b.  Click OK in the warning window that appears.

⇒ The template icon appears gray in the template tree to indicate 
the template is inactive and is not available to GCOS.

2. To activate a template:

a. Right-click the template of interest in the template tree and select 
Activate from the shortcut menu that appears. Alternatively, click 
the template and select Template → Activate from the menu bar.

⇒  The template icon is restored to full color in the template tree to 
indicate the template is active and is available to GCOS.

Renaming a Template

1. In the template tree, right-click the template that you want to rename 
and select Rename from the shortcut menu that appears. Alternatively, 
click the template and select Template → Rename from the menu bar.

2. Enter a name for the template and press ENTER.

You cannot duplicate an existing name for the same type of template.
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Working with Attributes

To view a shortcut menu of attribute commands, right-click an attribute 
number (Figure 15.70). Alternatively, click an attribute number and select 
Template → Attribute from the shortcut menu that appears.

 

■ To select an attribute for a command, click the attribute number. 
■ To select a group of adjacent attributes, press and hold the Shift key 

while you click the number of the first and last attribute in the group.
■ To select non-adjacent attributes, press and hold the Ctrl key while 

you click the attribute numbers.

Figure 15.70    
Attributes pane, shortcut menu

Attribute 
number
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Inserting an Attribute

You can insert a blank row in the template.

1. Right-click the attribute number below the insertion point and select 
Insert from the shortcut menu that appears. Alternatively, click the 
attribute number and select Template → Insert from the menu bar.

⇒ A blank row is inserted in the template.

2. Define the attribute and click Apply.

Deactivating an Attribute

A deactivated attribute is not displayed in the template for sample 
registration or experiment setup in GCOS.

1. Right-click the number of the attribute that you want to deactivate and 
select Deactivate from the shortcut menu that appears. Alternatively, 
click the attribute number and select Template → Attribute → 
Deactivate from the menu bar.

⇒ The attribute remains in the template, but appears grayed-out.

2. Click Apply.

⇒ A warning message appears.

3. Click OK to deactivate the attribute.

Activating an Attribute

1. Right-click the number of the attribute that you want to activate and 
select Activate from the shortcut menu that appears. Alternatively, click 
the attribute number and select Template → Attribute → Activate from 
the menu bar.

⇒ The attribute is no longer grayed-out.

2. Click Apply.

⇒ The attribute becomes active and is available in the template.

In GCOS, the attribute is displayed in samples and experiments that 
were saved using the attribute. These cannot be modified. A deactivated 
attribute is not available for new samples or experiments.



  Affymetrix®  GeneChip®  Operating Software User’s Guide 357
Cutting, Copying or Pasting an Attribute

1. To cut an attribute, right-click the attribute number and select Cut from 
the shortcut menu that appears. Alternatively, click the attribute number 
and select Template → Attribute → Cut from the menu bar.

⇒ The attribute information is copied to the system clipboard.

2. To copy an attribute, right-click the attribute number and select Copy 
from the shortcut menu that appears. Alternatively, click the attribute 
number and select Template → Attribute → Copy from the menu bar.

⇒ The attribute information is copied to the system clipboard.

3. To paste an attribute, right-click the attribute number and select Paste 
from the shortcut menu that appears. Alternatively, click the attribute 
number and select Template → Attribute → Paste from the menu bar.

⇒ The attribute information on the system clipboard is pasted on the 
template at the end of the attribute list.

4. Click Apply.

Roles Tab

A role is a defined set of user access privileges. The administrator or other 
authorized user can create roles with different levels of access privilege for 
different users or groups of users. In this way, the roles function provides 
data security. This section of the manual explains how to create and manage 
roles. 

Roles Tab Window

■ Click the Roles tab to view the three Roles tab windowpanes 
(Figure 15.71).

The Roles tab is only available to GCOS users connected to a GCOS 
server.
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Figure 15.71    
Roles tab windowpanes

Role Definitions 
tree 

Displays the active server, the process database, the roles created on the 
server, and the members of each role (Figure 15.72).

Privileges pane Displays a list of the domains that reside on the active server.
 Shows the privileges that are associated with a role selected in the role 
definitions tree. Displays a template of privileges that is used to define 
privileges for a new role.

Task status/
Properties

Displays the property information or local task view, depending on the 
item selected in process database tree or the selected data pane. 
Property information is defined by the template that was used during 
sample registration in GCOS. The task status view shows the status of 
processes that may be occurring in the database (for example, export, 
import, delete, archive, or create). In the task status view, you can 
monitor these jobs while you work on other tasks in the system.

 Roles Definitions tree  Privilege/Domain pane

Task status/
Properties
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Creating a Role

A role defines a set of user access privileges. Each GCOS user is assigned to 
a role. Creating a role is a three-step process:

■ Name the role.
■ Define the role privileges (what the user can and cannot do).
■ Define role membership (add users to the role).

Naming the Role

1. Right-click an existing role in the role definitions tree and select Create 
Role from the shortcut menu that appears. Alternatively, click the role 
and select Role → Create Role from the menu bar.

⇒ The Create Role box appears (Figure 15.73).

Figure 15.72    
Role definitions tree

Figure 15.73    
Create Role box

Active server
List of role definitions

Process database

List of member 
definitions

Roll member



CHAPTER 15   GCOS Manager360
2. Enter a name for the role and click OK.

⇒ The role name appears in the role definitions tree (Figure 15.74).

3. In the role definitions tree, drag the role name to the process database.

⇒ The role is added to the list of member definitions under the process 
database. 

The role name is required and cannot duplicate an existing name.

Figure 15.74    
Role definitions tree

Figure 15.75    
Drag the role to the process database

Added role name
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Defining Privileges

1. In the role definitions tree, click the role that you want to define.

⇒ The Privileges pane displays a template of rights and privileges 
(Figure 15.76).

In the privilege template, the function list shows the privileges that can 
be granted to a role member with respect to their own data. The second 
column called Other User Data Access defines the rights of the role 
member with respect to other users’ data. Table 15.3 defines the privilege 
functions.

2. Click the check box next to a function to select that privilege for the role 
with respect to the user’s own data.

3. Click Yes /No in the right column to toggle between the two options and 
define the user privilege with respect to other users’ data.

Figure 15.76    
Default privilege settings
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Other User Data Access is always Yes and cannot be toggled for the 
following functions: Take Ownership, Maintain Roles, Import Process 
Data, and Delete Publish Data.

Table 15.13
Role privileges

Function Allows a user to...

Read Process Database Browse sample, experiment or analyses information in the 
process database.

Update Process Database Modify sample and experiment properties information in the 
process database.

Update Publish Database Overwrite experiment and analyses information in the publish 
database.

Archive Process Data Archive .dat, .cel, or .chp data to an user-specified location.

Delete Process Data Delete sample, experiment, analyses, userset and probe array 
type information from the process database.

Delete Publish Data Delete experiment and analyses information from any publish 
database.

Import Process Data Migrate Affymetrix® GCOS data files into the process database.

Export Process Data Copy sample, experiment, and analysis data from the GCOS 
server to a defined location.

Take Ownership of Process 
Data

Assume ownership of a sample, experiment or analysis 
information with the ability to overwrite a file with new 
contents (for example, reanalyze a .cel with different expression 
analysis parameter settings).

Maintain Roles Manage role, role membership, and set privileges.

Delete Server Tasks Delete publish tasks on or before a given date.

Maintain Templates Manage templates and their attributes.

Maintain Usersets Manage expression analysis parameter sets.

Create Publish Database Create a publish database.
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Defining Role Membership

You add a user to a role in order to assign the user the privileges that are 
defined for the role. You can also remove a user from a role.

Adding a User to a Role

1. In the role definitions tree, click the role of interest in the list of member 
definitions (under the process database).

⇒ The privilege/domain pane displays the domain name tree 
(Figure 15.77).

2. Expand the domain names and locate the user name of interest.

⇒ The tree displays the user groups that reside on the domain.

Figure 15.77    
Roles tab, domain names

 Privilege/Domain pane Roles Definitions tree

Task status/
Properties
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3. Drag the user name to the role of interest in the member definitions list.

⇒ The user is added to the role and the role name displays the new 
member name (Figure 15.78).

Deleting a User from a Role

1. In the role definitions tree (under the process database), expand the user 
list for the role of interest.

2. Right-click the member that you want to delete and select Remove User 
from the shortcut menu that appears (Figure 15.79). Alternatively, click the 
user and select Roles → Remove User from the menu bar.

Click and drag the  icon to add an entire user group to a role.

Figure 15.78    
Roles tab
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3. The user name is removed from the role membership.

Deleting Roles

1. In the role definitions tree (under the active server), right-click the role 
that you want to delete and select Delete Role from the shortcut menu 
that appears (Figure 15.80). Alternatively, click the role and select Roles → 
Delete Role from the menu bar.

Figure 15.79    
Role definitions tree

LIMS User and LIMS Administrator are default roles and cannot be 
deleted.

Figure 15.80    
Role definitions tree
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2. In the warning/confirmation box that appears, click Yes to proceed.

⇒ The role is deleted and is removed from the role definitions tree.



16



Chapter 16



GCOS Administrator 16

The GCOS Administrator provides tools to backup a database as well 
as data and help you manage your workstation disk space. This 
section of the manual explains how to use the GCOS Administrator to:

■ Backup (copy) a database, project, sample, or experiment to a 
compressed file format (.cab) 

■ Restore a database or data from a .cab file to a user-selected 
workstation drive or GCOS server

■ Automatically backup the process database on the workstation
■ Monitor available space on a workstation drive or database 
■ Relocate a publish database between workstation drives
■ Register or unregister a GCOS server

Getting Started

1. To start the GCOS Administrator, click the Windows Start menu button 

, then select Programs → Affymetrix → GCOS Administrator.

⇒ The GCOS Administrator starts and displays the user interface.

Figure 16.1 shows the user interface at startup when the workstation is the 
active server and Figure 16.2 shows the user interface at startup when a 
GCOS server is selected.
369
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Figure 16.1    
GCOS Administrator user interface at startup, workstation server selected

Data source selected 
in the server drop-
down list 

Toolbar

Backup and Restore 
Transfers data 
between the 
GCOS server 
and the GCOS 
workstation.

Space Manager 
Monitors available 
space on a 
workstation drive 
or database. 
Available only 
when connected to 
the local GCOS 
MSDE database.
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2. To select the active server, make a selection from the server drop-down 
list in the toolbar.

3. To display the GCOS Administrator backup and restore window, click 

the Backup and Restore button .

⇒ A data tree and property pane are displayed (Figure 16.3).

Figure 16.2    
GCOS Administrator user interface at startup, GCOS server selected

Server drop-down list
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4. To display the Space Manager window:

a. Select Local from the active server drop-down list.

b. Click the Space Manager button .

⇒ A data tree and property pane are displayed (Figure 16.4).

Figure 16.3    
GCOS Administrator, backup and restore window

The Space Manager functions are only available for the workstation 
database and not for a GCOS server.

Shortcut bar

Data tree

Property pane

Backup and restore window
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Figure 16.4    
GCOS Administrator, Space Manager window for the workstation database

Space Manager window

Shortcut bar Data tree Property pane
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GCOS Administrator Shortcut Bar & Windowpanes

Filtering Samples

In the backup and restore window, you can filter the samples that are 
displayed in the data tree (Figure 16.5). Sample filters are available when you 
click the Samples directory. The filters remain active from session to session 
until the parameters are changed.

1. Click the Backup and Restore button .

2. In the data tree, click the Samples folder.

⇒ The data tree displays the samples and the Filter button  
becomes available.

3. Click the Filter button .

⇒ The Sample Filter dialog box appears (Figure 16.5).

4. Select filter parameters from the drop-down boxes.

Shortcut 
bar 

Click the Backup and Restore button  to display the backup 
and restore window. Click the Space Manager button  to 
display the Space Manager window for the workstation database.

Data tree Backup and restore window: displays the process and publish 
databases on the active server, the assay projects and samples in 
the process database, and locations for backup locations.

Space Manager window (for the workstation): displays the publish 
databases on the active server, workstation drives, and the 
locations of the probe information (library) files and experiment 
data. (The file locations are in GCOS.)

Property 
pane

Backup and restore window: displays the cab files at the selected 
backup location.

Space Manager window (for the workstation): displays property 
information for the item selected in the data tree, the free and used 
space for a selected database or drive, or directory size.
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5. Click Apply. 

⇒ The sample filters are applied and the data tree is updated.

Figure 16.5    
Sample filters can be applied to the data tree in the backup and restore window

Specify sample filters 
that determine the 
samples displayed in 
the data tree.
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Role Privileges

Table 16.1 summarizes the role privileges that are required to carry out GCOS 
Administrator functions on a GCOS server. Privileges can be set using 
GCOS Manager. For more information on setting role privileges, see 
Creating a Role, on page 359. These privileges are not required for functions 
carried out on the GCOS workstation.

Table 16.1
Privilege requirements for GCOS Administrator functions on a GCOS server

Function on GCOS Server  Privilege Required on GCOS Server

Backup operation (create a .cab file) EXPORT PROCESS DATA

Restore a .cab file created by the same 
user

IMPORT PROCESS DATA

Restore a .cab file created by another 
user

IMPORT PROCESS DATA with other user data 
access rights

Copy a .cab file created by the same 
user to a GCOS server

IMPORT PROCESS DATA

Copy a .cab file created by another 
user to a GCOS server

IMPORT PROCESS DATA with other user data 
access rights

Copy a .cab file created by the same 
user from a GCOS server

EXPORT PROCESS DATA

Copy a .cab file created by another 
user from a GCOS server

EXPORT PROCESS DATA with other user data 
access rights

Delete a process database .cab file 
created by the same user

DELETE PROCESS DATA

Delete a process database .cab file 
created by another user

DELETE PROCESS DATA with other user data 
access rights

Delete a publish database .cab file 
created by the same user

DELETE PUBLISH DATA

Delete a publish database .cab file 
created by another user

DELETE PUBLISH DATA with other user data 
access rights
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Register or Unregister a 
GCOS Server

GCOS Administrator can register or unregister a GCOS server. The GCOS 
server can be the source of objects (a publish database or data) that you want 
to backup or the destination for objects that you want to restore. This enables 
the transfer of a publish database or data between a workstation and a GCOS 
server.

Registering a GCOS Server

1. Click the Server button . Alternatively, select Tools → Register 
GCOS Server from the menu bar.

⇒ The Register GCOS Server box appears (Figure 16.6).

2.  Select the server that you want to register and click OK.

⇒ The GCOS server name is added to the server drop-down list.

You may have more than one registered GCOS server; however, GCOS, 
GCOS Manager, and GCOS Administrator can connect to only one 
GCOS server at a time.

Figure 16.6    
Register GCOS Server box
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Unregistering a GCOS Server

1. Select the GCOS server that you want to unregister in the server drop-
down list (Figure 16.17).

2. Press the Delete key or select Tools → Unregister GCOS Server from 
the menu bar.

⇒ The GCOS server is unregistered and the server name is removed 
from the server drop-down list.

Changing a Database 
Password

You can change the password for the process database or a publish database 
on the workstation.

1. Click the Password button .

⇒ The Administrator Password Dialog opens (Figure 16.8).

Figure 16.7    
Server drop-down list

GCOS server 
selected in the 
server drop-down 
list 
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2. Make a selection from the Database drop-down list.

3. Enter the current password for the selected database.

4. Enter a new password for the database.

5. Re-enter the password to confirm it.

6. Click OK.

Figure 16.8    
Administrator Password Dialog
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Automatic Process 
Database Back Up

When the workstation is turned on, the GCOS Administrator automatically 
starts and runs in the background. The system tray displays the GCOS 
Administrator icon. For example, Figure 16.9 shows the GCOS application 
open and the GCOS Administrator running in the background.

The GCOS Administrator monitors the number of analyses that are added to 
the process database on the workstation. After every 50 analyses added to 
the process database, the software automatically backs up the process 
database to the GCOS directory (\backup subfolder).

The automated backup feature is only available for a process database 
on the workstation. It is not available for a process database on a GCOS 
server.
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Figure 16.9    
GCOS application window is open and GCOS Administrator runs in the background

GCOS Administrator icon in the system tray indicates the 
application is running in the background

System tray
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■ To maximize the GCOS Administrator application, double-click the  
icon.

■ To access a shortcut menu for the GCOS Administrator, right-click the 

GCOS Administrator icon  in the system tray.

If you exit the GCOS Administrator application, the process database will 
not be automatically updated.

Copying a Database or Data

The GCOS Administrator can make a backup copy of a process or publish 
database, a project, a sample, or an experiment. The software copies a 
database or data to a .cab file, a compressed file format, that is saved to a 
user-specified backup location. Table 16.2 lists the items available for back up 
and the contents of the .cab file.

To perform backup operations on a GCOS server, you must have the 
EXPORT PROCESS DATA role privilege. If you perform a backup 
operation and are not in the GCOS Administrator role, each experiment is 
checked to see whether you have the right to back up the experiment based 
on your role. For more information on roles and privileges, see Roles Tab, on 
page 357 in Chapter 15. This privilege can be set using GCOS Manager and 
is not required for back up on the GCOS workstation.

You can conveniently transfer a database or data to another workstation drive 
or GCOS server by restoring a .cab file to a user-specified location. See 
Restoring a CAB File, on page 390. 

Shortcut Menu 
Command

Function

Maximize Maximizes the GCOS Administrator window.

Minimize Minimizes the GCOS Administrator window.

Exit Exit the GCOS Administrator application.



  Affymetrix®  GeneChip®  Operating Software User’s Guide 383
Table 16.2
Back up object and CAB file contents

Object Selected 
for Backup CAB File Contents

Process database All of the items in the process database, including projects, samples, 
experiment and sample annotations, image data, cell intensity data, 
and probe analysis data.

Publish database Cell intensity data, probe analysis data.

Project Samples, image data, cell intensity data, and probe analysis data.

Sample Sample, image data, cell intensity data, probe analysis data), and all 
associated annotations.

Experiment Sample, image data, cell intensity data, probe analysis data), and all 
associated annotations.
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1. To copy a database or data, click the Backup and Restore button in the 

shortcut bar .

2. Click the check box next to each item that you want to copy to a .cab file 
(Figure 16.10). 

To remove a check mark, click the check box again.

3. To select a location for the .cab file, navigate to the Backup Locations 
directory in the data tree and click a backup location.

Figure 16.10    
GCOS Administrator, backup and restore window

Place a check mark next to the object that 
you want to copy to a .cab file.

Select a location for the .cab file from the 
Backup Locations directory.

Shortcut bar

Data tree

Property pane



  Affymetrix®  GeneChip®  Operating Software User’s Guide 385
4. Click the Backup button . Alternatively, select Transfer → Backup 
from the menu bar.

⇒ The Backup Job Information dialog box appears (Figure 16.11).

5. To change the backup location for the .cab:

a. Click the Browse button .

⇒ The Browse for Folder box appears (Figure 16.12).

Figure 16.11    
Backup Job Information

Figure 16.12    
Browse for Folder box
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b. Click the folder where you want to store the .cab, and click OK. 

6. Enter the .cab file name (required) and any comments in the Backup Job 
Information box.

Unless the user performing the backup operation is in the GCOS 
Administrator role, each experiment is checked to see whether the user 
has the right to back up the file. Experiments that are not authorized to 
be backed up will be rejected and a warning message states that the 
experiment was not backed up due to authorization.

7. Click Start Backup in the Backup Job Information box.

⇒ The backup operation starts and the status pane displays messages 
about its progress. When the backup is completed, the property 
pane displays the .cab file(s) (Figure 16.13).

You can create multiple copies of a database or data object, but each 
.cab file must be given a unique name when saving to the same backup 
location.
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Managing Backup 
Locations

Cab files are saved to a user specified backup location.You can add or 
remove backup locations from the Backup Locations directory in the data 
tree. 

Figure 16.13    
GCOS Administrator, backup and restore window

Shortcut bar

Data tree

Backup and restore window

.cab file(s) in the selected 
backup location

Property pane
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Adding a Backup Location

1. Click the Add button . 

Alternatively, right-click the Backup Locations directory in the data tree 
and select Add Backup Location from the shortcut menu, or select 
Transfer → Add Backup Location from the menu bar.

⇒ The Browse for folder box appears (Figure 16.14).

2. Navigate to the folder of interest. 

3. Click OK.

⇒ The data tree displays the new backup location.

Removing a Backup Location

To remove a backup location from the data tree, do either of the following:

■ In the data tree, right-click the backup location that you want to remove, 
and select Remove Backup Location from the shortcut menu.

■ In the data tree, select the backup location and click the Remove button 

. Alternatively select Transfer → Remove Backup Location from the 
menu bar.

Figure 16.14    
Browse for Folder box



  Affymetrix®  GeneChip®  Operating Software User’s Guide 389
Working with CAB Files

In the backup and restore window, you can:

■ view .cab file properties
■ restore a .cab file to a user-specified workstation drive or GCOS 

server (data transfer)
■ delete a .cab file

To display the backup and restore window, click the Backup and Restore 

button in the shortcut bar .

Viewing CAB File Properties

1. In the data tree, click the backup location for the .cab of interest.

⇒ The property pane displays the .cab files at the selected backup 
location (Figure 16.15).

2. Right-click the .cab of interest and select Properties from the shortcut 
menu that appears.

⇒ The .cab file properties are displayed (Figure 16.15).

Figure 16.15    
Backup and restore window, .cab file properties
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Restoring a CAB File

GCOS Administrator can restore a .cab file to the process or publish 
database on the workstation or GCOS server. In this way, you can easily 
transfer a database or data to a new location. 

If you are using GCOS with a GCOS server, certain privileges are required 
to restore a .cab file. To restore a .cab file (that you created) on a GCOS 
server, you must have the IMPORT PROCESS DATA privilege on the 
GCOS server. To restore a .cab file created by another user on the GCOS 
server, you must have the IMPORT PROCESS DATA privilege with other 
user data access rights set on the GCOS server. These privileges are not 
required to restore a .cab file on the GCOS workstation.

1. In the data tree, navigate to the Backup Locations directory and click the 
backup location of the .cab file that you want to restore.

⇒ The property pane displays the .cab files at the selected backup 
location.

2. In the property pane, click the .cab that you want to restore and click the 

Restore button . Alternatively, select Tools → Restore from the menu 
bar.

⇒ The Restore Job Information dialog box appears and displays the 
backup location and name for the selected .cab (Figure 16.16).

It is recommended that users not publish and restore to the same 
publish database simultaneously. Sometimes the restore will be 
rejected and sometimes the publishing will be rejected. If the restore of 
a publish database fails, an error message is displayed.

Figure 16.16    
Restore Job Information dialog box
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3. If there is more than one available restore location, make a selection 
from the drop-down list.

4. Confirm the backup location and name of the .cab file that you want to 
restore.

5. Click Start Restore.

⇒ The restoration proceeds and the status pane displays messages 
about the status of the task.

Experiments and files restored to a GCOS server from a backup .cab file 
have the same ownership as they had on the system from which they 
originated. Unless you are the owner of the restored data, you will need 
to set access permission. 

To set access permission, use the GCOS Manager tool to update the 
Role information for the data owner to allow proper access (see 
Defining Privileges, on page 361 for more information). Alternatively, 
use GCOS Manager to take or assign data ownership (see Changing 
Data Ownership, on page 288 for more information).

You can omit step1 and 2, and click the Restore button. The Restore 
Job Information dialog box appears, with the Cab File Name field set to 
the current backup location. 

You must be a member of the “GCOS Administrator role” in order to 
assign/assume ownership of objects owned by role members that are 
not in your role(s), or objects currently owned by users that are not 
defined in the GCOS system because the data was restored from a .cab 
file backup from another system.

After a database or data object is restored, the .cab remains in the 
backup location.
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Copying a CAB File

You can copy a .cab file to another workstation drive or a GCOS server using 
the Send To feature. The .cab file is copied to the user-specified location, but 
the data or database is not restored.

If you are using GCOS connected to a GCOS server, certain privileges are 
required to copy .cab files. To copy a .cab file (that you created) to a GCOS 
server, you must have the IMPORT PROCESS DATA privilege on the 
GCOS server. To copy a .cab file created by another user to a GCOS server, 
you must have the IMPORT PROCESS DATA privilege with other user data 
access rights on the GCOS server.

To copy a .cab file (that you created) from a GCOS server, you must have the 
EXPORT PROCESS DATA privilege set on the GCOS server. To copy a .cab 
file created by another user from a GCOS server, you must have the 
EXPORT PROCESS DATA privilege with other user data access rights set 
on the GCOS server.

1. In the data tree, click the backup location of the .cab that you want to 
copy.

⇒ The property pane displays the .cab files at the selected backup 
location.

A .cab file cannot be copied using Microsoft® Windows Explorer. 

Figure 16.17    
Backup and restore window, send a .cab file

Property pane
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2. Right-click the .cab of interest and select Send To from the shortcut 
menu.

⇒ The Browse for Folder box appears (Figure 16.18).

3. Select the folder where you want to send a copy of the .cab file and click 
OK.

Deleting a CAB File

You can delete a .cab file from a workstation drive or a GCOS server. If you 
are using GCOS connected to a GCOS server, certain privileges are required 
to delete .cab files. To delete a process database .cab file (that you created) 
from a GCOS server, you must have the DELETE PROCESS DATA 
privilege on the GCOS server. To delete a process database .cab file created 
by another user from a GCOS server, you must have the DELETE 
PROCESS DATA privilege with other user data access rights on the GCOS 
server.

If you want to delete a publish database .cab file that you created from a 
GCOS server, you must have the DELETE PUBLISH DATA privilege on the 
GCOS server. To delete a publish database .cab file created by another user 
from a GCOS server, you must have the DELETE PUBLISH DATA 
privilege with other user data access rights on the GCOS server.

Figure 16.18    
Browse for Folder box
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1. In the data tree, click the backup location of the .cab file that you want 
to delete.

⇒ The property pane displays the .cab files at the selected backup 
location.

2. Right-click the .cab of interest and select Delete from the shortcut menu 
that appears (Figure 16.19).

⇒ A warning/confirmation box appears.

3. Click Yes to delete the selected .cab.

Managing Workstation 
Databases

GCOS Administrator provides tools to help you manage your process and 
publish databases on the workstation. 

■ To open the space management window (Figure 16.20), click the Space 

Manager button .

In this window, you can:

Figure 16.19    
Backup and restore window, delete a .cab file

Property pane
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■ view the properties of a workstation database, drive, or GeneChip 
directory

■ monitor free and used space on a workstation database, drive, or 
directory

■ relocate a database between workstation drives

The Space Manager functions are only available for the workstation.

Figure 16.20    
GCOS Administrator, Space Manager window

Shortcut bar

Property pane

Data tree
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Viewing Property & Space Information

■ To view information about a workstation database, drive, or directory, 
click the item of interest in the data tree.

⇒ The property pane displays information about the selected item 
(top) and a pie chart of space information.

Table 16.3 lists the types of information that are available.

Relocating a Publish Database

GCOS Administrator can move a workstation publish database to a user-
specified drive. 

1. In the data tree, click the publish database that you want to relocate.

⇒ The property pane displays the location and space allocation for the 
files that comprise the database (data device, log device, and index 
device) (Figure 16.21).

For more information on these files, see Performance Tuning for SQL 
Server Databases, on page 629.

2. In the property pane, make a selection from the Location drop-down list 
for the database file that you want to move.

3. Click outside the drop-down list (to lose focus).

⇒ The file is relocated to the selected drive.

4. Repeat step 2 and step 3 for each database file to be moved.

Table 16.3
Space management information

Item Property Pane Displays...

Database Database files names
Physical location of the database files
Disk space allocated to each database file
Pie chart of free and used database space

Drive Databases on the drive
Size of each database
Create date for each database
Pie chart of free and used drive space

GeneChip Data 
Directory

Number of files in the directory
Directory size
Pie chart of drive size and data size
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Publish Database Statistics

1. To view publish database statistics, click a publish database in the data 
tree.

⇒ The property pane displays all of the databases that comprise the 
publish database. For each database, it shows the:

■ database name
■ allocated size
■ create date
■ probe array type
■ number of published experiments

Figure 16.21    
GCOS Administrator, Space Manager window

Property paneData treeShortcut 
bar
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■ estimated number of experiments that can be published (with 
intensity data)

■ estimated number of experiments that can be published (without 
intensity data)

2. To find out how many experiments can be published using a particular 
probe array type, select the array type from the probe array drop-down 
list.
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Appendix A



Client Testing A

After installing the different client software applications, testing of the 
software must be completed to verify the functionality of the software 
components. Following the checklist below will complete the testing 
process.

GCOS Manager 1.0 Testing

For more details about the GCOS Manager 1.0 client application, refer to 
Chapter 15 on page 275.

The screen captures depicted in this section may not exactly match the 
windows displayed on your screen. 

If you encounter problems during testing, please refer to Appendix K, 
Troubleshooting, on page 635.

1. To perform the testing, login to the workstation as a user who has 
Administrator permissions.

2. Launch GCOS Manager 1.0 (Start → Programs → Affymetrix → 
GCOS Manager)

3. Verify that the a server is registered on the left hand side.

4. Click the Process, Publish, Import, Userset, Template and Roles 
tabs to verify that they are accessible.

The Roles tab is only available when GCOS Manager is connected to a 
GCOS server.
401
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Process Tab

5. Click the Process tab
The Process tab shows the administrator the data is in the system. In 
this tab you can archive, unarchive, delete, export, assume 
ownership, and print data.

6. Expand the Samples folder.

7. Verify that the Expression folder appears.

8. Expand the Expression folder. If this is an upgrade, existing samples 
should appear. 

Publish Tab

9. Click the Publish tab 
In this tab, users with access can create new publish databases or 
delete published data in any publish database on the system.

10. In the Publish tab, highlight the name of the active server.

11. Go to the menu bar and select Publish → Create SQL Server 
Database (if using SQL Server). If using Oracle, go to step 16

You can create a publish database on the workstation by following the 
steps for creating a database on a SQL server.
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Figure A.1 
Create SQL Server Publish Database window

12. Enter the following information: 
Database
■ Database Name - The name of the publish database to be 

created (in this example, MyPub).
■ Database Password - Enter password for access to the publish 

database.
■ Confirm Database Password - Re-enter password for 

confirmation.

The publish database is password protected. To access a publish 
database, users are required to enter the appropriate password.
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Data Device

■ Path – Full path location for the Data Device to reside on the 
GCOS server (for example, F:\GeneChipDBDevices).

■ Size – Size of the Data Device (128MB).
Index Device

■ Path – Full path location for the Index Device to reside on the 
GCOS server (i.e. F:\GeneChipDBDevices).

■ Size – Size of the Index Device (128MB).
Log Device

■ Path – Full path location for the Log Device to reside on the 
GCOS server (for example, F:\GeneChipDBDevices).

■ Size – Size of the Log Device (128MB).

The Microsoft® SQL Server database that you create must be between 
128MB to 1024 MB. If you want to expand the size after the database is 
created, use SQL Enterprise Manager to expand the database.

13. Click Install after all information is entered. 
This may take a few minutes depending on the size of the database 
created.

Creating a Publish database only needs to be tested once from a client. It 
does not need to be tested on additional clients, as publish databases 
are quite large. The path location for the devices must already exist on 
the server, otherwise creating the database will fail.

14. Click Close when the database is created.

15. Go to step 19.

16. To create an Oracle publish database, select  
Publish → Create Oracle Database from the menu bar.
⇒ Create Oracle Publish Database window (Figure A.2).

You can create an Oracle publish database when the GCOS Manager is 
connected to a GCOS server running Oracle.
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Figure A.2 
Create Oracle Publish Database window

17. Enter the following information:

Database:

■ Database name – Name of the Publish database (in this 
example, MyPub)

■ Database password – Enter password for access to publish 
database

■ Confirm database password – Re-enter password for 
confirmation

The publish database is password protected. To access a publish 
database, users will be required to enter the appropriate password.

Data Device:

■ Server device path – Full path location for the Device to reside 
on the GCOS server (for example, D:\GeneChipDBDevices\)

■ Database size – Small or Large (in this example, select Small)

The server device path directory specifies the file location on the actual 
publish database server. If the publish database is being created on a 
remote server, make sure the path specified is available on that server.
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An Oracle publish database is much larger than the default SQL Server 
database. Verify that there is adequate space on the server before 
creating an Oracle database. The Small Oracle publish database 
requires 8GB of hard disk space. The Large Oracle publish database 
requires 17 GB of hard disk space. These database sizes correspond to 
publishing approximately 500 and 1000 experiments respectively. 
Creating an Oracle database will take a while.

18. Click Close after the database is created.

You only need to test creating a publish database once from a client. 
You need not repeat the test on additional clients, as a publish database 
is quite large.

Import Tab

19. Click the Import tab. 
The Import function copies or imports experiment data created in 
GCOS and moves the data to a process database on the workstation or 
GCOS server. 

20. On the menu bar, select Tools → File Path. Set the path for the location 
of the files for import. For example, C:\GeneChip\TempData (Figure A.3).

Figure A.3 
Select Import File Path window
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21. Click OK.

22. Highlight the Expression Folder.  From the menu bar, select 
Import → Create Sample.
⇒ The Create Expression Sample window appears (Figure A.4).

Figure A.4 
Create Expression Sample window

23. Enter the following information:
■ Sample Name: ImportSample
■ Sample Project: MySampleProject
■ Sample Type: MySampleType
■ Description: <optional>
■ Comments: <optional>
The fields in blue are required fields.

24. Click OK.

GCOS Manager can import any data for which a library file has been 
installed. To preserve the experiment information, all data in the sample 
name, project, and array type should match the data in the experiment 
file.

25. Select the .exp file and drag it to the sample in the Data to import 
pane (Figure A.5).
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⇒ The .exp file brings all associated files with the same prefix when 
placed on the sample (Figure A.6).

Figure A.5 
Importing .exp data
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Figure A.6 
Importing .exp brings associated files

26. If there are additional .cel or .chp files associated with this 
experiment, select the CEL or CHP tab and drag the appropriate 
file to the sample in the Data to import pane.

27. When all of the files for the import are associated with a sample, 
select Import → Start Import from the menu bar. Alternatively, 
right-click any file in the Data To Import pane and select Start 
Import from the shortcut menu that appears.

28. If the import fails, check the import status in status pane. Double-
click Import in Task View and review the error message.
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Userset Tab

29. Click the Userset tab. 
In this tab you can create a userset that defines values for the user-
modifiable expression algorithm parameters. You can select the userset 
by name to analyze experiments using the same set of algorithm 
parameter settings. 

Figure A.7 
Upper right pane of the Userset tab

30. Enter a name for the set in the Create Set Name field (enter 
MySet).

31. Select the Probe Array Type (Hu6800) in the Probe Array Types 
Used field and move it by pressing >>. (Only one probe array type 
can be moved at a time.)

32. Click Create Set. The userset is created and the userset name is 
added to the right hand side of the pane.
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Template Tab

Template attributes cannot be deleted, only deactivated. A template can 
be deleted (right-click the template and select Delete from the shortcut 
menu that appears).

33. Click the Template tab. 
In this tab the administrator can add fields to the Experiment 
Template and the Sample Template that are used in GCOS.

34. To create an Experiment Template, highlight the Experiment 
Templates Folder.

35. Select Template → Create from the menu bar. (If it is grayed out, 
highlight the Experiment Templates Folder again, or right-click the 
Experiment Template Folder and select Create from the shortcut 
menu that appears) (Figure A.8).
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⇒ The Create Template box appears (Figure A.9).

Figure A.8    
Template Tab window

Figure A.9 
Create Template box
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36. Enter the name of the template (for example, exp_temp).   Click 
OK.
⇒ The experiment template attributes window appears in the 

upper right pane (Figure A.10).

Figure A.10 
Experiment Template Attributes window

37. Double-click in the Name field to get a blinking cursor.

38. Enter Comments in the Name field.

39. Select String in the Type field.

40. Select No in the Required field.
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Figure A.11 
Attributes and values entered

41. Click Apply.
⇒ The Exp_Temp experiment template is added to the Experiment 

Templates list. 
(You must select the Experiment Templates folder to see the 
newly added template.)

42. To create a Sample Template, highlight the Sample Templates 
Folder.

43. Select Template → Create from the menu bar. (If it is grayed out, 
highlight the Sample Templates folder again, or right-click the 
Sample Template folder and select Create from the shortcut menu 
that appears.) (Figure A.12)
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⇒ The Create Template window appears (Figure A.13).

Figure A.12    
Sample Template window

Figure A.13 
Create Template window

44. Enter the name of the template (for example, Sample_Temp).   
Click OK.
⇒ The sample template attributes window appears (Figure A.14).
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Figure A.14 
Sample Template Attributes window

45. Double-click in the Name field to get a blinking cursor.

46. Enter Additional Comments in the Name field.

47. Select String in the Type field.

48. Select No in the Required field.
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Figure A.15 
Attributes and Values Entered

49. Click Apply.
⇒ The Experiment and Sample templates are created and 

appear in the left hand pane (Figure A.16).

You must select the Experiment or Sample template folder to see the list 
of available templates.
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Roles Tab

Figure A.16 
Experiment and Sample Templates Added

The roles tab is only available when using GCOS Manager with a 
registered GCOS server.

50. Click the Roles tab. 
The Roles tab is used to set up security for the end-users. 
Therefore, the functions of the Roles tab are solely for the use of 
the system administrator and the tab only appears for users who 
have been granted the Maintain Roles privilege.

51. Click GCOS Server Administrator from the left hand pane under 
the name of the GCOS server.
⇒ The function of the GCOS Server Administrator is displayed. 

All privileges are granted for the administrator (Figure A.17).

Experiment and 
sample 
templates 
added
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Figure A.17 
Administrator Privileges window

52. Click GCOS Server User from the left hand pane under the GCOS 
server name.
⇒ The function of the GCOS Server User is displayed. 

By default, all privileges are granted for the User except for the last 
five privileges (Figure A.18).

Figure A.18 
Default User Privileges
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53. Under the GCOSServer3 database, expand the GCOS Server 
Administrator group and GCOS Server User group.
⇒ The domain name\Global Group appears and displays the 

group members (Figure A.19).

Figure A.19 
Roles Tab window

54. Click the right hand pane to expand the domain and the list of 
Global Groups.

55. Expand the GCOS Server Global Group.

56. Drag a specific user to the GCOS Server User or GCOS Server 
Administrator group.
This allows individual users or Global Groups access to certain 
functions on the GCOS server.

57. Click any existing role in the left pane.

58. In the Create Role dialog box, type a name for a new role.

59. Click OK.
⇒ The new role appears in the left pane under the server.
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Figure A.20    
Roles Tab window
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Event Viewer and Server Tasks

60. To display the Event Viewer for the GCOS server, select Tools → Server 
Event Viewer from the menu bar. 
⇒ The Event Viewer for the GCOS server is displayed (Figure A.21). 

You can view the System, Security and Application Log.

61. Close the Event Viewer.

62. To view the Server Tasks, select Tools → Server Tasks from the menu 
bar.
This monitors and displays the status of any published data and grows 
as more data are published.

Figure A.21 
Server Tasks window

The task list is populated after experiment data are published.
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GCOS 1.0 Testing

Preparing and Scanning an Experiment

63. Select File → New Experiment from the menu bar or click the 

Experiments button .

⇒ The Sample and Experiments window is displayed (Figure A.22).

Figure A.22 
Sample and Experiments window
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64. Enter the following information for Experiment 1 (Figure A.23):
■ Sample Name: MySample
■ Sample Type: SampleType
■ Project: SampleProject
■ Experiment Name: TestExp
■ Probe Array Type: Hu6800

Figure A.23    
Experiment 1 input
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65. Save the experiment information by selecting  
File → Save from the menu bar or click the Save button .

66. Enter the following information for Experiment 2 (Figure A.24):
■ Sample Name: MySample
■ Sample Type: SampleType
■ Project: SampleProject
■ Experiment Name: TestExp_2
■ ProbeArray Type: Hu6800

67. Select the Analysis Set (MySet) that was created in GCOS 
Manager. (Only analysis sets for the same probe array type appear.)

68. Select the Publish Database (MyPub) that was created in GCOS 
Manager.

69. Select Publish Intensities.
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Figure A.24    
Experiment 2 input

70. Save the experiment information by selecting  
File → Save from the menu bar or click the Save button .

71. A dialog box appears prompting for the publish database password. 
Enter the password and click Login.

72. From the Sample Template drop-down list, select Sample_Temp.

73. From the Experiment Template drop-down list, select Exp_Temp.
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74. Enter the following information for Experiment 3 (Figure A.25):

■ Sample Name: MySample
■ Sample Type: SampleType
■ Project: SampleProject
■ More Comments: This is a test.
■ Experiment Name: TestExp_3
■ ProbeArray Type: Hu6800
■ Comments: Additional comments

75. Set Analysis Set and Publish Database to [No analysis] and [No 
publish] respectively.

76. De-select Publish intensities.
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Figure A.25    
Experiment 3 input

77. Save the experimental information by selecting  
File → Save from the menu bar or click the Save button .
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Hybridizing an Experiment

78. To hybridize an experiment, select Run → Fluidics from the menu bar 
or click Instrument Control in the shortcut bar and click the Fluidics 

button .

79. Select Module 1 (Figure A.26).

Figure A.26 
Fluidics Station window

80. In the Experiment drop-down box, select TestExp.

81. In the Protocol drop-down box, select the protocol to run the 
experiment on. (Select the appropriate fluidics protocol for the 
probe array type.) (Figure A.27).
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Figure A.27 
Select Protocol

82. Click Run.
⇒ The Fluidics Station window displays the Current Stage of the 

hybridization (Figure A.28). This takes a few minutes.

Figure A.28 
Hybridizing experiment
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Figure A.29 
Hybridization complete

⇒ Hybridizing done is displayed when complete (Figure A.29). The 
experiment is ready to be scanned.

83. Click each module to verify that the hybridization is complete.

84. Click Close to exit the Fluidics station window.

85. For TestExp_2, select the GeneChip Software  

shortcut bar and click the Workflow Monitor icon .
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Figure A.30    
Workflow monitor window

86. If you want to skip the hybridization step and place the experiment 
in scan status, right-click TestExp_2 and select Advance to Scan 
from the shortcut menu that appears (Figure A.30). 
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Scanning an Experiment

87. To scan an experiment, select Run → Start Scanner from the menu bar, 
or click Instrument Control in the Instrument Control shortcut bar and 

then the Start Scanner button .

Figure A.31 
Scanner dialog box

88. Select TestExp the Experiment Name drop-down list.

Figure A.32 
Scanner dialog box, TestExp selected for scan
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89. Click Start to begin scanning the chip.

Figure A.33 
Scanner prompt

Scanning a chip through one scan takes approximately 5 minutes.  
Only one chip can be scanned at a time.

90. Load the chip into the scanner.
⇒ After the scan is completed, GCOS generates a .cel.

91. Scan the second experiment: from the menu bar select  
Run → Start Scanner or click the Instrument control shortcut bar 

and click the Start Scanner button .

92. From the Experiment Name drop-down list, select TestExp_2.

93. Click Start to begin scanning the probe array.
After the scan is completed, this experiment has the program 
automatically create the .cel and the .chp and publishes them into 
the MyPub database. This is done because Analysis Set and 
Publish Database fields were selected during the experiment 
setup.

94. Do not scan TestExp_3.

Running an Analysis

95. To generate a .chp, select the TestExp.CEL.

96. Right-click TestExp.CEL file and select Analyze (Figure A.34).
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⇒ The status log displays that it is running an analysis for the file. For 
example, Running analysis for 
\\<servername>\GeneChip\Affy_Data\Data\TestExp.CHP 
(Figure A.35).

Figure A.34 
Analyze Experiment window

Figure A.35    
Status log
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97.  The status log displays when the analysis is completed (i.e. 
Analysis completed for 
\\<servername>\GeneChip\Affy_Data\Data\TestExp.CHP). The 
.chp file is displayed.
If an error message is displayed, make a note of the error message 
and follow the suggestions in the error message. If problems persist, 
refer to GCOS Manager 1.0 Troubleshooting on page 640.

Figure A.36 
Analysis output file (.chp) displayed
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Publishing

98. To Publish an experiment, select Run → Publish from the menu bar or 
click the Publish button in the GeneChip Software shortcut bar .

⇒ The Publish window appears (Figure A.37).

Figure A.37    
Publish window
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99. To add data to be published, select Publish → Add Item from the 
menu bar or click the Add button  in the publish window area.
⇒ The Open window appears and displays experiments available 

for publishing (Figure A.38).

Figure A.38 
Open window

100.Highlight the TestExp experiment and click OK.

101.To publish the cell intensity data, select Publish → Options → 
Publish Intensities from the menu bar.
⇒ The Publish Database Login window appears.

102.Enter the password for the publish database and click Login.
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Figure A.39 
Publish window with intensities selected

103.To begin the publishing process, select Publish → Publish from the 
menu bar or click the Publish button  in the publish window.

Publish intensities:YES
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Figure A.40 
Publish status window

104.The task window shows the status of the publishing process.  Each 
task contains items that are in a particular task.
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Figure A.41 
Publish task item window

Running Reports

105.To configure the report settings, select Tools → Report Settings → 
Expression Report from the menu bar, or click the Report  
Settings in the shortcut bar and click Expression Report .
⇒ The Expression Report window appears (Figure A.42).
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Figure A.42 
Expression Report window

106.Select File → Report from the menu bar and select the .chp to 
generate the report. Alternatively, right-click a .chp in the data file 
tree, and select Report (use the TestExp.CHP file). 

Sample History

107.To view the sample history window (Figure A.43), select Run → Sample 

History from the menu bar, or click the Sample History button  in 
the shortcut bar.
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Figure A.43    
Sample history window

108.Click a sample.
⇒ The list of files pertaining to the sample appears in the right 

hand pane (Figure A.44).
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Figure A.44    
Sample history window, selected file

109.To view more history information, click the EXP icon  and 
information in the results window is displayed (Figure A.25).
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Figure A.45    
History for the selected file

110.To view history information, click the .dat, .cel, or .chp, click the 
file.
⇒ The history information is displayed in the bottom windowpane. 

Workflow Monitor

111.To view the workflow monitor, select Run → Workflow Monitor from 
the menu bar or click the Workflow Monitor icon  in the GeneChip 
Software shortcut bar.
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112.To filter information, select Tools → Filters… from the menu bar to 
display the Filters window.

113.Information can be filtered on the following items:

■ Assay Type 
■ Sample Name
■ Experiment
■ Sample Project
■ Probe Array Type
■ Sample Type
■ User
■ Date 

114.Click OK after any filter selections have been made.

115.The Workflow Monitor shows the current stage of the experiment.  The 
experiment could be in the following stage status:
■ Experiment Setup
■ Hybridization
■ Scan
■ Grid Alignment
■ Cell Intensity Analysis
■ Probe Array Analysis

116.Click the bottom tabs to see the stage where experiments currently 
stand.
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Data Mining Tool 3.1 
Testing

1. Is your GCOS server using a SQL Server or Oracle database?

2. If using SQL Server, go to step 5 If using Oracle, go to step 3

3. If using Oracle, verify that Oracle client utilities are installed.

4. Verify that the alias or aliases (if using a remote GCOS server) are 
created.

When you open the Data Mining Tool (DMT) for the first time a message 
appears stating “Unable to Determine Publish Database Name”. Click 
OK. This message appears because a publish database has not yet been 
registered.

5. Start Data Mining Tool (Start → Programs → Affymetrix → Data 
Mining Tool).

6. Select Edit → Register Database from the menu bar.
⇒ The Register Database dialog box appears (Figure A.46).

Figure A.46 
Register Database dialog box, publish database on GCOS server  
(Oracle® dialog box, top; Microsoft® SQL Server dialog box, bottom)

7. If using an Oracle database, go to step 8. If using a Microsoft® SQL 
Server database go to step 10.

8. Enter the server’s alias name in the Oracle Alias box.
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9. Enter the Publish Database name, then go to step 12.

10. Enter the Server Name, then click List Databases to display the 
publish databases for the server in the Publish Database drop-
down list.

11. Select a database from the Publish Database drop-down list.

12. Click Register.
⇒ DMT prompts for the Publish Database Password.

13. Enter the Password and click Login.
⇒ The database is available to DMT.

14. Select Edit → Select Data Source from the menu bar.

15. Select the Oracle Publish DSN (MyPub, or the name of the DSN 
created).

16. Select Data → New → Expression Data Mining Tool from the 
menu bar.

Figure A.47 
Data Mining Tool window
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17. Verify that the data published appears in the DMT window.

18. From the menu bar, select Query → Run Query to execute query  
or click the Query icon .  
⇒ The query results window is displayed (Figure A.48).

Figure A.48 
Query Results window

19. Pivot the query results data by selecting Query → Run Pivot  
from the menu bar or click the Pivot button .

Figure A.49 
Pivot running

20. Graph the results by selecting Graph → Scatter...  
from the menu bar or click the Scatter Graph button .
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Figure A.50 
Scatter Graph dialog box

21. Move the analysis files to the X-Axis and the Y-Axis.  Click OK

Figure A.51 
Scatter Graph



Affymetrix®  GeneChip®  Operating Software User’s Guide 451
GCOS Manager Additional 
Testing

This additional testing allows the system administrator to delete, archive, 
unarchive, export or take ownership of data. 

⇒ The task window displays the export process. It exports the .dat, 
.cel, and .chp (Figure A.53).

22. Start GCOS Manager 1.0 
(Start → Programs → Affymetrix → GCOS Manager).

23. Expand the Samples list.

24. Expand the Expression Sample list. 

Export an Experiment

25. Select Tools → File Path from the menu bar, or  
click the File Path button .

26. Select a path location to export the files to (for example, x:\temp).

27. Click the sample named MySample and select Process → File View.

28. In the right hand pane, select TestExp and right-click to select Export, 
or go to the menu bar and select Process → Export after selecting the 
TestExp (Figure A.52).

Figure A.52 
Export window
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⇒ The Select Archive Path Location window appears (Figure A.55).

Figure A.53 
Status window

29. Once completed, the status returns to Available. If it fails, the 
status returns ‘Failed.’ 

30. To view the error, double-click the Export icon in the Local Task 

pane .
⇒ A text file appears. View the error message and try to resolve it. 

Try exporting again. 

Archive and Unarchive

31. Click the Process Tab.

32. Expand the TestExp list in the right hand pane.

33. Select the TestExp.CEL file.

34. Right-click and select Archive (Figure A.54), or select Process → Archive 
from the menu bar.

Figure A.54 
Archive window
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Figure A.55 
Archive Path Location window

35. Select the path location to archive the files to (for example, 
c:\temp). Click OK.
⇒ The archive process begins. All files are archived from the 

parent down. If there are any files below, it archives them as 
well. In this example, the .cel and .chp are archived.

The archive process is completed when the status is Available.

Figure A.56 
Status window

36. Click MySample in the Samples list and select Process → Refresh 
from the menu bar.

37. Expand TestExp in the right hand pane. 
⇒ The files are archived and are displayed in gray.
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38. To unarchive, right-click the archived file and select Unarchive. 
Alternatively, click the archived file and select Process → Unarchive 
from the menu bar.
⇒ The Unarchive process begins. 

Publish Database Data Deletion

39. To delete files from the Publish database, select the Publish tab.

40. Expand the Probe Array Type list.  
⇒ A list of probe array types is displayed of published experiments.

41. Click Hu6800. 
⇒ The published experiments is displayed.

42. Click TestExp.
⇒ This expands the list to display the .cel and .chp files (Figure A.57).

Figure A.57 
Publish Tab

43. Select the TestExp.CHP file (the last file), right-click and select 
delete or select Publish → Delete from the menu bar.
⇒ The confirmation message to delete appears (Figure A.58).
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Figure A.58 
Confirmation to delete selected Publish data 

44. Click Yes.
⇒ A message appears informing that the file is being deleted. The 

deleted .chp is removed from the data tree.

45. If the experiment remains in the process database, the data can be 
republished.

Process Database Data Deletion

46. To delete data from the process database, select the Process tab.

47. Expand the Expression Samples list.

48. Expand MySample.

49. Right-click TestExp and select Delete from the shortcut menu that 
appears. Alternatively, click TestExp and select Process → Delete from 
the menu bar.
⇒ A confirmation window appears (Figure A.59).

Figure A.59 
Confirmation to delete specific experiment selected

50. Click Yes.
⇒ After deletion,  the experiment is removed from the list.

51. Client testing completed.
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Installing Data Mining Tool 3.1 B

The installation of Data Mining Tool 3.1 does not remove any 
previous versions of Data Mining Tool. If the DMT is installed in the 
same directory, it overwrites the previous versions’ files. 

Data Mining Tool 3.1

This section guides you through the installation of Data Mining Tool 3.1. 
Listed below is an overview of the steps needed to complete the installation:

Microsoft® SQL Server GCOS Server Users

1. Obtain the name of the GCOS server from your IT personnel if not 
known (this is needed during installation).

2. Install Data Mining Tool 3.1.

Oracle® GCOS Server Users

1. Install Oracle Client Utilities on the workstation (Oracle Client Utilities 
must be the same version installed on the GCOS server).

2. Install SQL* Loader (for better performance).

3. Create an Oracle Alias. Refer to Creating an Oracle® Alias on page 197.

4. Install Data Mining Tool 3.1.

The following are detailed installation instructions for installing DMT.
 

The screen captures depicted in this section may not exactly match the 
windows displayed on your screen.

You must be logged in as administrator to install the DMT 3.1 software.
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1. Log in as an administrator.

2. Insert the Affymetrix® DMT 3.1 CD-ROM.

3. If the autorun feature does not start the program:

a. Click Start → Run.

b. Type <cd drive letter>:\setup.exe.

c. Click OK.

⇒ The Affymetrix Software Setup window appears, followed by the 
Welcome window (Figure B.1).

4. Click Next.

5. Several consecutive Software License Agreement windows appear. 
Review the contents in each and click Yes to accept the terms of the 
agreement.

⇒ The Customer Information window appears (Figure B.2).

Figure B.1 
Welcome window
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6. Enter your Name, Company and Serial Number.

The serial number is located on the Affymetrix® Software Product 
Registration card.

 

7. Click Next.

⇒ The Choose Destination Location window appears (Figure B.3).

Figure B.2 
Customer Information window

If you do not have a serial number, contact Affymetrix Technical 
Support. If you are upgrading from a previous version, the Serial 
Number field populates automatically.
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8. Click Next.

⇒ The Select Database Compatibility window appears (Figure B.4).

Figure B.3 
Choose Destination Location window

Figure B.4 
Select Database Compatibility window
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9. Select the database that DMT will connect with. 

■ Affymetrix® GCOS Server - if connecting to a GCOS server

■ Affymetrix® GCOS - if connecting to the local MSDE database

10. Click Next.

⇒ The Select Database Type window appears (Figure B.5).

11. Select the database used on the GCOS server, either SQL Server or 
Oracle.

If you do not know the type of database you are using with the GCOS 
server, please contact your IT personnel or DBA.

12. Click Next.

⇒ The Enter Information window appears (Figure B.6).

Figure B.5 
Select Database Type window
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13. In the Enter Information window complete one of the following; 
■ If SQL Server is selected, enter the SQL Server Name (usually the 

name of the GCOS server). 

■ If Oracle® is selected, enter the Oracle Alias Name.

14. Click Next.

⇒ The Start Copying Files window appears.

15. In the Start Copying Files window, verify the information and click 
Next.

⇒ Program files are copied and the system configures the registry. 
Database connectivity is verified. 

⇒ The Setup Complete window appears.

16. Select Yes, I want to restart my computer now and click Finish.

Figure B.6 
Enter Information windows for the Microsoft® SQL Server database (left) or the Oracle® database (right)

For Oracle systems: If a warning message regarding SQL Loader 
appears, continue the DMT install until complete. Then, install SQL 
Loader (part of Oracle) for better DMT performance. After SQL Loader is 
installed, re-install DMT.
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GCOS Instrument Installation C

The instrument installation needs to be done only on an instrument system. 
Appendix C sections are:

■ Fluidics Station and Scanner Installation
■ Fluidics Station Installation (only)

■ GeneArray® Scanner Installation (only)

■ GeneChip® Scanner 3000 Installation (only)

The instrument installation needs to be run if there has been a change to any 
of the drivers, otherwise upgrading the software to GCOS is the only 
installation upgrade required.

Scanner with Fluidics 
Station Installation

GeneArray® 2500 Scanner and Fluidics Station Installation

Follow this section if you have the GeneArray® 2500 scanner. 

When you install the fluidics station software, confirm the presence of the 
correct Sealevel card. 

1. On an instrument workstation that will be controlling fluidics stations, 
there must be a Sealevel card for communication between the 

The instrument installation is for Microsoft® Windows 2000 Workstation 
only.

If you cannot confirm the presence of a Sealevel card, contact Affymetrix 
technical support.
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workstation and the fluidics stations. Review Figure C.1 to confirm that a 
Sealevel card is installed in your system.

2. Launch Windows 2000 Explorer.

3. Browse to the Instrument CD.

4. Double-click setup.exe within the Instrument CD.

⇒ The Welcome window appears. 

5. Click Next.

6. Several consecutive Software License Agreement windows appear. 
Click Yes in each window to accept the terms of the agreement.

⇒ The Choose Destination Location window appears (Figure C.2).

Figure C.1 
Confirming the Sealevel card setup: note the 25 pin connector and the 25 pin cable adaptor

A single 25 
pin connector

25 pin cable 
adaptor
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7. Click Browse and select the Destination to install the instrument driver 
(select the same location where you installed Microarray Suite).

8. Click Next.

⇒ The Select Components window appears (Figure C.3).

Figure C.2 
Choose Destination Location window

Figure C.3 
Select both the Scanner Files and Fluidics Station Files and Sealevel card files
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9. Select both the Affymetrix Scanner Files option and the Fluidics 
Station Files option (Figure C.3). Highlight the Affymetrix Scanner 
Files option and click Change... to select the type of scanner. 

⇒ The following dialog box opens and displays the choice of scanners, 
Affymetrix® or GeneArray® (Figure C.4).   

10. Select the GeneArray® 2500 scanner Files and click Continue.

If you click Continue with both scanners selected, the software will 
display the following message.

11. Click Next and enter the Port # for the COM serial port for the Sealevel 
serial card. Enter 2 (Figure C.5).

Figure C.4  
Select the GeneArray® scanner. Select one scanner but not both.

If the workstation is the GX110, GX260, or GX270, select COM Port 3.
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12. Click Next. 

⇒ The Start Copying Files window appears (Figure C.6). 

This is a summary of the information selected.

Figure C.5  
Select the Port Number (Sealevel card only)

Figure C.6 
Start Copying Files Window
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13. Review the information and click Next to continue.

⇒ Program files and device drivers are copied to your system, and the 
Setup Complete window appears (Figure C.7).

The Affymetrix®‘ Scanner 3000 with Fluidics Station Installation

Follow this section if you have the GeneChip® Scanner 3000. 

When you install the fluidics station software, confirm the presence of the 
correct Sealevel card. 

1. On an instrument workstation that will be controlling fluidics stations, 
there must be a Sealevel card for communication between the 
workstation and the fluidics stations. Review Figure C.8 to confirm that a 
Sealevel card is installed in your system.

Figure C.7 
Install Complete window

If you cannot confirm the presence of a Sealevel card, contact Affymetrix 
technical support.
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2. Launch Windows 2000 Explorer.

3. Browse to the Instrument CD.

4. Double-click setup.exe within the Instrument CD.

⇒ The Welcome window appears. 

5. Click Next.

6. Several consecutive Software License Agreement windows appear. 
Click Yes in each window to accept the terms of the agreement.

⇒ The Choose Destination Location window appears (Figure C.9).

Figure C.8 
Confirming the Sealevel card setup: note the 25 pin connector and the 25 pin cable adaptor

A single 25 
pin connector

25 pin cable 
adaptor
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7. Click Browse and select the Destination to install the instrument driver 
(select the same location where you installed GCOS).

8. Click Next.

⇒ The Select Components window appears (Figure C.10).

Figure C.9 
Choose Destination Location window

Figure C.10 
Select both the Scanner Files and Fluidics Station and Sealevel card files
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9. Select both the Affymetrix Scanner Files option and the Fluidics 
Station Files option (Figure C.10). Highlight the Affymetrix Scanner 
Files option and click Change... to select the type of scanner. 

⇒ The following dialog box opens and displays the choice of scanners, 
Affymetrix or GeneArray® (Figure C.11).   

10. Select the Affymetrix Scanner files and click Continue.

If you click Continue with both scanners selected, the software will 
display the following message.

11. Click Next and enter the Port # for the COM serial port for the Sealevel 
serial card. Enter 2 (Figure C.12).

Figure C.11  
Select the Affymetrix scanner. Select one scanner but not both.

If the workstation is the Dell GX110, select COM Port 3.
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12. Click Next. 

⇒ The Start Copying Files window appears (Figure C.13). 

This is a summary of the information selected.

Figure C.12  
Select the Port Number for the Sealevel card.

Figure C.13 
Start Copying Files Window
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13. Review the information and click Next to continue.

⇒ Program files and device drivers are copied to your system, and the 
Setup Complete window then appears (Figure C.14).

14. Click Finish. 

Fluidics Station Installation 
(only)

When you install the fluidics station software, confirm the presence of the 
correct Sealevel card. 

1. On an instrument workstation that will be controlling fluidics stations, 
there must be a Sealevel card for communication between the 

Figure C.14 
Install Complete window

If you cannot confirm the presence of a Sealevel card, contact Affymetrix 
technical support.
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workstation and the fluidics stations. Review Figure C.15 to confirm that a 
Sealevel card is installed in your system.

2. Launch Windows 2000 Explorer.

3. Browse to the Instrument CD.

4. Double-click setup.exe within the Instrument CD.

⇒ The Welcome window appears. 

5. Click Next.

6. Several consecutive Software License Agreement windows appear. 
Click Yes in each window to accept the terms of the agreement.

⇒ The Choose Destination Location window appears (Figure C.16).

Figure C.15 
Confirming the Sealevel card setup: note the 25 pin connector and the 25 pin cable adaptor

A single 25 
pin connector

25 pin cable 
adaptor
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7. Click Browse and select the Destination to install the instrument driver 
(select the same location where you installed Microarray Suite).

8. Click Next.

⇒ The Select Components window appears (Figure C.17).

Figure C.16 
Choose Destination Location window

Figure C.17 
Select only the Fluidic Station and Sealevel card files.
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9. Select the Fluidics Station Files option (Figure C.17).

This should be the only option selected.

10. Click Next.

11. Enter the Port # for the COM serial port for the Sealevel serial card. 
Enter 2 (Figure C.18).

12. Click Next. 

⇒ The Start Copying Files window appears (Figure C.19). 

This is a summary of the information that you selected.

If the workstation is the GX110, GX260 or GX270, select COM Port 3.

Figure C.18  
Select the Port Number (Sealevel card only)
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13. Review the information and click Next to continue.

⇒ Program files and device drivers are copied to your system, and the 
Install Complete window appears (Figure C.20).

14. Click Finish. 

Figure C.19 
Start Copying Files Window

Figure C.20 
Install Complete window
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GeneArray® 2500 Scanner 
Installation (only)

1. Launch Windows 2000 Explorer.

2. Browse to the Instrument CD.

3. Double-click setup.exe within the Instrument CD.

⇒ The Welcome window appears. 

4. Click Next.

5. Several consecutive Software License Agreement windows appear. 
Click Yes in each window to accept the terms of the agreement.

⇒ The Choose Destination Location window appears (Figure C.21).

6. Click Browse and select the Destination to install the instrument driver 
(select the same location where you installed Microarray Suite).

7. Click Next.

⇒ The Select Components window appears (Figure C.22).

Figure C.21 
Choose Destination Location window



  Affymetrix®  GeneChip®  Operating Software User’s Guide 483
8. Select only the Affymetrix Scanner Files option (Figure C.22). Highlight 
the Affymetrix Scanner Files option and click Change... to select the 
type of scanner. 

⇒ The following dialog box opens and displays the choice of scanners, 
Affymetrix or GeneArray® (Figure C.23).

   

Figure C.22 
Select only Scanner files for scanner installation

Figure C.23  
Select the GeneArray® scanner. Select one scanner but not both.
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9. Select the GeneArray® 2500 scanner Files and click Continue.

If you click Continue with both scanners selected, the software will 
display the following message.

10. Click Next. 

⇒ The Start Copying Files window appears (Figure C.24). 

This is a summary of the information that you selected.

11. Review the information and click Next to continue.

⇒ Program files and device drivers are copied to your system. 

Figure C.24 
Start Copying Files Window
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12. Click Finish. 

GeneChip® Scanner 3000 
Installation (only)

1. Launch Windows 2000 Explorer.

2. Browse to the Instrument CD.

3. Double-click setup.exe within the Instrument CD.

⇒ The Welcome window appears. 

4. Click Next.

5. Several consecutive Software License Agreement windows appear. 
Click Yes in each window to accept the terms of the agreement.

⇒ The Choose Destination Location window appears (Figure C.26).

Figure C.25 
Install Complete window

The instrument installation is for Microsoft® Windows 2000 Workstation 
only.
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6. Click Browse and select the Destination to install the instrument driver 
(select the same location where you installed Microarray Suite).

7. Click Next.

⇒ The Select Components window appears (Figure C.27).

Figure C.26 
Choose Destination Location window

Figure C.27 
Select Affymetrix Scanner files only for scanner installation
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8. Select only the Affymetrix Scanner Files option. Highlight the 
Affymetrix Scanner Files option and click Change... to select the type 
of scanner. 

⇒ The following dialog box opens and displays the choice of scanners, 
Affymetrix or GeneArray® (Figure C.28).   

9. Select the Affymetrix Scanner files and click Continue.

If you click Continue with both scanners selected, the software will 
display the following message.

10. Click Next. 

⇒ The Start Copying Files window appears (Figure C.29). 

This is a summary of the information that you selected.

Figure C.28  
Select the Affymetrix scanner. Select one scanner but not both.
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11. Review the information and click Next to continue.

⇒ The Install Complete window appears (Figure C.30).

12. Click Finish. 

Figure C.29 
Start Copying Files Window

Figure C.30 
Install Complete window
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Using the GeneChip® Scanner 3000 D

Affymetrix has designed a new scanner expressly for scanning 
GeneChip® probe arrays. The GeneChip® Scanner 3000 requires little 
maintenance. 

The instrument must be kept clean and free of dust. Dust buildup can 
degrade performance. Wipe the exterior surfaces clean using a mild 
dish detergent solution in water. Do not use ammonia based cleaners 
or organic solvents, such as alcohol or acetone, to clean the system 
because they may damage the exterior surfaces.

 

Figure D.1 
The Affymetrix® GeneChip® Scanner 3000
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Introduction

The Affymetrix® GeneChip® Scanner 3000 is a wide-field, epifluorescent, 
near-confocal microscope. The scanner uses a 532 nm solid-state laser to 
excite probe array fluorophores. This in turn produces an emission 
wavelength at about 570 nm. As the surface of the probe array is scanned, a 
photomultiplier tube collects and converts the fluorescent emissions into an 
electrical signal. An analog-digital converter in the scanner converts this 
signal into corresponding numeric values representative of fluorescent 
intensities. These digital intensity values are collected from discrete areas on 
the array surface and are stored on the computer workstation as pixels that 
comprise the image data file (the .dat file). See Chapter 9, Working with 
Images, on page 135 for more on image data.

Affymetrix’ patented “flying objective™” technology represents a radical 
departure from conventional laser scanners. The optical system comprises a 
scan arm that rapidly oscillates from side to side scanning the entire width of 
the probe array in a continuous arc while the probe array is advanced in front 
of the objective. The acquired image of the array is returned to the computer 
software as a set of arcs. The software then geometrically corrects these arcs 
to form a linear image of the array (Figure D.2). 

Do not remove the cover of the scanner. Use the scanner only as 
instructed in this User Guide. Do not attempt to service the instrument.
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The laser source excites the hybridized fluorophores and the photomultiplier 
system simultaneously captures the resulting fluorescent intensities. The 
optical components direct the fluorescent beam back through the objective 
lens, through a dichroic mirror and to the PMT. An analog-digital converter 
transforms the PMT output into 65536 levels of intensity. Each level of 
intensity is stored in the software as a 16 bit number (216=65536).

The scanner is equipped with an IEC 320 compliant power entry module 
located at the rear of scanner (Figure D.3).

The scanner is equipped with an RJ-45 interface connector compatible with 
10/100 Base T Ethernet for communications with the host workstation.

The GCOS application controls the scanner. The scan process times for each 
type of GeneChip® probe array are outlined in the next table. Affymetrix 
measures the process time from the “Start Scan” command to the return of 

Figure D.2 
Schematic of the scanner design
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the cartridge to the instrument entrance port along with the display of the 
completed scan image on the workstation monitor.

After the scanner has completed a scan, GCOS displays a picture of the 
image in the image window. The software displays the fluorescent intensity 
values from each pixel within the probe array feature in a grayscale or 
pseudocolor mode and superimposes a grid on the image to delineate the 
probe cells.

GCOS analyzes the image and derives a single intensity value for each probe 
cell on an array. This data is automatically generated and saved to the cell 
intensity file. See Chapter 9, Working with Images, on page 135. 

Safe Operation

To ensure safe operation of the GeneChip® Scanner 3000:

■ Read this section and Scanning a Probe Array–GeneChip® Scanner 
3000, on page 111 completely before operating the instrument.

■ Do not attempt to service this instrument. Any attempt at unauthorized 
service may damage the instrument and/or void the warranty.

■ The instrument weight is approximately 63 pounds (28.6 Kg). Do not 
place it on an unstable cart, stand, or table. Failure to properly support the 
instrument may cause serious damage or injury and may void the 
warranty. 

■ The instrument must be surrounded by adequate airspace. Slots and 
openings in the instrument and the electronics compartment covers are 
for ventilation. Do not block or cover them. 

Probe Array Type Process Time (typical)

49 5min 15sec

64 4min 30sec

100 3min 30sec

169 3min 30sec

400 2min 45sec

Heavy object. Two people are required to lift the scanner.
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■ Never push an object into the instrument ventilation slots; equipment 
damage or injury may result. Do not set liquids on top of the instrument.

■ The instrument has an AC receptacle with a safety ground appropriate for 
the country of destination. The plug is designed to connect only to a 
3-prong ground receptacle. This safety feature should not be 
compromised in any way. If the instrument AC plug does not mate with 
the available power source receptacle, consult a licensed electrician to 
install one that does.

When to Contact Affymetrix

Under any of the following conditions, unplug the instrument from the 
power source and contact technical Support:

■ When the power cord is damaged or frayed.
■ If any liquid has been spilled into the instrument.
■ If the instrument has been penetrated by water.
■ If, after service or calibration, the instrument does not perform in 

accordance with the capabilities stated in the specifications.
■ If the instrument has been dropped or otherwise damaged.

If the instrument must be returned for repair, call Affymetrix® Technical 
Support.

Laser Safety

The laser is equipped with an automatic shutter that inhibits its output beam 
and ensures safe operation under conditions encountered in normal 
operation. The instrument covers, probe array cartridge access port, and 
protective shutters ensure that during instrument operation no directed or 
stray laser light leaves the instrument.

Do not remove the cover of the scanner. Use the scanner only as 
instructed in this User Guide. Do not attempt to service the instrument. 
Only qualified service technicians can open and service the scanner. 
There are no customer serviceable parts. Removing the case exposes 
the customer to laser and electrical shock hazards.

The GeneChip scanner 3000 is a Class I laser product when the laser is 
enclosed in scanner case. The laser itself is a Class IIIB laser product.



APPENDIX D   Using the GeneChip® Scanner 3000496
The green laser is a 532nm solid-state laser. This is a Class IIIb laser and has 
visible outputs greater than 5mw but no more than 500mw. It must never be 
operated in an exposed manner. Any object in the direct path of the laser 
beam may be damaged. Eyes and skin can be seriously damaged by direct 
exposure to, specular reflections from, or diffuse reflections from this laser. 
If improperly used, a laser of this type can cause fires. When used according 
to the instructions in this manual and when all covers are in place, the 
GeneChip® Scanner 3000 is classified as a Class I Laser Device per 21 CFR 
1040.

Always take note of laser safety labels; they indicate areas where exposure 
to laser beams may be hazardous.

Electrical Safety

The scanner will automatically handle any input voltage from 100 to 240 
VAC nominal, 50 to 60 Hz 

DANGER
Laser radiation when open. 

Avoid direct exposure to beam.
The lasers can cause serious injury if 
the instrument is not operated in 
accordance with instructions in this 
user guide.

CAUTION
Use laser safety glasses when 

servicing
DO NOT STARE INTO BEAM.

The scanner’s power supply will autodetect the input voltage source and 
configure itself.



  Affymetrix®  GeneChip®  Operating Software User’s Guide 497
CAUTION

The power supply cord is used as the main disconnect device. Ensure that the 
socket outlet is located and installed near the equipment and is easily 
accessible.

ATTENTION

Le cordon d’alimentation est utilisé comme interrupteur general. La prise de 
courant doit être située ou installée a proximité du materiel et être facile 
d’accés.

ACHTUNG

Zur sicheren Trennung des Gerätes vom Netz ist der Netzstecker zu ziehen. 
Vergewissern Sie sich, daß die Steckdose leicht zugänglich ist.

Connections and Indicator 
Lights

The GeneChip® Scanner 3000 has the following connections on the back of 
the unit (Figure D.3):

■ AC power connection
■ Ethernet connection

If you must move the scanner, disconnect all cables first.

Connecting the Scanner

1. Connect the 3-pronged electric power plug to the workstation.

2. Connect the dedicated Ethernet cable from the scanner to the Ethernet 
port that is designated on the workstation. The port is located near the 
bottom of the workstation.

3. You can connect your company’s network cable to the indicated port 
near the center of the workstation.

CAUTION
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When you start GCOS, the software will make the proper 
communication connections.

Do not confuse your company’s network connections with the dedicated 
Ethernet port of the scanner-workstation. The proper scanner 
connection is located near the bottom of the workstation.

This 10/100 Base T Ethernet communications port is dedicated to the 
scanner-workstation interface. You cannot connect the scanner to your 
company’s Ethernet communications network. 

You can, however, connect the workstation’s second Ethernet port to the 
your company’s Ethernet network.

Figure D.3 
Scanner Connections- left: rear of scanner -right: rear of computer

The reset button is the scanner’s circuit breaker. The breaker switch will 
be tripped whenever the scanner experiences an electrical fault 
condition. Press to reset. If you cannot reset this switch, contact 
Affymetrix technical support. 
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Indicator Lights and On/Off Button

The front panel has the following button and indicators (Figure D.4).

1. I/O (on/off) button in the center.

2. Blue indicator light, running vertical at front center, indicates that the 
scanner is on.

3. Green and yellow light both on indicate scanner boot up in progress.

Figure D.4 
Scanner indicator lightsn and on/off (I/O) button

Blue
Indicator
Light

I/O (on/off)
button

Yellow light

Green light
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4. Yellow light

a. On = Idle, laser is warming up (laser not ready, green off)

b. Off = System ready, no errors (Green on)

c. Flashing = Error

5. Green light

a. On = System is ready to scan (yellow off)

b. Flashing = Scan in progress

Summary of Indicator Lights

The table below summarizes the light conditions and their meaning.

Condition Green 
Light

Yellow 
Light

Blue 
Indicator
Light

Meaning

Initial boot up Off Off On Initial power up; embedded 
PC takes control

Scanner boot up On On On Embedded PC takes 
control of scanner boot up

Laser warm up Off On On Software enabled and laser 
is warming up

System ready On Off On User communication with 
scanner enabled

Error Off Flashing On Fatal error, reboot scanner 
and software

Scanning enabled Flashing Off On Scanning in progress

During the initial power up (CPU boot up), both the green and yellow 
lights will be off.

During the scanner boot up, both the green and yellow lights will be on.



  Affymetrix®  GeneChip®  Operating Software User’s Guide 501
Using the Barcode Reader

If your scanner is equipped with a barcode reader, follow this section for 
instructions on its use.

1. Open the GCOS software to the Experiment Information window and 
place the cursor in the barcode reference field of the GCOS Experiment 
Information window (Figure D.5).

You should open a new experiment and place the cursor into the 
barcode field before triggering the reader. Otherwise, the barcode will 
be misinterpreted as some other kind of input. You are required to open 
a new experiment for each barcode and must enter certain other 
information before the experiment can be saved. See Table L.3, on 
page 674 for a summary of information that you can enter in the 
Experiment Information Window.

Figure D.5 
Experiment Information Window with cursor in the barcode field
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2. Hold a GeneChip probe array cartridge in front of the barcode reader 
and squeeze the trigger for approximately four seconds until you hear a 
beep (Figure D.6). 

3. The reader reads and sends the barcode to the GCOS Experiment 
Information window, Barcode field (Figure D.7).

Figure D.6 
Reading the cartridge barcode
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4. After the software adds the barcode, save the experiment.

5. Repeat steps 1 to 4 until all of the probe array cartridges have been read.

Scanner 3000 
Specifications

Figure D.7 

Item Parameter Value

Weight Shipping approx 78 pounds (35.4 Kg)

Free-standing 63 pounds (28.6 Kg)

Dimensions Width ~13.25 in. 

Depth ~27.5 in.

Height ~18.25 in. 
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Troubleshooting

Power Voltage
Current
Line Frequency

100 - 240 V ~
4 - 2 A
50 - 60 Hz

Working Environment Temperature 59°F-85°F (15°C-30°C)

Humidity 10-90% Non-condensing

Clearance 2 in. (5 cm) on side, back and 
top

Pollution Degree 2

Installation Category II

Altitude <2000m

Electrical Supply Provide voltage, frequency or power rating per unit label

Main Supply Voltage 
Fluctuations

Are not to exceed ±10% of the nominal supply voltage

If you use the scanner in a manner not specified in this user guide, you 
may impair the protection provided by the equipment.

Problem Possible Cause Corrective Action

No image when scanning Power off or cable loose Check all connections and 
power.

Loss of laser power Contact technical support.

Intermittent problems 
scanning

Loose cable Check all rear connections.

Scanner fails with probe array 
inside

Power failure Manually extract probe array. 
Check all connections to 
scanner. Turn scanner on, 
restart software.

Item Parameter Value
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Issues Relating to the Scanner’s Operation

The GeneChip® Scanner 3000 is a new type of scanner. In using the scanner 
you may encounter some issues, or problems, that may require your 
intervention. Below is a list of these issues. 

Issue Explanation

If communications are 
interrupted during a scan 
(by a faulty cable 
connection or power 
being lost at the scanner, 
for example)

GCOS will properly note the failure and present a message 
“Cannot connect to Scanner.” However, there are two issues to 
note. First, GCOS will report such a failure only after a network 
time-out of about 30 seconds. Second, rarely, if communications 
have been lost, GCOS and the Scanner may not be able to 
automatically restore communications once the problem is 
rectified, and both may become unresponsive. 

To restore proper operation, verify that the scanner is on, that 
communication cables are properly connected, and close and 
restart Windows then restart GCOS. If the system remains 
unresponsive, disconnect and reconnect power to the scanner, 
restart the scanner normally, close and restart Windows and 
GCOS.

Repeated attempts to 
send commands (Start, 
Turn Laser On, etc.) from 
GCOS to the Scanner 
while GCOS is reporting 
the scanner “Offline” 
may result in GCOS 
becoming unresponsive 
until communications are 
restored

If communications cannot be re-established, please follow the 
recommendations of item 1

If the Scanner 
experiences multiple 
auto-focus failures, the 
system may enter an 
unresponsive state. 

Follow the recommendations of item 1 to restore 
communications and correct operation.

Laser warm-up lasts for 
ten minutes, during 
which time the “Turn 
Laser On” button will 
remain unchanged and 
GCOS will display the 
status message 
“Warm-up”. 

Simply note that this is normal operation.
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Occasionally, when 
observing DAT images in 
GCOS, the user may 
notice, at specific zoom 
levels, that grid lines do 
not properly appear. 

Reducing the graphics acceleration parameter in Windows 
desktop Properties will eliminate this problem.

If no chip is inserted and 
a scan started.

The scanner will attempt go through the first parts of the 
auto-focus routine and then report “Failed to find chrome 
border”.

The scanner should be in the park mode to eject the chip.

Auto focus will fail if salt 
deposits accumulate on 
the array.

Use Tough-Spots to prevent leaks in the GeneChip® probe array. 
See the quick reference card, p/n 08-0076.

Issue Explanation



  Affymetrix®  GeneChip®  Operating Software User’s Guide 507
Manually Removing a Lodged Probe Array Cartridge

In the event that a probe array becomes lodged in the chip transport 
mechanism, follow the procedure outlined below.

1. Turn off the 
scanner. 

2. Insert a 
paper clip or 
small Allen 
wrench into 
the rescue 
hole on top 
of the scan-
ner and press 
to partially 
lift the car-
tridge loading 
door.

3. Using your fingers, gently lift the front edge of the door. As you lift 
the front edge, lift the back edge approximately 1/4” to open the 
door straight up to expose the rescue screw in the front.
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4. Using a stan-
dard (-) 
screwdriver, 
turn the res-
cue screw 
clockwise to 
raise the chip 
transport 
mechanism.

5. Continue to 
turn the 
screw until 
the probe 
array car-
tridge 
ascends suf-
ficiently to 
grab it.

Note that the screw is fine pitched and requires a number of turns. 
Stop if you encounter screw resistance. Do not over torque.
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6. When the 
cartridge has 
ascended 
sufficiently, 
remove it.

7. Rescrew the 
chip trans-
port mecha-
nism until it 
descends 
completely, 
or until you 
encounter 
resistance. 
Do not over 
torque.

8. Close the 
door.
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CE Mark Declaration of 
Conformity
We, Affymetrix, Inc. 
4G Crosby Drive, 
Bedford, Massachusetts 

Declare under sole responsibility that the Affymetrix® GeneChip® Scanner 3000 conforms with the relevant 
provisions of the following standards or other normative documents:

EU EMC Directive 89/336/EEC:

EN 61326:1998 Equipment for Measurement, Control and 
Laboratory Use, EMC Requirements

EN 55011:1998 Industrial, scientific and medical (ISM) 
radio-frequency equipment - Radio disturbance 
characteristics - Limits and methods of 
measurement

EN 61000-3-2:2001 Limits for harmonic current emissions 
(equipment input current up to and including 16 
A per phase)

EN 61000-3-3:1995 Limitation of voltage changes, voltage 
fluctuations and flicker in public low-voltage 
supply systems, for equipment with rated 
current less than or equal to 16 A per phase 
and not subject to conditional connection

EN 61000-4-2:1995 Electrostatic discharge immunity.

EN 61000-4-3:1995 Radiated, radio frequency, electromagnetic 
field immunity.

EN 61000-4-4:1988 Electrical fast transient/burst immunity.

EN 61000-4-5:1995 Surge immunity.

EN 61000-4-6:1996 Immunity to conducted disturbances induced 
by radio frequency fields.

EN 61000-4-11:1994 Voltage dips, short interruptions, and voltage 
variations immunity.

EU Low Voltage Directive 73/23/EEC

EN 61010-1:2001 Safety requirements for electrical equipment 
for measurement, control, and laboratory use -- 
Part 1: General requirements

EN 60825-1:1994+ A2:2001 Safety of laser products -- Part 1: Equipment 
classification, requirements and user's guide
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Regulatory

This device complies with Part 15, Subpart B, Class B of the FCC rules. 
Operation is subject to the following two conditions: (1) This device 
may not cause harmful interference, and (2) this device must accept 
any interference received, including interference that may cause 
undesirable operation.

This device complies with FDA performance standards for laser 
products except for deviations pursuant to Laser Notice No. 50, dated 
July 26, 2001.

For Research Use Only. Not for use in diagnostic procedures.

Regulatory Agency Certification

AL 02 12 39816 004

92AA

See the section entitled CE 
Mark Declaration of 
Conformity on page 510.

Class I Laser Device 21 CFR 1040.10 and 1040.11
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Expression Algorithm, Expression Analysis 
Metrics & Settings E

GCOS and versions of Microarray Suite higher than 5.0 run the Statistical 
expression algorithm. Previous versions of Microarray Suite (lower 
than 5.0) run the Empirical expression algorithm.

Expression Analysis 
Algorithm

Notation

A GeneChip® probe array consists of a number of cells (square-shaped areas 
on the array) and each contains many copies of a unique probe. Probes are 
tiled in probe pairs consisting of a perfect match (PM) and a mismatch 
(MM). 

The sequence of the PM and MM are the same, except for a base substitution 
in the middle of the MM probe sequence. A probe set includes a series of 
probe pairs and represents an expressed transcript (Figure E.1).

Figure E.1 
Probe set that includes 10 probe pairs
515
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Algorithm Output Definitions

Signal A measure of the abundance of a transcript.

Stat Pairs The number of probe pairs for a particular probe 
set on the array.

Stat Pairs Used  = Pairs - Masked probe pairs - Saturated MM 
probe pairs

This is the number of pairs used by the Statistical 
Expression algorithm to make the detection call 
in an single-array analysis.

Detection The call in an single-array analysis that indicates 
if the transcript was Present (P), Absent (A), 
Marginal (M), or No call (NC).

Detection p-value p-value that indicates the significance level of the 
Detection call.

Stat Common Pairs The intersection of the probe pairs from the 
baseline and experiment that are used by the 
Statistical Expression algorithm to make the 
Change call in a comparison analysis.

Change The call that indicates the change in transcript 
level between a baseline and an experiment array.

Change p-value p-value that indicates the significance level of the 
Change call.

Signal Log Ratio The change in expression level for a transcript 
between a baseline and an experiment array. This 
change is expressed as the log2 ratio.

Signal Log Ratio low The lower limit of the Log Ratio within a 95% 
confidence range.

Signal Log Ratio high The upper limit of the Signal Log Ratio within a 
95% confidence range.
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Background Subtraction

The first step in the analysis is to correct for background across the entire 
array. The calculated background establishes an intensity floor that is 
subtracted from all intensity values.

Raw cell intensities → Background-adjusted intensities

The algorithm:

■ divides the array into equally spaced zones (Figure E.2)

■ assigns an average background to the center of each zone
■ computes the distance from each cell to the center of every zone
■ computes a weighting factor (the reciprocal of the sum of a constant and 

the square of the distance from the cell to the zone center)
■ computes the background of each cell by applying the weighting factor to 

the zone average (the average background assigned to the center of each 
zone)

Figure E.2 
Array zones for computing background; the arrow color indicates the relative weights
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Single-Array Expression Analysis

Detection

The Detection call answers the question: Is the transcript of a particular 
probe set reliably detected by the probe array? We want an answer of Absent 
or Present. In this context, Absent means the expression level is below the 
threshold of detection. In the case of uncertainty, we can get a Marginal call.

Detection call results are easy to filter and interpret. For example, we may 
only want to look at genes whose transcripts are Present in a particular 
experiment. An additional advantage is that the Detection and the Signal 
values are calculated using independent algorithms that add additional 
information to the results.

Raw cell intensities → Absent, Present, or Marginal Detection call plus 
p-values

Discrimination Value

The algorithm computes a discrimination value that is used as a filter to 
remove from further consideration all probe sets with insignificant 
differences between PM and MM.

discrimination value = (PM - MM)/(PM + MM)

The median of the discrimination ratios of all the probe pairs of a probe set is 
compared to a user-modifiable parameter τ  (default = 0.015), and produces 
an intermediate call.

Making the Call

A one-sided Wilcoxon’s Signed Rank test is used to calculate a p-value that 
reflects the significance of the differences between PM and MM. The 
p-value or statistical significance of a result is the probability that the 

A No Call detection result occurs if all of the probe pairs of a probe set 
are excluded from the analysis. A probe pair is excluded if the PM or 
MM is masked or if the MM is saturated.

Increasing τ  can reduce the number of false Present calls, but may also 
reduce the number of true Present calls.
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observed change in a sample occurred by pure chance. For example, a 
p-value of 0.05 means there are five chances in 100 that the results are not 
significant. The lower the p-value, the greater the probability that the results 
are significant.

To make a call, the p-value for a probe set is examined on an axis with two 
user-definable thresholds, α1 and α2 (defaults α1 = 0.04 and α2 = 0.06). For 
p-values between zero and 0.5, α1and α2 define the thresholds for the calls 
(Figure E.3). See also Table E.1.

The result is reported as the Detection call that is associated with the 
calculated p-value.

Decreasing the significance level α1 can reduce the number of false 
detected calls and reduce the number of true detected calls.

Increasing the significance level α2 can reduce the number of false 
undetected calls and reduce the number of true undetected calls.

Figure E.3 
User-modifiable thresholds, α1 and α2
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Calculating the Signal

The signal represents the amount of transcript in solution.

Background-adjusted cell intensities → Probe set signal

For each PM intensity, a matching MM probe provides a reference 
background hybridization intensity. If the MM value is less than the PM 
value, the algorithm uses the MM value directly. However, if the MM value 
is larger than the PM value, the algorithm creates an adjusted MM value 
based on the average difference intensity between log2 PM and log2 MM, or 
if that measure is too small, some fraction of PM.

The adjusted MM values are used to calculate the log2 PM - log adjusted 
MM for each probe pair. The Signal for a probe set is calculated as the 
one-step biweight estimate of the combined differences of all the probe pairs 
in the probe set. 

Comparison Expression Analysis

A comparison analysis compares the expression levels of the transcripts on 
one array to those on another. By directly comparing matching cells on two 
arrays, any inherent differences in hybridization efficiency will cancel out. 
As a result, this is an accurate and sensitive method of determining changes 
in expression levels.

Differences between PM and MM and Differences between PM and 
Background (Experiment and Baseline) → Change call and p-value

The algorithm computes a primary normalization factor and two additional 
normalization factors that straddle the primary normalization factor. The 

Table E.1 
Statistical algorithm Detection call rules

Computed Detection p-values Detection Call

p < α1 Present

 α1 ≤ p < α2
Marginal (at the limit of 
detection)

p ≥ α2
Absent
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spread between the normalization factors is determined by the perturbation 
parameter (d).

To determine the p-values, a signed rank analysis is carried out on the PM 
and MM differences for each probe pair in a probe set from the two arrays in 
the comparison. The resulting p-values are used to make the change calls.

To make a call, the p-value for a probe set is examined on an axis with four 
thresholds (Figure E.4). For p-values between zero and 1.0, γ 1and γ 2 define the 
thresholds for the calls.

The result is reported as the Change call that is associated with the 
calculated p-value (see Table E.2). The output p-value is the critical p-value. 
The critical p-value is the p-value that determines the Change call.

The critical p-value, p, is defined by the following:

■ p = max(p0, p1, p2), if p0 < 0.5, p1 < 0.5 and p2 < 0.5

■ p = min(p0, p1, p2), if p0 > 0.5, p1 > 0.5 and p2 > 0.5

■ p = 0.5, otherwise

Figure E.4 
User-modifiable parameters, γ 1 and γ 2
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You may adjust γ 1 and γ 2 by specifying different values for: γ 1L, γ 1H, γ 2L, 
γ 2H. See Expression Analysis Settings, on page 532.

Decreasing γ 1 can reduce the number of false Increase and Decrease calls, 
but can also reduce the number of true Increase and Decrease calls. 
Increasing γ 2 can reduce the number of false No-Change calls, but can also 
reduce the number of true No-Change calls. Increasing the perturbation 
parameter (d) can increase the number of true No-Change calls, but can also 
increase the number of false No-Change calls.

Table E.2 
Statistical algorithm Change call rules

Computed Change 
p-values Change call

p0 < γ 1
p1 < γ 1
p2 < γ 1

Increasing

p0 < γ 2
p1 < γ 2
p2 < γ 2

Marginally increasing

Else No change

p0 > 1-γ 2
p1 > 1-γ 2 
p2 > 1-γ 2

Marginally decreasing

p0 > 1-γ 1
p1 > 1-γ 1 
p2 > 1-γ 1

Decreasing

A No Call occurs if all of the probe pairs of a probe set are excluded from 
the analysis. A probe pair is excluded if the PM or MM in the experiment 
or baseline is masked or saturated.
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Signal Log Ratio

Probes inherently hybridize with slightly different affinities. Relative 
expression values compare identical probes in the baseline and experiment. 
As a result, probe specific effects are canceled out.

Adjusted cell intensities (Baseline and Experiment) → Signal Log Ratio, 
Signal Log Ratio low, and Signal Log Ratio high

The Signal Log Ratio calculation is an extension of the signal calculation. 
The discrimination of the log2 ratio is used to correct for outlier probes. The 
one-step biweight method is used to compute the average log2 ratio of the 
probe set. The upper and lower limits of the 95th confidence interval are 
reported as Signal Log Ratio high and Signal Log Ratio low.
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Expression Analysis 
Metrics

GCOS and versions of Microarray Suite higher than 5.0 run the Statistical 
expression algorithm. Versions of Microarray Suite (lower than 5.0) run the 
Empirical expression algorithm.

Statistical Expression Algorithm

Single-Array Results

Signal

A measure of the abundance of a transcript.

Detection

The call that indicates whether the transcript is detected (P, Present), 
undetected (A, Absent), or at the limit of detection (M, Marginal).

Detection p-value

p-value that indicates the significance of the Detection call.

Stat Pairs

The number of probe pairs for a particular probe set on an array.

Stat Pairs Used

The number of probe pairs per probe set used in the analysis. This may be 
the total number of probes per probe set on the probe array or the number of 
probe pairs in a pre-designated subset (for example, probe pairs specified by 
a probe mask file and/or a masked image). Stat Pairs Used = total probe pairs 
per probe set – (probe pairs masked in a mask file) – (probe pairs masked in 
the image) – (saturated MM probe pairs).
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Comparison Results

Signal Log Ratio

The change in the expression level of a transcript between a baseline and an 
experiment array. This change is expressed as the log2 ratio. A log2 ratio of 1 
is equal to a fold change of 2.

Signal Log Ratio Low

The lower limit of the Log Ratio within a 95% confidence interval.

Signal Log Ratio High

The upper limit of the Log Ratio within a 95% confidence interval.

Change

The call that indicates the change in the transcript level between a baseline 
and experiment (Increase (I), Marginal Increase (MI), No Change (NC), 
Marginal Decrease (MD), Decrease (D)) 

Change p-value

p-value that indicates the significance of the Change call.

Stat Common Pairs

The intersection of the probe pairs from the baseline and experiment that are 
used by the Expression algorithm to make the Change call in a comparison 
analysis.
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Empirical Expression Algorithm

Versions of Microarray Suite lower than 5.0 run the Empirical Expression 
algorithm.

Single-Array Analysis Results

Positive & Negative

The number of probe pairs scored positive or negative. A probe pair is called 
positive if the intensity of the PM probe cell is significantly greater than that 
of the corresponding MM probe cell. A probe pair is called negative if the 
intensity of the MM probe cell is significantly greater than that of the 
corresponding PM probe cell. To evaluate the intensity, the algorithm 
calculates the ratio and difference associated with each probe pair and 
compares these values to the Statistical Difference Threshold (SDT) and the 
Statistical Ratio Threshold (SRT).

A probe pair is Positive if: PM – MM > SDT and PM/MM > SRT

A probe pair is Negative if: MM – PM > SDT and MM/PM > SRT

The SDT is a function of the noise (Q) and is calculated by the software: 
SDT = Q * SDTmult. The SDTmult and the SRT are user-modifiable 
parameters. The SDTmult is set at 2.0 for the standard staining protocol or 4.0 
for the antibody amplification protocol. (Refer to the Expression Analysis 
Technical Manual or the HuSNP® Mapping Assay User Manual). The default 
SRT value is 1.5. 

The number of positive and negative probe pairs is determined for every 
probe set and are used to derive parameters that describe probe set 
performance.

Pairs

The number of probe pairs for a particular probe set on an array.

Increasing the SDTmult and SRT increases analysis stringency, reducing 
these thresholds decreases analysis stringency.
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Pair Used

The number of probe pairs per probe set used in the analysis. This may be 
the total number of probes per probe set on the probe array or the number of 
probe pairs in a pre-designated subset (for example, probe pairs specified by 
a probe mask file and/or a masked image). 

Pairs Used = total probe pairs per probe set – (probe pairs masked in a mask 
file) – (probe pairs masked in the image).

Pairs in Avg

A trimmed probe set that excludes probes with extremely intense or weak 
signal from the analysis. If 8 or fewer probe pairs are used, Pairs in Avg = 
Pairs Used (or the number of probe pairs per probe set minus any that are 
masked). 

Super scoring is performed if more than 8 probe pairs are used. Superscoring 
is a process that excludes probe pairs from calculation of the Avg Diff and 
Log Avg Ratio if they are outside a given intensity range. Microarray Suite 
calculates the mean and standard deviation of the intensity differences (PM – 
MM) for an entire probe set (excluding the highest and lowest values). Those 
values within a set number of standard deviations (STP) are included in the 
calculation of the Avg Diff or Log Avg Ratio. The STP is a user-modifiable 
parameter with a default value = 3.

Pos Fraction

# positive probe pairs/# probe pairs used

Log Avg

Describes the hybridization performance of a probe set and is determined by 
calculating the ratio of the PM/MM intensities for each probe pair in a probe 
set, taking the logs of the resulting values, and averaging them for the probe 
set:

Log Avg = 10 x {[Σ log (PM/MM)] / Pairs in Avg}

Log Avg = 0 indicates random cross hybridization. The higher the Log 
Avg, the more confidence the transcript is present.
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Pos/Neg

The ratio of Positive probe pairs to Negative probe pairs in a probe set (# 
Positive probe pairs / # Negative probe pairs).

Avg Diff

This parameter serves as a relative indicator of the level of expression of a 
transcript. It is used to determine the change in the hybridization intensity of 
a given probe set between two different experiments.

The Avg Diff is calculated by taking the difference between the PM and MM 
of every probe pair (excluding the probe pairs where PM – MM is outside 
the STP standard deviation of the mean of PM-MM) in a probe set and 
averaging the differences for the entire probe set.

Absolute Call

Each transcript in an single-array analysis has three possible Absolute Call 
outcomes: Present (P), Absent (A), or Marginal (M). The Absolute call is 
derived from the Pos/Neg, Positive Fraction, and Log Avg Absolute call 
metrics. Each Absolute call metric is weighted and entered into a decision 
matrix to determine the status of the transcript.

Comparison Analysis Results

Increase

A probe pair is considered to increase if the intensity difference between the 
PM and MM probe cells in the experimental sample is significantly higher 
than in the baseline sample. Two criteria must be met for a probe pair to 
show a significant increase:

(PM – MM)exp – (PM – MM)base > Change Threshold (CT), and

[(PM – MM)exp – (PM – MM) base] / max [Q/2, min(|PM – MM|exp |PM – 
MM|base)] > Percent Change Threshold/100

The Avg Diff cannot be used to compare the hybridization intensity 
levels of two different probe sets on the same array.

Avg Diff
PM MM–( )∑

Pairs in Avg
---------------------------------=
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Decrease

A probe pair is considered to decrease if the intensity difference between the 
PM and MM probe cells in the experimental sample is significantly lower 
than in the baseline sample. Two criteria must be met for a probe pair to 
show a significant decrease:

(PM – MM) base – (PM – MM) exp > Change Threshold (CT), and

[(PM – MM)base – (PM – MM) exp] / max [Q/2, min(|PM – MM|exp, |PM – 
MM|base)] > Percent Change Threshold/100

The software calculates the Change Threshold (CT) using the SDT 
(Statistical Difference Threshold) of both the experimental and baseline 
data. Alternatively, the user may define the CT by entering a value for the 
CT Multiplier (in the Parameters tab of the Expression Analysis Settings 
dialog box), which is multiplied by the noise (Q) of the baseline or 
experimental data, whichever is greater. The Percent Change Threshold is a 
user-specified value (also set in the Parameters tab of the Expression 
Analysis Settings dialog box).

Inc Ratio

For each transcript: # Increased probed pairs / # probe Pairs Used

Dec Ratio

For each transcript: # Decreased Probe pairs / # probe Pairs Used

Pos Change

Positive probe pairsexp - # Positive probe pairsbaseline

Neg Change

Negative probe pairsexp - # Negative probe pairsbaseline

Inc/Dec

For each transcript: the # increased probe pairs / # decreased probe pairs
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DPos-DNeg Ratio

(Positive Change – Negative Change)/# probe Pairs Used

The DPos – DNeg Ratio and Log Avg Ratio Change are usually positive 
when a transcript changes from a very low to a relatively high expression 
level and are typically negative when the expression level changes from a 
high to a very low or undetectable level. Both metrics may have values close 
to zero if the transcript is present in both the baseline and experimental 
samples despite an increase or decrease in the level of the transcript.

Log Avg Ratio Change

Log Avgexp – Log Avgbase

The difference between the Log Avg Ratio of the baseline and experimental 
probe array data (in a comparison analysis) for each transcript. The Log Avg 
Ratios are recomputed for each for each probe set based on probe pairs used 
in both the baseline and experimental probe arrays (the recomputed values 
are not displayed by the software).

Difference Call

Each transcript in a comparison analysis has five possible Difference Call 
outcomes: (1) Increase (I), (2) Marginally Increase (MI), or (3) Decrease 
(D), (4) Marginally Decrease (MD), and (5) No Change (NC). The 
difference call is derived from the comparison metrics: Max [Increase/Total, 
Decrease/Total], Increase/Decrease Ratio, Log Average Ratio Change, and 
Dpos – Dneg Ratio. Each comparison metric is weighted and entered into a 
decision matrix to determine the status of the transcript.

Avg Diff Change

The Avg Diff values are recomputed for each probe set based on probe pairs 
used in both the baseline and experimental probe arrays (the recomputed 
values are not displayed by the software).

Avg Diff Change = Avg Diffexp – Avg Diffbaseline 

B=A

An asterisk (*) in this column indicates the transcript is called absent (A) in 
the baseline.
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Fold Change

The Fold Change indicates the relative change in the expression levels 
between the experiment and baseline targets. The Fold Change for a 
transcript is a positive number when the expression level in the experiment 
increases compared to the baseline and is a negative number when the 
expression level in the experiment declines. The Fold Change (FC) is 
calculated as:

The normalized or scaled Avg Diff values are recomputed in both the 
experimental and baseline data sets to include only probe pairs used in both 
the baseline and experiment arrays. Then the Avg Diff Change is calculated 
as:

Avg Diff Change = Avg Diffexp - Avg Diffbase

QC = max(Qexp, Qbase)

QM = 2.1 for a 50µm feature or 2.8 for a 24µm feature

If the noise (Q) of the experiment or baseline array is greater than the Avg 
Diff of the transcript (the baseline or experimental data), the Fold Change is 
calculated over the noise and is an approximation [a tilde character (~) 
precedes the approximated Fold Change value in the *.chp file]. 

Sort Score

The Sort Score is a ranking based on the Fold Change and the Avg Diff 
Change. The higher the Fold Change and the Avg Diff Change, the higher 
the Sort Score.

FC AvgDiffChange( )
max min AvgDiffbase  AvgDiffexp( , )  QM QC×,[ ]
-----------------------------------------------------------------------------------------------------------------------------⎝ ⎠

⎛ ⎞
+1  if  AvgDiffexp  AvgDiffbase≥( )

-1  if  AvgDiffexp  AvgDiffbase<( )⎩ ⎭
⎨ ⎬
⎧ ⎫

+=
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Expression Analysis 
Settings

The expression analysis settings are user-modifiable variables with defaults 
empirically determined by Affymetrix. They are organized by the tabs of the 
Expression Analysis Settings dialog box: 

■ Scaling
■ Normalization
■ Probe Mask
■ Baseline
■ Parameters

The Expression algorithm relies on these settings to derive biologically 
meaningful results from the hybridization intensity data.

Viewing Expression Analysis Settings

1. Click Analysis Settings in the shortcut bar, then click Expression . 
Alternatively, select Tools → Analysis Settings → Expression from the 
menu bar.

⇒ The Expression Analysis Settings dialog box appears (Figure E.5).

Figure E.5 
Expression Analysis Settings, Scaling tab, User Defined scaling option selected



  Affymetrix®  GeneChip®  Operating Software User’s Guide 533
2. Make a selection from the Probe Array Type drop-down list. 

The settings are specific for the selected probe array type and do not 
affect the settings for other types of probe arrays.

3. Click a tab to view the different types of expression analysis settings for 
the selected probe array type.

Scaling Tab

Scaling is a mathematical technique applied to the data from several 
different probe arrays (of the same type) to minimize discrepancies due to 
variables such as sample preparation, hybridization conditions, staining, or 
probe array lot. The Scale Factor is also applied to the noise value.

GCOS offers three types of scaling: User Defined, All Probe Sets, and 
Selected Probe Sets.

To view the scaling settings:

■ Click the Scaling tab in the Expression Analysis Settings dialog box 
(Figure E.5).

■ Make a selection from the Probe Array Type drop-down list.

User Defined Scaling 

The User Defined scaling option multiplies the signal of each probe set on 
the array by a user-specified scale factor. 
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1. In the Scaling tab, choose the User Defined option (Figure E.6).
 

2. Enter a number in the Scale Factor box.

3. Click OK to close the Expression Analysis Settings dialog box. 

Figure E.6 
Expression Analysis Settings, Scaling tab, User Defined scaling option with no scaling specified 
(scale factor = 1)

A scale factor of one is equivalent to no scaling.
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All Probe Sets Scaling

The All Probe Sets scaling option adjusts the trimmed mean signal of a 
probe array to a user-specified target signal value. 

The single-array analysis results (*.chp) from different experiments (probe 
arrays of the same type) that are scaled to the same target signal using the 
All Probe Sets scaling option may be directly compared.

1. In the Scaling tab, choose the All Probe Sets scaling option (Figure E.7).

2. Enter a target signal value. 

3. Click OK to close the Expression Analysis Settings dialog box. 

GCOS examines all of the probe sets on the array to compute the 
trimmed mean signal and derive a scale factor for the array so that:

Target Signal = Scale Factor x Trimmed Mean Signalprobe array 

The scale factor standardizes the trimmed mean signal of the array to the 
target signal (Figure E.8). 

Figure E.7 
Expression Analysis Settings, Scaling tab, All Probe Sets scaling option selected
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Selected Probe Sets Scaling

The Selected Probe Sets scaling option adjusts the trimmed mean signal of 
selected probe sets on a probe array to a user-specified target signal value. 

You can directly compare the single-array analysis results (*.chp) of 
different experiments (probe arrays of the same type) if the same probe sets 
have been scaled to the same target signal in each experiment using the 
Selected Probe Sets scaling option.

For this scaling option, GCOS utilizes user-selected probe sets (specified by 
a Scale Factor mask file) to calculate the trimmed mean signal and derive the 
scale factor for the probe array so that:

Target Signal = Scale Factor x Trimmed Mean Signalselected probe sets

The scale factor standardizes the trimmed mean signal of an array to the 
target signal (Figure E.8). Selected Probe Sets scaling does not change the 
single-array call because the software also multiplies the intensity of each 
probe set and the probe array noise by the scale factor. 

Figure E.8 
Scale factors (SF) standardize the average signal of each experiment to a user-specified target 
signal
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Creating a Scale Factor Mask File

1. In the Scaling tab, choose the Selected Probe Sets option (Figure E.9).

2. Enter a Target Signal value, then click Create/Open Probe Set Mask.

⇒ The Probe Set Mask File dialog box displays existing mask files 
(Figure E.10).

Figure E.9 
Expression Analysis Settings, Scaling tab, Selected Probe Sets scaling option

Mask files (*.msk) include Scale Factor, Normalization, and Probe mask 
files. Each type of mask file has a different function and is created in a 
separate tab of the Expression Analysis Settings dialog box.
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3. Enter a name for the scale factor mask file in the File name box, then 
click Open.

⇒ The Probe Set Mask Definition dialog box appears (Figure E.11).

4. To select probe sets for the mask file:

a. Highlight the desired probe set names in the Exclude list.

b. Click Include.

⇒ This adds the selected probe set names to the Include list for the 
scale factor mask file. 

5. To remove a probe set name(s) from the Include list:

Figure E.10 
Probe Set Mask Definition dialog box

Figure E.11 
Probe Set Mask Definition dialog box
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a. Highlight the name(s) in the Include list.

b. Click Exclude.

Include All automatically moves all of the probe set names from the 
Exclude list to the Include list. 

Exclude All automatically Moves all of the probe set names from the 
Include list to the Exclude list. 

6. Click OK when finished to create the scale factor mask file and close 
the Probe Set Mask Definition dialog box.

Selecting a Scale Factor Mask File

1. In the Scaling tab, choose the Selected Probe Sets option (Figure E.12). 

2. Click Browse (Figure E.12).

⇒ The Probe Set Mask File dialog box appears (Figure E.13).

Figure E.12 
Expression Analysis Settings, Scaling tab, Selected Probe Sets option
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3. Double-click the desired *.msk file.

⇒ The Expression Analysis Settings dialog box displays the currently 
selected *.msk file name in the Scale Factor Mask File box 
(Figure E.14).

Figure E.13 
Probe Set Mask File dialog box

Mask files (*.msk) are specific for the probe array type. GCOS will not 
open a mask file that is incompatible with the currently selected probe 
array type.

Figure E.14 
Expression Analysis Settings, Scaling tab, scale factor mask file selected
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Editing a Scale Factor Mask File

1. In the Scaling tab, choose the Selected Probe Sets option (Figure E.15).
 

2. Click Create/Open Probe Set Mask.

⇒ The Probe Set Mask File dialog box appears (Figure E.16).

Figure E.15 
Expression Analysis Settings, Scaling tab, Selected Probe Sets option

Figure E.16 
Probe Set Mask File dialog box
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3. Double-click the desired *.msk file.

⇒ The Probe Set Mask Definition dialog box appears (Figure E.17). 

The Include list displays the probe sets included in the scale factor 
mask file. The Exclude list displays probe sets not included in the scale 
factor mask file.

4. To remove a probe set(s) from the *.msk file:

a. Highlight the probe set name(s) in the Include list.

b. Click Exclude. 

5. To add a probe set(s) to the *.msk file, highlight the probe set name(s) in 
the Exclude list, then click Include. 

Include All automatically moves all of the probe set names from the 
Exclude list to the Include list. 

Exclude All automatically moves all of the probe set names from the 
Include list to the Exclude list. 

6. Click OK when finished to close the Probe Set Mask Definition dialog 
box. 

Figure E.17 
Probe Set Mask Definition dialog box
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Normalization Tab

Normalization is a mathematical technique similar to scaling that enables 
comparison analysis of an experiment and baseline array.

GCOS offers three types of normalization: User Defined, All Probe Sets, or 
Selected Probe Sets normalization. All Probe Sets or Selected Probe Sets 
normalization minimizes discrepancies between an experiment and baseline 
array due to variables such as sample preparation, hybridization conditions, 
staining, or probe array lot. 

User Defined Normalization 

User Defined normalization multiplies the signal of each probe set on an 
array by a user-specified normalization value. 

1. In the Normalization tab, choose the User Defined option (Figure E.18).

Figure E.18 
Expression Analysis Settings, Normalization tab, User Defined normalization option with no 
normalization specified (Normalization Value = 1)
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2. Enter a value in the Normalization Value box.

3. Click OK to close the Expression Analysis Settings dialog box.

All Probe Sets Normalization

All Probe Sets normalization adjusts or normalizes the trimmed mean signal 
of the experiment to the trimmed mean signal of the baseline (Figure E.19).

A normalization factor of one is equivalent to no normalization.

Figure E.19 
Normalization Value normalizes the average signal of the experiment to the average signal of 
the baseline
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1. In the Normalization tab, choose the All Probe Sets normalization 
option (Figure E.20).

2. Click OK to close the Expression Analysis Settings dialog box.

The software examines all probe sets on the experiment or baseline 
array to compute a trimmed mean signal for the experiment and a 
trimmed mean signal for the baseline. 

It computes a normalization value so that:

Trimmed Mean Signalbaseline = (Normalization Value) x (Trimmed Mean 
Signalexperiment)

Selected Probe Sets Normalization

Selected Probe Sets normalization adjusts or normalizes the trimmed mean 
signal of the experiment to the trimmed mean signal of the baseline 
(Figure E.19). 

For this normalization option, GCOS utilizes user-selected probe sets 
(specified by a normalization mask file) to compute the trimmed mean signal 
of the experiment and baseline, and derive a normalization value so that:

Trimmed Mean Signalbaseline selected probe sets = Normalization Value x Trimmed 
Mean Signalexperiment selected probe sets

Figure E.20 
Expression Analysis Settings, Normalization tab, All Probe Sets normalization option
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Creating a Normalization Mask File

1. In the Normalization tab, choose the Selected Probe Sets option 
(Figure E.21).

 

2. Click Create/Open Probe Set Mask.

⇒ The Probe Set Mask File dialog box appears (Figure E.22).
 

Figure E.21 
Expression Analysis Settings, Normalization tab, Selected Probe Sets option

Figure E.22 
Probe Set Mask File dialog box
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3. Enter a name for the new normalization mask file in the File name box 
and click Open.

⇒ The Probe Set Mask Definition dialog box appears (Figure E.23).

4. Highlight the desired probe set names in the Exclude list. Click Include 
to add them to the Include list for the new *.msk file. 

5. To remove a probe set name(s) from the Include list, highlight the 
name(s) in the Include list, then click Exclude. 

Include All automatically moves all of the probe set names from the 
Exclude list to the Include list. 

Exclude All automatically moves all of the probe set names from the 
Include list to the Exclude list. 

6. Click OK when finished to create the normalization mask file and close 
the Probe Set Mask Definition dialog box.

Selecting a Normalization Mask File

1. In the Normalization tab, click Browse (Figure E.24).

⇒ The Probe Set Mask File dialog box appears (Figure E.25).

The mask files (*.msk) include Scale Factor, Normalization, or Probe 
mask files. Each type of mask file has a different function and is created 
in a separate tab of the Expression Analysis Settings dialog box.

Figure E.23 
Probe Set Mask Definition dialog box
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Figure E.24 
Expression Analysis Settings, Normalization tab, Selected Probe Sets option

Figure E.25 
Probe Set Mask File dialog box

Mask files are specific for the probe array type. GCOS will not open a 
mask file that is incompatible with the currently selected probe array 
type.
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2. Double-click the desired *.msk file. 

⇒ The Probe Set Mask File dialog box closes and the Expression 
Analysis Settings dialog box displays the selected *.msk in the 
Normalization Mask File box (Figure E.26).

Figure E.26 
Expression Analysis Settings, Normalization tab, normalization mask file selected
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Editing a Normalization Mask File

1. In the Normalization tab, choose the Selected Probe Sets option 
(Figure E.27).

 

2. Click Create/Open Probe Set Mask (Figure E.27).

⇒ The Probe Set Mask File dialog box appears (Figure E.28).
 

Figure E.27 
Expression Analysis Settings, Normalization tab, Selected Probe Sets option

Figure E.28 
Probe Set Mask File dialog box
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3. Double-click the desired *.msk file.

⇒ The Probe Set Mask Definition dialog box appears (Figure E.29). 

The Include list displays the probe sets included in the *.msk file. The 
Exclude list displays the probe sets not included in the *.msk file.

4. To remove a probe set(s) from the *.msk file:

a. Highlight the probe set name(s) in the Include list.

b. Click Exclude. 

5. To add a probe set(s) to the *.msk file:

a. Highlight the probe set name(s) in the Exclude list

b. Click Include. 

Include All automatically moves all of the probe set names from the 
Exclude list to the Include list. 

Exclude All automatically moves all of the probe set names from the 
Include list to the Exclude list. 

6. Click OK when finished to close the Probe Set Mask Definition dialog 
box.

Figure E.29 
Probe Set Mask Definition dialog box
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Probe Mask Tab

User-selected probe pairs may be excluded or masked from an expression 
analysis. In the Probe Mask tab (Figure E.30), you can create a probe mask file 
that specifies the probe pairs to exclude from an analysis. 

GCOS also offers advanced features that automatically generate three types 
of probe masks: cross hybridization, hybridization, or spike mask. See 
Appendix G, Cross Hybridization, Hybridization, & Spike Probe Masks, on 
page 573 for more information about probe masks.

Figure E.30 
Expression Analysis Settings, Probe Mask tab
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Creating a Probe Mask 

1. In the Probe Mask tab, click Create/Open Probe Mask (Figure E.30).

⇒ The Probe Mask File dialog box appears (Figure E.31).
 

2. Enter a name for the new probe mask file in the File name box and click 
Open.

⇒ The Probe Mask Definition dialog box appears (Figure E.32) and 
displays the probe array type and the probe mask name.

 

Figure E.31 
Probe Mask File dialog box

The *.msk files include Scale Factor, Normalization, or Probe mask files. 
Each type of mask file has a different function and is created in a 
separate tab of the Expression Analysis Settings dialog box.

Figure E.32 
Probe Mask Definition dialog box
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3. Select the desired probe set name from the Probe Sets drop-down list 
and enter the desired probe pair numbers in the Probe Pairs field 
(following the example format: 1-4,7,15,19). 

These probe pairs will be omitted from the analysis.

4. Click the box below the Probe Sets drop-down list to add the probe 
pairs to the probe mask (Figure E.33).

 

5. Repeat step 3 and step 4 to specify additional probe pairs for the probe 
mask.

6. Click OK when finished adding probe pairs to the probe mask.

Figure E.33 
Probe pairs selected for the probe mask file
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Selecting a Probe Mask

1. In the Probe Mask tab, choose the Use Probe Mask File option 
(Figure E.34).

2. Click Browse.

⇒ The Probe Mask File dialog box appears (Figure E.35).
 

Figure E.34 
Expression Analysis Settings, Probe Mask tab

Figure E.35 
Probe Mask File dialog box
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3. Double-click the desired probe mask.

⇒ The Probe Mask tab displays the selected probe mask (Figure E.36).

Mask files are specific for the probe array type. GCOS will not open a 
mask file that is incompatible with the currently selected probe array 
type.

Figure E.36 
Expression Analysis Settings, Probe Mask tab
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Editing a Probe Mask 

1. In the Probe Mask tab, click Create/Open Probe Mask (Figure E.37).

⇒ The Probe Mask File dialog box appears (Figure E.38).
 

Figure E.37 
Expression Analysis Settings

Figure E.38 
Probe Mask File dialog box
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2. Click the desired probe mask file and click OK (or double-click the file 
name).

⇒ The Probe Mask Definition dialog box displays the probe pairs in 
the selected probe mask (Figure E.39).

3. Click the probe set/probe pair entry you wish to edit.

⇒ The Probe Sets and Probe Pairs box automatically display the 
selection (Figure E.40).

Figure E.39 
Probe Mask Definition dialog box
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4. Edit or delete the entry in the Probe Pairs field, then click the lower field 
to update the list of probe pairs (Figure E.40). 

5. Click OK when finished to close the Probe Mask Definition dialog box.

Figure E.40 
Edit entries in the Probe Pairs box and click the lower box (left) to update the probe pair list (right)



APPENDIX E   Expression Algorithm, Expression Analysis Metrics & Settings560
Baseline Tab

In the baseline tab, the user selects the analysis output file (*.chp) that will 
serve as the baseline in a comparison expression analysis (Figure E.41).

1. In the Baseline tab, choose the Use Baseline Comparison Data option 
(Figure E.41).

 

2. Click Browse.

⇒ The Baseline Comparison File dialog box appears (Figure E.42).
 

Do not choose the Use Baseline Comparison Data option for an 
single-array analysis.

Figure E.41 
Expression Analysis Settings, Baseline tab

The baseline file must be derived from the same type of probe array 
selected in the Probe Array Type drop-down list in the Expression 
Analysis Settings dialog box (Figure E.41).
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3. Double-click the baseline *.chp and click Open.

The Baseline tab displays the selected baseline file for comparison 
analyses (Figure E.43).

Figure E.42 
Baseline Comparison File dialog box

Figure E.43 
Expression Analysis Settings, Baseline tab
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Parameters Tab

The Parameters tab displays user-modifiable Statistical Expression 
algorithm parameters (Figure E.44). Table E.3 describes the parameters.

 

The parameter default values were determined through extensive empirical 
testing at Affymetrix. Changing a parameter value affects the:

■ algorithm output (see Appendix , Expression Analysis Metrics, on 
page 524 for more information about the Statistical and Empirical 
Expression algorithm outputs) 

■ assay sensitivity (ability to make true Detection or Change calls)
■ assay specificity (ability to minimize false Detection or Change calls)

Versions of Microarray Suite lower than 5.0 run the Empirical 
Expression algorithm. (See Expression Analysis Metrics, on page 524 for 
more information about the Empirical Expression algorithm.)

Figure E.44 
Expression Analysis Settings, Parameters tab
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Table E.3 
User-modifiable Statistical Expression algorithm parameters

Parameter Description Effect of Changing Parameter

Alpha1 (α1)

The p-value threshold that defines Present and 
Marginal Detection calls.
If: p < α1 the call is Present
α1 < p < α2 the call is Marginal

Decreasing α1 may reduce the number of 
false Present calls (increases specificity) and 
the number of true Present calls (decreases 
sensitivity).

Alpha2 (α2)

The p-value threshold that defines Marginal and 
Absent Detection calls.
If:  α1 < p < α2 the call is Marginal
p > α2 the call is Absent

Increasing α2 may reduce the number of false 
Absent calls (increases sensitivity) and the 
number of true Absent calls (decreases 
specificity).

Tau (τ )

Threshold for the probe set discrimination 
score. If the discrimination score < τ , the 
difference between the PM and MM cells in 
the probe set is considered insignificant. The 
algorithm does not make a call for the probe 
set.

Increasing τ  may reduce the number of false 
Present calls (increases specificity) and the 
number of true Present calls (decreases 
sensitivity).

Gamma1L (γ 1L)
The lower limit of γ 1 which is the p-value 
threshold that defines Increase and Marginal 
Increase Change calls.

Decreasing γ 1L and γ 1H decreases γ 1. 
Decreasing γ 1 may reduce the number of 
false Increase and Decrease calls (increases 
specificity) and may also reduce the number 
of true Increase and Decrease calls 
(decreases sensitivity).

Gamma1H 
(γ 1H)

The upper limit of γ 1 which is the p-value 
threshold that defines Increase and Marginal 
Increase Change calls.

Gamma2L (γ 2L)
The lower limit of γ 2 which is the p-value 
threshold that defines Marginal Increase and 
No Change calls.

Increasing γ 2L and γ 2H increases γ 2. 
Increasing γ 2 may reduce the number of false 
No Change calls (increases specificity) and 
may also reduce the number of true No 
Change calls (decreases sensitivity).Gamma2H 

(γ 2H)
The upper limit of γ 2 which is the p-value 
threshold that defines marginal, No Change and 
Change calls.

Perturbation (d)
Determines the spread between the three 
normalization factors the algorithm computes 
for an experiment and baseline in a comparison 
analysis.

Increasing d may increase the number of true 
No Change calls (increases sensitivity) and 
may also increase the number of false No 
Change calls (decreases specificity).



APPENDIX E   Expression Algorithm, Expression Analysis Metrics & Settings564
Changing a Parameter Value

1. In the Parameters tab and make a selection from the Probe Array Type 
drop-down list.

2.  Click the parameter you wish to change.

⇒ The parameter box displays the current value (Figure E.45).

3. Enter a new value for the parameter in the parameter box.

4. Click OK to close the Expression Analysis Settings dialog box.

Figure E.45 
Expression Analysis Settings, Parameters tab
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Appendix F



GCOS Data Types F

Probe Information (Library) 
Data 

The probe information or library data includes the probe array design 
characteristics, probe utilization and content, and scanning and analysis 
parameters. Library data are unique to each probe array type. Library data 
includes user-defined mask files (see Table F.1). The default path for the 
library directory is <servername>:\GeneChip\Affy_Data\Library. 

Table F.1 
User-defined mask files

Mask File Name File 
Extension Description

Probe Mask .msk A user-specified list of probe pairs that are excluded 
from an analysis.

Cross Hybridization 
Probe Mask

.msk A type of probe mask that specifies probe pairs that 
include a PM or MM probe cell whose intensity 
exceeds a user-specified limit. These probe pairs 
will be excluded from the analysis.

Hybridization Probe Mask .msk A type of probe mask that specifies probe pairs 
where PM – MM < Difference Threshold or PM/MM 
< Ratio Threshold. These probe pairs will be 
excluded from the analysis.

Spike Probe Mask .msk A type of probe mask that specifies probe pairs 
where: 
(PM – MM)spike – (PM – MM)unspike < Difference 
Threshold or (PM-MM)spike/(PM – MM)unspike < 1 + 
Ratio Threshold. These probe pairs will be excluded 
from the analysis.
567
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Fluidics Protocol Data 

The fluidics protocol data include the instrument control instructions used by 
the GeneChip® fluidics station. Fluidics protocols are written to a directory 
that is specified during GCOS installation. The default path for the fluidics 
protocols is <servername>:\GeneChip\Affy_Data\Protocol. 

Experiment Data

During experiment setup, you enter information to register the sample and 
define the experiment. The software generates the other experiment data 
(image, cell intensities, probe analysis data) as the analysis proceeds. 
Experiment data are written to a directory that is specified during GCOS 
installation. The default path for experiment data is 
<servername>:\GeneChip\Affy_Data\Data\. 

GCOS stores the experiment data in the process database, a relational 
database that maintains associations between experiments, samples, and the 
experiment data generated during analysis. Table F.2 explains the different 
types of experiment data in the process database. 
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Table F.2 
Experiment data files

Experiment 
Data Name Data Description

Experiment Information about the experiment name, sample, and probe array type. 
The experiment name also provides the default name for subsequent 
data that are generated during experiment analysis.

Image Data Image of the scanned probe array (.dat file) and information about the 
experiment & sample that the image pertains to.

Cell Intensities Single intensity value for each probe cell delineated by the grid (.cel file 
calculated by the Cell Analysis algorithm) and information about the: 1) 
image that the cell intensities were derived from, and 2) experiment and 
sample that the image pertains to.

Probe Analysis 
(chip data)

Output generated from the analysis of a probe array (.chp file) and 
information about the: 1) cell intensities for the analysis, 2) image that 
the cell intensities were derived from, and 3) experiment and sample 
that the image pertains to.

Report Report generated from the analysis output file (.chp) and information 
about the: 1) analysis output file (.chp) the report was derived from, 2) 
cell intensities for the analysis, 3) image that the cell intensities were 
derived from, and 4) experiment and sample that the image pertains to

Data A standard format for text files. GCOS exports text in this file format.

A standard format for Excel files. GCOS export text in this file format.
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Appendix G



Cross Hybridization, Hybridization, & 
Spike Probe Masks G

 A probe mask specifies probe pairs that are to be excluded from an 
expression analysis. There are three types of probe masks:

■ Cross hybridization probe mask specifies probe pairs that include a 
perfect match (PM) or mismatch (MM) probe cell intensity greater than a 
user-specified limit.

■ Hybridization probe mask includes probe pairs that meet either of the 
following criteria:

PM – MM < Difference Threshold

or

PM/MM < Ratio Threshold

■ Spike probe mask includes probe pairs that meet either of the following 
criteria:

(PM – MM)spike – (PM – MM)unspike < Difference Threshold, 

or

(PM – MM)spike /(PM – MM)unspike < 1 + Ratio Threshold
573



APPENDIX G   Cross Hybridization, Hybridization, & Spike Probe Masks574
Viewing the Probe Mask 
Tab

You can create, view, or edit probe masks in the Probe Mask tab of the 
Expression Analysis Settings dialog box. 

To view the probe mask tab:

1. Click Analysis Settings in the shortcut bar, then click Expression . 
Alternatively, select Tools → Analysis Settings → Expression from the 
menu bar.

⇒ The Expression Analysis Settings dialog box appears (Figure G.1).

2. Click the Probe Mask tab.

3. Make a selection from the Probe Array Type drop-down list. 

The settings are specific for the selected probe array type and do not 
affect the settings for other types of probe arrays.

Figure G.1 
Expression Analysis Settings, Scaling tab, User Defined scaling option selected
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Cross Hybridization Probe 
Mask 

GCOS analyzes one or more user-specified .cel files to generate a cross 
hybridization probe mask. The cross hybridization probe mask specifies 
probe pairs that have a perfect match (PM) or mismatch (MM) probe cell 
with an intensity that exceeds a user-specified limit. 

A series of .cel files may be analyzed and the results from each analysis may 
be combined in an And (intersection) or Or (union) fashion to create a 
composite cross hybridization probe mask. The probe pairs specified by the 
cross hybridization probe mask are excluded or masked from an expression 
analysis.

Creating a Cross Hybridization Probe Mask

1. In the shortcut bar, click Analysis Settings, then click Expression . 

Alternatively, select Tools → Analysis Settings → Expression from the 
menu bar.

⇒ The Expression Analysis Settings dialog box appears (Figure G.2).

Figure G.2 
Expression Analysis Settings, Probe Mask tab
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2. Click the Probe Mask tab

3. Click Create/Open Probe Mask.

⇒ The Probe Mask File dialog box appears (Figure G.3).

4. Enter a name for the new mask in the File Name box and click Open.

⇒ The Probe Mask Definition dialog box appears (Figure G.4).

Figure G.3 
Probe Mask File dialog box

Figure G.4 
Probe Mask Definition dialog box
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5. Click Cross Hyb.

⇒ The Cross Hybridization dialog box appears (Figure G.5).
 

6. Enter a new upper intensity limit (if necessary).

7. Click Add File.

⇒ This displays the Open dialog box (Figure G.6).

8. Double-click a .cel file in the Open dialog box.

⇒ This adds the selected .cel to the Cross Hybridization dialog box 
(Figure G.7).

Figure G.5 
Cross Hybridization dialog box

Figure G.6 
Open dialog box displays .cel files available for the cross hybridization probe mask
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9. Repeat step 7 and step 8 until all desired .cel files have been added to the 
Cross Hybridization dialog box. 

GCOS identifies the probe pairs in each .cel file that include a PM or 
MM probe cell with an intensity greater than the user-specified Upper 
Intensity Limit (the default is 1000). 

The results from each .cel file may be combined in an And (intersection) 
or Or (union) fashion to create the cross hybridization probe mask. 

10. Double-click the second (and any subsequent) .cel file name to toggle 
between the And and Or option (Figure G.8).

 

Figure G.7 
Cross Hybridization dialog box displays .cel files selected for the cross hybridization probe 
mask

Figure G.8 
And combined .cel files (left), Or combined .cel files (right)
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11. Click OK to generate the cross hybridization probe mask. 

⇒ The Probe Mask Definition dialog box displays a list of the probe 
pairs in the cross hybridization probe mask (Figure G.9).

12. Click OK to close the Probe Mask Definition dialog box.

Figure G.9 
Probe pairs in the Cross Hybridization Probe mask
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Editing a Cross Hybridization Probe Mask

1. In the Probe Mask tab, click Create/Open Probe Mask (Figure G.10).

⇒ The Probe Mask File dialog box appears (Figure G.11).
 

Figure G.10 
Expression Analysis Settings dialog box, Probe Mask tab

Figure G.11 
Probe Mask File dialog box
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2. Double-click the cross hybridization probe mask file (.msk) you wish to 
edit (Figure G.11).

⇒ The Probe Mask Definition dialog box displays the probe pairs in 
the currently selected probe mask (Figure G.12).

 

3. In the lower box, click the Probe Set/Probe Pair entry you wish to edit.

⇒ The Probe Sets box and Probe Pairs box automatically display the 
selection (Figure G.13).

Figure G.12 
Probe Mask Definition dialog box
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4. Edit or delete the entry in the Probe Pairs field. 

5. Click the lower field to update the list of probe pairs (Figure G.13). 

6. Click OK when finished to close the Probe Mask Definition dialog box.

Combining Cross Hybridization Probe Masks

A cross hybridization mask may be combined with (And or Or fashion) or 
overwrite an existing cross hybridization mask. 

1. In the Probe Mask tab, click Create/Open Probe Mask (Figure G.14).

⇒ The Probe Mask File dialog box appears (Figure G.15).

Figure G.13 
Edit the Probe Pairs box and then click the lower box (left) to update the probe pair list (right)



  Affymetrix®  GeneChip®  Operating Software User’s Guide 583
 

2. In the Probe Mask File dialog box, double-click the cross hybridization 
probe mask you wish to combine with another cross hybridization probe 
mask(s) (Figure G.15).

⇒ The Probe Mask Definition dialog box appears (Figure G.16).

Figure G.14 
Expression Analysis Settings dialog box, Probe Mask tab

Figure G.15 
Probe Mask File dialog box
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3. Click Cross Hyb.

⇒ The Cross Hybridization dialog box appears (Figure G.17).

4. Enter a new Upper Intensity Limit if desired.

5. Click Add File.

⇒ This displays the Open dialog box (Figure G.18).

Figure G.16 
Probe Mask Definition dialog box

Figure G.17 
Cross Hybridization dialog box
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6. Double-click the .cel file you wish to combine with the cross 
hybridization mask selected in step 2.

⇒ The Cross Hybridization dialog box displays the selected .cel file 
(Figure G.19).

7. Click OK and repeat step 5 and step 6 to add additional .cel files to the 
Cross Hybridization dialog box.

8. Double-click the second (and any subsequent) .cel file name to toggle 
between And and Or (Figure G.19).

Figure G.18 
Open dialog box

Figure G.19 
Cross Hybridization dialog box
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9. Choose a Combine with previous results option (And, Or, or 
Overwrite), then click OK. 

GCOS analyzes the selected .cel files and identifies all probe pairs with 
a PM or MM probe cell that has an intensity greater than the 
user-specified Upper Intensity Limit. It combines the results from the 
.cel files (And or Or or Overwrite) to create a composite cross 
hybridization probe mask. 

This composite probe mask is combined with the probe mask selected in 
step 2 (for example, Hu6800X-hyb.MSK in Figure G.15) as specified in 
step 9 (And or Or fashion, or overwrites the selected cross hybridization 
probe mask).

Hybridization Probe Mask

GCOS analyzes one or more user-specified cell intensity files (.cel) to 
generate a hybridization probe mask comprised of probe pairs that meet 
either of the following criteria: 

PM – MM < Difference Threshold

or

PM/MM < Ratio Threshold

The Difference and Ratio Thresholds are user-modifiable with defaults of 30 
and 1.5 respectively. See Appendix E, Expression Algorithm, Expression 
Analysis Metrics & Settings, on page 515 for more information about the 
Difference Threshold and Ratio Threshold.

You can analyze a series of .cel files and combine the results from each 
analysis in an And (intersection) or Or (union) fashion to create a composite 
hybridization probe mask.
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Creating a Hybridization Probe Mask

1. In the Probe Mask tab, click Create/Open Probe Mask (Figure G.20).

⇒ The Probe Mask File dialog box appears (Figure G.21).

Figure G.20 
Expression Analysis Settings dialog box, Probe Mask tab

Figure G.21 
Probe Mask File dialog box
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2. Enter a name for the new hybridization probe mask in the File Name 
box, then click Open.

⇒ The Probe Mask Definition dialog box appears (Figure G.22).
 

3. Click Hyb.

⇒ The Hybridization Behavior dialog box appears (Figure G.23).

Figure G.22 
Probe Mask Definition dialog box

Figure G.23 
Hybridization Behavior dialog box
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4. Click Add File.

⇒ This displays the Open dialog box (Figure G.24).

5. Double-click the .cel file of interest.

⇒ This adds the selected .cel file to the Hybridization Behavior dialog 
box (Figure G.25).

6. If desired, click Add File again to select and add another .cel file to the 
Hybridization Behavior dialog box. Repeat step 4 and step 5 until all 
desired .cel files have been added. 

Figure G.24 
Open dialog box

Figure G.25 
Hybridization Behavior dialog box
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You can combine the results from the analysis of each .cel file in an And 
(intersection) or Or (union) fashion to create the hybridization probe 
mask.

7. Double-click the second (and each subsequent) .cel file name to toggle 
between the And and Or option (Figure G.26).

8. Click OK to generate the hybridization probe mask. 

⇒ The Probe Mask Definition dialog box displays the probe pairs of 
the Hybridization probe mask (Figure G.27).

Figure G.26 
And combined .cel files analysis results (left), Or combined .cel file analysis results (right)
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Editing a Hybridization Probe Mask

1. In the Probe Mask tab, click Create/Open Probe Mask (Figure G.28).

⇒ The Probe Mask File dialog box appears (Figure G.29).
 

Figure G.27 
Probe pairs in the hybridization probe mask

Figure G.28 
Expression Analysis Settings dialog box, Probe Mask tab
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2. Double-click the hybridization probe mask (.msk) of interest 
(Figure G.29).

⇒ The Probe Mask Definition dialog box displays the probe pairs in 
the selected hybridization probe mask (Figure G.30).

 

Figure G.29 
Probe Mask File dialog box

Figure G.30 
Probe Mask Definition dialog box
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3. In the lower box, click the desired Probe Set/Probe Pair entry you wish 
to edit.

⇒ The Probe Sets box and Probe Pairs box automatically display the 
selection (Figure G.31).

4. Edit or delete the entry in the Probe Pairs box, then click the lower box 
to update the list of probe pairs (Figure G.31). 

5. Click OK when finished to close the Probe Mask Definition dialog box.

Figure G.31 
Edit the entry in the Probe Pairs box (left) and click the lower box to update the probe pair list (right)
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Combining Hybridization Probe Masks

A hybridization probe mask may be combined with (And or Or fashion) or 
overwrite an existing hybridization probe mask. 

1. In the Probe Mask tab, click Create/Open Probe Mask (Figure G.32).

⇒ The Probe Mask File dialog box appears (Figure G.33).

Figure G.32 
Expression Analysis Settings dialog box, Probe Mask tab

Figure G.33 
Probe Mask File dialog box
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2. Double-click the hybridization probe mask (.msk) of interest.

⇒ The Probe Mask Definition dialog box appears (Figure G.34).
 

3. Click Hyb.

⇒ The Hybridization Behavior dialog box appears (Figure G.35). 

Figure G.34 
Probe Mask Definition dialog box

Figure G.35 
Hybridization Behavior dialog box
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4. Enter new Difference Threshold or Ratio Threshold values if desired.

5. Click Add File in the Hybridization Behavior dialog box.

⇒ This displays the Open dialog box (Figure G.36).

6. Double-click the .cel file you wish to combine with the hybridization 
mask selected in step 2.

⇒ The Hybridization Behavior dialog box displays the selected .cel 
file (Figure G.37).

7. Click OK. Repeat step 5 and step 6 to add additional .cel files to the 
Hybridization Behavior dialog box (Figure G.37).

Figure G.36 
Open dialog box

Figure G.37 
Hybridization Behavior dialog box
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8. Double-click the second (and any subsequent) .cel file name to combine 
the .cel files in an And and Or fashion.

9. Choose a Combine with previous results option (And, Or, or 
Overwrite), then click OK. 

GCOS analyzes the selected .cel files to identify the probe pairs where 
PM-MM < Difference Threshold or PM/MM < Ratio Threshold. The 
software combines the results from each .cel file in an And or Or fashion 
to create a new composite Hybridization probe mask. 

This combines the composite hybridization mask with the mask selected 
in step 2 (for example, Hu6800Hyb.msk in Figure G.33) as specified in 
step 9 (And or Or fashion, or overwrites the selected hybridization 
mask). 

Spike Probe Mask

GCOS compares two .cel files, one derived from a spiked target that 
contained known amounts of a control transcript(s) and one derived from an 
unspiked target. 

The software identifies any probe pairs where: 

(PM – MM)spike – (PM – MM)unspike < Difference Threshold, 

or

(PM – MM)spike /(PM – MM)unspike < 1 + Ratio Threshold

and automatically generates a spike probe mask (.msk) comprised of all 
probe pairs that meet either of the above criteria. The Difference and Ratio 
Thresholds are user modifiable with defaults of 30 and 1 respectively.



APPENDIX G   Cross Hybridization, Hybridization, & Spike Probe Masks598
Creating a Spike Probe Mask

1. In the Probe Mask tab, click Create/Open Probe Mask (Figure G.38). 

⇒ The Probe Mask File dialog box appears (Figure G.39).

Figure G.38 
Expression Analysis Settings dialog box, Probe Mask tab

Figure G.39 
Probe Mask File dialog box
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2. Enter a name in the File Name box for the new spike probe mask, then 
click Open (Figure G.39).

⇒ The Probe Mask Definition dialog box appears (Figure G.40).

3. Click Spike.

⇒ The Spike Behavior dialog box appears (Figure G.41).
 

Figure G.40 
Probe Mask Definition dialog box

Figure G.41 
Spike Behavior dialog box
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4. To select a spiked .cel file, click Browse (upper button).

⇒ This displays the Open dialog box (Figure G.42).

5. Double-click the .cel file derived from the spiked target.

⇒ This adds the selected .cel to the Spiked Cell File box (Figure G.41).

6. To select an unspiked .cel, click Browse (lower button) in the Spike 
Behavior dialog box (Figure G.41).

⇒ This displays the Open dialog box (Figure G.42).

7. Double-click the .cel file derived from the unspiked target.

⇒ This adds the selected .cel to the Unspiked Cell File box 
(Figure G.41).

8. Click OK to generate the spike probe mask. 

⇒ The Probe Mask Definition dialog box displays the probe pairs of 
the spike probe mask (Figure G.43).

Figure G.42 
Open dialog box
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Editing a Spike Probe Mask

1. In the Probe Mask tab, click Create/Open Probe Mask (Figure G.44).

⇒ The Probe Mask File dialog box appears (Figure G.45).
 

Figure G.43 
Probe Mask Definition dialog box

Figure G.44 
Expression Analysis Settings, Probe Mask tab



APPENDIX G   Cross Hybridization, Hybridization, & Spike Probe Masks602
2. Double-click the spike probe mask you wish to edit (Figure G.45).

⇒ The Probe Mask Definition dialog box displays the probe pairs in 
the selected spike probe mask (Figure G.46).

 

3. In the lower box, click the probe set/probe pair entry you wish to edit.

⇒ The Probe Sets box and Probe Pairs box automatically display the 
selection (Figure G.47).

Figure G.45 
Probe Mask File dialog box

Figure G.46 
Probe Mask Definition dialog box
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4. Edit or delete the entry in the Probe Pairs box, then click the lower field 
to update the list of probe pairs (Figure G.47). 

5. Click OK when finished to close the Probe Mask Definition dialog box.

Combining Spike Probe Masks

A spike probe mask may be combined with (And or Or fashion) or overwrite 
an existing spike probe mask. 

1. In the Probe Mask tab, click Create/Open Probe Mask (Figure G.48).

⇒ The Probe Mask File dialog box appears (Figure G.49).

Figure G.47 
Edit the Probe Pairs box and click the lower box (left) to update the probe pair list (right)
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2. Double-click the spike probe mask of interest (Figure G.49).

⇒ The Probe Mask Definition dialog box displays the probe pairs in 
the selected spike probe mask (Figure G.50).

Figure G.48 
Expression Analysis Settings, Probe Mask tab

Figure G.49 
Probe Mask File dialog box
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3. Click Spike.

⇒ The Spike Behavior dialog box appears (Figure G.51).
 

4. To select a spiked .cel file, click Browse (upper button).

⇒ This displays the Open dialog box (Figure G.52).

Figure G.50 
Probe Mask Definition dialog box

Figure G.51 
Spike Behavior dialog box
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5. Double-click the .cel file derived from the spiked target.

⇒ This adds the selected .cel to the Spiked Cell File box (Figure G.51).

6. To select an unspiked .cel, click Browse (lower button) in the Spike 
Behavior dialog box (Figure G.51).

⇒ This displays the Open dialog box (Figure G.52).

7. Double-click the .cel file derived from the unspiked target.

⇒ This adds the selected .cel to the Unspiked Cell File box 
(Figure G.51).

8. Select a Combine with previous results option (And, Or, or Overwrite) 
and click OK.

GCOS analyzes the two selected .cel files and identifies all probe pairs 
that meet either of the following criteria:

(PM – MM)spike – (PM – MM)unspike < Difference Threshold

or

(PM – MM)spike /(PM – MM)unspike < 1 + Ratio Threshold

The software combines the results from the .cel files to create a new 
composite spike probe mask. This combines the composite spike probe 
mask with the spike probe mask selected in step 2 (for example, 
Hu6800Spike.MSK in Figure G.45) as specified in step 8 (And or Or 
fashion, or overwrites the selected spike probe mask).

Figure G.52 
Open dialog box
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Base Codes and Amino Acid AbbreviationsH

IUPAC Base Codes

Table H.1 
Base Codes

IUPAC Code Group Base(s)

A A Adenine

C C Cytosine

G G Guanine

T T Thymine

M A or C aMino

R A or G puRine

W A or T (U) Weak interaction (2 H 
bonds)

Y C or T (U) pYrimidine

S C or G Strong interaction (3 H 
bonds)

K G or T(U) Keto

V A or C or G not-T or not-U (since V 
follows U)

H A or C or T(U) not-G (since H follows G)

D A or G or T(U) not-C (since D follows C)

B C or G or T(U) not-A (since B follows A)

N A, C, G or T(U) aNy
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Amino Acid Abbreviations

Table H.2 
Amino acid abbreviations

One Letter Three Letter Amino Acid

A Ala Alanine

B Asx Asparagine or Aspartic 
acid

C Cys Cysteine

D Asp Aspartic acid

E Glu Glutamic acid

F Phe Phenylalanine 

G Gly Glycine

H Hi Histidine

I Ile Isoleucine

K Lys Lysine

L Leu Leucine

M Met Methionine

N Asn Asparagine

P Pro Proline

Q Gln Glutamine

R Arg Arginine

S Ser Serine

T Thr Threonine

V Val Valine

W Trp Tryptophan

Y Tyr Tyrosine

Z Glx Glutamine or Glutamic 
acid
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Toolbars, Hot Keys, & Windowpanes I

This appendix reviews toolbar button functions, hot keys, and explains 
how to resize windowpanes or columns.

Toolbars

You can display toolbars with text labels (Figure I.1). To display the toolbar 
button labels, select View → Toolbar → Text Labels from the menu bar.

GCOS Toolbars

Main Toolbar

Figure I.1 
Main toolbar

Table I.1 
Main toolbar

Menu Bar Command Toolbar 
Button Function

File → Open Displays the Open dialog box so that data (for example, probe analysis data 
or image data) may be opened.

File → Save Saves the open image, experiment, or report.

File → Print Displays the Print dialog box.
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Window → Data Tree Displays or hides the data tree.

Window → Shortcut Bar Displays or hides the shortcut bar.

Window → Status Log Displays or hides the status log.

Run → Experiment Info Displays experiment window.

Run → Fluidics Displays the Station Selection dialog box for the Affymetrix® Fluidics 
Station 400.

Run → Scanner Displays the Scanner dialog box.

Run → Stop Scanner Stops a scan in progress.

Run → Analysis Runs an analysis on the open *.dat or *.cel data.

Edit → Image Settings Displays the Image Settings dialog box.

Help → Contents Displays GCOS help.

Table I.1 
Main toolbar

Menu Bar Command Toolbar 
Button Function
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Expression Analysis Window (EAW) Toolbar

Figure I.2 
EAW toolbar

Table I.2 
EAW toolbar button functions

Menu Bar Command
EAW 
Toolbar 
Button

Function

Edit → Find Displays the Find Probe Set dialog box.

Edit → Sort Displays the Sort dialog box.

View → Hide Selected Hides selected probe set(s) in the metrics or pivot table.

View → Hide Unselected Hides unselected probe set(s) in the metrics or pivot table.

View → Unhide All Displays all probe sets previously hidden in the metrics or pivot table.

Analysis → Options Displays the Analysis Options dialog box.

Graph → Clear Selected 
Graphs

Clears selected graphs from the graph pane in the EAW.

Graph → Scatter Correlation 
Graph

Displays the Scatter Graph dialog box.

Graph → Series Graph Displays the Select Series Graph Parameter dialog box.

Graph → Intensity Bar Graph Plots the Intensity Bar Graph for the selected probe set(s).

Graph → Measured Images Displays the hybridization intensity image data (.dat) for the selected probe 
set(s).
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Batch Analysis Toolbar

Graph → Lasso Points Changes the cursor to a drawing tool that enables the user to draw a circle 
around points in a scatter graph.

Figure I.3 
Batch analysis toolbar

Table I.3 
Batch analysis toolbar button functions

Menu Bar Command
Batch Analysis 
Toolbar 
Button

Function

Edit → Add Item Displays the Open dialog box to select and add *.cel files to the Batch 
Analysis window.

Edit → Remove Item Removes the selected *.cel files from the Batch Analysis window.

Edit → Start Analysis Starts the batch analysis.

Edit → Stop Analysis Stops the batch analysis.

View → Options Displays the Batch Analysis Options dialog box.

Table I.2 
EAW toolbar button functions

Menu Bar Command
EAW 
Toolbar 
Button

Function
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Report Toolbar

Figure I.4 
Report window toolbar

Table I.4 
Report toolbar button functions

Menu Bar Command
Report
Toolbar 
Button

Function

Edit → Cut Removes a highlighted selection from the report.

Edit → Copy Copies a highlighted selection in the report to the system clipboard.

Edit → Paste Pastes a copied or cut selection at the current insertion point.

Edit → Find Displays the Find dialog box.

Edit → Find Next Performs a text search for the item specified in the Find dialog box.
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Publish Toolbar

Figure I.5 
Publish window toolbar

Table I.5 
Publish toolbar button functions

Menu Bar 
Command

Publish Window 
Toolbar Button Function

Publish → Add Item Displays the Open dialog box to select and add experiment data (task 
items) to the publish task.

Publish → Remove 
Item

Removes the selected task item(s) from the publish task.

Publish → Publish Send the task to the GCOS server to be published during the time 
specified by the GCOS Server administrator.

Publish → Monitor → 
Cancel Publish

Cancels a task (changes the task status from WAIT to CANCELED).

Publish → Monitor → 
Restart Publish

Reinstates a canceled task to be published during the time specified by 
the GCOS Server administrator (changes the task status from 
CANCELED to WAIT).
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GCOS Manager Toolbar

Figure I.6 
GCOS Manager toolbar

Table I.6 
GCOS Manager toolbar button functions

Menu Bar 
Command

GCOS Manager 
Toolbar Button Function

Process → Print 
Experiment

Prints experiment information.

Tools → Register 
GCOS Server

Opens the Register GCOS Server dialog box

Tools → Server 
Event Viewer

Opens the Server Event Viewer

Tools → Server 
Tasks

Displays the Task List for the active server.

Tools → File Path Displays the Select Export File Path dialog box

Tools → Find Opens the Find dialog box

Tools → Filter Opens the Sample Filters dialog box

Tools → Help Topics Opens GCOS Manager online help.
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GCOS Administrator Toolbar & Icons

Figure I.7 
GCOS Administrator toolbar

Table I.7 
GCOS Administrator toolbar button functions

Menu Bar 
Command

GCOS 
Administrator 
Toolbar Button

Function

 Opens the Administrator Password dialog box so that a system 
administrator password or publish database password can be created 
and updated.

Refreshes the data tree in the copy or space management view. 
Refresh the data tree to view new data or databases added to the 
system during the current session.

Tools → Register 
GCOS Server

Opens the Register GCOS Server box.

Tools → Server 
Tasks

Opens the Sample Filters dialog box.

Tools → Help Topics Opens GCOS Manager online help.
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Table I.8 
GCOS Administrator Icons

Process Database or LIMS 
System Database (yellow)

Project Sample 

Publish Database  
(gray)

Experiment Information Filter
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Hot Keys

Table I.9 
GCOS hot key descriptions

Menu Bar Command Hot Key

File → Open Ctrl + O

File → Print Ctrl + P

Edit → Copy Ctrl + C

File → Save Ctrl + S

Edit → Image Settings S

Edit → Delete Del

Edit → Find Next F3

Edit → Unmask All Cells Shift + U

View → Grid G

View → Probe Cell Data C

View → Corner → Upper Left F5

View → Corner → Upper Right F6

View → Corner → Lower Left F7

View → Corner → Lower Right F8

View → Image → Measured M

View → Image → Difference D

View → Image → Average A

View → Next Highlight N

View → Previous Highlight P

View → Clear Highlights E

View → Probe Tiling T
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1, 2, 3, etc.
(toggle between open image 
windows)

I
(Image window zoom in)

O
(Image window zoom out)

Shift+O
(Image window full zoom out)

L 
(intensity autoscale)

Edit → Mask Cells X

Edit → Unmask Cells U

Help F1

Scroll up one page Page Up

Scroll down one page Page Down

Scroll left one page Ctrl + Page Up

Scroll right one page Ctrl + Page Down

Scroll up 1/10 page Up arrow

Scroll down 1/10 page Down arrow

Scroll left 1/10 page Left arrow

Scroll right 1/10 page Right arrow

Table I.9 
GCOS hot key descriptions

Menu Bar Command Hot Key
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Working with 
Windowpanes & Columns

You can resize windowpanes. 

1. Place the mouse pointer over a windowpane border so that it changes to 

a double arrow  (Figure I.8).
 

Table I.10 
GCOS Manager hot key descriptions

Menu Bar Command Hot Key

View → Refresh F5

Figure I.8 
Resize windowpanes horizontally or vertically
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2. Drag the border to resize the windowpane.

Resizing or Hiding 
Columns in the EAW

You can resize or hide columns in the Expression Analysis window (EAW). 
GCOS stores the column settings for future sessions on a per user basis 
(identified by the logon name) so that one user’s settings do not affect the 
settings of another. 

1. Position the mouse over the left or right cell border in the column header 
so that it changes to a double arrow . 

2. Drag the cell border to resize the width of the column. 

3. To hide a column, drag the left or right cell border of the column header 
until the column width is reduced to zero. Alternatively, right-click the 
column header in the EAW and select Hide Column from the shortcut 
menu that appears.
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Appendix J



Database Management & Data Source 
Name Descriptions J

Performance Tuning for 
SQL Server  
Databases

Microsoft® SQL Server automatically tunes many of the server 
configuration options, therefore requiring little, if any, tuning by a 
database administrator. Although these configuration options can be 
modified by the database administrator, it is generally recommended 
that they are left at their default values, allowing SQL Server to 
automatically tune itself based on run-time conditions.

However, if necessary, the following components can be configured to 
optimize server performance:

■ SQL Server Memory
■ I/O subsystem 

■ Microsoft® Windows options

To improve performance of querying, it is recommended that the SQL 
Server database is in three devices: data, index and log. With this 
separation, reading and writing of data is improved which helps 
decrease amount of time it takes to query data.

Data Device

The data device stores the experimental data, published data, and other data 
associated with GCOS. These data are accessed by GCOS and all 
applications that work on GCOS. The name of this device is  
<publish database name>_DAT.mdf.
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To improve performance, the Data Device file should be placed on a 
dedicated physical disk.

Index Device

The Index Device is available for publish databases. The Index Device 
provides quick access to data and can enforce uniqueness on the rows in a 
table. With this device, it allows searches in a database program to find data 
in a table without scanning the entire table. This device is a list of values in a 
table with the storage locations of rows in the table that contain a value. The 
name of this device is  
<publish database name>_INDEX_mdf.

Basic Configuration

The index files can be located with the Data Device files, however, 
performance may be gained by placing the Index Device file on a different 
disk with low activity.

Advanced Configuration

Place the Index Device file on a dedicated physical disk. If a remote AADM 
server is used, place the Data Device file on a dedicated physical disk.

To move the locations of data devices from one disk to another, use the 
Space Manager tool in GCOS Administrator.

To move the locations of data devices from one disk to another, use the 
Space Manager tool in GCOS Administrator.
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Log Device

The Log Device holds the information used to recover the database. There 
must be at least one log file for each database.

Basic Configuration

The Log Device file can be placed where there is space.

Advanced Configuration

Place the Log Device file on a dedicated physical disk.

If a remote AADM server is used, place the Data Device file on a dedicated 
physical disk.

Additional Performance Tuning Information

These are other suggestions that can help improve the performance of your 
system.

■ Separate all devices SQL Server uses. For example, place the data 
device, index device, and log device each on their own individual physical 
disk. The separation of these files improves the performance by allowing 
the drive heads to perform read only or write only operations during the 
majority of the publishing operation.

■ Use a remote AADM server for publishing and place the data device, 
index device, and log device each on their own individual physical disk.

■ Placing both the index device and log device on the same disk can slow 
performance since there is a lot of read and write activity being 
performed.

To move the locations of log devices from one disk to another, use the 
Space Manager tool in GCOS Administrator.
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Client Tuning

As part of the software requirement for the client, it is recommended 
to install SQL*Loader on the client running Data Mining Tool if 
connecting to an Oracle® GCOS server. Also, a registry setting can be 
added on the client machine when preforming a large pivot.

SQL*Loader

If your GCOS server uses an Oracle® database, it is advisable to install 
SQL*Loader on the client workstation. Contact your Database 
Administrator to install SQL*Loader. SQL*Loader is included on the 
Oracle® installation CD.

SQL*Loader is used to bulk loading probe set lists and annotations that 
users save into the database. With SQL*Loader installed on the client, the 
process of saving large amounts of data at time is improved. Without 
SQL*Loader installed on the client, it may take a long time to save the 
information.

The same version of SQL*Loader must be installed on the workstation 
as on the GCOS server.
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Troubleshooting K

This section of the manual helps you troubleshoot problems that may 
be encountered during installation or administration of the server and 
the different software products on the clients.

This will also help you with some basic troubleshooting techniques 
and what information should be gathered to help Technical Support 
work towards providing a resolution to a potential problem that you 
are experiencing. 

Troubleshooting Questions

Some basic tests may quickly reveal the cause of the problems. It is 
important to isolate the problem down to a particular area. Some questions to 
answer before calling Technical Support for help:

Is it a client or a server problem?

If server, has anything changed? Addition of software? Addition of network 
functions? Restoring of databases?

Check the Event log.

Check the SQL Server log (if using a Microsoft® SQL Server database).

Which database is being accessed?

Is there enough free space available?

Can you reproduce the problem? What steps were taken?

What is the exact error message?

Does it happen with a particular user or all users?

What has changed on the client?
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Is the user logged onto the correct domain? Does the user have permissions 
to access GCOS Server?

Can you write to the publish database?

Can you access other databases?

Can you reproduce the problem? What steps were taken?

What is the exact error message?

GCOS 1.0 Troubleshooting

Installation

■ I am unable to install the software.
Verify that you have administrative privileges in order to install the 
software.

■ Error connecting to GCOS Server database.
Check the connectivity. Check the server is running.

■ When installing GCOS 1.0 the installation tries to copy files, 
however, the error message “cannot move error - 145” appears. 
What should I do?
Verify that all Affymetrix applications are closed and not running. Log in 
as another user and, again, try installing the application. It may be the 
user’s profile is corrupted.

■ The GCOS software shows the following dialog box when installing 
the software or MSDE fails to install.

Figure 16.22    
Stop message
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GCOS requires MSDE. In order to install MSDE, the "Server" service also 
known as the "lanmanmanger" service needs to be installed and running. 
GCOS will attempt to start the service if it has stopped.
To see if the "Server" service is installed, right-click "My Computer" and 
select "Manage". Navigate to the "Services and Applications" Node". 
Select Services and see if the Server service is installed.
To install the Server service the workstation must have a Network 
Interface Card (NIC) or a Microsoft loop-back adapter. Once the NIC has 
been installed, the "Server" service can be installed by adding the "File 
and Printer Sharing for Microsoft Networks" to the Local Area Connection 
properties. Refer to www.microsoft.com or contact your system 
administrator for details on installing the server service.

Installing Pre-GCOS Version Libraries (LIMS 3.0 Libraries) on the Client

In order to install LIMS 3.0 version libraries (pre-June 2003 libraries) on a 
GCOS client, you must complete the following four steps. 

1. Run ToggleLIMS3LibrarySupport.exe file by double-clicking the file. 
(The ToggleLIMS3LibrarySupport.exe file is located in the directory 
where GOCS was installed.) This enables the older library installer and 
temporarily disables GCOS.

2. Install the old version library.

3. Run the ToggleLIMS3LibrarySupport.exe file by double-clicking the 
file again. This enables GCOS and disables the old library installer. 
GCOS cannot be run until this step is completed.

4. Run the library migrate program (from the subdirectory 'Migrate' 
contained in the GCOS Target directory, or a new version library install 
CD).

Publishing

■ Unable to publish data. The server task window displays that it is in 
the queue and says “wait”.
Verify that the publishing service is active in the server task window of 
GCOS 1.0. If the service is stopped, contact the system administrator to 
start the gcdoservice.

■ GCOS shows “Publishing Stopped” when a publish window is launched.
Check if CGCDOService is started.
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■ Unable to publish the .chp file. The user is able to publish any .exp 
and .cel files, however, when publishing the .chp file, the error 
message “Failed to publish x.chp: SQL Command Failure.”
This is possibly due to a probe array type that has been installed and 
published. However, a new probe array with the same name containing 
new probe information was installed. The probe set names were 
changed and therefore do not match and that is why the .chp file with the 
new probe array information cannot be published.
Workaround: Delete the data that is published from that probe array type. 
Reanalyze that existing .chp files and publish again.

■ Unable to Publish to an Oracle® GCOS Server system and the 
Oracle® Publish database was created successfully. 
Check the registry setting: HKLM\Software\ODBC\ODBC.INI on the 
GCOS server.
Locate the Oracle ODBC DSN created <servername>_ORCL_GATC.

Verify the values: 

For the Publish database: <publish database name>_AffyPub:

Do the temporary files get created? *.ctl on the root of the c: drive for the 
Oracle database.
The temporary files on the c:\ drive for SQL Server are s*.* (short file 
names).
There must be enough free space to create these temporary files (at 
least 400MB).

■ “Failed to read <name of experiment> from GCOS Server for the 
.dat file” message appears when publishing.

Oracle® 8.1.7
String Value Name Value
HOST_OS WinNT4
HOST_SQLLOAD sqlldr

Note: String values are case-sensitive

String Value Name Value

PWD <encrypted password>

UID <publish database name>

Alias <name of the alias>

Note: The name of the alias created points to the GATC publish server
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There is no .dat file. The experiment needs to be scanned and is currently 
in the scan stage.

■ “Failed to read <name of experiment> from GCOS Server for Chip.” 
message appears when publishing.
There is no object file. The experiment is currently in the hybridization 
queue and needs to be hybridized and scanned.

■ Publish Task Queue should be purged from time to time. As the task 
queue grows, especially above 10,000 entries, GCOS will appear to hang 
temporarily when placing jobs in the publish queue. You may want to 
backup the text of this log prior to purging.

Licensing

■ Upon Launching GCOS 1.0, the license window appears. I enter the 
license, however the window keeps appearing.
Verify that when entering the license, the license number is entered 
exactly as seen. The license is case sensitive. Ensure that you do not 
enter any additional spaces.

Workflow

■ Failure in GetSampleBy name command error.
Verify that you did not enter any illegal characters used when creating a 
sample or experiment. Some illegal characters include: < >:;\”^|*/?

■ Cannot connect to Affymetrix GCOS Server.
Verify that the network is up. Also, verify that the server is online. On the 
client side, verify that the registry key values are correct.

■ Experiments don't show up in the data tree.
Verify your filter is not filtering out everything, especially the date range.

■ When trying to reanalyze an analysis after an upgrade in GCOS, the 
error message “Base call failed for 
\\<servername>\gcgcosserver\data\\<file.chp> - Invalid base call 
algorithm. Verify base call default settings for this Probe Array Type 
or verify Tools\Defaults\File locations settings” appears.
One indication of this error message is that the library file update on the 
server may not have updated properly. 
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GCOS Manager 1.0 
Troubleshooting

Installation

■ When trying to register a GCOS server or click a tab in GCOS 
Manager, the error message “GCOS Server Component not 
installed” appears. What does this mean?
This means that there is a permission or access problem, or may occur 
where the shared pool size is too small.
Verify that the user has permissions to access the server. The logon 
name is part of the GCOS Server Global Group.
Verify that the user is registering a server with the GCOS Server 
components installed.
Verify that the database services are started (either SQL or Oracle).

■ The Roles tab in GCOS Manager is missing.
The Roles tab is unavailable when you work with GCOS connected to the 
local MSDE database server.
The global group may have the wrong domain name prefix in the GCOS 
Server Admin database table 'USERS'. This will happen if your MIS 
changes the name of the domain. As users begin to migrate to Win2K 
from NT, some administrators might change the domain name. If they 
do, you will need to change the domain name in the 'USERS' table.

■ Slow connection when trying to connect to the server with one of 
the client applications (i.e.: GCOS Manager). What is going on?
If users experience slow connection to the server, verify that the Domain 
Controller and DNS are properly configured and registered with other 
Domain Controllers within the network.

Delete

■ Unable to delete data from the process database.
Verify the error message. Error message displayed “Failed to read 
experiment: xxx.EXP” It is possible that the data was migrated in from a 
beta version and the character limit exceeded 25 characters. In this case, 
the entire sample must be deleted in order to remove the file in question.

■ When trying to delete data from a Publish database, it displays 
“failed” When viewing the log, the message “IpublishData – Failure 
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in CheckForOpenConnections: cannot delete database with open 
connections (2)” What does this mean?
If another user has the database open (using DMT or publishing data), 
data cannot be deleted. This is because the tables are locked and cannot 
be accessed. Wait until the users are done publishing and not using 
DMT.

Archiving

■ Unable to archive. Error message “Archive File Copy Error”.
Verify that the path location specified for archiving has enough free space 
to archive the file(s) selected.

Importing

■ Unable to import. I get a copy file error message in the text log.
Verify that the permissions are set properly.
There is enough free space to import the files.
If the data is on a CD, try copying it to the local hard drive and import 
again.

■ Trying to import and the error message “Cannot modify experiment 
<name of experiment>. It is waiting to be hybridized, scanned, or it’s 
image file requires grid alignment.” 
The experiment that is selected to be imported cannot be imported 
because this experiment is already on the queue and is waiting to be 
completed by one of the above steps.

■ Trying to import data and it fails. Verify that the .exp and .dat files 
exist with the same name. 
Verify that the files are a valid size. If the data is on a jaz disk, CD-ROM, or 
other media, try copying it to the local hard drive and import again.

Usersets

■ In GCOS Manager, the user is unable to create a userset. 
Verify that the information entered is correct. 
Verify that the userset parameters are valid in GCOS Manager.
Verify that the library files have been installed or updated.

■ In GCOS Manager, I click the Usersets tab and get the message 
“Failed to load probe arrays -?|” 
This means that there have not been any probe arrays (library files) 
installed.
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Templates

■ Unable to create a template.
Verify that there is not any other template with the same name. Verify 
that the template was saved.

Exporting

■ Unable to export. Error message “CopyFile Error=112”.
Verify that the path location specified for exporting has enough free 
space to write the .exp, .dat, .cel and .chp files.

Publish

■ Unable to create new Publish database.
Verify that the username and password entered are correct. 
Verify that the path location specified exists.
Verify that the path location specified has enough hard disk space.
Verify that the open cursors set to 200 (Oracle databases only).
Verify that the publish database name does not start with a number. All 
publish databases and database passwords must begin with a letter.

■ Creating a SQL Server Publish database. The error message “Device 
too small” or “Device too large” is displayed. What should the 
creation size be? 
The size of creating the publish database is between 128 MB and 1024 
MB. 

■ Trying to create an Oracle® publish database and it fails.
Verify that the username and password entered is correct. The password 
for the username gatc is ‘gatc’ (all lowercase). Verify that the path exists. 
Verify that the open cursors is set to 200. Verify there is enough hard disk 
space.

■ Creating an Oracle® database and it fails. The log shows that there 
are not enough cursors. What does this mean? 
Verify that the INIT.ORA contains the open_cursors =200 (It needs 
enough cursors to create a database, otherwise all cursors are locked and 
in use).

■ Unable to delete Publish data from the publish AADM database. 
The publish data selected to be deleted may be in use by another user. 
Other users may have the Data Mining Tool application open and 
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connected to that publish AADM database. Therefore, in order to delete 
the data, the other user must exit out of DMT.

■ After removing a publish database from the database application, 
the database name still appears in the publish tab. Why?
The system DSN still exists in the ODBC Control Panel. Remove the DSN 
and it will not appear in the application.

GCOS Manager FAQs

This section of the manual lists frequently asked questions (FAQs) regarding 
Affymetrix GCOS Manager. If you still need assistance after reviewing these 
questions and answers, please contact Affymetrix Technical Support. For 
support contact information, see Technical Support, on page 6.

Q: I want to view information about other expression samples. I try to select 
another sample by clicking its icon, but the software doesn’t change to a 
different sample. What should I do?

A: In GCOS Manager, click the text representing the sample or experiment 
name rather than the icon.

Q: How can I change the “export to” or “import from” location?

A: On the menu bar, click the  icon. If you are in the Process, Publish, or 
Find tabs, this will select a target location for exported files. If you are in 
the Import tab, this will select a location to import files.

Q: How do I use the Find command to search the Publish database?

A: The Find command only works with the Process database.

Q: I know some of my samples (projects or experiments) are in the process 
database. However, when I use the Find command, the results produce an 
empty set. Why does this happen?
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A: In the Find window, the Select Object tab, the Advanced Filter tab, and 
the Data Filter tab are additive. Therefore, if you select experiments with 
the text string “xxxAssay” using the Select Object tab and then limit the 
search to Project X using the Advanced Filter tab, the Find command 
searches for experiments with the text string “xxxx” that are members of 
Project X.

Q: I want to delete (assume ownership, export, or archive) multiple data 
items (experiments or samples) at one time. However I cannot select 
multiple data items at one time in the process database. How can I 
accomplish this?

A: You can SHIFT-select or Ctrl-select multiple data items at one time in the 
Find window. Most of the functions that are available in the Process tab 
are also available in the Find window.

Q: I want to archive a sample but the software will not let me choose that 
function. How do I archive a sample?

A: Experiments or samples cannot be archived. A list of available functions 
in the Find window is listed below:

Analysis data: archive, assume ownership, delete, and export

Experiments: assume ownership, delete, export, and rename

Samples: assume ownership, delete, and rename

Q: How do I get out of the Find window and back to the process database?

A: Simply close Find window or go to the Windows menu and select “GCOS 
server manager.”

Q: Can I view property information about files in the publish database?

A: No, this information is not available. But you can view property 
information about files in the process database in the Publish or Process 
tab.
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Q: I cannot find my image data (.dat) under the Import tab. I have confirmed 
that the .dat file exists on the local drive and that I have the import location 
mapped correctly. Why doesn't GCOS Manager let me import my image 
data (.dat)?

A: GCOS Manager imports .exp data and the associated image data (.dat) 
with the same name. Make certain that the folder with the image data 
(.dat) includes the .exp data with the same name. As a last resort, open the 
image data (.dat) in Affymetrix® GCOS. If an .exp does not exist for the 
image data (.dat), GCOS will automatically create one.

Q: When I try to open a Sample folder, only a few samples are displayed and 
I know that there should be more in the database. What happened to the 
samples?

A: The Sample filter remains active during successive sessions. Reset Sample 
Filter parameters. See Filtering Data, on page 65.
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Library Files 
Troubleshooting

Installation

■ During the library file installation on the server, it shows that the 
ask is “not responding” in task manager. What is wrong?
The library file installation is responding. During this time, it is writing the 
gene descriptions and sequence information into the databases. This will 
take a while depending on the number of probe arrays selected. Do not 
stop or cancel the task.

■ After an upgrade, the library files update installation is run. The 
installation completes very fast. Is this correct?
Yes. The update copies the *.cif file in the X:\GeneChipDB\Library 
directory and adds new parameters to the database. Descriptions and 
sequences are not installed.



L



Appendix L



Using the GeneChip® AutoLoader L

Affymetrix has designed a new scanner addition expressly for 
scanning multiple GeneChip® probe arrays. This is the AutoLoader. It 
can scan up to 48 probe arrays automatically without operator 
presence.

 

Figure L.1 
The Affymetrix® GeneChip® Scanner 3000 with AutoLoader
649



APPENDIX L   Using the GeneChip® AutoLoader650
Setting Up the AutoLoader

The GeneChip® Scanner 3000 with an AutoLoader has the following 
connections on the unit (Figure L.3):

■ AC power connection

■ Ethernet connection

■ Keyboard/barcode reader connection

If you must move the scanner, disconnect all cables first.

■ The instrument weight is approximately 100 pounds (45.36 Kg). Do not 
place it on an unstable cart, stand, or table. Failure to properly support the 
instrument may cause serious damage or injury and may void the 
warranty. 

Connecting the Scanner and Workstation

1. Couple the barcode reader to the keyboard using the coupling block 
(Figure L.2). Connect the coupling block to the workstation’s keyboard 
port (Figure L.3).

Heavy object. Two people are required to lift the scanner-AutoLoader.

Figure L.2 
Coupling the barcode reader to the keyboard

Barcode reader-
Keyboard
Coupling Block

Cable to
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Keyboard
Receptacle
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Keyboard

Cable to
Barcode
Reader
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2. Connect the 3-pronged electric power plug to the workstation (Figure L.3).

3. Connect the dedicated Ethernet cable from the scanner to the Ethernet 
port that is designated on the workstation. The port is located near the 
bottom of the workstation (Figure L.3).

4. You can connect your company’s network cable to the indicated port 
near the center of the workstation (Figure L.3).

When you start GCOS, the software will make the proper 
communication connections.

5. Connect the cabling to the scanner with AutoLoader (Figure L.4)

6. On the rear of the AutoLoader, there are two drain tubes: an upper and a 
lower drain tube. Place the upper drain tube in a beaker or other 
receptacle to collect the condensation from the AutoLoader (Figure L.4).

Do not confuse your company’s network connections with the dedicated 
Ethernet port of the scanner-workstation. The proper scanner 
connection is located near the bottom of the workstation.

This 10/100 Base T Ethernet communications port is dedicated to the 
scanner-workstation interface. You cannot connect the scanner to your 
company’s Ethernet communications network. 

You can, however, connect the workstation’s second Ethernet port to the 
your company’s Ethernet network.

The reset button is the scanner’s circuit breaker. The breaker switch will 
be tripped whenever the scanner experiences an electrical fault 
condition. Press to reset. If you cannot reset this switch, contact 
Affymetrix technical support. 
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Figure L.3 
Workstation rear cable connections
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Figure L.4 
Scanner with AutoLoader rear connections
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Indicator Lights and On/Off Button

The front panel has the following button and indicators (Figure L.5).

1. I/O (on/off) button in the center.

2. Blue indicator light on scanner body, running vertical at front center. 
This light extends to the bottom of the AutoLoader and is always on 
when the scanner is on.

Figure L.5 
The AutoLoader indicator lights

Blue
Autoloader
Indicator
Light

Blue
Scanner
Indicator
Light

I/O (on/off)
button

Yellow light

Green light



  Affymetrix®  GeneChip®  Operating Software User’s Guide 655
3. Blue indicator light on AutoLoader, running vertical at front center. This 
light appears to be merely an extension of the scanner light. However, 
when on, it indicates that the AutoLoader door is closed and locked. It 
will turn off when the door is unlocked.

4. Green and yellow light both on indicate scanner boot up in progress.

5. Yellow light

a. On = Idle, laser is warming up (laser not ready, green off)

b. Off = System ready, no errors (Green on)

c. Flashing = Error

6. Green light

a. On = System is ready to scan (yellow off)

b. Flashing = Scan in progress

Summary of Indicator Lights

The table below summarizes the light conditions and their meaning.

Condition Green 
Light

Yellow 
Light

Blue 
Scanner 
Indicator 
Light

Blue 
AutoLoader
Indicator Light

Meaning

Initial boot up Off Off On Off Initial power up; embedded PC takes 
control

Scanner boot up On On On Off Embedded PC takes control of scanner 
boot up

Laser warm up Off On On Off Software enabled and laser is warming 
up

System ready On Off On Off Scanner ready for use and AutoLoader 
door is unlocked waiting to receive a 
carousel

Error Off Flashing On Off Fatal error, reboot scanner and 
software, AutoLoader door is unlocked 
to remove carousel if necessary

Scanning Flashing Off On On Scanning is in progress and 
AutoLoader door locked

Scanning Flashing Off On Off Scanning is in progress and 
AutoLoader door is unlocked
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Installing and Configuring 
the E-mail System

In the event of an AutoLoader error condition, you can enable the software 
to send an e-mail containing error information using Microsoft Exchange 
server or SMTP.

The user sets up the e-mail system just once. 

E-mail System Installation

The instrument installation software is on a separate CD. Use this CD and 
the following procedure to install the instrument control software.

1. Launch Windows 2000 Explorer.

2. Double-click setup.exe within the Instrument folder.

⇒ The Welcome window appears.

3.  Click Next.

⇒ Several consecutive Software License Agreement windows appear.

4. Click Yes in each window to accept the terms of the agreement.

5. The Choose Destination Location window appears.

6. Click Browse and select the Destination to install the instrument driver 
(select the same location where you installed GCOS).

7. Click Next.

⇒ The Select Components window appears (Figure L.6).
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8. Remove the check from the Fluidics station and Sealevel card files 
box. Select only the Affymetrix Scanner Files option. Highlight the 
Affymetrix Scanner Files option and click Change... to select the type 
of scanner. The following dialog box opens and displays the choice of 
scanners, Affymetrix or GeneArray (Figure L.7).

Figure L.6 
The Select Components window, only the Affymetrix Scanner files box checked

Figure L.7 
The Select Sub-components window, only the Affymetrix Scanner files box checked
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9. Select the Affymetrix Scanner files and click Continue.

10. Click Next.

⇒  The Email Option window appears (Figure L.8).

Using Microsoft Exchange

If you are using Microsoft Outlook with Microsoft Exchange, you must 
configure Outlook XP to work with the Exchange server. 

Each user can set up an individual distribution list, and all users share 
the same name for each of their own individual distribution lists. Thus 
there can be two cases in sending e-mail:

■ There is a single e-mail contact for everybody
■ There is a common distribution list name, and every user must set up 

a list with that name.

Configure it by the following steps.

Figure L.8 
The Email Option window with Microsoft Exchange Server checked
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1. Select the Microsoft Exchange Server. Enter an e-mail address or a 
distribution list that has been set up in Outlook. To set up a distribution 
list see the section below.

Setting up Outlook for a distribution list

Let us call the name of the distribution list AutoLoaderGroup.

1. Launch Microsoft Outlook.

2. On the File menu, point to New, and then click Distribution List. 

3. In the Name box, type the name that is used in the Instrument Install 
(e.g. AutoLoaderGroup). 

4. Click Select Members. 

5. In “Show names from the list,” choose the address book that contains 
the e-mail addresses you want in your distribution list. 

6. In the “Type name or select from list box,” type a name you want to 
include, or select a name from the list below, and then click Members. 
Do this for each person you want to add to the distribution list, and then 
click OK. 

If you want to add a longer description of the distribution list, click the 
Notes tab, and then type the text. 

7. You save the distribution list in your Contacts folder by the name you 
give it. 

All e-mail generated during an AutoLoader run will be sent to the 
people in the distribution list

Each user, who plans to run the AutoLoader through his/her user 
account, should create a distribution list.

Configuring SMTP 

If you are using SMTP, configure it as follows.

When an e-mail is sent during a normal run, you must be logged into the 
workstation and have an account on the exchange server.
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1. Enter the IP address of the SMTP server and the port number at which 
SMTP transactions occur.

2. Enter an e-mail address or comma separated list of e-mail addresses to 
which the e-mail must be sent.

No E-mail Options

Select this option to disable the e-mail system. Place a check in box None.

Figure L.9 
The e-mail contact configuration window with SMTP configured
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E-mail Messages

If the e-mail system is enabled, the instrument control software sends an 
e-mail alert for conditions that may occur during an AutoLoader run. 

In case of a fatal error:

1. The software sends an e-mail to the specified set of e-mail addresses or 
to the Outlook distribution list.

2. The software provides you with the ability to send an e-mail without 
your intervention.

3. The software uses extended MAPI to send an e-mail.

4. Each e-mail message contains the following information:

a. Date and Time

b. Scanner ID

c. All experiment information displayed in the status window. The 
table below lists the relevant e-mail messages (Table L.1).

For a list of serious errors, see the section entitled AutoLoader Error 
Messages on page 700.

Table L.1  
E-mail Message Conditions. These will appear on the scan status field of the status screen at 
the bottom of the GCOS GUI such as the Experiment Information Window. (See the section 
entitled Troubleshooting on page 699 for recommended action).

 Condition Detected By Action/Mitigation

Carousel Home Error Carousel Home not detected after more 
than one carousel rotation

Log error, stop run, notify 
user via GUI and e-mail

Grip Home Error Grip Home not detected after more than 
full actuator travel, a mechanical error

Log error, stop run, notify 
user via GUI and e-mail

Feeder Fail Cartridge not detected in scanner or 
AutoLoader during load or unload

Log error, stop run, notify 
user via GUI and e-mail

Load Request Error, 
Cartridge in Scanner

Cartridge already in scanner when 
software directs AutoLoader to load a 
cartridge

Log error, stop run, notify 
user via GUI and e-mail
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Unload Error, Cartridge 
in AutoLoader

Cartridge detected already in 
AutoLoader when software directs 
AutoLoader to unload a cartridge 
(Autoloader cannot unload the 
cartridge.)

Log error, stop run, notify 
user via GUI and e-mail

Cooling Over 
Temperature

Cooling set point not attained within 1 
hour of activation

Log error, disable cooling, 
notify user via GUI and 
e-mail, continue 
AutoLoader run

Cooling Under 
Temperature

Cooling temperature < 5ºC Log error, disable cooling, 
notify user via GUI and 
e-mail, continue 
AutoLoader run

Door Opened Door was opened in the middle of a 
scan causing current chip to be 
rescanned

Log error and e-mail

Power failure/restore Power was lost/or restored to the 
workstation and /or AutoLoader

If a UPS is attached to the 
workstation, an e-mail will 
be sent

Network disconnect A network disconnect between 
workstation and scanner was detected 

Log error and e-mail user

End of Run Scanner stops the AutoLoader run upon 
encountering a chip previously scanned 
or after scanning 48 chips

Notify user via GUI and 
e-mail that the run has 
completed 

Table L.1  (Continued)
E-mail Message Conditions. These will appear on the scan status field of the status screen at 
the bottom of the GCOS GUI such as the Experiment Information Window. (See the section 
entitled Troubleshooting on page 699 for recommended action).

 Condition Detected By Action/Mitigation
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Operating the 
Scanner-AutoLoader

This chapter describes how to use GCOS to control the Affymetrix® 
GeneChip® Scanner and AutoLoader (Figure L.10).

Figure L.10 
Assay & analysis flow chart
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Quick Reference 
Walkthrough

The table below illustrates the steps required to scan a set of probe arrays. 

Step Description

1. Enter and save 
the experiment 
information in 
the Experiment 
Information 
Window.

For more information, 
see the section, The 
Experiment Information 
Window, on page 673.

2. Hybridize the 
probe arrays.

For more information, 
see the GeneChip® 
Expression Analysis 
Technical Manual and 
relevant package 
inserts. 
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3. Wash the probe 
arrays.

For more information, 
see the GeneChip® 
Fluidics Station 450/250 
User’s Guide and 
relevant package 
inserts. 

4. Apply 
Tough-Spots™

For more information, 
see the section, Using 
Tough-Spots™ to 
Prevent Leaks, on 
page 677.

5. Load probe 
array cartridges 
into carousel.

For more information, 
see the section, Loading 
Cartridges into the 
Carousel, on page 681.

Step Description
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6. Load carousel 
into the 
AutoLoader. Set 
properly by 
turning it to set 
flush with 
housing. Close 
the door.

For more information, 
see the section, Loading 
the Carousel into the 
AutoLoader, on 
page 683.

7. Start the 
AutoLoader run.

For more information, 
see the section, 
Scanning a Probe Array 
in Automode, on 
page 685.

• If you want to scan the probe arrays without waiting for them to 
have warmed up, check box.

• If you want to rescan currently loaded probe arrays that had 
been scanned in a previous run, check Allow rescans box. The 
.dat file from the previous run will not be overwritten.

Step Description
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The AutoLoader Run

This section shows you how to scan multiple GeneChip® probe arrays using 
the new Affymetrix® GeneChip® Scanner 3000 equipped with the 
AutoLoader.

Quick Reference Guide to Using the AutoLoader

The following table can help you find specific procedures based on the type 
of task you are looking for.

Figure L.11 
Affymetrix® GeneChip® probe array cartridge: note the location of the flange. The AutoLoader 
will accept the cartridge in only one orientation.

If you want to: Then do this:

Use the 
AutoLoader in 
automode

1. Click Tools → Defaults. 

2. Clear the check box Enable Manual Mode.

3. Click OK (Figure L.21).

Use the 
AutoLoader in 
manual mode

1. Click Tools → Defaults. 

2. Check Enable Manual Mode.

3. Click OK (Figure L.24).
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Turn on the laser 
immediately when 
you launch GCOS

1. Click Tools → Defaults. 

2. Check Turn on Laser at startup. 

3. Click OK (Figure L.30).

Add an 
experiment 1. Open the GCOS software, and click Experiments.  to open 

the Experiment Information window.

2. Enter and save the experiment information in the Experiment 
Information Window.

If you want to: Then do this:
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Add a barcode

• Note: A new 
experiment must 
be opened for each 
barcode.

1. Open the GCOS software to the Experiment Information 
window.

2. Place cursor in the barcode field.

3. Hold a GeneChip probe array cartridge in front of the barcode 
reader and squeeze the trigger for up to four seconds until you 
hear a beep. 

The reader reads and sends the barcode to the GCOS Experiment 
Information window, Barcode field. The software automatically fills 
other fields.

4. After the software adds the barcode, save the experiment.

5. Repeat steps 1 to 4 until you have read all of the probe array 
cartridges.

If you want to: Then do this:
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Start a scanning 
run

1. Load the carousel and place the carousel into the AutoLoader.

2. Click the Start button .

• If the arrays are at room 
temperature, or you 
want to scan the probe 
arrays without waiting 
for them to warm up, 
check the appropriate 
box.

• If you want to allow the 
probe arrays to be 
rescanned, check the 
appropriate box.

(The rescan function is handy if you want to rescan a currently 
loaded probe array that had been scanned in a previous run.)

3. Click OK. The AutoLoader homes and performs an inventory of 
the probe arrays and the scanning run begins.

If you want to: Then do this:
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Add a probe array 
during a scan 1. Click the Add button  or select Run → Add Chips.

• If you want to unlock the door and immediately begin adding 
cartridges, click the Add Now button. The blue indicator light on 
the front of the AutoLoader will go out signifying that the door is 
unlocked and you can load more cartridges.

The cartridge being scanned, if any, will be rescanned, 
and the previously created .dat file WILL BE 
OVERWRITTEN.

• If you want to wait for the scan to complete before adding a 
probe array, click the Add after Scan button. The current scan 
will continue until completion, then the door will unlock and you 
can load more cartridges. The Autoloader blue indicator light will 
go out to signify that the door is unlocked.

• In both cases, after you have added your cartridges and closed 
the door, the following window will appear. Click OK.

2. Click the Resume  button or Run → Resume. The door 
then locks and the blue indicator light turns on.

Use GCOS without 
a scanner

1. Click Tools → Defaults. 

2. Clear the check box Scanner Installed.

3. Click OK (Figure L.28).

Disable 
AutoLoader and 
use the scanner 
only

1. Click Tools → Defaults.

2. Check Disable AutoLoader. 

3. Click OK. (Figure L.29).

If you want to: Then do this:
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Terminating a scan run

The AutoLoader run will terminate under certain normal circumstances. The 
following table Table L.2 outlines under what conditions a scan run will or 
will not terminate.

 

Stop a scan
1. Click the Stop button .

2. When the 
following 
window 
appears, 
click OK.

Caution: If 
you stop the scanner while a probe array is in the 
process of scanning, you will lose all scan information 
from that probe array. If you rescan the array, it may be 
affected due to uneven photo-bleaching. This could 
potentially make the data from the array difficult to 
compare to other array data.

Table L.2  
Summary of scan run termination conditions

The scan run will terminate if: The scan run will not terminate if:

You press the Stop button. Caution: 
If you stop the scanner while a probe 
array is in the process, you will lose 
all scan information from that probe 
array. If you rescan the array, it may 
be affected due to uneven 
photo-bleaching. This could 
potentially make the data from the 
array difficult to compare to other 
array data.

You check Allow Rescans box. When the 
AutoLoader encounters a probe array 
that was previously scanned in an earlier 
run, it will rescan that probe array and 
will create additional .dat files (.dat1, 
.dat2, etc.). 

The AutoLoader detects a probe 
array with the same barcode in the 
current run, i.e., in the currently 
loaded carousel. The probe array will 
not be rescanned.

You clear the Allow Rescans box. When 
the AutoLoader encounters a probe array 
that was previously scanned in an earlier 
run, it will log the probe array but will not 
rescan it. It will continue the run.

If you want to: Then do this:
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The Experiment Information Window

The Experiment Information window (EIW) provides you with the means 
for generating and saving a database of your experimental data (Figure L.15).  

Certain information has to be entered before the experiment can be saved. 
(Table L.3) lists the available fields and their definitions and whether or not 
they are required in order to save the experimental data.

For more information, see the section, Registering a Sample & Defining an 
Experiment, on page 74.

The AutoLoader detects 48 scanned 
cartridges in the same run. 

You click the Add Now button. The 
AutoLoader door will unlock to accept 
new probe array cartridges. The scan in 
progress will complete. When you close 
the door and continue, the AutoLoader 
will home, take inventory and move to 
the same probe array that was in the 
process of being scanned when the door 
was opened. It will discard the earlier 
.dat file and rescan that probe array. 

Note: this has nothing to do with the 
Allow Rescans check box.

You click the Add After Scan button. The 
AutoLoader door will wait until the scan 
in progress is complete then unlock the 
door. When you close the door and 
continue, the AutoLoader will home, 
take inventory and move to the next 
probe array from that which was in the 
process of being scanned when the door 
was opened. 

Before you can advance to the next experiment, you must first save the 
current experiment.

Table L.2  (Continued)
Summary of scan run termination conditions

The scan run will terminate if: The scan run will not terminate if:
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Table L.3  
Definitions of the experiment data fields in the Experiment Information Window

Field Definition Required for save

Sample Template Dropdown box for templates associated 
with samples

No

Sample Name The name of the sample. Yes

Sample Type The type of sample. This is an attribute 
of the sample that describes its type. 
Example: blood, cell line, tissue, etc.

Yes

Sample Project The name of the project associated with 
the sample.

Yes

Sample owner Read-only field showing the owner of 
the sample in the database.

Yes

Experiment Template Dropdown box for experiment 
templates

No

Experiment Name The name of the experiment. Yes

Probe Array Type This is the probe array type associated 
with the experiment, and automatically 
filled in when you enter the barcode.

Yes

Barcode User entered barcode Yes (No if 
AutoLoader is in 
manual mode)

Expiration Date Array Expiration date embedded in 
Affymetrix barcode, and automatically 
filled in when you enter the barcode.

No

Probe array Lot 
number

Array lot number embedded in 
Affymetrix barcode, and automatically 
filled in when you enter the barcode.

No

Experiment owner Read-only field showing experiment 
owner

Yes

User-set Drop down list of user-sets in the 
database used for storing analysis 
parameters

No

Publish Database Drop down list of names of the publish 
databases. Used when selecting 
automation

No

Publish Intensities Checkbox to be selected if publishing 
intensities to the database after 
completing the analysis

No
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Status Window

GCOS software provides you with the status of all scans, the status of the 
AutoLoader door and status of the current scan. This window is located at 
the bottom of user interface (Figure L.12). Below (Table L.4) describes the status 
fields.

Figure L.12 
The status window

Table L.4  
The GCOS Status Fields and Descriptions

Status Field Description

Position Position occupied by a given cartridge in the AutoLoader 
carousel

Experiment Name The experiment name associated with the scan associated 
with a given cartridge position

Probe Array Type The probe array type for the scan associated with a given 
cartridge position

Barcode ID The unique identifier in the barcode for the scan associated 
with a given cartridge position

Status
window
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User Name of the user (experiment owner) for the scan 
associated with a given cartridge position

Time & Date The date and time when scan started and completed

Scan Status

The status of the scan. (Autofocus, scanning). This field 
displays all scanner status strings associated with the scan 
and retrieved from the scanner.
The message strings that may appear in this field are listed 
below. 
Note: Not all of these messages will appear in each 
AutoLoader run.

AutoLoader Door 
(viewed in status bar)

The status of the AutoLoader door

Number of Cartridges 
(viewed in status bar)

Number of cartridges in the AutoLoader carousel as 
determined by inventory

History 
(viewed as a log)

A running history of the last 99 arrays scanned and the 
information on the current array (if any) being scanned

Table L.4  (Continued)
The GCOS Status Fields and Descriptions

Status Field Description

Status Field Strings

Autofocus 

Scan Status - % of lines 
scanned

Scan Complete status

Grid alignment errors

Autofocus Errors 

The experiment XXX has 
already been scanned

Chip load failures

Invalid barcode errors

Experiment does not exist 
errors

AutoLoader door open errors 
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Turning on the Scanner-AutoLoader

Press the on/off (I/O) switch on the front panel. The scanner’s onboard 
computer will boot up. The bootup process takes a few of minutes. During 
this time both the yellow and green light will be on. The scanner enters the 
laser warm-up state. During this warm-up time, the green light will turn off 
and the yellow light will remain on. You must wait 10 minutes for the laser 
to stabilize.

Using Tough-Spots™ to Prevent Leaks

Tough-Spots™ are chemically inert polyvinyl labels that adhere to all 
plastics. Affymetrix recommends using 3/8-inch circle diameter 
Tough-Spots to prevent leakage from the cartridge septa.

Before loading the probe array cartridge, follow this procedure to prevent the 
leaking of fluids from the cartridge during scanning.

Even if you have already applied Tough-Spots to the cartridge prior to 
hybridization or after washing, you must remove the old Tough-Spots and 
apply new ones before you load them into the AutoLoader.

Affymetrix recommends the use of Tough-Spots™  obtained from 
Affymetrix P/N 64-0158

or from

USA Scientific, Inc. P.O. Box 3565 Ocala, FL 34478 
(800)LAB-TIPS P/N 9185-0000

To reduce the risk of leakage, do not use excessively large pipette tips to 
pierce the septa. 
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1. On the back of the probe array cartridge, clean excess fluid from around 
septa (Figure L.13).

2. Carefully apply one Tough-Spot over each of the two septa. Press to 
ensure that the spots remain flat. If a Tough-Spot does not apply 
smoothly; that is, if you observe bumps, bubbles, tears or curled edges, 
do not attempt to smooth them out. Remove the spot and apply a new 
one (Figure L.14).

Figure L.13 
The GeneChip® probe array cartridge

Figure L.14 
Applying Tough-Spots™ to cartridge septa

Tough-SpotsTM
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Using the Barcode Reader

If you have not already done this during the initial experiment setup, you 
must now add a new barcode for each experiment.

1. Open the GCOS software to the Experiment Information window and 
place the cursor in the barcode reference field of the GCOS Experiment 
Information window (Figure L.15).

2. Hold a GeneChip probe array cartridge in front of the barcode reader 
and squeeze the trigger for up to four seconds until you hear a beep 
(Figure L.16). 

You should open a new experiment and place the cursor into the 
barcode field before triggering the reader. Otherwise, the barcode will 
be misinterpreted as some other kind of input. A new experiment has to 
be opened for each barcode, and certain other information has to be 
entered before the experiment can be saved.

Figure L.15 
Experiment Information Window with cursor in the barcode field



APPENDIX L   Using the GeneChip® AutoLoader680
3. The reader reads and sends the barcode to the GCOS Experiment 
Information window, Barcode field (Figure L.17).

The software also automatically fills in the “Probe Array Type,” “Probe 
Array Lot,” and “Expiration Date” fields. These are read-only fields.

Figure L.16 
Reading the cartridge barcode
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4. After the software adds the barcode, save the experiment.

5. Repeat steps 1 to 4 until all of the probe array cartridges have been read.

Loading Cartridges into the Carousel

1. Load your cartridges into the carousel (up to 48). Note that only one 
orientation is possible (Figure L.18).

Cartridges should be loaded into the carousel starting at position #1. 
Additional cartridges need not be contiguous. A run will stop after 48 
cartridges OR when the same barcode is read within the same run.

Figure L.17 
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Figure L.18 
Loading the cartridge into the chip carousel, note that each slot is numbered., 1 through 48, 
and each cartridge can fit in only one orientation
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Loading the Carousel into the AutoLoader

1. Load the carousel into the AutoLoader by inserting the carousel into the 
AutoLoader and turning the carousel until the alignment pin seats into 
the alignment hole (Figure L.19).

Figure L.19 
Loading the cartridge carousel into the AutoLoader

Alignment
Key in the
Autoloader

Alignment
Hole

Alignment
Pin

Carousel
Mounting
Key Flat
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2. Turn the carousel clockwise until the carousel mounting key flat seats 
gently into the AutoLoader alignment key. You may have to turn the 
carousel several times before it will seat into the alignment pin and 
alignment key. When seated properly, the carousel will be flush with the 
AutoLoader housing. Close the AutoLoader door (Figure L.20). 

Figure L.20 
Inserting and turning the carousel; the carousel should be seated and flush with housing.

The seating of the key flat is confirmed by a gentle falling of the carousel 
into the key.
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Scanning a Probe Array in Automode

If all probe arrays have valid, associated barcodes, you can run the 
AutoLoader in automode.

1. Set the default settings.

a. Click Tools → Defaults (Figure L.21).

b. Clear the check box of Enable Manual Mode.

c. Click OK.

2. Click the Start button  in the Instrument Control shortcut bar or the 
main toolbar. Alternatively, select Run → Start Scanner from the menu 
bar.

⇒ The Start window appears (Figure L.22).

If there exists an identical barcode within the database from an earlier 
AutoLoader run, and you want to rescan the current probe array with 
that same barcode, check the Allow Rescans box (Figure L.22). This will 
create additional .dat files. The original .dat file WILL NOT BE 
OVERWRITTEN.

However, if the AutoLoader encounters the same barcode within the 
same run, the run will terminate.

Figure L.21 
Defaults window showing “Enable Manual Mode” with the check box cleared
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If you have not already loaded your probe array cartridges, do so now.

If you want to skip the ten minute warm-up period before scanning the 
first probe array, keep the default check in the Arrays at room 
temperature box. 

3. Click OK in the GeneChip Scanner dialog box to start the run.
■ The AutoLoader blue indicator light will light up signifying that the 

AutoLoader door is now locked.
■ The carousel automatically homes itself and performs inventory to 

determine the number and position of cartridges present. 
■ The scanning run begins. During the scan, the green light will flash, 

and the yellow light will be off. 
■ The AutoLoader completes the autofocus operation before scanning 

each of the probe arrays. This takes approximately two to three 
minutes. The scanner cannot be stopped during this period.

■ The run will stop automatically when the last cartridge is scanned.
■ At the completion of each scan, the GCOS software will attempt grid 

alignment. If it is successful, the scan data will be automatically 
advanced to the Grid Alignment processing state.

■ If the View Scan In Progress feature is enabled (select View → Scan 
in Progress from the menu bar), the Image window automatically 
opens in the main display area when a scan starts. It displays the 
fluorescence intensity of the probe array at approximately 200 lines 
at a time as the scan progresses. 

Figure L.22 
The Start Scanner window in automode
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■ To enable (or disable) this option, select View from the menu bar and 
place (or remove) a check mark next to Scan in Progress. 

After the scan is completed, GCOS:

a. saves the image data to an image data file (*.dat) (displayed in the 
main display area)

b. aligns a grid on the *.dat to identify the probe cells

c. automatically computes probe cell intensities and saves the data to 
the cell intensity file (*.cel)

d. ejects the probe array.

■ The AutoLoader will skip probe array cartridges if the AutoLoader 
encounters:

a. cartridges with unreadable or invalid barcodes or without barcodes

b. cartridges with barcodes that are not associated with an experiment

c. cartridges that have been previously scanned if the Allow Rescans 
checkbox is cleared (Figure L.22).

AUTOROTATION

The AutoLoader is equipped with a heater to warm up the cartridges 
prior to scanning in order to reduce condensation and fogging of the 
probe array cartridge window.

The autorotation routine is used for temperature stability but only after 
the AutoLoader run is complete or during a power failure as described 
below. 

Autorotation occurs during a power failure only if the uninterrupted 
power supply (UPS) is included as an accessory. The UPS provides 
power to the scanner/AutoLoader during a power failure. If the power 
fails during the scan of an array, that scan is completed and then the 
system turns off the heater and enters the autorotation mode to 
conserve power and cool the chips in the carousel. The system will also 
attempt to send an e-mail to notify the user of the power failure.

During an AutoLoader run, the carousel is rotating as the chips are 
processed to introduce the next chip to the scanner, so autorotation is 
not needed. After the AutoLoader run is complete the heater is turned 
off and the carousel is rotated to get even cooling of the chips.
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Adding Cartridges during a run

The software provides you with a button that will allow you to unlock the 
AutoLoader door and add additional probe array cartridges while in the 
middle of an AutoLoader run. You have two choices: to add cartridges 
immediately even while a scan is in progress (in which case the .dat file is 
discarded and replaced with a newly collected one after the AutoLoader run 
is resumed), or, as a second choice, to add cartridges after a scan has 
completed (in which case the .dat file is saved).

Click the Add Chips button , or select Run → Add Chips from the 
menu bar.

⇒ The software displays a dialog box with three buttons (1) Add Now 
(2) Add after scan is complete (3) Cancel (Figure L.23). 

1. If you click the Add Now button:

a. The blue AutoLoader indicator light will turn off signifying that the 
AutoLoader door is now unlocked. Open the door and add probe 
array cartridges.
If a scan is in progress, the software will continue to record the 
scan. However, to avoid the possibility of generating a corrupt .dat 
file, it will discard that scan that was in progress when the door was 
opened. 

The Add Chips button is enabled only after the AutoLoader has started a 
run in automatic mode. 

Figure L.23 
The Add Chips selection buttons

The Resume button  is available only for the Add Chips procedure. 
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b. After you have added your cartridges, close the door and the 
following window appears.

c. Click OK and then click the Resume  button or select Run → 
Resume.
The blue AutoLoader indicator light turns on signifying that the door 
is locked. The software homes the carousel and inventories the 
number of present probe arrays. The carousel then moves to that 
last previously scanned probe array (when the door was 
opened) and continues the scanning run by rescanning that 
probe array cartridge.
The cartridge is rescanned and a new .dat file overwrites the 
previous .dat file.

2. If you click the Add after scan is complete button, 

a. The AutoLoader will wait until the current probe array cartridge has 
undergone the autofocus and scan procedures before unlocking the 
door to allow you to add probe array cartridges.

b. The blue AutoLoader indicator light will turn off signifying that the 
AutoLoader door is now unlocked. 

c. Open the door and add probe array cartridges.

d. After you have added your cartridges, close the door and the 
following window appears. 

The GCOS status bar will also display a “waiting to start” status.

Do not load a cartridge into the same carousel position that was 
occupied by the cartridge that had just been scanned, i.e., do not replace 
cartridges.
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e. Click OK and then click the Resume  button or select Run → 
Resume.
The blue AutoLoader indicator light turns on signifying that the door 
is locked. The software homes the carousel and takes inventory of 
the probe array cartridges present. The carousel then proceeds to 
the next cartridge position following the previously scanned 
probe array. The AutoLoader continues the run from that cartridge 
position.

3. If you click the Cancel button, the AutoLoader will continue the 
AutoLoader run.

Scanning a Probe Array in Manual Mode

In the AutoLoader Automode, each probe array cartridge requires a valid 
barcode in order to be scanned. The manual mode feature allows you to scan 
one probe array at a time without the requirement of a barcode. This is useful 
if you must scan probe arrays that have invalid or absent barcodes.

1. Set the default settings.

a. Click Tools → Defaults (Figure L.24). 

b. Check Enable Manual Mode.

c. Click OK.
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2. Click the Start button in the Instrument Control shortcut bar or 
the main toolbar. Alternatively, select Run → Start AutoLoader 
from the menu bar (Figure L.25).

Figure L.24 
Enable Manual Mode checked
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⇒ The scanner Start window appears. At this point, you can choose 
from a number of options:

1. You can click Start without selecting an experiment. If your cartridge 
has a valid barcode, the software will get the barcode from the cartridge 
in the AutoLoader and select the correct experiment.

2. If your cartridge has a valid barcode, you can scan the barcode on the 
probe array cartridge in to the barcode field. The software will retrieve 
the experiment associated with the array.

3. If your cartridge does not have a valid barcode, you can manually select 
an experiment as described below.

a. The Experiment Name drop-down list displays the experiments 
(*.exp) in the current directory that have not been scanned (no *.dat 
file containing scan data exists for the experiments).

b. To include scanned experiments in the Experiment Name 
drop-down list, choose the Include Scanned Experiments option. 

Figure L.25 
The Scanner control window

If filters have been applied in GCOS Server mode, the drop-down list 
may not include all experiments. Click Filter to open the Filters dialog 
box and view or specify filters.
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c. Select the experiment name of the probe array to be scanned from 
the Experiment Name drop-down list.

■ The Probe Array Type field automatically displays the probe array 
type that was entered during experiment setup. GCOS sets the 
Number of Scans per probe array type (one for the GeneChip® 
Scanner 3000). 

■ You may change the number of scans in the Scanner dialog box 
(Figure L.25). Multiple scans are statistically averaged to create a single 
image data file (*.dat).

d. Click Start.

⇒ The Scanner dialog box appears (Figure L.26).

■ You can check Array at room temperature if you want to skip the 
ten-minute warm-up period before scanning the probe array. The 
default has the box already checked.

4. Load the probe array cartridge into slot number 1. 

Increasing the number of scans increases the scan time as well as the 
amount of fluorophore bleaching and may result in lower fluorescence 
intensities.

Figure L.26 
The start scanner window in manual mode

You can eject or load a cartridge by clicking on the Load/Eject button at 
any time except during the time the scanner is engaged in the autofocus 
operation or the scanning run.

The cartridge slot at position number 1 is the only slot available in 
Manual Mode.
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5. Click OK in the Start Scanner box (Figure L.26) to start the autofocus 
routine. This takes approximately two to three minutes. The scanner 
cannot be stopped during this period.

During the scan, the green light will flash, and the yellow light will be 
off.

If the View Scan In Progress feature is enabled (select View → Scan in 
Progress from the menu bar), the Image window automatically opens in 
the main display area when a scan starts. It displays the fluorescence 
intensity of the probe array at approximately 200 lines at a time as the 
scan progresses. 

To enable (or disable) this option, select View from the menu bar and 
place (or remove) a check in the box next to Scan in Progress. 

After the scan is completed, GCOS:

a. saves the image data to an image data file (*.dat) (displayed in the 
main display area)

b. aligns a grid on the *.dat to identify the probe cells

c. automatically computes probe cell intensities and saves the data to 
the cell intensity file (*.cel)

d. ejects the probe array.

Ejecting a probe array cartridge

The probe array cartridge will automatically eject after a run; however, if 
you must eject a cartridge, click the Load/Eject button (Figure L.25). This 
command is only available in manual mode.

This completes the manual mode section.

Stopping an AutoLoader Run

The Stop button is only available after you have clicked the Start button. 
Click this button if you want to abort a scan or run in progress.

If you stop the scanner while a probe array is in the process, you will 
lose all scan information from that probe array. If you rescan the array, it 
may be affected due to uneven photo-bleaching. This could potentially 
make the data from the array difficult to compare to other array data.
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1. Click the STOP toolbar button  or select Run → Stop Scanner from 
the menu bar.

2. At the prompt, click Yes to stop the scanner or No to elect not to stop the 
AutoLoader run (Figure L.27).

3. A window will display the message “The scanner will not stop until 
autofocus has finished.” Click OK. After you stop a scan, the scanner 
will automatically eject the cartridge. 

Shutting Down the Scanner

1. Close the GCOS software. This is the best way to shut off the laser. 

2. Press the I/O button on the front panel to turn off the instrument.

Using GCOS without a Scanner.

In the event that you would like to use GCOS and do not have or do not want 
to attach a scanner, you should clear the check box of the Scanner Installed 
option in the Defaults window. This will prevent the software from 
continually attempting to make contact with the scanner.

1. Click Tools → Defaults. 

2. Clear the check box of Scanner Installed (Figure L.28).

3. Click OK.

Figure L.27 
Stop AutoLoader prompt
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Using GCOS with the AutoLoader Disabled.

If you have a working scanner but the AutoLoader is not operating, you can 
still use the scanner, but you must check the Disable AutoLoader option in 
the Defaults window. This will disable the AutoLoader and enable you to 
use the scanner alone as you would in manual mode.

1. Click Tools → Defaults. 

2. Check Disable AutoLoader. 

3. Click OK. (Figure L.29).

Figure L.28 
Scanner Installed with the check box cleared
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⇒ A window will appear 
asking that you reboot the 
scanner. 

4. Press the scanner front panel I/O 
button once to turn off the 
scanner (Figure L.5). Wait a few moments, the press the I/O button to turn 
on the scanner.

5. Open the AutoLoader door.

6. Manually load a probe array cartridge into the slot. 

7. Close the AutoLoader door.

8. Scan the probe array in the same manner as the AutoLoader in manual 
mode. See the section entitled Scanning a Probe Array in Manual Mode 
on page 690.

9. After scanning the probe array, you must manually remove the probe 
array cartridge from the AutoLoader.  See Steps 7 though 13 in the the 

Figure L.29 
Disable AutoLoader checked
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section entitled Manually Removing a Lodged Probe Array Cartridge 
on page 701.

Turning on the Laser at GCOS Launch

You have two options as to how to control the actuation of the laser. You can 
have the GCOS software turn on the laser at the launch of the GCOS 
software. This allows you to begin the ten-minute warmup period 
immediately. Or you can wait until you are about to run a series of probe 
array cartridges to turn on the laser. You still wait ten minutes for the laser to 
warm up.

1. Click Tools → Defaults (Figure L.30). 

a. If you want to turn on the laser immediately upon launching the 
GCOS software, check Turn on Laser at startup.

b. If you want to wait until you are ready to run a scanning procedure, 
before turning on the laser, clear the check box for Turn on Laser at 
startup.

2. Click OK.

Figure L.30 
Turn on Laser at startup checked
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Cleaning and Maintenance

The AutoLoader requires little in the way of customer maintenance. The 
instrument must be kept clean and free of dust. Dust buildup can degrade 
performance. Wipe the exterior surfaces clean using a mild dish detergent 
solution in water. Do not use ammonia based cleaners or organic solvents, 
such as alcohol or acetone, to clean the system because they may damage the 
exterior surfaces.

Clean the carousel by hand using warm water and, if necessary, mild 
detergent. 

Troubleshooting

Problem Possible Cause Corrective Action

No image when scanning • Power off or cable loose Check all connections and 
power.

• Loss of laser power Contact technical support.

• Image display disabled Enable image display

Intermittent problems 
scanning

• Loose cable Check all rear connections.

Scanner fails with probe array 
inside

• Power failure Manually extract probe array. 
Check all connections to 
scanner. Turn scanner on, 
restart software.

Carousel does not 
automatically home

• Check for stuck cartridge

• Carousel not seated on D 
ring

• Alignment Pin not 
engaged in Carousel

• Door is open or ajar

• Door is open when blue 
LED is off.
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AutoLoader Error Messages

The following error messages indicate a serious malfunction of the scanner 
with AutoLoader. Your probe arrays, or the data generated from them, may 
be at risk. You should shut down the AutoLoader and remove the carousel. 

Carousel does not rotate • Door is open or ajar

• System is warming up, 
chip in heater

• Carousel not seated on D 
ring

• Alignment Pin not 
engaged in Carousel

• Laser in Scanner is 
warming up. GCOS has 
Start grayed out in this 
case

Carousel misses next chip • Cartridge UP sensor not 
working, call technical 
support.

Stuck cartridge  See the section entitled 
Manually Removing a 
Lodged Probe Array 
Cartridge on page 701

AutoLoader freezes up • Door is open or ajar

AutoLoader overheats • Heater Failure

• TE failure

• TE hot fans vent blocked

Call technical support.

Call technical support.

Autofocus routine fails to 
conclude 

• Try to rescan chip.   

• Check for salt on chrome 
border. If still error, call 
technical support.

The cartridge does not 
descend into scanner.

• Carousel not seated 
correctly

• Door is open or ajar

• Heater is waiting until chip 
is at temperature.

Problem Possible Cause Corrective Action
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Do not continue to use the AutoLoader in Automode. Call Affymetrix 
Technical Support.

However, if the AutoLoader appears to be operating normally, you can 
continue to use the AutoLoader in Manual Mode. See the section entitled 
Scanning a Probe Array in Manual Mode on page 690.

Manually Removing a Lodged Probe Array Cartridge

In the event that a probe array becomes lodged in the chip transport 
mechanism, follow the procedure outlined below.

 

HEATER_LOW “Warning: The warming chamber 
temperature is low. Refer to the 
troubleshooting guide.”

COLD_CHAMBER_LOW “Warning: The cold chamber 
temperature is low. Refer to the 
troubleshooting guide.” 

COOL_HOTSIDE_HIGH “Warning: The cooler hot-side 
temperature is high. Refer to the 
troubleshooting guide.” 
Note: Before calling technical support, 
check around the ventilation vents to 
ensure that nothing is blocking them.

COLD_CHAMBER_HIGH “Warning: The cold chamber 
temperature is high. Refer to the 
troubleshooting guide.”
Note: Before calling technical support, 
check the AutoLoader door to ensure that 
it is not open.

HEATER_HIGH “Warning: The warming chamber 
temperature is high. Refer to the 
troubleshooting guide.”

1. Turn the AutoLoader off and remove the power cord from the back of the 
unit.

2. Open the AutoLoader door on top of the unit. 

3. Remove the carousel from the system. (Keep cartridges in carousel at 
proper temperature while recovering the cartridge still in the scanner).
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4. Remove the 
hole plug, 
which is just in 
front of the 
cartridge slot 
in the base 
piece of 
insulation. In 
the photo to 
the left, the 
screwdriver is 
inserted into 
this hole.

5. Using a standard, flat (-) screwdriver, (13-0257) gently slide it down 
through the hole making sure not to damage the shaft and spring that are 
protruding into the hole. When the screwdriver stops, it should be in 
contact with the scanner Y stage screw. Slowly turn the screwdriver until 
you feel it engaging the slot on the screw of the scanner Y stage.

6. Slowly turn the screw clockwise until it hits a hard stop and cannot turn 
further. (Do not try to turn it further or use excessive force because it will 
break the Y stage in the scanner). The Y stage has now ascended to its 
maximum position.
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7. Using your 
fingers, slowly 
slide the slot 
pin, which is 
sticking 
through the 
slot in the 
base piece of 
insulation, to 
the right until 
it stops. You 
should see the 
little pinch 
rollers near the 
cartridge slot 
close a little as 
you do this.

Pinch 

Rollers

Slot 

Pin
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8. Insert a 3/16” 
hex driver 
(13-0255) into 
the hole that is 
located on the 
front of the 
AutoLoader 
housing on the 
left. You 
should feel it 
engage a 
coupling.

9. Turn the hex 
driver counter 
clock wise 
until you see 
the cartridge 
appear 
through its 
opening. (The 
cartridge 
should stay up 
if you stop 
turning the 
hex driver). If 
you don't see 
the cartridge 
after turning 
the hex driver 
ten seconds go 
to step 11.

10. Grab and hold the cartridge with your fingers. Using your other hand 
slowly slide the slot pin (Step 7) back to the left. This should open up the 
pinch rollers. Pull the cartridge out. 

11. If you do not see the cartridge after turning the hex driver for 10 seconds, 
stop. 

12. Using tool (13-0256) with the hook down and toward the 
back, slide it vertically down against the front of the 
cartridge opening, about 1.5 inches. (There is a small 
groove made for this tool in the middle of the front 
cartridge guide) 
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13. Pull the top finger grip of the tool toward the front of the unit, and then 
pull it up while still putting pressure towards the front. The cartridge 
should come up with the tool. When you see it, grab the cartridge and pull 
it out of the unit.

14. If you cannot get the cartridge out after doing this procedure, call for 
Affymetrix technical support.

15. Put the hole plug back into the hole in the base piece of insulation.

16. Plug the scanner back in and turn it on.

17. Load the carousel after the scanner boots up.

18. If cartridges continue to become lodged in the AutoLoader, you should 
call technical support.
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GeneChip® Scanner 3000 - 
AutoLoader Specifications

Item Parameter Value

Weight Shipping approx 115 pounds (52.2 Kg)

Free-standing approx 100 pounds (45.4 Kg)

Dimensions Width ~13.25 in. 

Depth ~21.25 in.

Height ~32 in. 

Power See the section entitled 
Scanner 3000 Specifications 
on page 503.

Working Environment Temperature 59°F-85°F (15°C-30°C)

Humidity 10-90% Non-condensing

Clearance 2 in. (5 cm) on side, back 
12.5 in. on top

Pollution Degree 2

Installation Category II

Altitude <2000m

Electrical Supply See the section entitled 
Scanner 3000 Specifications 
on page 503.

Main Supply Voltage 
Fluctuations

See the section entitled 
Scanner 3000 Specifications 
on page 503.
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CE Mark Declaration of 
Conformity
We, Affymetrix, Inc. 
4G Crosby Drive, 
Bedford, Massachusetts 

Declare under sole responsibility that the Affymetrix® GeneChip® Scanner 3000-AutoLoader conforms with the 
relevant provisions of the following standards or other normative documents:

EU EMC Directive 89/336/EEC:

EN 61326:1998 Equipment for Measurement, Control and 
Laboratory Use, EMC Requirements

EN 55011:1998 Industrial, scientific and medical (ISM) 
radio-frequency equipment - Radio disturbance 
characteristics - Limits and methods of 
measurement

EN 61000-3-2:2001 Limits for harmonic current emissions 
(equipment input current up to and including 16 
A per phase)

EN 61000-3-3:1995 Limitation of voltage changes, voltage 
fluctuations and flicker in public low-voltage 
supply systems, for equipment with rated 
current less than or equal to 16 A per phase 
and not subject to conditional connection

EN 61000-4-2:1995 Electrostatic discharge immunity.

EN 61000-4-3:1995 Radiated, radio frequency, electromagnetic 
field immunity.

EN 61000-4-4:1988 Electrical fast transient/burst immunity.

EN 61000-4-5:1995 Surge immunity.

EN 61000-4-6:1996 Immunity to conducted disturbances induced 
by radio frequency fields.

EN 61000-4-11:1994 Voltage dips, short interruptions, and voltage 
variations immunity.

EU Low Voltage Directive 73/23/EEC

EN 61010-1:2001 Safety requirements for electrical equipment 
for measurement, control, and laboratory use -- 
Part 1: General requirements

EN 60825-1:1994+ A2:2001 Safety of laser products -- Part 1: Equipment 
classification, requirements and user's guide
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Regulatory

This device complies with Part 15 of FCC Rules. Operation is subject 
to the following two conditions: (1) This device may not cause 
harmful interference, and (2) This device must accept any interference 
received, including interference that may cause undesired operation.

This device complies with FDA performance standards for laser 
products except for deviations pursuant to Laser Notice No. 50, dated 
July 26, 2001.

This Class A digital apparatus meets all requirements of the Canadian 
Interference-Causing Equipment Regulation.

Cet appareil numérique de la classe A respecte toutes les exigences du 
Règlement sur le matériel broullier du Canada.

For Research Use Only. Not for use in diagnostic procedures.

Regulatory Agency Certification

AL 02 12 39816 004

92AA

See the section entitled 
GeneChip® Scanner 3000 - 
AutoLoader Specifications on 
page 706.

Class I Laser Device 21 CFR 1040.10 and 1040.11
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A
Affymetrix Technical Support 6
algorithm

Alignment 138
Expression 46

empirical 526
statistical 524

expression 515

Alignment algorithm 138

alpha1 563

alpha2 563

amino acid codes 610

analysis information 188
exporting 180

analysis information table 178
exporting 180

analysis settings 263

archiving data 285–287

attributes 355
activate in template 356
deactivate in template 356
edit in template 357
insert in template 356

AutoLoader 649–708
AC power connection 650
disabled 696
email system 656
Ethernet connection 650
indicator lights 654
manual mode 690
Microsoft Exchange 658
regulatory 708
scanning a probe array 667–

698
setting up 650
SMTP 659
specifications 706
stopping a scan 694
troubleshooting 699

automode 685

avg diff
empirical analysis 528

avg diff change
empirical analysis 530

B
B=A

empirical analysis 530

background subtraction 517

backup data or database 384–
387

backup location
add 388
remove 388

barcode 669

barcodes 74, 77, 100, 113, 114, 
121

baseline data 560

batch analysis
renaming results 238–240
resuming 241
running 240
selecting baseline 235
selecting userset 234

Batch Analysis window 230
removing data 240
toolbar 616

batch file
exporting 241
importing 242

bookmarks
creating 157
editing 159
viewing 158

C
CAB file 382, 383

copy 392
delete 393
restore 390
view 389

call 518

carousel 681, 683

CE Mark Declaration of Confor-
mity 510

cell coordinates 257

cell intensity data 44
computing 141
image settings 143–149
recalculating 142

change 516

change p-value 516

client software
testing

DMT 447
GCOS Manager 401, 

451
troubleshooting

GCOS 636
GCOS Manager 640

codes
amino acid 610
IUPAC base 609

columns
resizing, hiding, or reorder-

ing 625

comparison analysis results
empirical algorithm 528
statistical algorithm 525

comparison expression analy-
sis 166–167, 172–177, 520

selecting baseline 172

configure
data storage 55
fluidics station 68
scanner 69

controls
See expression report con-

trols.
cross hybridization probe 

mask 575
combining masks 582
creating 575
editing 580
711
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D
data

archiving 285–287
exporting 293
filtering 65–67
opening 63
unarchiving 287
viewing information 63

Data Mining Tool
installing 459–464

data ownership 288
assign 288
assume 288

data storage
configure 55

data tree 60
display options 61
shortcut menu 61

data types 63
experiment data 568
fluidics protocols 568
probe information 567

database
change password 378
gene information 47
process 47
publish 47

database (workstation)
relocate 396

dec ratio
empirical analysis 529

decrease
empirical analysis 529

defaults
analysis settings 263
image settings 256–260

descriptions 186

detection 516, 518

detection p-value 516

difference call
empirical analysis 530

discrimination value 518

documentation
conventions used 4

online 5

DPos-DNeg ratio
empirical analysis 530

E
editing

experiment information 80
expression report 223

empirical algorithm
metrics 526

Entrez 186

error messages 700

experiment
defining 74
renaming 62

experiment data
publishing 47

experiment information
editing 80
viewing 80

Experiment Information Win-
dow 673

experiment setup 42

exporting data 293
analysis information 180
batch file 241
metrics table 182–184

expression algorithm 515

expression analysis 46
analysis information 188
analysis information table 

178
exporting 180

comparison 166–167, 172–
177

selecting baseline 172
graphs

intensity bar graph 210
scatter graph 194
series graph 206, 210

measured images 191
metrics table 181
report 214–220
settings 168
single-array 164–165, 169–

170

expression analysis settings
baseline 560
normalization 543
probe masks
scaling 533
user-modifiable parameters 

562

Expression Analysis window 
(EAW) 46, 178

expression report 214–220
controls 222
editing 223
find feature 223
generating 214
parameters 218–220
printing 271
settings 216

F
filter samples

process tab 304

filters 65–67

find feature 188
expression report 223
probe set information 188

fluidics protocol
bypassing steps 103
editing 104
resuming 102
running 101
setting up 100–101

fluidics station
configuring 68
editing ID 105
priming 98–100

G
Gamma 563

GCOS
installing

new users 9–14
upgrading from MAS

15–22
installing library files (new 
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install) 25–29
installing library files (up-

graded install) 30–35
starting 53
troubleshooting 636
user interface 56–62

GCOS Administrator
backup function 382
Space Manager 394
starting 369

GCOS Manager
functions 277
Import tab 318
Process tab 283
Publish tab 306
Roles tab 357
starting 275
Template tab 344
troubleshooting 640
Userset tab 335

GCOS server
register 295, 377
unregister 296, 378
view events 296
view publish tasks 297

GCOS server tasks
cancel or restart 300

gene information database 47

GeneArray scanner
See scanner.

GeneChip assay
overview 40–47

GeneChip AutoLoader 649

graphs
intensity bar graph 210
scatter graph 194–205
series graph 206, 210

grid 260
manual alignment 139–140
viewing 138

H
highlights 148, 259

hybridization 43, 573
cross probe mask 575

hybridization probe mask 586
combining masks 594
creating 587
editing 591

I
image data

calculating average intensity 
143

image settings 143–149
probe cell intensity

cell image view 150
difference image view

150
measured image view

150

image data file 687, 694

image settings 143–149, 256–
260

cell coordinates 257
color 257
current image only 144
global 145
grid 260
highlights 148, 259
intensity 256
intensity range 145
pixel coordinates 146, 257

Image window 135
opening multiple windows 

137
task bar 137

import tab
filter samples 319
windowpanes 318–322

importing data 322–334
associate data and samples 

329–333
remove a sample for import 

328
specify sample for import 

324–329
start import 334

importing files
Batch Analysis Window 242

inc ratio

empirical analysis 529

inc/dec
empirical analysis 529

installing
GCOS

new users 9–14
upgrading from MAS

15–22
library files (new GCOS in-

stall) 25–29
library files (upgraded GCOS 

install) 30–35

instrument installation 467

intensity 256

intensity bar graph 210–214
clearing 214
options 211
plotting 211

intensity range 145

Internet Browser window 199

IUPAC base codes 609

L
library files 567

new GCOS install 25–29
upgraded GCOS install 30–

35

license
troubleshooting 639

log avg
empirical analysis 527

log avg ratio change
empirical analysis 530

M
mask file 546

masks
See probe mask.

measured images
expression probe array 191

metrics
empirical algorithm 526
statistical expression algo-

rithm 524
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metrics table 181
exporting 182–184

MIAME sample template 345

Microsoft SQL Server database 
47, 312

MSDE database 47, 312

N
neg change

empirical analysis 529

NetAffx 186

normalization 543–551
all probe sets 544
selected probe sets 545
user defined 543

normalization mask file
creating 546
editing 550
selecting 547

O
online documentation 5

Oracle database 47

Oracle publish database 316

outliers
masking 160
unmasking 160
viewing 159

P
pair used

empirical analysis 527

pairs in avg
empirical analysis 527

password
change 378

perturbation 563

pivot table 184
display options 185
exporting 187

pixel coordinates 146, 257

pos change
empirical analysis 529

pos fraction
empirical analysis 527

pos/neg
empirical analysis 528

printing
cell intensity data 269
image data 269
report 271

privilege settings
functions defined 362

probe array
highlighting tiles 156
hybridization 43
notation 515
scanning 44, 667–698
tiling information 153

probe array type
delete 292, 308

probe cell intensity
cell image view 150
difference image view 150
measured image view 150

probe cells
calculating average intensity 

143
data 151–152
viewing data 154

probe mask 552–559
creating 553
cross hybridization 575
editing 557
hybridization 586
selecting 555
spike 597

probe set
descriptions 186
obtaining information 186

probe set information
finding 188
hiding 190
reordering or removing 189
sorting 188

process data
delete 290

process database 47
automatic backup 380

find feature 301–304

process tab
filter samples 304
functions 284
windowpanes 283–284

project 62
renaming 62

publish database 47
accessing 308
capacity 312
create 311–318

Oracle on GCOS server
316

SQL on GCOS server
314

workstation 312
locations and sizes 312
selecting 246

publish tab windowpanes 306–
307

published data
delete 309

publishing 47
canceling a task 251
intensity data 250
overwriting data 250
publishing a task 251
restarting a task 252
specifying a task 247

R
register

GCOS server 295

register GCOS server 377

renaming 62
experiment, sample, project 

62

renaming feature 62

report
printing 271

reports
expression analysis 214–220

roles
create 359–362
define privileges 361–362
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delete 365
delete a user 364
naming 359
role membership 363

roles tab windowpanes 357–
358

S
sample

registering 42, 74
renaming 62

sample history
data view 85
displaying 85
process view 85, 87–89

scale factor 533

scale factor mask file
creating 537
editing 541
selecting 539

scaling 533–542
all probe sets 535
selected probe sets 536
user defined 533

scanner
configuring 69
GeneArray scanner

editing ID 126
options 123
scanning a probe array

120–125
shutting down 125
stopping a scan 125

GeneChip Scanner 3000 491
CE Mark Declaration of 

Conformity 510
laser safety 495
options 116
regulatory 511
scanning a probe array

111–118
shutdown 119
shutting down 119
specifications 504
stopping a scan 118
troubleshooting 504

scanning 44, 667–698

scatter graph
options 202
plotting 195
selecting points 200

series graph 206–210
options 208
plotting 207

shortcut bars 56–59
GeneChip Software 56
Instrument Control 58
Settings 59

Signal 516

signal calculation 520

signal log ratio 516, 523
high 516
low 516

single-array analysis 164–165, 
518

single-array analysis results
statistical algorithm 524

sort score 531

sorting
probe set information 188

Space Manager 394

spike probe mask 597
combining masks 603
creating 598
editing 601

SQL server 2000 publish data-
base 314

stat common pairs 516

stat pairs 516

statistical expression algo-
rithm 218–220, 524

status log 62, 170

T
task bar 137

tau 563

technical support 6
template tab windowpanes 

344–345

templates
activate attributes 356
attributes 355
create 347–353
deactivate attributes 356
deactivate or activate 354
edit 353
edit attributes 357
insert attributes 356
MIAME 345
rename 354

testing
DMT 447
GCOS Manager 401, 451

tiles
highlighting 156

tiling information 153

toolbars
Batch Analysis Window 616
main 613
publish 618
report 617

TOUGH-SPOTS™ 111

Tough-Spots™ 677

troubleshooting 635, 699
autoloader 699
GCOS 636
GCOS Manager 640

U
unarchiving data 287

unregister GCOS server 378

user interface 56–62

userset
create 337–340
delete 343
modify 340–343

userset tab windowpanes 335–
337

W
windowpanes

resizing 624

windows
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Expression Analysis win-
dow (EAW) 46, 178

GCOS Administrator 370
GCOS Manager 276
Image window 135
Internet Browser 199

workflow monitor 41, 90
cell intensity analysis tab 94
grid alignment tab 92
hybridization tab 92
probe array analysis 94
publish tab 94
scan tab 92

workstation database
property information 396
relocate 396
space information 396
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